]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- more macros,
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(pl):    GNU Bourne Again Shell (bash)
3 Summary(de):    GNU Bourne Again Shell (bash)
4 Summary(fr):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.03
8 Release:        5
9 Group:          Shells
10 Group(pl):      Pow³oki
11 Copyright:      GPL
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/bash/%{name}-%{version}.tar.gz
13 Source1:        bashrc
14 Patch0:         bash-arm.patch
15 Patch1:         bash-fixes.patch
16 Patch2:         bash-paths.patch
17 Patch3:         bash-security.patch
18 Patch4:         bash-autoconf.patch
19 Patch5:         bash-info.patch
20 Prereq:         fileutils
21 Prereq:         grep
22 Prereq:         /sbin/install-info
23 BuildPrereq:    ncurses-devel
24 Buildroot:      /tmp/%{name}-%{version}-root
25
26 %description
27 Bash is an sh-compatible command language interpreter that
28 executes commands read from the standard input or from a
29 file.  Bash also incorporates useful features from the
30 Korn and C shells (ksh and csh).
31
32 Bash is ultimately intended to be a conformant implementation
33 of the IEEE Posix Shell and Tools specification (IEEE
34 Working Group 1003.2).
35
36 %description -l pl
37 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
38 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
39 shelli Korn i C (ksh i csh). 
40
41 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
42 specyfikacj± - IEEE Working Group 1003.2.
43
44 %description -l de
45 Bash ist ein sh-kompatibler Befehlssprachen-Interpreter, der
46 über die Standardeingabe oder eine Datei gelesene Befehle ausführt.
47 Bash beinhaltet außerdem nützliche Funktionen der Korn- und der
48 C-Shell (ksh und csh).
49
50 Bash soll eine kompatible Implementierung der
51 'IEEE Posix Shell and Tools Specification' (IEEE
52 Working Group 1003.2) sein.
53
54 %description -l fr
55 Bash est un interpréteur de commande compatible sh qui exécute
56 les commandes lues sur l'entrée standard ou depuis un fichier.
57 Bash inclue également des fonctionnalités utiles des shells Korn et C
58 (ksh et csh).
59
60 Bash est prévu pour être une implémentation de shell conforme la
61 spécification Posix IEEE sur les shell et les outils (Groupe de 
62 travail IEEE 1003.2).
63
64 %description -l tr
65 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh uyumlu
66 bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C kabuklarýnýn (ksh ve
67 csh) kullanýþlý özelliklerini de kapsar. Bash, IEEE Posix Kabuk ve Araç
68 ayrýntýlarýna (IEEE Working Group 1003.2) uyumlu bir uygulama olarak
69 tasarlanmýþtýr.
70
71 %prep
72 %setup  -q
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77 %patch4 -p1
78 %patch5 -p1
79
80 %build
81 LDFLAGS="-s" CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
82     ./configure \
83         --prefix=%{_prefix} \
84         --enable-alias \
85         --enable-help-builtin \
86         --enable-history \
87         --enable-job-control \
88         --enable-restricted \
89         --enable-readline \
90         --with-curses \
91         --enable-extended-glob \
92         --infodir=%{_infodir} %{_target_platform}
93
94 make
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 install -d $RPM_BUILD_ROOT/{usr/share/{man,info},bin,etc}
100
101 make \
102     prefix=$RPM_BUILD_ROOT%{_prefix} \
103     infodir=$RPM_BUILD_ROOT%{_infodir} \
104     mandir=$RPM_BUILD_ROOT%{_mandir} \
105     install
106
107 mv $RPM_BUILD_ROOT%{_bindir}/bash       $RPM_BUILD_ROOT/bin/bash
108
109 rm -f $RPM_BUILD_ROOT%{_bindir}/{installed-bash,bash.old}
110
111 install %{SOURCE1} $RPM_BUILD_ROOT/etc/bashrc
112
113 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
114
115 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
116
117 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/{info/bash.info,man/man1/*} \
118         NEWS README 
119
120 %post
121 mv /etc/shells /etc/shells.org
122 (cat /etc/shells.org; echo "/bin/bash"; echo "/bin/rbash" ) | sort -u > /etc/shells
123 rm -f /etc/shells.org
124 /sbin/install-info %{_infodir}/bash.info.gz /etc/info-dir
125
126 %preun
127 if [ "$1" = "0" ]; then
128         mv /etc/shells /etc/shells.org
129         cat /etc/shells.org | egrep -v "/bin/bash|/bin/rbash" > /etc/shells
130         rm -f /etc/shells.org
131         /sbin/install-info --delete %{_infodir}/bash.info.gz /etc/info-dir
132 fi
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc {NEWS,README}.gz
140
141 /etc/bashrc
142
143 %attr(755,root,root) /bin/*
144 %attr(755,root,root) %{_bindir}/*
145
146 %{_infodir}/bash.info.gz
147 %{_mandir}/man1/*
148
149 %changelog
150 * Wed May 19 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
151   [2.03-5]
152 - more macros,
153 - FHS 2.0.
154
155 * Mon May  3 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
156   [2.03-4]
157 - added {un}registering info page for bash (added bash-info.patch).
158
159 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
160   [2.03-1]
161 - removed /bin/sh link from bash (this is now provided by pdksh),
162 - removed man group from man pages,
163 - gzipping instead bzipping2 man pages,
164 - rewrited %post, %preun,
165 - removed %config and %verify rules from /etc/bashrc (all extensions can be
166   added by adding /etc/profile.d/*.sh scripts).
167
168 * Sun Sep 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
169   [2.02.1-1d]
170 - fixed files permissions,
171 - build with restricted shell support.
172
173 * Wed Jun 17 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
174   [14.7-9d]
175 - build against glibc-2.1,
176 - translation modified for pl,
177 - added %defattr support,
178 - build from non root's account,
179 - start at RH spec.
This page took 0.078243 seconds and 4 git commands to generate.