]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
typo
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(pl):    GNU Bourne Again Shell (bash)
3 Summary(de):    GNU Bourne Again Shell (bash)
4 Summary(fr):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.03
8 Release:        7
9 Group:          Shells
10 Group(pl):      Pow³oki
11 Copyright:      GPL
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/bash/%{name}-%{version}.tar.gz
13 Source1:        bashrc
14 Source2:        bash-extra.tar.bz2
15 Patch0:         bash-arm.patch
16 Patch1:         bash-fixes.patch
17 Patch2:         bash-paths.patch
18 Patch3:         bash-security.patch
19 Patch4:         bash-autoconf.patch
20 Patch5:         bash-info.patch
21 BuildPrereq:    ncurses-devel
22 PreReq:         /sbin/install-info
23 PreReq:         grep
24 PreReq:         /bin/mv
25 Buildroot:      /tmp/%{name}-%{version}-root
26
27 %description
28 Bash is an sh-compatible command language interpreter that
29 executes commands read from the standard input or from a
30 file.  Bash also incorporates useful features from the
31 Korn and C shells (ksh and csh).
32
33 Bash is ultimately intended to be a conformant implementation
34 of the IEEE Posix Shell and Tools specification (IEEE
35 Working Group 1003.2).
36
37 %description -l pl
38 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
39 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
40 shelli Korn i C (ksh i csh). 
41
42 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
43 specyfikacj± - IEEE Working Group 1003.2.
44
45 %description -l de
46 Bash ist ein sh-kompatibler Befehlssprachen-Interpreter, der
47 über die Standardeingabe oder eine Datei gelesene Befehle ausführt.
48 Bash beinhaltet außerdem nützliche Funktionen der Korn- und der
49 C-Shell (ksh und csh).
50
51 Bash soll eine kompatible Implementierung der
52 'IEEE Posix Shell and Tools Specification' (IEEE
53 Working Group 1003.2) sein.
54
55 %description -l fr
56 Bash est un interpréteur de commande compatible sh qui exécute
57 les commandes lues sur l'entrée standard ou depuis un fichier.
58 Bash inclue également des fonctionnalités utiles des shells Korn et C
59 (ksh et csh).
60
61 Bash est prévu pour être une implémentation de shell conforme la
62 spécification Posix IEEE sur les shell et les outils (Groupe de 
63 travail IEEE 1003.2).
64
65 %description -l tr
66 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh uyumlu
67 bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C kabuklarýnýn (ksh ve
68 csh) kullanýþlý özelliklerini de kapsar. Bash, IEEE Posix Kabuk ve Araç
69 ayrýntýlarýna (IEEE Working Group 1003.2) uyumlu bir uygulama olarak
70 tasarlanmýþtýr.
71
72 %package static
73 Summary:        Staticly linked GNU Bourne Again Shell (bash)
74 Summary(pl):    Statycznie zlinkowany GNU Bourne Again Shell (bash)
75 Group:          Shells
76 Group(pl):      Pow³oki
77 Requires:       %{name}
78
79 %description static
80 Bash is an sh-compatible command language interpreter that
81 executes commands read from the standard input or from a
82 file.  Bash also incorporates useful features from the
83 Korn and C shells (ksh and csh).
84
85 Bash is ultimately intended to be a conformant implementation
86 of the IEEE Posix Shell and Tools specification (IEEE
87 Working Group 1003.2).
88
89 This packege contains staticly linked version of bash.
90
91 %description static -l pl
92 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
93 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
94 shelli Korn i C (ksh i csh). 
95
96 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
97 specyfikacj± - IEEE Working Group 1003.2.
98
99 W tym pakiecie jest statycznie zlinkowany bash.
100
101 %prep
102 %setup  -q -a2
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108 %patch5 -p1
109
110 %build
111 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
112 ./configure \
113         --prefix=%{_prefix} \
114         --enable-alias \
115         --enable-help-builtin \
116         --enable-history \
117         --enable-job-control \
118         --enable-restricted \
119         --enable-readline \
120         --with-curses \
121         --enable-extended-glob \
122         --enable-dparen-arithmetic \
123         --enable-static-link \
124         --infodir=%{_infodir} \
125         %{_target_platform}
126
127 make TERMCAP_LIB="-lncurses"
128 mv bash bash.static
129 make TERMCAP_LIB="-lncurses" STATIC_LD=""
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 install -d $RPM_BUILD_ROOT{%{_mandir},%{_infodir}}
135 install -d $RPM_BUILD_ROOT/{bin,etc}
136
137 make install \
138         prefix=$RPM_BUILD_ROOT%{_prefix} \
139         infodir=$RPM_BUILD_ROOT%{_infodir} \
140         mandir=$RPM_BUILD_ROOT%{_mandir} 
141
142 mv $RPM_BUILD_ROOT%{_bindir}/bash       $RPM_BUILD_ROOT/bin
143 install -s bash.static  $RPM_BUILD_ROOT/bin
144
145 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/bashrc
146 cp -a   skel            $RPM_BUILD_ROOT/etc
147 echo    .so bash.1 >    $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
148 ln -sf  bash            $RPM_BUILD_ROOT/bin/rbash
149
150 gzip -9nf       $RPM_BUILD_ROOT{%{_infodir}/bash.info,%{_mandir}/man1/*} \
151                 NEWS README doc/{FAQ,INTRO}
152
153 %post
154 if [ ! -f /etc/shells ]; then
155         echo "/bin/bash" > /etc/shells
156         echo "/bin/rbash" >> /etc/shells
157 else
158         if ! grep '^/bin/bash$' /etc/shells > /dev/null; then
159                 echo "/bin/bash" >> /etc/shells
160         fi
161         if ! grep '^/bin/rbash$' /etc/shells > /dev/null; then
162                 echo "/bin/rbash" >> /etc/shells
163         fi
164
165 fi
166
167 /sbin/install-info %{_infodir}/bash.info.gz /etc/info-dir
168
169 %post static
170 if [ ! -f /etc/shells ]; then
171         echo "/bin/bash.static" > /etc/shells
172 else
173         if ! grep '^/bin/bash.static$' /etc/shells > /dev/null; then
174                 echo "/bin/bash.static" >> /etc/shells
175         fi
176 fi
177
178 %preun
179 if [ $1 = 0 ]; then
180         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
181         mv /etc/shells.new /etc/shells
182 fi
183
184 /sbin/install-info --delete %{_infodir}/bash.info.gz /etc/info-dir
185
186 %preun static
187 if [ $1 = 0 ]; then
188         grep -v /bin/bash.static /etc/shells > /etc/shells.new
189         mv /etc/shells.new /etc/shells
190 fi
191
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %files
197 %defattr(644,root,root,755)
198 %doc {NEWS,README}.gz doc/{FAQ,INTRO}.gz
199
200 /etc/bashrc
201 /etc/skel
202
203 %attr(755,root,root) /bin/bash
204 %attr(755,root,root) /bin/rbash
205 %attr(755,root,root) %{_bindir}/bashbug
206
207 %{_infodir}/bash.info.gz
208 %{_mandir}/man1/*
209
210 %files static
211 %defattr(644,root,root,755)
212 %attr(755,root,root) /bin/bash
213
214 %changelog
215 * Sat Jun  5 1999 Jan Rêkorajski <baggins@pld.org.pl>
216   [2.03-7]
217 - added static subpackage
218
219 * Wed May 19 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
220   [2.03-5]
221 - more macros,
222 - FHS 2.0.
223
224 * Mon May  3 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
225   [2.03-4]
226 - added {un}registering info page for bash (added bash-info.patch).
227
228 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
229   [2.03-1]
230 - removed /bin/sh link from bash (this is now provided by pdksh),
231 - removed man group from man pages,
232 - gzipping instead bzipping2 man pages,
233 - rewrited %post, %preun,
234 - removed %config and %verify rules from /etc/bashrc (all extensions can be
235   added by adding /etc/profile.d/*.sh scripts).
236
237 * Sun Sep 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
238   [2.02.1-1d]
239 - fixed files permissions,
240 - build with restricted shell support.
241
242 * Wed Jun 17 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
243   [14.7-9d]
244 - build against glibc-2.1,
245 - translation modified for pl,
246 - added %defattr support,
247 - build from non root's account,
248 - start at RH spec.
This page took 0.078511 seconds and 4 git commands to generate.