]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- added %%verify flags for %%{_sysconfdir}/bashrc file,
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(de):    GNU Bourne Again Shell (bash)
3 Summary(fr):    Le shell Bourne Again de GNU
4 Summary(pl):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.05
8 Release:        6
9 License:        GPL
10 Group:          Applications/Shells
11 Group(de):      Applikationen/Shells
12 Group(pl):      Aplikacje/Pow³oki
13 Source0:        ftp://prep.ai.mit.edu/pub/gnu/bash/%{name}-%{version}.tar.gz
14 Source1:        %{name}rc
15 Source2:        %{name}-skel-.bash_logout
16 Source3:        %{name}-skel-.bash_profile
17 Source4:        %{name}-skel-.bashrc
18 Patch0:         %{name}-paths.patch
19 Patch1:         %{name}-security.patch
20 Patch2:         %{name}-autoconf.patch
21 Patch3:         %{name}-info.patch
22 Patch4:         %{name}-profile.patch
23 Patch5:         %{name}-requires.patch
24 Patch6:         %{name}-compat.patch
25 Patch7:         %{name}-shellfunc.patch
26 Patch8:         http://www.t17.ds.pwr.wroc.pl/~misiek/ipv6/bash-2.05-ipv6-20010418.patch.gz
27 Patch9:         %{name}-DESTDIR.patch
28 Patch10:        %{name}-rlimit_locks.patch
29 Patch11:        %{name}-sighup.patch
30 Patch12:        %{name}-tmpfile.patch
31 BuildRequires:  ncurses-devel >= 5.2
32 BuildRequires:  readline-devel >= 4.2
33 BuildRequires:  glibc-devel >= 2.2
34 %if %{!?_without_static:1}%{?_without_static:0}
35 # Require static library only for static build
36 BuildRequires:  ncurses-static >= 5.2
37 BuildRequires:  readline-static >= 4.2
38 BuildRequires:  glibc-static >= 2.2
39 %endif
40 BuildRequires:  bison
41 PreReq:         grep
42 PreReq:         fileutils
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44 Obsoletes:      bash-doc
45 Obsoletes:      bash2
46 Obsoletes:      bash2-doc
47 Obsoletes:      etcskel
48
49 %description
50 Bash is a GNU project sh-compatible shell or command language
51 interpreter. Bash (Bourne Again shell) incorporates useful features
52 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
53 be run by bash without modification. Bash offers several improvements
54 over sh, including command line editing, unlimited size command
55 history, job control, shell functions and aliases, indexed arrays of
56 unlimited size and integer arithmetic in any base from two to 64. Bash
57 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
58 Shell and Tools standard. Bash is the default shell for Linux
59 Mandrake. You should install bash because of its popularity and power.
60 You'll probably end up using it.
61
62 %description -l de
63 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
64 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
65 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
66 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
67 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
68 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
69 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
70 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
71 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
72 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
73 Mandrake.
74
75 %description -l fr
76 Bash est un shell (interpréteur de commande) du projet GNU, compatible
77 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
78 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
79 plupart des scripts sh sont exécutables sans modifications. Bash
80 comprend nombre d'améliorations par rapport à sh : édition de la ligne
81 de commande, historique illimité, contrôle des processus
82 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
83 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
84 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
85 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
86 l'installer du fait de sa puissance et de sa popularité. Vous finirez
87 probablement par l'utiliser.
88
89 %description -l pl
90 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
91 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci shelli
92 Korn i C (ksh i csh). Bash ma równie¿ zaimplementowany IEEE Posix
93 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2.
94
95 %description -l tr
96 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
97 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
98 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
99 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
100 uyumlu bir uygulama olarak tasarlanmýþtýr.
101
102 %package static
103 Summary:        Staticly linked GNU Bourne Again Shell (bash)
104 Summary(pl):    Statycznie zlinkowany GNU Bourne Again Shell (bash)
105 Group:          Applications/Shells
106 Group(de):      Applikationen/Shells
107 Group(pl):      Aplikacje/Pow³oki
108 Requires:       %{name}
109 PreReq:         grep
110 PreReq:         fileutils
111
112 %description static
113 Bash is a GNU project sh-compatible shell or command language
114 interpreter. Bash (Bourne Again shell) incorporates useful features
115 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
116 be run by bash without modification. Bash offers several improvements
117 over sh, including command line editing, unlimited size command
118 history, job control, shell functions and aliases, indexed arrays of
119 unlimited size and integer arithmetic in any base from two to 64. Bash
120 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
121 Shell and Tools standard. Bash is the default shell for Linux
122 Mandrake. You should install bash because of its popularity and power.
123 You'll probably end up using it. This packege contains staticly linked
124 version of bash.
125
126 %description static -l pl
127 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
128 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci shelli
129 Korn i C (ksh i csh). Bash ma równie¿ zaimplementowany IEEE Posix
130 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
131 tym pakiecie jest statycznie zlinkowany bash.
132
133 %prep
134 %setup  -q
135 %patch0 -p1
136 %patch1 -p1
137 %patch2 -p1
138 %patch3 -p1
139 %patch4 -p1
140 %patch5 -p1
141 %patch6 -p1
142 %patch7 -p1
143 %patch8 -p1
144 %patch9 -p1
145 %patch10 -p1
146 %patch11 -p1
147 %patch12 -p1
148
149 echo %{version} > _distribution
150 echo %{release} > _patchlevel
151
152 %build
153 %{__autoconf}
154 for mode in %{!?_without_static:static} shared; do
155 %configure \
156         --enable-alias \
157         --enable-help-builtin \
158         --enable-history \
159         --enable-job-control \
160         --enable-restricted \
161         --enable-readline \
162         --with-curses \
163         --enable-extended-glob \
164         --enable-dparen-arithmetic \
165         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
166         --with-installed-readline
167
168 %{__make} DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
169
170 [ "$mode" = "static" ] && %{__mv} -f bash bash.static || :
171 done
172
173 %install
174 %{__rm} -rf $RPM_BUILD_ROOT
175 %{__install} -d $RPM_BUILD_ROOT/{bin,etc/skel}
176
177 %{__make} install DESTDIR=$RPM_BUILD_ROOT
178
179 %{__mv} -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
180 %{?_without_static:#}install    bash.static $RPM_BUILD_ROOT/bin
181
182 %{__install} %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
183 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
184
185 %{__ln_s} -f bash $RPM_BUILD_ROOT/bin/rbash
186
187 %{__install} %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
188 %{__install} %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
189 %{__install} %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
190
191 %{__gzip} -9nf NEWS README doc/{FAQ,INTRO}
192
193 %post
194 if [ ! -f /etc/shells ]; then
195         echo "/bin/bash" > /etc/shells
196         echo "/bin/rbash" >> /etc/shells
197 else
198         if ! grep -q '^/bin/bash$' /etc/shells; then
199                 echo "/bin/bash" >> /etc/shells
200         fi
201         if ! grep -q '^/bin/rbash$' /etc/shells; then
202                 echo "/bin/rbash" >> /etc/shells
203         fi
204 fi
205
206 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
207
208 %post static
209 if [ ! -f /etc/shells ]; then
210         echo "/bin/bash.static" > /etc/shells
211 else
212         if ! grep -q '^/bin/bash.static$' /etc/shells; then
213                 echo "/bin/bash.static" >> /etc/shells
214         fi
215 fi
216
217 %preun
218 if [ "$1" = "0" ]; then
219         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
220         mv -f /etc/shells.new /etc/shells
221 fi
222
223 %preun static
224 if [ "$1" = "0" ]; then
225         grep -v /bin/bash.static /etc/shells > /etc/shells.new
226         mv -f /etc/shells.new /etc/shells
227 fi
228
229 %postun
230 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
231
232 %clean
233 %{__rm} -rf $RPM_BUILD_ROOT
234
235 %files
236 %defattr(644,root,root,755)
237 %doc {NEWS,README}.gz doc/{FAQ,INTRO}.gz
238
239 %config %verify(not md5 size mtime) %{_sysconfdir}/bashrc
240 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bash_logout
241 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bash_profile
242 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bashrc
243
244 %attr(755,root,root) /bin/bash
245 %attr(755,root,root) /bin/rbash
246 %attr(755,root,root) %{_bindir}/bashbug
247
248 %{_infodir}/bash.info.gz
249 %{_mandir}/man1/*
250
251 %{?_without_static:#}%files static
252 %{?_without_static:#}%defattr(644,root,root,755)
253 %{?_without_static:#}%attr(755,root,root) /bin/bash.static
This page took 0.062332 seconds and 4 git commands to generate.