]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
troche zmian changes ...
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(pl):    GNU Bourne Again Shell (bash)
3 Summary(de):    GNU Bourne Again Shell (bash)
4 Summary(fr):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.03
8 Release:        6
9 Group:          Shells
10 Group(pl):      Pow³oki
11 Copyright:      GPL
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/bash/%{name}-%{version}.tar.gz
13 Source1:        bashrc
14 Source2:        bash-extra.tar.bz2
15 Patch0:         bash-arm.patch
16 Patch1:         bash-fixes.patch
17 Patch2:         bash-paths.patch
18 Patch3:         bash-security.patch
19 Patch4:         bash-autoconf.patch
20 Patch5:         bash-info.patch
21 BuildPrereq:    ncurses-devel
22 Buildroot:      /tmp/%{name}-%{version}-root
23
24 %description
25 Bash is an sh-compatible command language interpreter that
26 executes commands read from the standard input or from a
27 file.  Bash also incorporates useful features from the
28 Korn and C shells (ksh and csh).
29
30 Bash is ultimately intended to be a conformant implementation
31 of the IEEE Posix Shell and Tools specification (IEEE
32 Working Group 1003.2).
33
34 %description -l pl
35 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
36 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
37 shelli Korn i C (ksh i csh). 
38
39 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
40 specyfikacj± - IEEE Working Group 1003.2.
41
42 %description -l de
43 Bash ist ein sh-kompatibler Befehlssprachen-Interpreter, der
44 über die Standardeingabe oder eine Datei gelesene Befehle ausführt.
45 Bash beinhaltet außerdem nützliche Funktionen der Korn- und der
46 C-Shell (ksh und csh).
47
48 Bash soll eine kompatible Implementierung der
49 'IEEE Posix Shell and Tools Specification' (IEEE
50 Working Group 1003.2) sein.
51
52 %description -l fr
53 Bash est un interpréteur de commande compatible sh qui exécute
54 les commandes lues sur l'entrée standard ou depuis un fichier.
55 Bash inclue également des fonctionnalités utiles des shells Korn et C
56 (ksh et csh).
57
58 Bash est prévu pour être une implémentation de shell conforme la
59 spécification Posix IEEE sur les shell et les outils (Groupe de 
60 travail IEEE 1003.2).
61
62 %description -l tr
63 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh uyumlu
64 bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C kabuklarýnýn (ksh ve
65 csh) kullanýþlý özelliklerini de kapsar. Bash, IEEE Posix Kabuk ve Araç
66 ayrýntýlarýna (IEEE Working Group 1003.2) uyumlu bir uygulama olarak
67 tasarlanmýþtýr.
68
69 %prep
70 %setup  -q -a2
71 %patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74 %patch3 -p1
75 %patch4 -p1
76 %patch5 -p1
77
78 %build
79 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
80 ./configure \
81         --prefix=%{_prefix} \
82         --enable-alias \
83         --enable-help-builtin \
84         --enable-history \
85         --enable-job-control \
86         --enable-restricted \
87         --enable-readline \
88         --with-curses \
89         --enable-extended-glob \
90         --enable-dparen-arithmetic \
91         --enable-static-link \
92         --infodir=%{_infodir} \
93         %{_target_platform}
94
95 make TERMCAP_LIB="-lncurses"
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 install -d $RPM_BUILD_ROOT%{_datadir}/{man,info}
101 install -d $RPM_BUILD_ROOT/{bin,etc}
102
103 make install \
104         prefix=$RPM_BUILD_ROOT%{_prefix} \
105         infodir=$RPM_BUILD_ROOT%{_infodir} \
106         mandir=$RPM_BUILD_ROOT%{_mandir} \
107
108 mv $RPM_BUILD_ROOT%{_bindir}/bash       $RPM_BUILD_ROOT/bin
109
110 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/bashrc
111 cp -a   skel            $RPM_BUILD_ROOT/etc
112 echo    .so bash.1 >    $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
113 ln -sf  bash            $RPM_BUILD_ROOT/bin/rbash
114
115 gzip -9nf       $RPM_BUILD_ROOT{%{_infodir}/bash.info,%{_mandir}/man1/*} \
116                 NEWS README doc/{FAQ,INTRO}
117
118 %post
119 if [ ! -f /etc/shells ]; then
120         echo "/bin/bash" > /etc/shells
121         echo "/bin/rbash" >> /etc/shells
122 else
123         if ! grep '^/bin/bash$' /etc/shells > /dev/null; then
124                 echo "/bin/bash" >> /etc/shells
125         fi
126         if ! grep '^/bin/rbash$' /etc/shells > /dev/null; then
127                 echo "/bin/rbash" >> /etc/shells
128         fi
129
130 fi
131
132 /sbin/install-info %{_infodir}/bash.info.gz /etc/info-dir
133
134 %preun
135 if [ $1 = 0 ]; then
136         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
137         mv /etc/shells.new /etc/shells
138 fi
139
140 /sbin/install-info --delete %{_infodir}/bash.info.gz /etc/info-dir
141
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %doc {NEWS,README}.gz doc/{FAQ,INTRO}.gz
149
150 /etc/bashrc
151 /etc/skel
152
153 %attr(755,root,root) /bin/bash
154 %attr(755,root,root) /bin/rbash
155 %attr(755,root,root) %{_bindir}/bashbug
156
157 %{_infodir}/bash.info.gz
158 %{_mandir}/man1/*
159
160 %changelog
161 * Wed May 19 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
162   [2.03-5]
163 - more macros,
164 - FHS 2.0.
165
166 * Mon May  3 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
167   [2.03-4]
168 - added {un}registering info page for bash (added bash-info.patch).
169
170 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
171   [2.03-1]
172 - removed /bin/sh link from bash (this is now provided by pdksh),
173 - removed man group from man pages,
174 - gzipping instead bzipping2 man pages,
175 - rewrited %post, %preun,
176 - removed %config and %verify rules from /etc/bashrc (all extensions can be
177   added by adding /etc/profile.d/*.sh scripts).
178
179 * Sun Sep 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
180   [2.02.1-1d]
181 - fixed files permissions,
182 - build with restricted shell support.
183
184 * Wed Jun 17 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
185   [14.7-9d]
186 - build against glibc-2.1,
187 - translation modified for pl,
188 - added %defattr support,
189 - build from non root's account,
190 - start at RH spec.
This page took 0.047407 seconds and 4 git commands to generate.