]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- masive changes:
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(pl):    GNU Bourne Again Shell (bash)
3 Summary(de):    GNU Bourne Again Shell (bash)
4 Summary(fr):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.03
8 Release:        4
9 Group:          Shells
10 Group(pl):      Pow³oki
11 Copyright:      GPL
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/bash/%{name}-%{version}.tar.gz
13 Source1:        bashrc
14 Patch0:         bash-arm.patch
15 Patch1:         bash-fixes.patch
16 Patch2:         bash-paths.patch
17 Patch3:         bash-security.patch
18 Patch4:         bash-autoconf.patch
19 Patch5:         bash-info.patch
20 Prereq:         fileutils
21 Prereq:         grep
22 Prereq:         /sbin/install-info
23 BuildPrereq:    ncurses-devel
24 Buildroot:      /tmp/%{name}-%{version}-root
25 Obsoletes:      bash2
26
27 %description
28 Bash is an sh-compatible command language interpreter that
29 executes commands read from the standard input or from a
30 file.  Bash also incorporates useful features from the
31 Korn and C shells (ksh and csh).
32
33 Bash is ultimately intended to be a conformant implementation
34 of the IEEE Posix Shell and Tools specification (IEEE
35 Working Group 1003.2).
36
37 %description -l pl
38 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
39 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
40 shelli Korn i C (ksh i csh). 
41
42 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
43 specyfikacj± - IEEE Working Group 1003.2.
44
45 %description -l de
46 Bash ist ein sh-kompatibler Befehlssprachen-Interpreter, der
47 über die Standardeingabe oder eine Datei gelesene Befehle ausführt.
48 Bash beinhaltet außerdem nützliche Funktionen der Korn- und der
49 C-Shell (ksh und csh).
50
51 Bash soll eine kompatible Implementierung der
52 'IEEE Posix Shell and Tools Specification' (IEEE
53 Working Group 1003.2) sein.
54
55 %description -l fr
56 Bash est un interpréteur de commande compatible sh qui exécute
57 les commandes lues sur l'entrée standard ou depuis un fichier.
58 Bash inclue également des fonctionnalités utiles des shells Korn et C
59 (ksh et csh).
60
61 Bash est prévu pour être une implémentation de shell conforme la
62 spécification Posix IEEE sur les shell et les outils (Groupe de 
63 travail IEEE 1003.2).
64
65 %description -l tr
66 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh uyumlu
67 bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C kabuklarýnýn (ksh ve
68 csh) kullanýþlý özelliklerini de kapsar. Bash, IEEE Posix Kabuk ve Araç
69 ayrýntýlarýna (IEEE Working Group 1003.2) uyumlu bir uygulama olarak
70 tasarlanmýþtýr.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75 %patch1 -p1
76 %patch2 -p1
77 %patch3 -p1
78 %patch4 -p1
79 %patch5 -p1
80
81 %build
82 LDFLAGS="-s" CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
83 ./configure %{_target} \
84         --prefix=/usr \
85         --enable-alias \
86         --enable-help-builtin \
87         --enable-history \
88         --enable-job-control \
89         --enable-restricted \
90         --enable-readline \
91         --with-curses
92
93 make
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 install -d $RPM_BUILD_ROOT/{usr,bin,etc}
99 make prefix=$RPM_BUILD_ROOT/usr install
100
101 mv $RPM_BUILD_ROOT/usr/bin/bash $RPM_BUILD_ROOT/bin/bash
102 rm -f $RPM_BUILD_ROOT/usr/bin/installed-bash
103
104 rm -f $RPM_BUILD_ROOT/usr/bin/bash.old
105
106 install %{SOURCE1} $RPM_BUILD_ROOT/etc/bashrc
107
108 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
109
110 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
111
112 gzip -9nf $RPM_BUILD_ROOT/usr/{info/bash.info,man/man1/*} \
113         NEWS README 
114
115 %post
116 mv /etc/shells /etc/shells.org
117 (cat /etc/shells.org; echo "/bin/bash"; echo "/bin/rbash" ) | sort -u > /etc/shells
118 rm -f /etc/shells.org
119 /sbin/install-info %{_infodir}/bash.info.gz /etc/info-dir
120
121 %preun
122 if [ "$1" = "0" ]; then
123         mv /etc/shells /etc/shells.org
124         cat /etc/shells.org | egrep -v "/bin/bash|/bin/rbash" > /etc/shells
125         rm -f /etc/shells.org
126         /sbin/install-info --delete %{_infodir}/bash.info.gz /etc/info-dir
127 fi
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc {NEWS,README}.gz
135
136 /etc/bashrc
137
138 %attr(755,root,root) /bin/*
139 %attr(755,root,root) /usr/bin/*
140
141 %{_infodir}/bash.info.gz
142 %{_mandir}/man1/*
143
144 %changelog
145 * Mon May  3 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
146   [2.03-4]
147 - added {un}registering info page for bash (added bash-info.patch).
148
149 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
150   [2.03-1]
151 - removed /bin/sh link from bash (this is now provided by pdksh),
152 - removed man group from man pages,
153 - gzipping insterad bzipping2 man pages,
154 - rewrited %post, %preun,
155 - removed %config and %verify rules from /etc/bashrc (all extensions can be
156   added by adding /etc/profile.d/*.sh scripts).
157
158 * Sun Sep 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
159   [2.02.1-1d]
160 - fixed files permissions,
161 - build with restricted shell support.
162
163 * Wed Jun 17 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
164   [14.7-9d]
165 - build against glibc-2.1,
166 - translation modified for pl,
167 - added %defattr support,
168 - build from non root's account.
169
170 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
171 - translations modified for de, fr, tr
172
173 * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
174 - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
175   is based on a change made in bash 2.0.  Should fix some early exit
176   problems with suspends and fg.
177
178 * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
179 - added %clean
180
181 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
182 - added comment explaining why install-info isn't used
183 - added mips patch 
184
185 * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
186 - added BuildRoot
187
188 * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
189 - built against glibc
This page took 0.071768 seconds and 4 git commands to generate.