]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- updated to 2.03,
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(pl):    GNU Bourne Again Shell (bash)
3 Summary(de):    GNU Bourne Again Shell (bash)
4 Summary(fr):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.03
8 Release:        1
9 Group:          Shells
10 Copyright:      GPL
11 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Source1:        bashrc
13 Patch0:         %{name}.patch
14 Patch1:         %{name}-fixes.patch
15 Patch2:         %{name}-paths.patch
16 Patch3:         %{name}-security.patch
17 Prereq:         fileutils
18 Prereq:         grep 
19 Buildroot:      /tmp/%{name}-%{version}-root
20
21 %description
22 Bash is an sh-compatible command language interpreter that
23 executes commands read from the standard input or from a
24 file.  Bash also incorporates useful features from the
25 Korn and C shells (ksh and csh).
26
27 Bash is ultimately intended to be a conformant implementation
28 of the IEEE Posix Shell and Tools specification (IEEE
29 Working Group 1003.2).
30
31 %description -l pl
32 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
33 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
34 shelli Korn i C (ksh i csh). 
35
36 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
37 specyfikacj± - IEEE Working Group 1003.2.
38
39 %description -l de
40 Bash ist ein sh-kompatibler Befehlssprachen-Interpreter, der
41 über die Standardeingabe oder eine Datei gelesene Befehle ausführt.
42 Bash beinhaltet außerdem nützliche Funktionen der Korn- und der
43 C-Shell (ksh und csh).
44
45 Bash soll eine kompatible Implementierung der
46 'IEEE Posix Shell and Tools Specification' (IEEE
47 Working Group 1003.2) sein.
48
49 %description -l fr
50 Bash est un interpréteur de commande compatible sh qui exécute
51 les commandes lues sur l'entrée standard ou depuis un fichier.
52 Bash inclue également des fonctionnalités utiles des shells Korn et C
53 (ksh et csh).
54
55 Bash est prévu pour être une implémentation de shell conforme la
56 spécification Posix IEEE sur les shell et les outils (Groupe de 
57 travail IEEE 1003.2).
58
59 %description -l tr
60 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh uyumlu
61 bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C kabuklarýnýn (ksh ve
62 csh) kullanýþlý özelliklerini de kapsar. Bash, IEEE Posix Kabuk ve Araç
63 ayrýntýlarýna (IEEE Working Group 1003.2) uyumlu bir uygulama olarak
64 tasarlanmýþtýr.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71 %patch3 -p1
72
73 %build
74 LDFLAGS="-s" CFLAGS="$RPM_OPT_FLAGS" \
75 ./configure \
76         --prefix=/usr \
77         --enable-alias \
78         --enable-help-builtin \
79         --enable-history \
80         --enable-job-control \
81         --enable-restricted \
82         --enable-readline \
83         --enable-static-link
84 make 
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 install -d $RPM_BUILD_ROOT/{usr,bin,etc}
90 make prefix=$RPM_BUILD_ROOT/usr install
91
92 mv $RPM_BUILD_ROOT/usr/bin/bash $RPM_BUILD_ROOT/bin/bash
93 rm -f $RPM_BUILD_ROOT/usr/bin/installed-bash
94
95 rm -f $RPM_BUILD_ROOT/usr/bin/bash.old
96
97 install %{SOURCE1} $RPM_BUILD_ROOT/etc/bashrc
98
99 echo .so bash.1 > $RPM_BUILD_ROOT/usr/man/man1/sh.1
100 echo .so bash.1 > $RPM_BUILD_ROOT/usr/man/man1/rbash.1
101
102 ln -sf bash $RPM_BUILD_ROOT/bin/sh
103 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
104
105 gzip -9nf $RPM_BUILD_ROOT/usr/{info/bash.info,man/man1/*}
106
107 bzip2 -9 NEWS README 
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 (cat /etc/shells; echo "/bin/sh"; echo "/bin/bash"; echo "/bin/rbash") | sort -u > /etc/shells
114
115 %preun
116 cat /etc/shells | egrep -v "/bin/bash|/bin/bash|/bin/rbash" > /etc/shells
117
118 %files
119 %defattr(644,root,root,755)
120 %doc NEWS.bz2 README.bz2 
121
122 /etc/bashrc
123
124 %attr(755,root,root) /bin/*
125 %attr(755,root,root) /usr/bin/*
126
127 /usr/info/bash.info.gz
128 /usr/man/man1/*
129
130 %changelog
131 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
132   [2.03-1]
133 - removed man group from man pages,
134 - gzipping insterad bzipping2 man pages,
135 - rewrited %post, %preun,
136 - removed %config and %verify rules from /etc/bashrc (all extensions can be
137   added by adding /etc/profile.d/*.sh scripts).
138
139 * Sun Sep 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
140   [2.02.1-1d]
141 - updated to 2.02.1,
142 - fixed files permissions,
143 - build with restricted shell support.
144
145 * Wed Jun 17 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
146   [14.7-9d]
147 - build against glibc-2.1,
148 - translation modified for pl,
149 - added %defattr support,
150 - build from non root's account.
151
152 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
153 - translations modified for de, fr, tr
154
155 * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
156 - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
157   is based on a change made in bash 2.0.  Should fix some early exit
158   problems with suspends and fg.
159
160 * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
161 - added %clean
162
163 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
164 - added comment explaining why install-info isn't used
165 - added mips patch 
166
167 * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
168 - added BuildRoot
169
170 * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
171 - built against glibc
This page took 0.072026 seconds and 3 git commands to generate.