]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
e1e7fcad9ceea60ec927a1e2fbe84fdf86993048
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 %bcond_without  tests   # do not perform "make test"
6 ##
7 %define         _ver            3.2
8 %define         _patchlevel     003
9 #
10 Summary:        GNU Bourne Again Shell (bash)
11 Summary(fr):    Le shell Bourne Again de GNU
12 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
13 Name:           bash
14 Version:        %{_ver}.%{_patchlevel}
15 Release:        1%{?with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
19 # Source0-md5:  00bfa16d58e034e3c2aa27f390390d30
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
26 Patch0:         %{name}-paths.patch
27 Patch1:         %{name}-security.patch
28 Patch2:         %{name}-autoconf.patch
29 Patch3:         %{name}-info.patch
30 Patch4:         %{name}-profile.patch
31 Patch5:         %{name}-requires.patch
32 Patch6:         %{name}-compat.patch
33 Patch8:         %{name}-sighup.patch
34 Patch9:         %{name}-backup_history.patch
35 Patch10:        %{name}-act_like_sh.patch
36 Patch1001:      ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-001
37 Patch1002:      ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-002
38 Patch1003:      ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-003
39 URL:            http://www.gnu.org/software/bash/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  bison
43 BuildRequires:  ncurses-devel >= 5.2
44 BuildRequires:  readline-devel >= 5.2
45 BuildRequires:  texinfo
46 %if %{with static}
47 # Require static library only for static build
48 BuildRequires:  glibc-static >= 2.2
49 BuildRequires:  ncurses-static >= 5.2
50 BuildRequires:  readline-static >= 5.2
51 %endif
52 Requires(post,preun):   grep
53 Requires(preun):        fileutils
54 Requires:       grep
55 Requires:       readline >= 5.2
56 Requires:       setup >= 2.4.6-2
57 Obsoletes:      bash-doc
58 Obsoletes:      bash2
59 Obsoletes:      bash2-doc
60 Obsoletes:      etcskel
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Bash is a GNU project sh-compatible shell or command language
65 interpreter. Bash (Bourne Again shell) incorporates useful features
66 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
67 be run by bash without modification. Bash offers several improvements
68 over sh, including command line editing, unlimited size command
69 history, job control, shell functions and aliases, indexed arrays of
70 unlimited size and integer arithmetic in any base from two to 64. Bash
71 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
72 Shell and Tools standard. Bash is the default shell for Linux
73 Mandrake. You should install bash because of its popularity and power.
74 You'll probably end up using it.
75
76 %description -l es
77 Bash es un interpretador de comandos compatible con sh, que ejecuta
78 comandos leídos de la entrada padrón o de un archivo. Bash también
79 incorpora características útiles de las shells Korn y C (ksh y csh).
80 Bash ha sido desarrollado para ser una adición compatible con la
81 especificación IEEE Posix para shells y herramientas (IEEE Working
82 Group 1003.2).
83
84 %description -l de
85 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
86 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
87 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
88 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
89 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
90 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
91 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
92 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
93 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
94 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
95 Mandrake.
96
97 %description -l fr
98 Bash est un shell (interpréteur de commande) du projet GNU, compatible
99 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
100 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
101 plupart des scripts sh sont exécutables sans modifications. Bash
102 comprend nombre d'améliorations par rapport à sh : édition de la ligne
103 de commande, historique illimité, contrôle des processus
104 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
105 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
106 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
107 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
108 l'installer du fait de sa puissance et de sa popularité. Vous finirez
109 probablement par l'utiliser.
110
111 %description -l pl
112 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
113 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
114 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
115 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
116 stosunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
117 historii poleceñ, funkcje i aliasy, indeksowane tablice
118 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
119 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
120 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
121
122 %description -l pt_BR
123 Bash é um interpretador de comandos compatível com sh, que executa
124 comandos lidos da entrada padrão ou de um arquivo. Bash também
125 incorpora características úteis das shells Korn e C (ksh e csh). Bash
126 tem sido desenvolvido para ser uma implementação compatível com a
127 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
128 1003.2).
129
130 %description -l ru
131 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
132 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
133 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
134 (ksh É csh).
135
136 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
137 Tools specification (IEEE Working Group 1003.2).
138
139 %description -l tr
140 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
141 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
142 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
143 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
144 uyumlu bir uygulama olarak tasarlanmýþtýr.
145
146 %description -l uk
147 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
148 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
149 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
150
151 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
152 Tools specification (IEEE Working Group 1003.2).
153
154 %package static
155 Summary:        Statically linked GNU Bourne Again Shell (bash)
156 Summary(pl):    Statycznie skonsolidowany GNU Bourne Again Shell (bash)
157 Group:          Applications/Shells
158 Requires(post,preun):   grep
159 Requires(preun):        fileutils
160 Requires:       %{name} = %{version}-%{release}
161
162 %description static
163 Bash is a GNU project sh-compatible shell or command language
164 interpreter. Bash (Bourne Again shell) incorporates useful features
165 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
166 be run by bash without modification. Bash offers several improvements
167 over sh, including command line editing, unlimited size command
168 history, job control, shell functions and aliases, indexed arrays of
169 unlimited size and integer arithmetic in any base from two to 64. Bash
170 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
171 Shell and Tools standard. Bash is the default shell for Linux
172 Mandrake. You should install bash because of its popularity and power.
173 You'll probably end up using it. This package contains statically
174 linked version of bash.
175
176 %description static -l pl
177 Bash jest zaawansowan± pow³ok±, która wykonuje komendy czytane ze
178 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
179 Korn i C (ksh i csh). Bash jest równie¿ zaimplementowany IEEE Posix
180 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
181 tym pakiecie jest wersja basha skonsolidowana statycznie.
182
183 %prep
184 %setup -q -n %{name}-%{_ver} -a5
185 %patch1001 -p0
186 %patch1002 -p0
187 %patch1003 -p0
188 %patch0 -p1
189 %patch1 -p1
190 %patch2 -p1
191 %patch3 -p1
192 %patch4 -p1
193 %patch5 -p1
194 %patch6 -p1
195 %patch8 -p1
196 %{?with_bash_history:%patch9 -p1}
197 %patch10 -p1
198
199 %build
200 cp -f /usr/share/automake/config.* support
201 %{__autoconf}
202 for mode in %{?with_static:static} shared; do
203 %configure \
204         --enable-alias \
205         --enable-help-builtin \
206         --enable-history \
207         --enable-job-control \
208         --enable-restricted \
209         --enable-readline \
210         --with-curses \
211         --enable-extended-glob \
212         --enable-dparen-arithmetic \
213         --enable-separate-helpfiles \
214         --without-bash-malloc \
215         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
216         --with-installed-readline
217
218 %{__make} \
219         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
220
221 [ "$mode" = "static" ] && mv -f bash bash.static || :
222 done
223
224 %{?with_tests:%{__make} tests}
225
226 %install
227 rm -rf $RPM_BUILD_ROOT
228 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
229 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
230
231 %{__make} install \
232         DESTDIR=$RPM_BUILD_ROOT
233
234 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
235 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
236
237 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
238 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
239
240 for d in es fr it ja ko nl pl ; do
241         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
242         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
243         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
244 done
245
246 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
247
248 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
249 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
250 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
251 rm -f $RPM_BUILD_ROOT/usr/share/info/dir
252
253 %find_lang %{name}
254
255 %clean
256 rm -rf $RPM_BUILD_ROOT
257
258 %post
259 umask 022
260 if [ ! -f /etc/shells ]; then
261         echo "/bin/bash" > /etc/shells
262         echo "/bin/rbash" >> /etc/shells
263 else
264         if ! grep -q '^/bin/bash$' /etc/shells; then
265                 echo "/bin/bash" >> /etc/shells
266         fi
267         if ! grep -q '^/bin/rbash$' /etc/shells; then
268                 echo "/bin/rbash" >> /etc/shells
269         fi
270 fi
271
272 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
273
274 %preun
275 if [ "$1" = "0" ]; then
276         umask 022
277         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
278         mv -f /etc/shells.new /etc/shells
279 fi
280
281 %post static
282 umask 022
283 if [ ! -f /etc/shells ]; then
284         echo "/bin/bash.static" > /etc/shells
285 else
286         if ! grep -q '^/bin/bash.static$' /etc/shells; then
287                 echo "/bin/bash.static" >> /etc/shells
288         fi
289 fi
290
291 %preun static
292 if [ "$1" = "0" ]; then
293         umask 022
294         grep -v /bin/bash.static /etc/shells > /etc/shells.new
295         mv -f /etc/shells.new /etc/shells
296 fi
297
298 %postun
299 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
300
301 %files -f %{name}.lang
302 %defattr(644,root,root,755)
303 %doc CHANGES NEWS README doc/{FAQ,INTRO}
304
305 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
306 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
307 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
308 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
309
310 %attr(755,root,root) /bin/bash
311 %attr(755,root,root) /bin/rbash
312 %attr(755,root,root) %{_bindir}/bashbug
313
314 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
315 %{_infodir}/bash.info*
316 %{_mandir}/man1/*
317 %lang(es) %{_mandir}/es/man1/*
318 %lang(fr) %{_mandir}/fr/man1/*
319 %lang(it) %{_mandir}/it/man1/*
320 %lang(ja) %{_mandir}/ja/man1/*
321 %lang(ko) %{_mandir}/ko/man1/*
322 %lang(nl) %{_mandir}/nl/man1/*
323 %lang(pl) %{_mandir}/pl/man1/*
324 %{_datadir}/%{name}
325
326 %if %{with static}
327 %files static
328 %defattr(644,root,root,755)
329 %attr(755,root,root) /bin/bash.static
330 %endif
This page took 0.085881 seconds and 3 git commands to generate.