]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- added using CVS keywords in %changelog (for automating them).
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(pl):    GNU Bourne Again Shell (bash)
3 Summary(de):    GNU Bourne Again Shell (bash)
4 Summary(fr):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.03
8 Release:        7
9 Group:          Shells
10 Group(pl):      Pow³oki
11 Copyright:      GPL
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/bash/%{name}-%{version}.tar.gz
13 Source1:        bashrc
14 Source2:        bash-skel-.bash_logout
15 Source3:        bash-skel-.bash_profile
16 Source4:        bash-skel-.bashrc
17 Source5:        bash-skel_pl-.bashrc
18 Patch0:         bash-arm.patch
19 Patch1:         bash-fixes.patch
20 Patch2:         bash-paths.patch
21 Patch3:         bash-security.patch
22 Patch4:         bash-autoconf.patch
23 Patch5:         bash-info.patch
24 BuildPrereq:    ncurses-devel
25 PreReq:         /sbin/install-info
26 PreReq:         grep
27 PreReq:         fileutils
28 Buildroot:      /tmp/%{name}-%{version}-root
29
30 %description
31 Bash is an sh-compatible command language interpreter that executes commands
32 read from the standard input or from a file.  Bash also incorporates useful
33 features from the Korn and C shells (ksh and csh).
34
35 Bash is ultimately intended to be a conformant implementation of the IEEE
36 Posix Shell and Tools specification (IEEE Working Group 1003.2).
37
38 %description -l de
39 Bash ist ein sh-kompatibler Befehlssprachen-Interpreter, der über die
40 Standardeingabe oder eine Datei gelesene Befehle ausführt. Bash beinhaltet
41 außerdem nützliche Funktionen der Korn- und der C-Shell (ksh und csh).
42
43 Bash soll eine kompatible Implementierung der 'IEEE Posix Shell and Tools
44 Specification' (IEEE Working Group 1003.2) sein.
45
46 %description -l fr
47 Bash est un interpréteur de commande compatible sh qui exécute les commandes
48 lues sur l'entrée standard ou depuis un fichier. Bash inclue également des
49 fonctionnalités utiles des shells Korn et C (ksh et csh).
50
51 Bash est prévu pour être une implémentation de shell conforme la
52 spécification Posix IEEE sur les shell et les outils (Groupe de travail IEEE
53 1003.2).
54
55 %description -l pl
56 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
57 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
58 shelli Korn i C (ksh i csh). 
59
60 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
61 specyfikacj± - IEEE Working Group 1003.2.
62
63 %description -l tr
64 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh uyumlu
65 bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C kabuklarýnýn (ksh ve
66 csh) kullanýþlý özelliklerini de kapsar. Bash, IEEE Posix Kabuk ve Araç
67 ayrýntýlarýna (IEEE Working Group 1003.2) uyumlu bir uygulama olarak
68 tasarlanmýþtýr.
69
70 %package static
71 Summary:        Staticly linked GNU Bourne Again Shell (bash)
72 Summary(pl):    Statycznie zlinkowany GNU Bourne Again Shell (bash)
73 Group:          Shells
74 Group(pl):      Pow³oki
75 Requires:       %{name}
76 PreReq:         grep
77 PreReq:         fileutils
78
79 %description static
80 Bash is an sh-compatible command language interpreter that executes commands
81 read from the standard input or from a file. Bash also incorporates useful
82 features from the Korn and C shells (ksh and csh).
83
84 Bash is ultimately intended to be a conformant implementation of the IEEE
85 Posix Shell and Tools specification (IEEE Working Group 1003.2).
86
87 This packege contains staticly linked version of bash.
88
89 %description static -l pl
90 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
91 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci shelli Korn i
92 C (ksh i csh).
93
94 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze
95 specyfikacj± - IEEE Working Group 1003.2.
96
97 W tym pakiecie jest statycznie zlinkowany bash.
98
99 %prep
100 %setup  -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105 %patch4 -p1
106 %patch5 -p1
107
108 %build
109 LDFLAGS="-s"; export LDFLAGS
110 %configure \
111         --enable-alias \
112         --enable-help-builtin \
113         --enable-history \
114         --enable-job-control \
115         --enable-restricted \
116         --enable-readline \
117         --with-curses \
118         --enable-extended-glob \
119         --enable-dparen-arithmetic \
120         --enable-static-link
121
122 make TERMCAP_LIB="-lncurses"
123 mv bash bash.static
124 make TERMCAP_LIB="-lncurses" STATIC_LD=""
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_mandir},%{_infodir}} \
129         $RPM_BUILD_ROOT/{bin,etc/skel/{C,pl}}
130
131 make install \
132         bindir=$RPM_BUILD_ROOT%{_bindir} \
133         infodir=$RPM_BUILD_ROOT%{_infodir} \
134         mandir=$RPM_BUILD_ROOT%{_mandir} 
135
136 mv $RPM_BUILD_ROOT%{_bindir}/bash       $RPM_BUILD_ROOT/bin
137 install -s bash.static  $RPM_BUILD_ROOT/bin
138
139 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/bashrc
140 echo    .so bash.1 >    $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
141 ln -sf  bash            $RPM_BUILD_ROOT/bin/rbash
142
143 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/C/.bash_logout
144 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/C/.bash_profile
145 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/C/.bashrc
146 install %{SOURCE5} $RPM_BUILD_ROOT/etc/skel/pl/.bashrc
147
148 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/bash.info,%{_mandir}/man1/*} \
149         NEWS README doc/{FAQ,INTRO}
150
151 %post
152 if [ ! -f /etc/shells ]; then
153         echo "/bin/bash" > /etc/shells
154         echo "/bin/rbash" >> /etc/shells
155 else
156         if ! grep '^/bin/bash$' /etc/shells > /dev/null; then
157                 echo "/bin/bash" >> /etc/shells
158         fi
159         if ! grep '^/bin/rbash$' /etc/shells > /dev/null; then
160                 echo "/bin/rbash" >> /etc/shells
161         fi
162 fi
163
164 /sbin/install-info %{_infodir}/bash.info.gz /etc/info-dir
165
166 %post static
167 if [ ! -f /etc/shells ]; then
168         echo "/bin/bash.static" > /etc/shells
169 else
170         if ! grep '^/bin/bash.static$' /etc/shells > /dev/null; then
171                 echo "/bin/bash.static" >> /etc/shells
172         fi
173 fi
174
175 %preun
176 if [ $1 = 0 ]; then
177         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
178         mv /etc/shells.new /etc/shells
179 fi
180
181 /sbin/install-info --delete %{_infodir}/bash.info.gz /etc/info-dir
182
183 %preun static
184 if [ $1 = 0 ]; then
185         grep -v /bin/bash.static /etc/shells > /etc/shells.new
186         mv /etc/shells.new /etc/shells
187 fi
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files
193 %defattr(644,root,root,755)
194 %doc {NEWS,README}.gz doc/{FAQ,INTRO}.gz
195
196 /etc/bashrc
197 /etc/skel/C/.*
198 %lang(pl) /etc/skel/pl/.*
199
200 %attr(755,root,root) /bin/bash
201 %attr(755,root,root) /bin/rbash
202 %attr(755,root,root) %{_bindir}/bashbug
203
204 %{_infodir}/bash.info.gz
205 %{_mandir}/man1/*
206
207 %files static
208 %attr(755,root,root) /bin/bash.static
This page took 0.067858 seconds and 3 git commands to generate.