]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
b8ccb8398ca27710c2cd52d7dea12891972c4bbc
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 ##
6 %define         _ver            3.1
7 %define         _patchlevel     005
8 %define         _rel            1
9 #
10 Summary:        GNU Bourne Again Shell (bash)
11 Summary(fr):    Le shell Bourne Again de GNU
12 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
13 Name:           bash
14 Version:        %{_ver}.%{_patchlevel}
15 Release:        %{_rel}%{?with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        ftp://ftp.gnu.org/pub/gnu/bash/%{name}-%{_ver}.tar.gz
19 # Source0-md5:  ef5304c4b22aaa5088972c792ed45d72
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
26 Patch0:         %{name}-paths.patch
27 Patch1:         %{name}-security.patch
28 Patch2:         %{name}-autoconf.patch
29 Patch3:         %{name}-info.patch
30 Patch4:         %{name}-profile.patch
31 Patch5:         %{name}-requires.patch
32 Patch6:         %{name}-compat.patch
33 Patch8:         %{name}-sighup.patch
34 Patch9:         %{name}-backup_history.patch
35 Patch10:        %{name}-pmake.patch
36 Patch11:        %{name}-act_like_sh.patch
37 Patch101:       ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/bash31-001
38 Patch102:       ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/bash31-002
39 Patch103:       ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/bash31-003
40 Patch104:       ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/bash31-004
41 Patch105:       ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/bash31-005
42 URL:            http://www.gnu.org/software/bash/
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  bison
46 BuildRequires:  ncurses-devel >= 5.2
47 BuildRequires:  readline-devel >= 5.1
48 BuildRequires:  texinfo
49 %if %{with static}
50 # Require static library only for static build
51 BuildRequires:  glibc-static >= 2.2
52 BuildRequires:  ncurses-static >= 5.2
53 BuildRequires:  readline-static >= 5.1
54 %endif
55 Requires(post,preun):   grep
56 Requires(preun):        fileutils
57 Requires:       readline >= 5.1
58 Requires:       setup >= 2.4.6-2
59 Obsoletes:      bash-doc
60 Obsoletes:      bash2
61 Obsoletes:      bash2-doc
62 Obsoletes:      etcskel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Bash is a GNU project sh-compatible shell or command language
67 interpreter. Bash (Bourne Again shell) incorporates useful features
68 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
69 be run by bash without modification. Bash offers several improvements
70 over sh, including command line editing, unlimited size command
71 history, job control, shell functions and aliases, indexed arrays of
72 unlimited size and integer arithmetic in any base from two to 64. Bash
73 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
74 Shell and Tools standard. Bash is the default shell for Linux
75 Mandrake. You should install bash because of its popularity and power.
76 You'll probably end up using it.
77
78 %description -l es
79 Bash es un interpretador de comandos compatible con sh, que ejecuta
80 comandos leídos de la entrada padrón o de un archivo. Bash también
81 incorpora características útiles de las shells Korn y C (ksh y csh).
82 Bash ha sido desarrollado para ser una adición compatible con la
83 especificación IEEE Posix para shells y herramientas (IEEE Working
84 Group 1003.2).
85
86 %description -l de
87 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
88 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
89 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
90 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
91 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
92 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
93 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
94 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
95 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
96 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
97 Mandrake.
98
99 %description -l fr
100 Bash est un shell (interpréteur de commande) du projet GNU, compatible
101 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
102 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
103 plupart des scripts sh sont exécutables sans modifications. Bash
104 comprend nombre d'améliorations par rapport à sh : édition de la ligne
105 de commande, historique illimité, contrôle des processus
106 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
107 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
108 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
109 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
110 l'installer du fait de sa puissance et de sa popularité. Vous finirez
111 probablement par l'utiliser.
112
113 %description -l pl
114 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
115 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
116 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
117 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
118 stosunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
119 historii poleceñ, funkcje i aliasy, indeksowane tablice
120 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
121 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
122 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
123
124 %description -l pt_BR
125 Bash é um interpretador de comandos compatível com sh, que executa
126 comandos lidos da entrada padrão ou de um arquivo. Bash também
127 incorpora características úteis das shells Korn e C (ksh e csh). Bash
128 tem sido desenvolvido para ser uma implementação compatível com a
129 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
130 1003.2).
131
132 %description -l ru
133 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
134 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
135 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
136 (ksh É csh).
137
138 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
139 Tools specification (IEEE Working Group 1003.2).
140
141 %description -l tr
142 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
143 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
144 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
145 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
146 uyumlu bir uygulama olarak tasarlanmýþtýr.
147
148 %description -l uk
149 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
150 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
151 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
152
153 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
154 Tools specification (IEEE Working Group 1003.2).
155
156 %package static
157 Summary:        Statically linked GNU Bourne Again Shell (bash)
158 Summary(pl):    Statycznie skonsolidowany GNU Bourne Again Shell (bash)
159 Group:          Applications/Shells
160 Requires(post,preun):   grep
161 Requires(preun):        fileutils
162 Requires:       %{name} = %{version}-%{release}
163
164 %description static
165 Bash is a GNU project sh-compatible shell or command language
166 interpreter. Bash (Bourne Again shell) incorporates useful features
167 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
168 be run by bash without modification. Bash offers several improvements
169 over sh, including command line editing, unlimited size command
170 history, job control, shell functions and aliases, indexed arrays of
171 unlimited size and integer arithmetic in any base from two to 64. Bash
172 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
173 Shell and Tools standard. Bash is the default shell for Linux
174 Mandrake. You should install bash because of its popularity and power.
175 You'll probably end up using it. This package contains statically
176 linked version of bash.
177
178 %description static -l pl
179 Bash jest zaawansowan± pow³ok±, która wykonuje komendy czytane ze
180 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
181 Korn i C (ksh i csh). Bash jest równie¿ zaimplementowany IEEE Posix
182 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
183 tym pakiecie jest wersja basha skonsolidowana statycznie.
184
185 %prep
186 %setup -q -n %{name}-%{_ver} -a5
187 # official patches
188 %patch101 -p0
189 %patch102 -p0
190 %patch103 -p0
191 %patch104 -p0
192 %patch105 -p0
193
194 %patch0 -p1
195 %patch1 -p1
196 %patch2 -p1
197 %patch3 -p1
198 %patch4 -p1
199 %patch5 -p1
200 %patch6 -p1
201 %patch8 -p1
202 %{?with_bash_history:%patch9 -p1}
203 #%patch10 -p1   -- no longer needed?
204 %patch11 -p1
205
206 %build
207 %{__autoconf}
208 cp -f /usr/share/automake/config.* support
209 for mode in %{?with_static:static} shared; do
210 %configure \
211         --enable-alias \
212         --enable-help-builtin \
213         --enable-history \
214         --enable-job-control \
215         --enable-restricted \
216         --enable-readline \
217         --with-curses \
218         --enable-extended-glob \
219         --enable-dparen-arithmetic \
220         --enable-separate-helpfiles \
221         --without-bash-malloc \
222         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
223         --with-installed-readline
224
225 %{__make} \
226         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
227
228 [ "$mode" = "static" ] && mv -f bash bash.static || :
229 done
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
234 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
235
236 %{__make} install \
237         DESTDIR=$RPM_BUILD_ROOT
238
239 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
240 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
241
242 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
243 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
244
245 for d in es fr it ja ko nl pl ; do
246         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
247         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
248         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
249 done
250
251 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
252
253 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
254 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
255 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
256 rm -f $RPM_BUILD_ROOT/usr/share/info/dir
257
258 %find_lang %{name}
259
260 %clean
261 rm -rf $RPM_BUILD_ROOT
262
263 %post
264 umask 022
265 if [ ! -f /etc/shells ]; then
266         echo "/bin/bash" > /etc/shells
267         echo "/bin/rbash" >> /etc/shells
268 else
269         if ! grep -q '^/bin/bash$' /etc/shells; then
270                 echo "/bin/bash" >> /etc/shells
271         fi
272         if ! grep -q '^/bin/rbash$' /etc/shells; then
273                 echo "/bin/rbash" >> /etc/shells
274         fi
275 fi
276
277 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
278
279 %preun
280 if [ "$1" = "0" ]; then
281         umask 022
282         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
283         mv -f /etc/shells.new /etc/shells
284 fi
285
286 %post static
287 umask 022
288 if [ ! -f /etc/shells ]; then
289         echo "/bin/bash.static" > /etc/shells
290 else
291         if ! grep -q '^/bin/bash.static$' /etc/shells; then
292                 echo "/bin/bash.static" >> /etc/shells
293         fi
294 fi
295
296 %preun static
297 if [ "$1" = "0" ]; then
298         umask 022
299         grep -v /bin/bash.static /etc/shells > /etc/shells.new
300         mv -f /etc/shells.new /etc/shells
301 fi
302
303 %postun
304 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
305
306 %files -f %{name}.lang
307 %defattr(644,root,root,755)
308 %doc CHANGES NEWS README doc/{FAQ,INTRO}
309
310 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
311 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
312 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
313 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
314
315 %attr(755,root,root) /bin/bash
316 %attr(755,root,root) /bin/rbash
317 %attr(755,root,root) %{_bindir}/bashbug
318
319 %{?with_bash_history:%attr(751,root,root) %dir /var/log/bash_hist}
320 %{_infodir}/bash.info*
321 %{_mandir}/man1/*
322 %lang(es) %{_mandir}/es/man1/*
323 %lang(fr) %{_mandir}/fr/man1/*
324 %lang(it) %{_mandir}/it/man1/*
325 %lang(ja) %{_mandir}/ja/man1/*
326 %lang(ko) %{_mandir}/ko/man1/*
327 %lang(nl) %{_mandir}/nl/man1/*
328 %lang(pl) %{_mandir}/pl/man1/*
329 %{_datadir}/%{name}
330
331 %if %{with static}
332 %files static
333 %defattr(644,root,root,755)
334 %attr(755,root,root) /bin/bash.static
335 %endif
This page took 0.051769 seconds and 3 git commands to generate.