]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- official patches
[packages/bash.git] / bash.spec
1 # TODO:
2 # - patch 001 (ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-001)
3 # - patch 002 (ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-002 ; replaces -po.patch)
4 # - patch 003 (ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-003)
5 # - broken octal mode in echo if first digit is non-zero (e.g. \137, breaks mc on dirs containing '_')
6 #
7 # Conditional build:
8 %bcond_without  static          # don't build static version
9 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
10 %bcond_without  tests   # do not perform "make test"
11 ##
12 %define         _ver            3.2
13 %define         _patchlevel     000
14 #
15 Summary:        GNU Bourne Again Shell (bash)
16 Summary(fr):    Le shell Bourne Again de GNU
17 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
18 Name:           bash
19 Version:        %{_ver}
20 #.%{_patchlevel}
21 Release:        1%{?with_bash_history:inv}
22 License:        GPL
23 Group:          Applications/Shells
24 Source0:        ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
25 # Source0-md5:  00bfa16d58e034e3c2aa27f390390d30
26 Source1:        %{name}rc
27 Source2:        %{name}-skel-.%{name}_logout
28 Source3:        %{name}-skel-.%{name}_profile
29 Source4:        %{name}-skel-.%{name}rc
30 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
32 Patch0:         %{name}-paths.patch
33 Patch1:         %{name}-security.patch
34 Patch2:         %{name}-autoconf.patch
35 Patch3:         %{name}-info.patch
36 Patch4:         %{name}-profile.patch
37 Patch5:         %{name}-requires.patch
38 Patch6:         %{name}-compat.patch
39 Patch8:         %{name}-sighup.patch
40 Patch9:         %{name}-backup_history.patch
41 Patch10:        %{name}-po.patch
42 Patch11:        %{name}-act_like_sh.patch
43 URL:            http://www.gnu.org/software/bash/
44 BuildRequires:  autoconf
45 BuildRequires:  automake
46 BuildRequires:  bison
47 BuildRequires:  ncurses-devel >= 5.2
48 BuildRequires:  readline-devel >= 5.2
49 BuildRequires:  texinfo
50 %if %{with static}
51 # Require static library only for static build
52 BuildRequires:  glibc-static >= 2.2
53 BuildRequires:  ncurses-static >= 5.2
54 BuildRequires:  readline-static >= 5.2
55 %endif
56 Requires(post,preun):   grep
57 Requires(preun):        fileutils
58 Requires:       grep
59 Requires:       readline >= 5.2
60 Requires:       setup >= 2.4.6-2
61 Obsoletes:      bash-doc
62 Obsoletes:      bash2
63 Obsoletes:      bash2-doc
64 Obsoletes:      etcskel
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 Bash is a GNU project sh-compatible shell or command language
69 interpreter. Bash (Bourne Again shell) incorporates useful features
70 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
71 be run by bash without modification. Bash offers several improvements
72 over sh, including command line editing, unlimited size command
73 history, job control, shell functions and aliases, indexed arrays of
74 unlimited size and integer arithmetic in any base from two to 64. Bash
75 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
76 Shell and Tools standard. Bash is the default shell for Linux
77 Mandrake. You should install bash because of its popularity and power.
78 You'll probably end up using it.
79
80 %description -l es
81 Bash es un interpretador de comandos compatible con sh, que ejecuta
82 comandos leídos de la entrada padrón o de un archivo. Bash también
83 incorpora características útiles de las shells Korn y C (ksh y csh).
84 Bash ha sido desarrollado para ser una adición compatible con la
85 especificación IEEE Posix para shells y herramientas (IEEE Working
86 Group 1003.2).
87
88 %description -l de
89 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
90 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
91 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
92 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
93 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
94 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
95 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
96 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
97 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
98 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
99 Mandrake.
100
101 %description -l fr
102 Bash est un shell (interpréteur de commande) du projet GNU, compatible
103 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
104 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
105 plupart des scripts sh sont exécutables sans modifications. Bash
106 comprend nombre d'améliorations par rapport à sh : édition de la ligne
107 de commande, historique illimité, contrôle des processus
108 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
109 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
110 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
111 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
112 l'installer du fait de sa puissance et de sa popularité. Vous finirez
113 probablement par l'utiliser.
114
115 %description -l pl
116 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
117 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
118 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
119 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
120 stosunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
121 historii poleceñ, funkcje i aliasy, indeksowane tablice
122 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
123 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
124 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
125
126 %description -l pt_BR
127 Bash é um interpretador de comandos compatível com sh, que executa
128 comandos lidos da entrada padrão ou de um arquivo. Bash também
129 incorpora características úteis das shells Korn e C (ksh e csh). Bash
130 tem sido desenvolvido para ser uma implementação compatível com a
131 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
132 1003.2).
133
134 %description -l ru
135 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
136 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
137 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
138 (ksh É csh).
139
140 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
141 Tools specification (IEEE Working Group 1003.2).
142
143 %description -l tr
144 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
145 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
146 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
147 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
148 uyumlu bir uygulama olarak tasarlanmýþtýr.
149
150 %description -l uk
151 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
152 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
153 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
154
155 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
156 Tools specification (IEEE Working Group 1003.2).
157
158 %package static
159 Summary:        Statically linked GNU Bourne Again Shell (bash)
160 Summary(pl):    Statycznie skonsolidowany GNU Bourne Again Shell (bash)
161 Group:          Applications/Shells
162 Requires(post,preun):   grep
163 Requires(preun):        fileutils
164 Requires:       %{name} = %{version}-%{release}
165
166 %description static
167 Bash is a GNU project sh-compatible shell or command language
168 interpreter. Bash (Bourne Again shell) incorporates useful features
169 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
170 be run by bash without modification. Bash offers several improvements
171 over sh, including command line editing, unlimited size command
172 history, job control, shell functions and aliases, indexed arrays of
173 unlimited size and integer arithmetic in any base from two to 64. Bash
174 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
175 Shell and Tools standard. Bash is the default shell for Linux
176 Mandrake. You should install bash because of its popularity and power.
177 You'll probably end up using it. This package contains statically
178 linked version of bash.
179
180 %description static -l pl
181 Bash jest zaawansowan± pow³ok±, która wykonuje komendy czytane ze
182 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
183 Korn i C (ksh i csh). Bash jest równie¿ zaimplementowany IEEE Posix
184 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
185 tym pakiecie jest wersja basha skonsolidowana statycznie.
186
187 %prep
188 %setup -q -n %{name}-%{_ver} -a5
189 %patch0 -p1
190 %patch1 -p1
191 %patch2 -p1
192 %patch3 -p1
193 %patch4 -p1
194 %patch5 -p1
195 %patch6 -p1
196 %patch8 -p1
197 %{?with_bash_history:%patch9 -p1}
198 %patch10 -p1
199 %patch11 -p1
200
201 %build
202 cp -f /usr/share/automake/config.* support
203 %{__autoconf}
204 for mode in %{?with_static:static} shared; do
205 %configure \
206         --enable-alias \
207         --enable-help-builtin \
208         --enable-history \
209         --enable-job-control \
210         --enable-restricted \
211         --enable-readline \
212         --with-curses \
213         --enable-extended-glob \
214         --enable-dparen-arithmetic \
215         --enable-separate-helpfiles \
216         --without-bash-malloc \
217         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
218         --with-installed-readline
219
220 %{__make} \
221         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
222
223 [ "$mode" = "static" ] && mv -f bash bash.static || :
224 done
225
226 %{?with_tests:%{__make} tests}
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
231 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
232
233 %{__make} install \
234         DESTDIR=$RPM_BUILD_ROOT
235
236 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
237 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
238
239 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
240 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
241
242 for d in es fr it ja ko nl pl ; do
243         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
244         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
245         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
246 done
247
248 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
249
250 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
251 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
252 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
253 rm -f $RPM_BUILD_ROOT/usr/share/info/dir
254
255 %find_lang %{name}
256
257 %clean
258 rm -rf $RPM_BUILD_ROOT
259
260 %post
261 umask 022
262 if [ ! -f /etc/shells ]; then
263         echo "/bin/bash" > /etc/shells
264         echo "/bin/rbash" >> /etc/shells
265 else
266         if ! grep -q '^/bin/bash$' /etc/shells; then
267                 echo "/bin/bash" >> /etc/shells
268         fi
269         if ! grep -q '^/bin/rbash$' /etc/shells; then
270                 echo "/bin/rbash" >> /etc/shells
271         fi
272 fi
273
274 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
275
276 %preun
277 if [ "$1" = "0" ]; then
278         umask 022
279         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
280         mv -f /etc/shells.new /etc/shells
281 fi
282
283 %post static
284 umask 022
285 if [ ! -f /etc/shells ]; then
286         echo "/bin/bash.static" > /etc/shells
287 else
288         if ! grep -q '^/bin/bash.static$' /etc/shells; then
289                 echo "/bin/bash.static" >> /etc/shells
290         fi
291 fi
292
293 %preun static
294 if [ "$1" = "0" ]; then
295         umask 022
296         grep -v /bin/bash.static /etc/shells > /etc/shells.new
297         mv -f /etc/shells.new /etc/shells
298 fi
299
300 %postun
301 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
302
303 %files -f %{name}.lang
304 %defattr(644,root,root,755)
305 %doc CHANGES NEWS README doc/{FAQ,INTRO}
306
307 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
308 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
309 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
310 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
311
312 %attr(755,root,root) /bin/bash
313 %attr(755,root,root) /bin/rbash
314 %attr(755,root,root) %{_bindir}/bashbug
315
316 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
317 %{_infodir}/bash.info*
318 %{_mandir}/man1/*
319 %lang(es) %{_mandir}/es/man1/*
320 %lang(fr) %{_mandir}/fr/man1/*
321 %lang(it) %{_mandir}/it/man1/*
322 %lang(ja) %{_mandir}/ja/man1/*
323 %lang(ko) %{_mandir}/ko/man1/*
324 %lang(nl) %{_mandir}/nl/man1/*
325 %lang(pl) %{_mandir}/pl/man1/*
326 %{_datadir}/%{name}
327
328 %if %{with static}
329 %files static
330 %defattr(644,root,root,755)
331 %attr(755,root,root) /bin/bash.static
332 %endif
This page took 0.057551 seconds and 3 git commands to generate.