]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- added Group(pl).
[packages/bash.git] / bash.spec
1 Summary:        GNU Bourne Again Shell (bash)
2 Summary(pl):    GNU Bourne Again Shell (bash)
3 Summary(de):    GNU Bourne Again Shell (bash)
4 Summary(fr):    GNU Bourne Again Shell (bash)
5 Summary(tr):    GNU Bourne Again Shell (bash)
6 Name:           bash
7 Version:        2.03
8 Release:        1
9 Group:          Shells
10 Group(pl):      Pow³oki
11 Copyright:      GPL
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
13 Source1:        bashrc
14 Patch0:         bash-arm.patch
15 Patch1:         bash-fixes.patch
16 Patch2:         bash-paths.patch
17 Patch3:         bash-security.patch
18 Prereq:         fileutils
19 Prereq:         grep
20 Buildroot:      /tmp/%{name}-%{version}-root
21
22 %description
23 Bash is an sh-compatible command language interpreter that
24 executes commands read from the standard input or from a
25 file.  Bash also incorporates useful features from the
26 Korn and C shells (ksh and csh).
27
28 Bash is ultimately intended to be a conformant implementation
29 of the IEEE Posix Shell and Tools specification (IEEE
30 Working Group 1003.2).
31
32 %description -l pl
33 Bash jest zaawansowanym shellem, który wykonuje komendy czytane ze
34 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci 
35 shelli Korn i C (ksh i csh). 
36
37 Bash ma równie¿ zaimplementowany IEEE Posix Shell oraz jest zgodny ze 
38 specyfikacj± - IEEE Working Group 1003.2.
39
40 %description -l de
41 Bash ist ein sh-kompatibler Befehlssprachen-Interpreter, der
42 über die Standardeingabe oder eine Datei gelesene Befehle ausführt.
43 Bash beinhaltet außerdem nützliche Funktionen der Korn- und der
44 C-Shell (ksh und csh).
45
46 Bash soll eine kompatible Implementierung der
47 'IEEE Posix Shell and Tools Specification' (IEEE
48 Working Group 1003.2) sein.
49
50 %description -l fr
51 Bash est un interpréteur de commande compatible sh qui exécute
52 les commandes lues sur l'entrée standard ou depuis un fichier.
53 Bash inclue également des fonctionnalités utiles des shells Korn et C
54 (ksh et csh).
55
56 Bash est prévu pour être une implémentation de shell conforme la
57 spécification Posix IEEE sur les shell et les outils (Groupe de 
58 travail IEEE 1003.2).
59
60 %description -l tr
61 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh uyumlu
62 bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C kabuklarýnýn (ksh ve
63 csh) kullanýþlý özelliklerini de kapsar. Bash, IEEE Posix Kabuk ve Araç
64 ayrýntýlarýna (IEEE Working Group 1003.2) uyumlu bir uygulama olarak
65 tasarlanmýþtýr.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72 %patch3 -p1
73
74 %build
75 LDFLAGS="-s" CFLAGS="$RPM_OPT_FLAGS" \
76 ./configure \
77         --prefix=/usr \
78         --enable-alias \
79         --enable-help-builtin \
80         --enable-history \
81         --enable-job-control \
82         --enable-restricted \
83         --enable-readline \
84         --enable-static-link
85 make 
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 install -d $RPM_BUILD_ROOT/{usr,bin,etc}
91 make prefix=$RPM_BUILD_ROOT/usr install
92
93 mv $RPM_BUILD_ROOT/usr/bin/bash $RPM_BUILD_ROOT/bin/bash
94 rm -f $RPM_BUILD_ROOT/usr/bin/installed-bash
95
96 rm -f $RPM_BUILD_ROOT/usr/bin/bash.old
97
98 install %{SOURCE1} $RPM_BUILD_ROOT/etc/bashrc
99
100 echo .so bash.1 > $RPM_BUILD_ROOT/usr/man/man1/rbash.1
101
102 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
103
104 gzip -9nf $RPM_BUILD_ROOT/usr/{info/bash.info,man/man1/*} \
105         NEWS README 
106
107 %post
108 mv /etc/shells /etc/shells.org
109 (cat /etc/shells.org; echo "/bin/bash"; echo "/bin/rbash" ) | sort -u > /etc/shells
110 rm -f /etc/shells.org
111
112 %preun
113 mv /etc/shells /etc/shells.org
114 cat /etc/shells.org | egrep -v "/bin/bash|/bin/rbash" > /etc/shells
115 rm -f /etc/shells.org
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc {NEWS,README}.gz
123
124 /etc/bashrc
125
126 %attr(755,root,root) /bin/*
127 %attr(755,root,root) /usr/bin/*
128
129 /usr/info/bash.info.gz
130 /usr/man/man1/*
131
132 %changelog
133 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
134   [2.03-1]
135 - removed /bin/sh link from bash (thi is now provided by pdksh),
136 - removed man group from man pages,
137 - gzipping insterad bzipping2 man pages,
138 - rewrited %post, %preun,
139 - removed %config and %verify rules from /etc/bashrc (all extensions can be
140   added by adding /etc/profile.d/*.sh scripts).
141
142 * Sun Sep 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
143   [2.02.1-1d]
144 - fixed files permissions,
145 - build with restricted shell support.
146
147 * Wed Jun 17 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
148   [14.7-9d]
149 - build against glibc-2.1,
150 - translation modified for pl,
151 - added %defattr support,
152 - build from non root's account.
153
154 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
155 - translations modified for de, fr, tr
156
157 * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
158 - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
159   is based on a change made in bash 2.0.  Should fix some early exit
160   problems with suspends and fg.
161
162 * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
163 - added %clean
164
165 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
166 - added comment explaining why install-info isn't used
167 - added mips patch 
168
169 * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
170 - added BuildRoot
171
172 * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
173 - built against glibc
This page took 0.041023 seconds and 3 git commands to generate.