]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
32992fd6a941598af72731f3901e9aa0a8806c2c
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 ##
6 Summary:        GNU Bourne Again Shell (bash)
7 Summary(es):    GNU Bourne Again Shell (bash)
8 Summary(fr):    Le shell Bourne Again de GNU
9 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
10 Summary(pt_BR): GNU Bourne Again Shell (bash)
11 Summary(ru):    GNU Bourne Again Shell (bash)
12 Summary(uk):    GNU Bourne Again Shell (bash)
13 Name:           bash
14 Version:        3.0
15 Release:        2%{?with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        ftp://ftp.gnu.org/pub/gnu/bash/%{name}-%{version}.tar.gz
19 # Source0-md5:  26c4d642e29b3533d8d754995bc277b3
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
26 Patch0:         %{name}-paths.patch
27 Patch1:         %{name}-security.patch
28 Patch2:         %{name}-autoconf.patch
29 Patch3:         %{name}-info.patch
30 Patch4:         %{name}-profile.patch
31 Patch5:         %{name}-requires.patch
32 Patch6:         %{name}-compat.patch
33 Patch7:         %{name}-rlimit_locks.patch
34 Patch8:         %{name}-sighup.patch
35 Patch9:         %{name}-backup_history.patch
36 Patch10:        %{name}-pmake.patch
37 Patch11:        %{name}-act_like_sh.patch
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  bison
41 BuildRequires:  ncurses-devel >= 5.2
42 BuildRequires:  readline-devel >= 5.0
43 BuildRequires:  texinfo
44 %if %{with static}
45 # Require static library only for static build
46 BuildRequires:  glibc-static >= 2.2
47 BuildRequires:  ncurses-static >= 5.2
48 BuildRequires:  readline-static >= 5.0
49 %endif
50 PreReq:         grep
51 Requires(preun):        fileutils
52 Requires:       setup >= 2.4.6-2
53 Requires:       readline >= 5.0
54 Obsoletes:      bash-doc
55 Obsoletes:      bash2
56 Obsoletes:      bash2-doc
57 Obsoletes:      etcskel
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Bash is a GNU project sh-compatible shell or command language
62 interpreter. Bash (Bourne Again shell) incorporates useful features
63 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
64 be run by bash without modification. Bash offers several improvements
65 over sh, including command line editing, unlimited size command
66 history, job control, shell functions and aliases, indexed arrays of
67 unlimited size and integer arithmetic in any base from two to 64. Bash
68 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
69 Shell and Tools standard. Bash is the default shell for Linux
70 Mandrake. You should install bash because of its popularity and power.
71 You'll probably end up using it.
72
73 %description -l es
74 Bash es un interpretador de comandos compatible con sh, que ejecuta
75 comandos leídos de la entrada padrón o de un archivo. Bash también
76 incorpora características útiles de las shells Korn y C (ksh y csh).
77 Bash ha sido desarrollado para ser una adición compatible con la
78 especificación IEEE Posix para shells y herramientas (IEEE Working
79 Group 1003.2).
80
81 %description -l de
82 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
83 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
84 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
85 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
86 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
87 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
88 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
89 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
90 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
91 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
92 Mandrake.
93
94 %description -l fr
95 Bash est un shell (interpréteur de commande) du projet GNU, compatible
96 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
97 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
98 plupart des scripts sh sont exécutables sans modifications. Bash
99 comprend nombre d'améliorations par rapport à sh : édition de la ligne
100 de commande, historique illimité, contrôle des processus
101 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
102 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
103 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
104 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
105 l'installer du fait de sa puissance et de sa popularité. Vous finirez
106 probablement par l'utiliser.
107
108 %description -l pl
109 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
110 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
111 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
112 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
113 stosunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
114 historii poleceñ, funkcje i aliasy, indeksowane tablice
115 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
116 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
117 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
118
119 %description -l pt_BR
120 Bash é um interpretador de comandos compatível com sh, que executa
121 comandos lidos da entrada padrão ou de um arquivo. Bash também
122 incorpora características úteis das shells Korn e C (ksh e csh). Bash
123 tem sido desenvolvido para ser uma implementação compatível com a
124 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
125 1003.2).
126
127 %description -l ru
128 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
129 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
130 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
131 (ksh É csh).
132
133 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
134 Tools specification (IEEE Working Group 1003.2).
135
136 %description -l tr
137 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
138 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
139 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
140 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
141 uyumlu bir uygulama olarak tasarlanmýþtýr.
142
143 %description -l uk
144 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
145 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
146 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
147
148 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
149 Tools specification (IEEE Working Group 1003.2).
150
151 %package static
152 Summary:        Statically linked GNU Bourne Again Shell (bash)
153 Summary(pl):    Statycznie skonsolidowany GNU Bourne Again Shell (bash)
154 Group:          Applications/Shells
155 Requires(post,preun):   grep
156 Requires(preun):        fileutils
157 Requires:       %{name} = %{version}-%{release}
158
159 %description static
160 Bash is a GNU project sh-compatible shell or command language
161 interpreter. Bash (Bourne Again shell) incorporates useful features
162 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
163 be run by bash without modification. Bash offers several improvements
164 over sh, including command line editing, unlimited size command
165 history, job control, shell functions and aliases, indexed arrays of
166 unlimited size and integer arithmetic in any base from two to 64. Bash
167 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
168 Shell and Tools standard. Bash is the default shell for Linux
169 Mandrake. You should install bash because of its popularity and power.
170 You'll probably end up using it. This package contains statically
171 linked version of bash.
172
173 %description static -l pl
174 Bash jest zaawansowan± pow³ok±, która wykonuje komendy czytane ze
175 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
176 Korn i C (ksh i csh). Bash jest równie¿ zaimplementowany IEEE Posix
177 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
178 tym pakiecie jest wersja basha skonsolidowana statycznie.
179
180 %prep
181 %setup -q -a5
182 %patch0 -p1
183 %patch1 -p1
184 %patch2 -p1
185 %patch3 -p1
186 %patch4 -p1
187 %patch5 -p1
188 %patch6 -p1
189 %patch7 -p1
190 %patch8 -p1
191 %{?with_bash_history:%patch9 -p1}
192 #%patch10 -p1   -- no longer needed?
193 %patch11 -p1
194
195 echo %{version} > _distribution
196 echo %{release} > _patchlevel
197
198 %build
199 %{__autoconf}
200 cp -f /usr/share/automake/config.* support
201 for mode in %{?with_static:static} shared; do
202 %configure \
203         --enable-alias \
204         --enable-help-builtin \
205         --enable-history \
206         --enable-job-control \
207         --enable-restricted \
208         --enable-readline \
209         --with-curses \
210         --enable-extended-glob \
211         --enable-dparen-arithmetic \
212         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
213         --with-installed-readline
214
215 %{__make} \
216         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
217
218 [ "$mode" = "static" ] && mv -f bash bash.static || :
219 done
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 install -d $RPM_BUILD_ROOT/{bin,etc/skel}
224 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
225
226 %{__make} install \
227         DESTDIR=$RPM_BUILD_ROOT
228
229 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
230 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
231
232 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
233 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
234
235 for d in es fr it ja ko nl pl ; do
236         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
237         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
238         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
239 done
240
241 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
242
243 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
244 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
245 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
246
247 %find_lang %{name}
248
249 %clean
250 rm -rf $RPM_BUILD_ROOT
251
252 %post
253 umask 022
254 if [ ! -f /etc/shells ]; then
255         echo "/bin/bash" > /etc/shells
256         echo "/bin/rbash" >> /etc/shells
257 else
258         if ! grep -q '^/bin/bash$' /etc/shells; then
259                 echo "/bin/bash" >> /etc/shells
260         fi
261         if ! grep -q '^/bin/rbash$' /etc/shells; then
262                 echo "/bin/rbash" >> /etc/shells
263         fi
264 fi
265
266 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
267
268 %preun
269 if [ "$1" = "0" ]; then
270         umask 022
271         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
272         mv -f /etc/shells.new /etc/shells
273 fi
274
275 %post static
276 umask 022
277 if [ ! -f /etc/shells ]; then
278         echo "/bin/bash.static" > /etc/shells
279 else
280         if ! grep -q '^/bin/bash.static$' /etc/shells; then
281                 echo "/bin/bash.static" >> /etc/shells
282         fi
283 fi
284
285 %preun static
286 if [ "$1" = "0" ]; then
287         umask 022
288         grep -v /bin/bash.static /etc/shells > /etc/shells.new
289         mv -f /etc/shells.new /etc/shells
290 fi
291
292 %postun
293 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
294
295 %files -f %{name}.lang
296 %defattr(644,root,root,755)
297 %doc CHANGES NEWS README doc/{FAQ,INTRO}
298
299 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/bashrc
300 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bash_logout
301 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bash_profile
302 %config(noreplace,missingok) %verify(not md5 size mtime) /etc/skel/.bashrc
303
304 %attr(755,root,root) /bin/bash
305 %attr(755,root,root) /bin/rbash
306 %attr(755,root,root) %{_bindir}/bashbug
307
308 %{?with_bash_history:%attr(751,root,root) %dir /var/log/bash_hist}
309 %{_infodir}/bash.info*
310 %{_mandir}/man1/*
311 %lang(es) %{_mandir}/es/man1/*
312 %lang(fr) %{_mandir}/fr/man1/*
313 %lang(it) %{_mandir}/it/man1/*
314 %lang(ja) %{_mandir}/ja/man1/*
315 %lang(ko) %{_mandir}/ko/man1/*
316 %lang(nl) %{_mandir}/nl/man1/*
317 %lang(pl) %{_mandir}/pl/man1/*
318
319 %if %{with static}
320 %files static
321 %defattr(644,root,root,755)
322 %attr(755,root,root) /bin/bash.static
323 %endif
This page took 0.079595 seconds and 3 git commands to generate.