]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
265fda6d10eaeab9a6db49241da7cc54b59a0a5c
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %define         _ver            3.2
8 %define         _patchlevel     15
9 %define         _rel            1
10 Summary:        GNU Bourne Again Shell (bash)
11 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
12 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
13 Name:           bash
14 Version:        %{_ver}.%{_patchlevel}
15 Release:        %{_rel}%{?with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
19 # Source0-md5:  00bfa16d58e034e3c2aa27f390390d30
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
26 # based on GNU TP; omitted: eo (not supported), rw (empty)
27 Source6:        %{name}-translations.tar.bz2
28 # Source6-md5:  99701bc1f919cfc527cb95fadbc66c93
29 Patch0:         %{name}-paths.patch
30 Patch1:         %{name}-security.patch
31 Patch2:         %{name}-autoconf.patch
32 Patch3:         %{name}-info.patch
33 Patch4:         %{name}-profile.patch
34 Patch5:         %{name}-requires.patch
35 Patch6:         %{name}-compat.patch
36 Patch8:         %{name}-sighup.patch
37 Patch9:         %{name}-backup_history.patch
38 Patch10:        %{name}-act_like_sh.patch
39 %patchset_source -f ftp://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03g 1 %{_patchlevel}
40 URL:            http://www.gnu.org/software/bash/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  bison
44 BuildRequires:  ncurses-devel >= 5.2
45 BuildRequires:  readline-devel >= 5.2
46 BuildRequires:  rpmbuild(macros) >= 1.353
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  texinfo
49 %if %{with static}
50 # Require static library only for static build
51 BuildRequires:  glibc-static >= 2.2
52 BuildRequires:  ncurses-static >= 5.2
53 BuildRequires:  readline-static >= 5.2
54 %endif
55 Requires(post,preun):   grep
56 Requires(preun):        fileutils
57 Requires:       grep
58 Requires:       readline >= 5.2
59 Requires:       setup >= 2.4.6-2
60 Obsoletes:      bash-doc
61 Obsoletes:      bash2
62 Obsoletes:      bash2-doc
63 Obsoletes:      etcskel
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Bash is a GNU project sh-compatible shell or command language
68 interpreter. Bash (Bourne Again shell) incorporates useful features
69 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
70 be run by bash without modification. Bash offers several improvements
71 over sh, including command line editing, unlimited size command
72 history, job control, shell functions and aliases, indexed arrays of
73 unlimited size and integer arithmetic in any base from two to 64. Bash
74 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
75 Shell and Tools standard. Bash is the default shell for Linux
76 Mandrake. You should install bash because of its popularity and power.
77 You'll probably end up using it.
78
79 %description -l es.UTF-8
80 Bash es un interpretador de comandos compatible con sh, que ejecuta
81 comandos leídos de la entrada padrón o de un archivo. Bash también
82 incorpora características útiles de las shells Korn y C (ksh y csh).
83 Bash ha sido desarrollado para ser una adición compatible con la
84 especificación IEEE Posix para shells y herramientas (IEEE Working
85 Group 1003.2).
86
87 %description -l de.UTF-8
88 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
89 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
90 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
91 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
92 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
93 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
94 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
95 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
96 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
97 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
98 Mandrake.
99
100 %description -l fr.UTF-8
101 Bash est un shell (interpréteur de commande) du projet GNU, compatible
102 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
103 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
104 plupart des scripts sh sont exécutables sans modifications. Bash
105 comprend nombre d'améliorations par rapport à sh : édition de la ligne
106 de commande, historique illimité, contrôle des processus
107 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
108 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
109 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
110 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
111 l'installer du fait de sa puissance et de sa popularité. Vous finirez
112 probablement par l'utiliser.
113
114 %description -l pl.UTF-8
115 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
116 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
117 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
118 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
119 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
120 historii poleceń, funkcje i aliasy, indeksowane tablice
121 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
122 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
123 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
124
125 %description -l pt_BR.UTF-8
126 Bash é um interpretador de comandos compatível com sh, que executa
127 comandos lidos da entrada padrão ou de um arquivo. Bash também
128 incorpora características úteis das shells Korn e C (ksh e csh). Bash
129 tem sido desenvolvido para ser uma implementação compatível com a
130 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
131 1003.2).
132
133 %description -l ru.UTF-8
134 Bash - это sh-совместимый интерпретатор командного языка (shell),
135 исполняющий команды, поступающие со стандартного ввода или из файла.
136 Bash включает полезные расширения из интерпретаторов Korn и C shell
137 (ksh и csh).
138
139 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
140 Tools specification (IEEE Working Group 1003.2).
141
142 %description -l tr.UTF-8
143 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
144 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
145 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
146 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
147 uyumlu bir uygulama olarak tasarlanmıştır.
148
149 %description -l uk.UTF-8
150 Bash - це sh-сумістний інтерпретатор командної мови (shell),
151 виконуючий команди зі стандартного вводу або з файла. Bash містить
152 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
153
154 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
155 Tools specification (IEEE Working Group 1003.2).
156
157 %package static
158 Summary:        Statically linked GNU Bourne Again Shell (bash)
159 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
160 Group:          Applications/Shells
161 Requires(post,preun):   grep
162 Requires(preun):        fileutils
163 Requires:       %{name} = %{version}-%{release}
164
165 %description static
166 Bash is a GNU project sh-compatible shell or command language
167 interpreter. Bash (Bourne Again shell) incorporates useful features
168 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
169 be run by bash without modification. Bash offers several improvements
170 over sh, including command line editing, unlimited size command
171 history, job control, shell functions and aliases, indexed arrays of
172 unlimited size and integer arithmetic in any base from two to 64. Bash
173 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
174 Shell and Tools standard. Bash is the default shell for Linux
175 Mandrake. You should install bash because of its popularity and power.
176 You'll probably end up using it. This package contains statically
177 linked version of bash.
178
179 %description static -l pl.UTF-8
180 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
181 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
182 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
183 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
184 tym pakiecie jest wersja basha skonsolidowana statycznie.
185
186 %prep
187 %setup -q -n %{name}-%{_ver} -a5
188 # official patches
189 %patchset_patch 1 %{_patchlevel}
190 %patch0 -p1
191 %patch1 -p1
192 %patch2 -p1
193 %patch3 -p1
194 %patch4 -p1
195 %patch5 -p1
196 %patch6 -p1
197 %patch8 -p1
198 %{?with_bash_history:%patch9 -p1}
199 %patch10 -p1
200 tar xjf %SOURCE6 -C po
201 sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
202
203 %build
204 cp -f /usr/share/automake/config.* support
205 %{__autoconf}
206 for mode in %{?with_static:static} shared; do
207 %configure \
208         --enable-alias \
209         --enable-help-builtin \
210         --enable-history \
211         --enable-job-control \
212         --enable-restricted \
213         --enable-readline \
214         --with-curses \
215         --enable-extended-glob \
216         --enable-dparen-arithmetic \
217         --enable-separate-helpfiles \
218         --without-bash-malloc \
219         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
220         --with-installed-readline
221
222 %{__make} \
223         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
224
225 [ "$mode" = "static" ] && mv -f bash bash.static || :
226 done
227
228 %{?with_tests:%{__make} tests}
229
230 %install
231 rm -rf $RPM_BUILD_ROOT
232 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
233 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
234
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
239 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
240
241 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
242 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
243
244 for d in es fr it ja ko nl pl ; do
245         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
246         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
247         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
248 done
249
250 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
251
252 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
253 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
254 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
255 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
256
257 %find_lang %{name}
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post
263 umask 022
264 if [ ! -f /etc/shells ]; then
265         echo "/bin/bash" > /etc/shells
266         echo "/bin/rbash" >> /etc/shells
267 else
268         if ! grep -q '^/bin/bash$' /etc/shells; then
269                 echo "/bin/bash" >> /etc/shells
270         fi
271         if ! grep -q '^/bin/rbash$' /etc/shells; then
272                 echo "/bin/rbash" >> /etc/shells
273         fi
274 fi
275
276 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
277
278 %preun
279 if [ "$1" = "0" ]; then
280         umask 022
281         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
282         mv -f /etc/shells.new /etc/shells
283 fi
284
285 %post static
286 umask 022
287 if [ ! -f /etc/shells ]; then
288         echo "/bin/bash.static" > /etc/shells
289 else
290         if ! grep -q '^/bin/bash.static$' /etc/shells; then
291                 echo "/bin/bash.static" >> /etc/shells
292         fi
293 fi
294
295 %preun static
296 if [ "$1" = "0" ]; then
297         umask 022
298         grep -v /bin/bash.static /etc/shells > /etc/shells.new
299         mv -f /etc/shells.new /etc/shells
300 fi
301
302 %postun
303 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
304
305 %files -f %{name}.lang
306 %defattr(644,root,root,755)
307 %doc CHANGES NEWS README doc/{FAQ,INTRO}
308
309 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
310 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
311 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
312 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
313
314 %attr(755,root,root) /bin/bash
315 %attr(755,root,root) /bin/rbash
316 %attr(755,root,root) %{_bindir}/bashbug
317
318 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
319 %{_infodir}/bash.info*
320 %{_mandir}/man1/*
321 %lang(es) %{_mandir}/es/man1/*
322 %lang(fr) %{_mandir}/fr/man1/*
323 %lang(it) %{_mandir}/it/man1/*
324 %lang(ja) %{_mandir}/ja/man1/*
325 %lang(ko) %{_mandir}/ko/man1/*
326 %lang(nl) %{_mandir}/nl/man1/*
327 %lang(pl) %{_mandir}/pl/man1/*
328 %{_datadir}/%{name}
329
330 %if %{with static}
331 %files static
332 %defattr(644,root,root,755)
333 %attr(755,root,root) /bin/bash.static
334 %endif
This page took 0.090068 seconds and 3 git commands to generate.