]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- up to 4.3.27 (it's effectively the same as our 4.3.26-2)
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 %bcond_without  tests   # do not perform "make test"
6
7 # NOTE: when updating patchleve, do not forget to update 'sources' file!
8 %define         ver             4.3
9 %define         patchlevel      27
10 %define         rel             1
11 Summary:        GNU Bourne Again Shell (bash)
12 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
13 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
14 Name:           bash
15 Version:        %{ver}%{?patchlevel:.%{patchlevel}}
16 Release:        %{rel}%{?with_bash_history:inv}
17 License:        GPL
18 Group:          Applications/Shells
19 Source0:        http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
20 # Source0-md5:  81348932d5da294953e15d4814c74dd1
21 Source1:        %{name}rc
22 Source2:        %{name}-skel-.bash_logout
23 Source3:        %{name}-skel-.bash_profile
24 Source4:        %{name}-skel-.bashrc
25 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
26 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
27 Patch0:         %{name}-paths.patch
28 Patch1:         %{name}-security.patch
29 Patch2:         %{name}-autoconf.patch
30 Patch3:         %{name}-info.patch
31 Patch4:         %{name}-profile.patch
32 Patch5:         %{name}-requires.patch
33 Patch6:         %{name}-compat.patch
34 Patch8:         %{name}-sighup.patch
35 Patch9:         %{name}-backup_history.patch
36 Patch10:        %{name}-act_like_sh.patch
37 Patch11:        %{name}-elinks_cont.patch
38 Patch12:        %{name}-pl.po-update.patch
39 # from FC
40 Patch13:        bash-4.2-cve-2014-7169-2.patch
41 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
42 URL:            http://www.gnu.org/software/bash/
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  bison
46 BuildRequires:  ncurses-devel >= 5.2
47 BuildRequires:  readline-devel >= 6.3
48 BuildRequires:  rpmbuild(macros) >= 1.462
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  texinfo
51 %if %{with static}
52 # Require static library only for static build
53 BuildRequires:  glibc-static >= 2.2
54 BuildRequires:  ncurses-static >= 5.2
55 BuildRequires:  readline-static >= 6.3
56 %endif
57 Requires:       readline >= 6.3
58 Requires:       setup >= 2.4.6-2
59 Obsoletes:      bash-doc
60 Obsoletes:      bash2
61 Obsoletes:      bash2-doc
62 Obsoletes:      etcskel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Bash is a GNU project sh-compatible shell or command language
67 interpreter. Bash (Bourne Again shell) incorporates useful features
68 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
69 be run by bash without modification. Bash offers several improvements
70 over sh, including command line editing, unlimited size command
71 history, job control, shell functions and aliases, indexed arrays of
72 unlimited size and integer arithmetic in any base from two to 64. Bash
73 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
74 Shell and Tools standard. Bash is the default shell for Linux
75 Mandrake. You should install bash because of its popularity and power.
76 You'll probably end up using it.
77
78 %description -l es.UTF-8
79 Bash es un interpretador de comandos compatible con sh, que ejecuta
80 comandos leídos de la entrada padrón o de un archivo. Bash también
81 incorpora características útiles de las shells Korn y C (ksh y csh).
82 Bash ha sido desarrollado para ser una adición compatible con la
83 especificación IEEE Posix para shells y herramientas (IEEE Working
84 Group 1003.2).
85
86 %description -l de.UTF-8
87 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
88 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
89 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
90 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
91 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
92 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
93 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
94 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
95 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
96 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
97 Mandrake.
98
99 %description -l fr.UTF-8
100 Bash est un shell (interpréteur de commande) du projet GNU, compatible
101 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
102 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
103 plupart des scripts sh sont exécutables sans modifications. Bash
104 comprend nombre d'améliorations par rapport à sh : édition de la ligne
105 de commande, historique illimité, contrôle des processus
106 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
107 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
108 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
109 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
110 l'installer du fait de sa puissance et de sa popularité. Vous finirez
111 probablement par l'utiliser.
112
113 %description -l pl.UTF-8
114 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
115 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
116 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
117 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
118 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
119 historii poleceń, funkcje i aliasy, indeksowane tablice
120 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
121 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
122 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
123
124 %description -l pt_BR.UTF-8
125 Bash é um interpretador de comandos compatível com sh, que executa
126 comandos lidos da entrada padrão ou de um arquivo. Bash também
127 incorpora características úteis das shells Korn e C (ksh e csh). Bash
128 tem sido desenvolvido para ser uma implementação compatível com a
129 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
130 1003.2).
131
132 %description -l ru.UTF-8
133 Bash - это sh-совместимый интерпретатор командного языка (shell),
134 исполняющий команды, поступающие со стандартного ввода или из файла.
135 Bash включает полезные расширения из интерпретаторов Korn и C shell
136 (ksh и csh).
137
138 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
139 Tools specification (IEEE Working Group 1003.2).
140
141 %description -l tr.UTF-8
142 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
143 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
144 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
145 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
146 uyumlu bir uygulama olarak tasarlanmıştır.
147
148 %description -l uk.UTF-8
149 Bash - це sh-сумістний інтерпретатор командної мови (shell),
150 виконуючий команди зі стандартного вводу або з файла. Bash містить
151 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
152
153 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
154 Tools specification (IEEE Working Group 1003.2).
155
156 %package static
157 Summary:        Statically linked GNU Bourne Again Shell (bash)
158 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
159 Group:          Applications/Shells
160 Requires:       %{name} = %{version}-%{release}
161
162 %description static
163 Bash is a GNU project sh-compatible shell or command language
164 interpreter. Bash (Bourne Again shell) incorporates useful features
165 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
166 be run by bash without modification. Bash offers several improvements
167 over sh, including command line editing, unlimited size command
168 history, job control, shell functions and aliases, indexed arrays of
169 unlimited size and integer arithmetic in any base from two to 64. Bash
170 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
171 Shell and Tools standard. Bash is the default shell for Linux
172 Mandrake. You should install bash because of its popularity and power.
173 You'll probably end up using it. This package contains statically
174 linked version of bash.
175
176 %description static -l pl.UTF-8
177 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
178 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
179 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
180 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
181 tym pakiecie jest wersja basha skonsolidowana statycznie.
182
183 %prep
184 %setup -q -n %{name}-%{ver} -a5
185 # official patches
186 %{?patchlevel:%patchset_patch 1 %{patchlevel}}
187 %patch0 -p1
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191 %patch4 -p1
192 %patch5 -p1
193 %patch6 -p1
194 %patch8 -p1
195 %{?with_bash_history:%patch9 -p1}
196 %patch10 -p1
197 %patch11 -p1
198 %patch12 -p1
199 %patch13 -p0
200
201 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
202
203 %build
204 cp -f /usr/share/automake/config.* support
205 %{__autoconf}
206 for mode in %{?with_static:static} shared; do
207 %configure \
208         --enable-alias \
209         --enable-help-builtin \
210         --enable-history \
211         --enable-job-control \
212         --enable-restricted \
213         --enable-readline \
214         --with-curses \
215         --enable-extended-glob \
216         --enable-dparen-arithmetic \
217         --enable-separate-helpfiles \
218         --without-bash-malloc \
219         $([ "$mode" = "static" ] && echo "--enable-static-link") \
220         --with-installed-readline
221
222 %{__make} \
223         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
224
225 [ "$mode" = "static" ] && mv -f bash bash.static
226 done
227
228 %{?with_tests:%{__make} tests}
229
230 %install
231 rm -rf $RPM_BUILD_ROOT
232 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
233 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
234
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
239 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
240
241 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
242 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
243
244 for d in es fr it ja ko nl pl ; do
245         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
246         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
247         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
248 done
249
250 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
251
252 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
253 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
254 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
255 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
256
257 # use our bugtracker, upstream will ignore reports from this anyway
258 rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
259
260 %find_lang %{name}
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post   -p <lua>
266 %lua_add_etc_shells /bin/bash /bin/rbash
267 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
268
269 %preun  -p <lua>
270 if arg[2] == 0 then
271         %lua_remove_etc_shells /bin/bash /bin/rbash
272 end
273
274 %postun -p      /sbin/postshell
275 -/usr/sbin/fix-info-dir -c %{_infodir}
276
277 %post static -p <lua>
278 %lua_add_etc_shells /bin/bash.static
279
280 %preun static -p <lua>
281 if arg[2] == 0 then
282         %lua_remove_etc_shells /bin/bash.static
283 end
284
285 %files -f %{name}.lang
286 %defattr(644,root,root,755)
287 %doc CHANGES NEWS README doc/{FAQ,INTRO}
288
289 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
290 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
291 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
292 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
293
294 %attr(755,root,root) /bin/bash
295 %attr(755,root,root) /bin/rbash
296
297 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
298 %{_infodir}/bash.info*
299 %{_mandir}/man1/*
300 %lang(es) %{_mandir}/es/man1/*
301 %lang(fr) %{_mandir}/fr/man1/*
302 %lang(it) %{_mandir}/it/man1/*
303 %lang(ja) %{_mandir}/ja/man1/*
304 %lang(ko) %{_mandir}/ko/man1/*
305 %lang(nl) %{_mandir}/nl/man1/*
306 %lang(pl) %{_mandir}/pl/man1/*
307 %dir %{_datadir}/%{name}
308 %doc %{_datadir}/%{name}/*
309
310 %if %{with static}
311 %files static
312 %defattr(644,root,root,755)
313 %attr(755,root,root) /bin/bash.static
314 %endif
This page took 0.079033 seconds and 3 git commands to generate.