]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
d243c1cad3d0513539e86a7114be7e476335498c
[packages/balsa.git] / balsa.spec
1 # TODO:
2 #       - not packaged /usr/share/locale/ar/LC_MESSAGES/balsa.mo
3 #       - problems with id locale
4 #
5 # Conditional build:
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_with     gpgme           # build with GPG support (experimental)
8 %bcond_without  esmtp           # build without ESMTP support
9 %bcond_without  gtkhtml         # build without HTML support
10 %bcond_with     gtkhtml2        # build with libgtkhtml-2 (default gtkhtml-3)
11 %bcond_with     compface        # build with Compface
12 %bcond_with     gtksourceview   # build with GtkSourceView
13 %bcond_without  gtkspell        # build without GtkSpell
14 %bcond_with     sqlite          # build with SQLite for GPE address books
15 #
16 Summary:        Balsa Mail Client
17 Summary(es.UTF-8):      Balsa es un lector de e-mail
18 Summary(pl.UTF-8):      Balsa - klient poczty
19 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
20 Name:           balsa
21 Version:        2.3.14
22 Release:        2
23 License:        GPL
24 Group:          X11/Applications
25 Source0:        http://balsa.gnome.org/%{name}-%{version}.tar.bz2
26 # Source0-md5:  6a86f8bebc21bd279b9fd4d2a21a36c0
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-includes.patch
29 Patch2:         %{name}-without_id_lang.patch
30 URL:            http://balsa.gnome.org/
31 BuildRequires:  ORBit2-devel >= 1:2.12.4
32 BuildRequires:  aspell-devel >= 2:0.50
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 %{?with_compface:BuildRequires: compface-devel}
36 BuildRequires:  krb5-devel
37 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
38 BuildRequires:  libgnomeprintui-devel >= 1.106.0
39 BuildRequires:  glib2-devel >= 2.6.4-1
40 BuildRequires:  gmime-devel >= 2.1.9
41 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
42 BuildRequires:  gtk+2-devel >= 2:2.2.0
43 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
44 %{?with_gtkspell:BuildRequires: gtkspell-devel}
45 BuildRequires:  intltool
46 %if %{with gtkhtml}
47 %{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
48 %{!?with_gtkhtml2:BuildRequires:        gtkhtml-devel >= 3.0}
49 %endif
50 BuildRequires:  libltdl-devel
51 BuildRequires:  libgnomeprintui-devel >= 2.1.4
52 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
53 BuildRequires:  libtool
54 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
55 BuildRequires:  openssl-devel >= 0.9.7d
56 BuildRequires:  pcre-devel >= 3.0
57 BuildRequires:  rpmbuild(macros) >= 1.197
58 BuildRequires:  scrollkeeper >= 0.1.4
59 # actually, it requires sqlite >= 2.8
60 %{?with_sqlite:BuildRequires:   sqlite3-devel}
61 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
62 Requires(post,postun):  scrollkeeper
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Balsa is an e-mail reader.  This client is part of the GNOME
67 desktop environment.  It supports local mailboxes, POP3 and
68 IMAP.
69
70 %description -l es.UTF-8
71 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
72 cajas de correo electrónico locales, POP3 y IMAP.
73
74 %description -l pl.UTF-8
75 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
76 IMAP oraz lokalne skrzynki pocztowe. 
77
78 %description -l pt_BR.UTF-8
79 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
80 Suporta caixas de correio locais, POP3 a IMAP.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87
88 %build
89 %{__intltoolize}
90 %{__glib_gettextize}
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__autoconf}
96 %configure \
97         --with-gss \
98         --with-ssl \
99         %{!?with_esmtp:--without-esmtp} \
100         %{!?with_gtkhtml:--disable-gtkhtml}\
101         %{?with_gtkhtml2:--with-gtkhtml=2}\
102         %{?with_gpgme:--with-gpgme} \
103         %{?with_compface:--with-compface} \
104         %{?with_gtksourceview:--with-gtksourceview} \
105         %{?with_gtkspell:--with-gtkspell} \
106         %{?with_sqlite:--with-sqlite} \
107         %{?with_ldap:--with-ldap}
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %find_lang %{name} --with-gnome --all-name
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post
122 %scrollkeeper_update_post
123
124 %postun
125 %scrollkeeper_update_postun
126
127 %files -f %{name}.lang
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog NEWS README TODO
130 %attr(755,root,root) %{_bindir}/*
131 %{_sysconfdir}/sound/events/*
132 %{_datadir}/%{name}
133 %{_datadir}/sounds/%{name}
134 %{_libdir}/bonobo/servers/*.server
135 %{_datadir}/idl/*.idl
136 %{_mandir}/man1/*
137 %{_omf_dest_dir}/%{name}
138 %{_desktopdir}/*.desktop
139 %{_pixmapsdir}/*
140 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.265148 seconds and 3 git commands to generate.