]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
- decrease rel to 0.1
[packages/axis.git] / axis.spec
1 # TODO
2 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
3 #  - package axis2, axis is obsolete. see NOTE below.
4 # NOTE
5 #  - it won't compile with java 1.6. see:
6 #    https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
7 %define archivever %(echo %{version} | tr . _)
8 Summary:        A SOAP implementation in Java
9 Summary(pl.UTF-8):      Implementacja SOAP w Javie
10 Name:           axis
11 Version:        1.4
12 Release:        0.1
13 License:        Apache Software License
14 Group:          Development/Languages/Java
15 Source0:        http://ws.apache.org/axis/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
16 # Source0-md5:  3dcce3cbd37f52d70ebeb858f90608dc
17 Source1:        axis-build.properties
18 Patch0:         axis-classpath.patch
19 Patch1:         axis-missing_xsd.patch
20 URL:            http://ws.apache.org/axis/
21 BuildRequires:  ant >= 1.6
22 BuildRequires:  ant-nodeps
23 BuildRequires:  java-gcj-compat-devel
24 # Mandatory requires
25 BuildRequires:  jaf
26 BuildRequires:  java-commons-discovery
27 BuildRequires:  java-commons-httpclient
28 BuildRequires:  java-commons-logging
29 BuildRequires:  java-xmlbeans
30 BuildRequires:  javamail
31 BuildRequires:  jaxp_parser_impl
32 BuildRequires:  jpackage-utils
33 BuildRequires:  logging-log4j
34 BuildRequires:  rpmbuild(macros) >= 1.300
35 BuildRequires:  servletapi5
36 BuildRequires:  wsdl4j
37 # optional requires
38 BuildRequires:  castor
39 BuildRequires:  httpunit
40 BuildRequires:  jakarta-oro
41 # BuildRequires:        jimi
42 # BuildRequires:        jms
43 BuildRequires:  jsse
44 BuildRequires:  junit
45 Requires:       jaf
46 Requires:       jakarta-commons-discovery
47 Requires:       jakarta-commons-httpclient
48 Requires:       jakarta-commons-logging
49 Requires:       java
50 Requires:       javamail
51 Requires:       jaxp_parser_impl
52 Requires:       logging-log4j
53 Requires:       jpackage-utils
54 Requires:       log4j
55 Requires:       wsdl4j
56 BuildArch:      noarch
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Apache AXIS is an implementation of the SOAP ("Simple Object Access
61 Protocol") submission to W3C.
62
63 From the draft W3C specification:
64
65 SOAP is a lightweight protocol for exchange of information in a
66 decentralized, distributed environment. It is an XML based protocol
67 that consists of three parts: an envelope that defines a framework for
68 describing what is in a message and how to process it, a set of
69 encoding rules for expressing instances of application-defined
70 datatypes, and a convention for representing remote procedure calls
71 and responses.
72
73 This project is a follow-on to the Apache SOAP project.
74
75 %description -l pl.UTF-8
76 Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
77 przekazanego do W3C.
78
79 Z projektu specyfikacji W3C:
80
81 SOAP to lekki protokół do wymiany informacji w scentralizowanym,
82 rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
83 się z trzech części: koperty definiującej szkielet do opisu zawartości
84 i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
85 wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
86 konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
87
88 Ten projekt jest następcą projektu Apache SOAP.
89
90 %package javadoc
91 Summary:        Javadoc for %{name}
92 Summary(pl.UTF-8):      Dokumentacja javadoc dla pakietu %{name}
93 Group:          Documentation
94 Requires:       jpackage-utils
95
96 %description javadoc
97 Javadoc for %{name}.
98
99 %description javadoc -l pl.UTF-8
100 Dokumentacja javadoc dla pakietu %{name}.
101
102 %package manual
103 Summary:        Manual for %{name}
104 Summary(pl.UTF-8):      Podręcznik do pakietu %{name}
105 Group:          Development/Languages/Java
106
107 %description manual
108 Documentation for %{name}.
109
110 %description manual -l pl.UTF-8
111 Podręcznik do pakietu %{name}.
112
113 %prep
114 %setup -q -n %{name}-%{archivever}
115
116 # Remove provided binaries
117 find -name '*.jar' | xargs rm -v
118 find -name '*.class' | xargs rm -v
119
120 %patch0 -p1
121 %patch1 -p1
122
123 cp %SOURCE1 build.properties
124
125 %build
126 export JAVA_HOME=%{java_home}
127
128 CLASSPATH=$(build-classpath ecj tools)
129 export CLASSPATH
130 %ant dist
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 ### Jar files
135 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
136
137 cd build/lib
138 install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
139         $RPM_BUILD_ROOT%{_javadir}/%{name}
140 cd -
141
142 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
143 for jar in *.jar ; do
144         vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
145         mv $jar $vjar
146         ln -fs $vjar $jar
147 done
148 cd -
149
150 ### Javadoc
151 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
152 cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
153 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post javadoc
159 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
160
161 %files
162 %defattr(644,root,root,755)
163 %doc LICENSE README release-notes.html changelog.html
164 %dir %{_javadir}/%{name}
165 %{_javadir}/%{name}/*.jar
166
167 %files javadoc
168 %defattr(644,root,root,755)
169 %{_javadocdir}/%{name}-%{version}
170 %ghost %{_javadocdir}/%{name}
171
172 %files manual
173 %defattr(644,root,root,755)
174 %doc docs/*
This page took 0.086986 seconds and 4 git commands to generate.