]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- reverte last change and bump _release_ to *.2.
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 #
3 # Conditional build:
4 # _without_qt           - disables QT support
5 # _with_divx4           - enables divx4linux support (proprietary, binary-only lib)
6 #
7 %define         _snapver        20020913
8 %define         _snap           %{_snapver}
9 Summary:        Library for playing AVI files
10 Summary(pl):    Biblioteka do odtwarzania plików AVI
11 Summary(pt_BR): Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
12 Name:           avifile
13 Version:        0.7.16
14 Release:        0.%{_snap}.2
15 Epoch:          3
16 License:        GPL
17 Group:          X11/Libraries
18 Source0:        http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
19 Source1:        %{name}.desktop
20 Patch0:         %{name}-shareware.patch
21 Patch1:         %{name}-no_libnsl.patch
22 URL:            http://avifile.sourceforge.net/
23 BuildRequires:  SDL-devel >= 1.2.0
24 BuildRequires:  XFree86-devel
25 BuildRequires:  a52dec-libs-devel
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 %{?_with_divx4:BuildRequires:   divx4linux-devel}
30 BuildRequires:  lame-libs-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libogg-devel
33 BuildRequires:  libtool >= 0:1.4.2-9
34 BuildRequires:  libvorbis-devel >= 1:1.0
35 BuildRequires:  nas-devel
36 %{?!_without_qt:BuildRequires:  qt-devel >= 3.0.5}
37 BuildRequires:  unzip
38 %ifarch %{ix86} ppc
39 BuildRequires:  xvid-devel
40 %endif
41 BuildConflicts: wine-devel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _prefix         /usr/X11R6
45 %define         _mandir         %{_prefix}/man
46
47 %description
48 Avifile is a library that allow programs to read and write compressed
49 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
50 (De)compression is performed with various plugins (Win32, FFMpeg,...)
51
52 %description -l pl
53 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
54 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
55 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
56
57 %description -l pt_BR
58 Avifile busca criar uma biblioteca usável de suporte a arquivos AVI e
59 um conjunto básico de utilitários (para reprodução, captura e edição)
60 para o Linux. Contém classes C++ para leitura e criação de AVIs e
61 interfaces para compressores e descompresseores de áudio e vídeo.
62
63 %package devel
64 Summary:        Header file required to build programs using libavifile
65 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
66 Summary(pt_BR): Componentes para desenvolvimento com a avifile
67 Group:          X11/Development/Libraries
68 Requires:       XFree86-devel
69 Requires:       %{name} = %{version}
70
71 %description devel
72 Header files required to build programs using libavifile.
73
74 %description devel -l pl
75 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
76 libavifile.
77
78 %description devel -l pt_BR
79 Componentes para desenvolvimento com a avifile.
80
81 %package aviplay
82 Summary:        Player for AVI/ASF/WMF files
83 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
84 Group:          X11/Applications/Multimedia
85 Requires:       %{name} = %{version}
86
87 %description aviplay
88 Sample player for AVI, ASF, WFM (with straming support) files.
89
90 %description aviplay -l pl
91 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
92 odtwarzania z sieci.)
93
94 %package utils
95 Summary:        Sample programs using the avifile library
96 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
97 Group:          X11/Applications/Multimedia
98 Requires:       %{name} = %{version}
99
100 %description utils
101 Qt-based AVI utilities with few other useful supporting tools for TV
102 capturing, AVI recompression, benchmarking, joining AVI files. These
103 programs have more bugs as they are not as extensively developed as
104 player.
105
106 %description utils -l pl
107 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
108 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
109 s± tak intensywnie rozwijane jak odtwarzacz.
110
111 %package win32
112 Summary:        Win32 audio/video plugin
113 Summary(pl):    Plugin audio/video win32
114 Group:          X11/Libraries
115 Requires:       %{name} = %{version}
116 Requires:       w32codec
117
118 %description win32
119 Plugin for using Win32 DLL libraries in avifile located in
120 /usr/lib/win32.
121
122 %description win32 -l pl
123 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
124 bibliotek DLL Win32.
125
126 %package ffmpeg
127 Summary:        GPL MPEG4 codec
128 Summary(pl):    Kodek MPEG4 na licencji GPL
129 Group:          X11/Libraries
130 Requires:       %{name} = %{version}
131
132 %description ffmpeg
133 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
134 server and a generic audio and video file converter.
135
136 It can grab from a standard Video4Linux video source and convert it
137 into several file formats based on DCT/motion compensation encoding.
138 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
139 stream.
140
141 %description ffmpeg -l pl
142 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
143 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
144
145 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
146 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
147 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
148 kompatybilnego z AC3 strumienia.
149
150 %package divx
151 Summary:        Fast MPEG4 codec
152 Summary(pl):    Szybki kodek MPEG4
153 Group:          X11/Libraries
154 Requires:       %{name} = %{version}
155 Requires:       divx4linux
156 Obsoletes:      avifile-divx4
157
158 %description divx
159 DivX MPEG-4 decoder and encoder.
160
161 %description divx -l pl
162 Dekoder i koder MPEG-4 DivX.
163
164 %package vorbis
165 Summary:        Vorbis audio plugin
166 Summary(pl):    Plugin vorbis audio.
167 Group:          X11/Libraries
168 Requires:       %{name} = %{version}
169
170 %description vorbis
171 Plugin for decompression of Vorbis audio streams.
172
173 %description vorbis -l pl
174 Plugin do dekompresji strumieni audio Vorbis.
175
176 %package mad
177 Summary:        MAD - MPEG audio plugin
178 Summary(pl):    MAD - plugin MPEG audio
179 Group:          X11/Libraries
180 Requires:       %{name} = %{version}
181
182 %description mad
183 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
184
185 %description mad -l pl
186 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
187
188 %package lame_audioenc
189 Summary:        MP3 audio encoder plugin
190 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
191 Group:          X11/Libraries
192 Requires:       %{name} = %{version}
193
194 %description lame_audioenc
195 Plugin for mp3 encoding capability of avirecompress tool.
196
197 %description lame_audioenc -l pl
198 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
199
200 %package xvid
201 Summary:        XVID codec
202 Summary(pl):    Kodek XVID
203 Group:          X11/Libraries
204 Requires:       %{name} = %{version}
205 Requires:       xvid
206
207 %description xvid
208 XVID decoder and encoder.
209
210 %description xvid -l pl
211 Dekoder i koder XVID.
212
213 %prep
214 %setup -q -n avifile0.7-%{version}
215 %patch0 -p1
216 %patch1 -p1
217
218 %build
219 rm -f missing aclocal.m4
220 %{__libtoolize}
221 %{__aclocal}
222 autoheader
223 %{__autoconf}
224 %{__automake}
225
226 cd plugins/libmad/libmad
227 %{__autoconf}
228 cd ../../..
229
230 cd libmmxnow
231 %{__autoconf}
232 cd ..
233
234 # This is The WRONG Way (tm)
235 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
236 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
237
238 %configure \
239         CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
240         FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
241         --with-qt-includes=%{_includedir}/qt \
242         --with-qt-libraries=%{_libdir} \
243         --enable-a52 \
244         --enable-release \
245         --enable-ffmpeg \
246         --enable-ffmpeg-a52 \
247         %{?_with_divx4:--enable-divx4} \
248 %ifarch i586 i686 athlon
249         --enable-x86opt \
250 %else
251         --disable-x86opt \
252 %endif
253         %{?_without_qt:--without-qt}
254
255 touch lib/dummy.cpp
256 %{__make}
257
258 %install
259 rm -rf $RPM_BUILD_ROOT
260 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
261
262 %{__make} install \
263         DESTDIR="$RPM_BUILD_ROOT" \
264         m4datadir="%{_aclocaldir}"
265
266 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
267
268 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
269 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
270
271 %clean
272 rm -rf $RPM_BUILD_ROOT
273
274 %post   -p /sbin/ldconfig
275 %postun -p /sbin/ldconfig
276
277 %files
278 %defattr(644,root,root,755)
279 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
280 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
281 %attr(755,root,root) %{_libdir}/lib*.so.*.*
282 %dir %{_libdir}/avifile*
283 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
284 %attr(755,root,root) %{_libdir}/avifile*/audiodec.la
285 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
286 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.la
287 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
288 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.la
289 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
290 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.la
291
292 %files devel
293 %defattr(644,root,root,755)
294 %doc doc/README-DEVEL*
295 %attr(755,root,root) %{_bindir}/avifile-config
296 %attr(755,root,root) %{_bindir}/mmxnow-config
297 %attr(755,root,root) %{_libdir}/lib*.la
298 %{_libdir}/lib*.so
299 %{_includedir}/%{name}
300 %{_includedir}/*.h
301 %{_aclocaldir}/*.m4
302
303 %if %{?_without_qt:0}%{!?_without_qt:1}
304 %files aviplay
305 %defattr(644,root,root,755)
306 %attr(755,root,root) %{_bindir}/aviplay
307 %{_datadir}/%{name}*
308 %{_applnkdir}/Multimedia/*
309 %{_pixmapsdir}/*
310
311 %files utils
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
314 %attr(755,root,root) %{_bindir}/kv4lsetup
315 %endif
316
317 %ifarch %{ix86}
318 %files win32
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
321 %attr(755,root,root) %{_libdir}/avifile*/win32.la
322 %endif
323
324 %files ffmpeg
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
327 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.la
328
329 %if %{?_with_divx4:1}%{!?_with_divx4:0}
330 %files divx
331 %defattr(644,root,root,755)
332 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
333 %attr(755,root,root) %{_libdir}/avifile*/divx*.la
334 %endif
335
336 %files vorbis
337 %defattr(644,root,root,755)
338 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
339 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.la
340
341 %files mad
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
344 %attr(755,root,root) %{_libdir}/avifile*/mad*.la
345
346 %files lame_audioenc
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
349 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.la
350
351 %ifarch %{ix86} ppc sparc sparc64 sparcv9
352 %files xvid
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
355 %attr(755,root,root) %{_libdir}/avifile*/xvid.la
356 %endif
This page took 0.0833700000000001 seconds and 4 git commands to generate.