]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- fix building on ppc
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 #
3 # Conditional build:
4 # _without_qt           - disables QT support
5 # _with_divx4           - enables divx4linux support (proprietary, binary-only lib)
6 #
7 %define         _snapver        20020913
8 %define         _snap           %{_snapver}
9 Summary:        Library for playing AVI files
10 Summary(pl):    Biblioteka do odtwarzania plików AVI
11 Summary(pt_BR): Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
12 Name:           avifile
13 Version:        0.7.16
14 Release:        0.%{_snap}.2
15 Epoch:          3
16 License:        GPL
17 Group:          X11/Libraries
18 Source0:        http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
19 Source1:        %{name}.desktop
20 Patch0:         %{name}-shareware.patch
21 Patch1:         %{name}-no_libnsl.patch
22 Patch2:         %{name}-vidix.patch
23 URL:            http://avifile.sourceforge.net/
24 BuildRequires:  SDL-devel >= 1.2.0
25 BuildRequires:  XFree86-devel
26 BuildRequires:  a52dec-libs-devel
27 BuildRequires:  audiofile-devel
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 %{?_with_divx4:BuildRequires:   divx4linux-devel}
31 BuildRequires:  lame-libs-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libogg-devel
34 BuildRequires:  libtool >= 0:1.4.2-9
35 BuildRequires:  libvorbis-devel >= 1:1.0
36 BuildRequires:  nas-devel
37 %{?!_without_qt:BuildRequires:  qt-devel >= 3.0.5}
38 BuildRequires:  unzip
39 %ifarch %{ix86} ppc
40 BuildRequires:  xvid-devel
41 %endif
42 BuildConflicts: wine-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _prefix         /usr/X11R6
46 %define         _mandir         %{_prefix}/man
47
48 %description
49 Avifile is a library that allow programs to read and write compressed
50 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
51 (De)compression is performed with various plugins (Win32, FFMpeg,...)
52
53 %description -l pl
54 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
55 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
56 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
57
58 %description -l pt_BR
59 Avifile busca criar uma biblioteca usável de suporte a arquivos AVI e
60 um conjunto básico de utilitários (para reprodução, captura e edição)
61 para o Linux. Contém classes C++ para leitura e criação de AVIs e
62 interfaces para compressores e descompresseores de áudio e vídeo.
63
64 %package devel
65 Summary:        Header file required to build programs using libavifile
66 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
67 Summary(pt_BR): Componentes para desenvolvimento com a avifile
68 Group:          X11/Development/Libraries
69 Requires:       XFree86-devel
70 Requires:       %{name} = %{version}
71
72 %description devel
73 Header files required to build programs using libavifile.
74
75 %description devel -l pl
76 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
77 libavifile.
78
79 %description devel -l pt_BR
80 Componentes para desenvolvimento com a avifile.
81
82 %package aviplay
83 Summary:        Player for AVI/ASF/WMF files
84 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
85 Group:          X11/Applications/Multimedia
86 Requires:       %{name} = %{version}
87
88 %description aviplay
89 Sample player for AVI, ASF, WFM (with straming support) files.
90
91 %description aviplay -l pl
92 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
93 odtwarzania z sieci.)
94
95 %package utils
96 Summary:        Sample programs using the avifile library
97 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
98 Group:          X11/Applications/Multimedia
99 Requires:       %{name} = %{version}
100
101 %description utils
102 Qt-based AVI utilities with few other useful supporting tools for TV
103 capturing, AVI recompression, benchmarking, joining AVI files. These
104 programs have more bugs as they are not as extensively developed as
105 player.
106
107 %description utils -l pl
108 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
109 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
110 s± tak intensywnie rozwijane jak odtwarzacz.
111
112 %package win32
113 Summary:        Win32 audio/video plugin
114 Summary(pl):    Plugin audio/video win32
115 Group:          X11/Libraries
116 Requires:       %{name} = %{version}
117 Requires:       w32codec
118
119 %description win32
120 Plugin for using Win32 DLL libraries in avifile located in
121 /usr/lib/win32.
122
123 %description win32 -l pl
124 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
125 bibliotek DLL Win32.
126
127 %package ffmpeg
128 Summary:        GPL MPEG4 codec
129 Summary(pl):    Kodek MPEG4 na licencji GPL
130 Group:          X11/Libraries
131 Requires:       %{name} = %{version}
132
133 %description ffmpeg
134 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
135 server and a generic audio and video file converter.
136
137 It can grab from a standard Video4Linux video source and convert it
138 into several file formats based on DCT/motion compensation encoding.
139 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
140 stream.
141
142 %description ffmpeg -l pl
143 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
144 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
145
146 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
147 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
148 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
149 kompatybilnego z AC3 strumienia.
150
151 %package divx
152 Summary:        Fast MPEG4 codec
153 Summary(pl):    Szybki kodek MPEG4
154 Group:          X11/Libraries
155 Requires:       %{name} = %{version}
156 Requires:       divx4linux
157 Obsoletes:      avifile-divx4
158
159 %description divx
160 DivX MPEG-4 decoder and encoder.
161
162 %description divx -l pl
163 Dekoder i koder MPEG-4 DivX.
164
165 %package vorbis
166 Summary:        Vorbis audio plugin
167 Summary(pl):    Plugin vorbis audio.
168 Group:          X11/Libraries
169 Requires:       %{name} = %{version}
170
171 %description vorbis
172 Plugin for decompression of Vorbis audio streams.
173
174 %description vorbis -l pl
175 Plugin do dekompresji strumieni audio Vorbis.
176
177 %package mad
178 Summary:        MAD - MPEG audio plugin
179 Summary(pl):    MAD - plugin MPEG audio
180 Group:          X11/Libraries
181 Requires:       %{name} = %{version}
182
183 %description mad
184 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
185
186 %description mad -l pl
187 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
188
189 %package lame_audioenc
190 Summary:        MP3 audio encoder plugin
191 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
192 Group:          X11/Libraries
193 Requires:       %{name} = %{version}
194
195 %description lame_audioenc
196 Plugin for mp3 encoding capability of avirecompress tool.
197
198 %description lame_audioenc -l pl
199 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
200
201 %package xvid
202 Summary:        XVID codec
203 Summary(pl):    Kodek XVID
204 Group:          X11/Libraries
205 Requires:       %{name} = %{version}
206 Requires:       xvid
207
208 %description xvid
209 XVID decoder and encoder.
210
211 %description xvid -l pl
212 Dekoder i koder XVID.
213
214 %prep
215 %setup -q -n avifile0.7-%{version}
216 %patch0 -p1
217 %patch1 -p1
218 %patch2 -p1
219
220 %build
221 rm -f missing aclocal.m4
222 %{__libtoolize}
223 %{__aclocal}
224 autoheader
225 %{__autoconf}
226 %{__automake}
227
228 cd plugins/libmad/libmad
229 %{__autoconf}
230 cd ../../..
231
232 cd libmmxnow
233 %{__autoconf}
234 cd ..
235
236 # This is The WRONG Way (tm)
237 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
238 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
239
240 %configure \
241         CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
242         FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
243         --with-qt-includes=%{_includedir}/qt \
244         --with-qt-libraries=%{_libdir} \
245         --enable-a52 \
246         --enable-release \
247         --enable-ffmpeg \
248         --enable-ffmpeg-a52 \
249         %{?_with_divx4:--enable-divx4} \
250 %ifarch i586 i686 athlon
251         --enable-x86opt \
252 %else
253         --disable-x86opt \
254 %endif
255         %{?_without_qt:--without-qt}
256
257 touch lib/dummy.cpp
258 %{__make}
259
260 %install
261 rm -rf $RPM_BUILD_ROOT
262 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
263
264 %{__make} install \
265         DESTDIR="$RPM_BUILD_ROOT" \
266         m4datadir="%{_aclocaldir}"
267
268 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
269
270 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
271 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
272
273 %clean
274 rm -rf $RPM_BUILD_ROOT
275
276 %post   -p /sbin/ldconfig
277 %postun -p /sbin/ldconfig
278
279 %files
280 %defattr(644,root,root,755)
281 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
282 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
283 %attr(755,root,root) %{_libdir}/lib*.so.*.*
284 %dir %{_libdir}/avifile*
285 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
286 %attr(755,root,root) %{_libdir}/avifile*/audiodec.la
287 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
288 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.la
289 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
290 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.la
291 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
292 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.la
293
294 %files devel
295 %defattr(644,root,root,755)
296 %doc doc/README-DEVEL*
297 %attr(755,root,root) %{_bindir}/avifile-config
298 %attr(755,root,root) %{_bindir}/mmxnow-config
299 %attr(755,root,root) %{_libdir}/lib*.la
300 %{_libdir}/lib*.so
301 %{_includedir}/%{name}
302 %{_includedir}/*.h
303 %{_aclocaldir}/*.m4
304
305 %if %{?_without_qt:0}%{!?_without_qt:1}
306 %files aviplay
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_bindir}/aviplay
309 %{_mandir}/man1/aviplay.1*
310 %{_datadir}/%{name}*
311 %{_applnkdir}/Multimedia/*
312 %{_pixmapsdir}/*
313
314 %files utils
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
317 %attr(755,root,root) %{_bindir}/kv4lsetup
318 %endif
319
320 %ifarch %{ix86}
321 %files win32
322 %defattr(644,root,root,755)
323 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
324 %attr(755,root,root) %{_libdir}/avifile*/win32.la
325 %endif
326
327 %files ffmpeg
328 %defattr(644,root,root,755)
329 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
330 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.la
331
332 %if %{?_with_divx4:1}%{!?_with_divx4:0}
333 %files divx
334 %defattr(644,root,root,755)
335 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
336 %attr(755,root,root) %{_libdir}/avifile*/divx*.la
337 %endif
338
339 %files vorbis
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
342 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.la
343
344 %files mad
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
347 %attr(755,root,root) %{_libdir}/avifile*/mad*.la
348
349 %files lame_audioenc
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
352 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.la
353
354 %ifarch %{ix86} ppc sparc sparc64 sparcv9
355 %files xvid
356 %defattr(644,root,root,755)
357 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
358 %attr(755,root,root) %{_libdir}/avifile*/xvid.la
359 %endif
This page took 0.069616 seconds and 4 git commands to generate.