]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- added no_libnsl patch.
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 #
3 # Conditional build:
4 # _without_qt           - disables QT support
5 # _without_divx4        - disables divx4linux support
6 #
7 %ifnarch %{ix86}
8 %define         _without_divx4  1
9 %endif
10 %define         _snapver        20020816
11 %define         _snap           %{_snapver}
12 %define         _ver    0.7.15
13 Summary:        Library for playing AVI files
14 Summary(pl):    Biblioteka do odtwarzania plików AVI
15 Name:           avifile
16 Version:        %{_ver}
17 Release:        0.%{_snap}.2
18 Epoch:          3
19 License:        GPL
20 Group:          X11/Libraries
21 Source0:        http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
22 Source1:        %{name}.desktop
23 Patch0:         %{name}-shareware.patch
24 Patch1:         %{name}-no_libnsl.patch
25 URL:            http://avifile.sourceforge.net/
26 BuildRequires:  SDL-devel >= 1.2.0
27 BuildRequires:  XFree86-devel
28 BuildRequires:  a52dec-libs-devel
29 BuildRequires:  audiofile-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %{!?_without_divx4:BuildRequires:       divx4linux-devel}
33 BuildRequires:  lame-libs-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libogg-devel
36 BuildRequires:  libtool >= 0:1.4.2-9
37 BuildRequires:  libvorbis-devel >= 1:1.0
38 BuildRequires:  nas-devel
39 %{?!_without_qt:BuildRequires:  qt-devel >= 3.0.5}
40 BuildRequires:  unzip
41 %ifarch %{ix86} ppc sparc sparc64 sparcv9
42 BuildRequires:  xvid-devel
43 %endif
44 BuildConflicts: wine-devel
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _prefix         /usr/X11R6
48 %define         _mandir         %{_prefix}/man
49
50 %description
51 Avifile is a library that allow programs to read and write compressed
52 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
53 (De)compression is performed with various plugins (Win32, FFMpeg,...)
54
55 %description -l pl
56 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
57 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
58 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
59
60 %package devel
61 Summary:        Header file required to build programs using libavifile
62 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
63 Group:          X11/Development/Libraries
64 Requires:       XFree86-devel
65 Requires:       %{name} = %{version}
66
67 %description devel
68 Header files required to build programs using libavifile.
69
70 %description devel -l pl
71 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
72 libavifile.
73
74 %package aviplay
75 Summary:        Player for AVI/ASF/WMF files
76 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
77 Group:          X11/Applications/Multimedia
78 Requires:       %{name} = %{version}
79
80 %description aviplay
81 Sample player for AVI, ASF, WFM (with straming support) files.
82
83 %description aviplay -l pl
84 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
85 odtwarzania z sieci.)
86
87 %package utils
88 Summary:        Sample programs using the avifile library
89 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
90 Group:          X11/Applications/Multimedia
91 Requires:       %{name} = %{version}
92
93 %description utils
94 Qt-based AVI utilities with few other useful supporting tools for TV
95 capturing, AVI recompression, benchmarking, joining AVI files. These
96 programs have more bugs as they are not as extensively developed as
97 player.
98
99 %description utils -l pl
100 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
101 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
102 s± tak intensywnie rozwijane jak odtwarzacz.
103
104 %package win32
105 Summary:        Win32 audio/video plugin
106 Summary(pl):    Plugin audio/video win32
107 Group:          X11/Libraries
108 Requires:       %{name} = %{version}
109 Requires:       w32codec
110
111 %description win32
112 Plugin for using Win32 DLL libraries in avifile located in
113 /usr/lib/win32.
114
115 %description win32 -l pl
116 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
117 bibliotek DLL Win32.
118
119 %package ffmpeg
120 Summary:        GPL MPEG4 codec
121 Summary(pl):    Kodek MPEG4 na licencji GPL
122 Group:          X11/Libraries
123 Requires:       %{name} = %{version}
124
125 %description ffmpeg
126 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
127 server and a generic audio and video file converter.
128
129 It can grab from a standard Video4Linux video source and convert it
130 into several file formats based on DCT/motion compensation encoding.
131 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
132 stream.
133
134 %description ffmpeg -l pl
135 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
136 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
137
138 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
139 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
140 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
141 kompatybilnego z AC3 strumienia.
142
143 %package divx
144 Summary:        Fast MPEG4 codec
145 Summary(pl):    Szybki kodek MPEG4
146 Group:          X11/Libraries
147 Requires:       %{name} = %{version}
148 Requires:       divx4linux
149 Obsoletes:      avifile-divx4
150
151 %description divx
152 DivX MPEG-4 decoder and encoder.
153
154 %description divx -l pl
155 Dekoder i koder MPEG-4 DivX.
156
157 %package vorbis
158 Summary:        Vorbis audio plugin
159 Summary(pl):    Plugin vorbis audio.
160 Group:          X11/Libraries
161 Requires:       %{name} = %{version}
162
163 %description vorbis
164 Plugin for decompression of Vorbis audio streams.
165
166 %description vorbis -l pl
167 Plugin do dekompresji strumieni audio Vorbis.
168
169 %package mad
170 Summary:        MAD - MPEG audio plugin
171 Summary(pl):    MAD - plugin MPEG audio
172 Group:          X11/Libraries
173 Requires:       %{name} = %{version}
174
175 %description mad
176 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
177
178 %description mad -l pl
179 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
180
181 %package lame_audioenc
182 Summary:        MP3 audio encoder plugin
183 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
184 Group:          X11/Libraries
185 Requires:       %{name} = %{version}
186
187 %description lame_audioenc
188 Plugin for mp3 encoding capability of avirecompress tool.
189
190 %description lame_audioenc -l pl
191 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
192
193 %package xvid
194 Summary:        XVID codec
195 Summary(pl):    Kodek XVID
196 Group:          X11/Libraries
197 Requires:       %{name} = %{version}
198 Requires:       xvid
199
200 %description xvid
201 XVID decoder and encoder.
202
203 %description xvid -l pl
204 Dekoder i koder XVID.
205
206 %prep
207 %setup -q -n avifile0.7-%{_ver}
208 %patch0 -p1
209 %patch1 -p1
210
211 %build
212 rm -f missing aclocal.m4
213 %{__libtoolize}
214 %{__aclocal}
215 autoheader
216 %{__autoconf}
217 %{__automake}
218
219 cd plugins/libmad/libmad
220 %{__autoconf}
221 cd ../../..
222
223 cd libmmxnow
224 %{__autoconf}
225 cd ..
226
227 # This is The WRONG Way (tm)
228 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
229 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
230
231 %configure \
232         CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
233         FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
234         --with-qt-includes=%{_includedir}/qt \
235         --with-qt-libraries=%{_libdir} \
236         --enable-a52 \
237         --enable-release \
238         --enable-ffmpeg \
239         --enable-ffmpeg-a52 \
240         %{?_without_divx4:--disable-divx4} \
241 %ifarch i586 i686 athlon
242         --enable-x86opt \
243 %endif
244         %{?_without_qt:--without-qt}
245
246 touch lib/dummy.cpp
247 %{__make}
248
249 %install
250 rm -rf $RPM_BUILD_ROOT
251 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
252
253 %{__make} install \
254         DESTDIR="$RPM_BUILD_ROOT" \
255         m4datadir="%{_aclocaldir}"
256
257 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
258
259 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
260 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post   -p /sbin/ldconfig
266 %postun -p /sbin/ldconfig
267
268 %files
269 %defattr(644,root,root,755)
270 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
271 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
272 %attr(755,root,root) %{_libdir}/lib*.so.*.*
273 %dir %{_libdir}/avifile*
274 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
275 %attr(755,root,root) %{_libdir}/avifile*/audiodec.la
276 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
277 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.la
278 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
279 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.la
280 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
281 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.la
282
283 %files devel
284 %defattr(644,root,root,755)
285 %doc doc/README-DEVEL*
286 %attr(755,root,root) %{_bindir}/avifile-config
287 %attr(755,root,root) %{_bindir}/mmxnow-config
288 %attr(755,root,root) %{_libdir}/lib*.la
289 %{_libdir}/lib*.so
290 %{_includedir}/%{name}
291 %{_includedir}/*.h
292 %{_aclocaldir}/*.m4
293
294 %if %{?_without_qt:0}%{!?_without_qt:1}
295 %files aviplay
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_bindir}/aviplay
298 %{_datadir}/%{name}*
299 %{_applnkdir}/Multimedia/*
300 %{_pixmapsdir}/*
301
302 %files utils
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
305 %attr(755,root,root) %{_bindir}/kv4lsetup
306 %endif
307
308 %ifarch %{ix86}
309 %files win32
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
312 %attr(755,root,root) %{_libdir}/avifile*/win32.la
313 %endif
314
315 %files ffmpeg
316 %defattr(644,root,root,755)
317 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
318 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.la
319
320 %if %{?_without_divx4:0}%{!?_without_divx4:1}
321 %files divx
322 %defattr(644,root,root,755)
323 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
324 %attr(755,root,root) %{_libdir}/avifile*/divx*.la
325 %endif
326
327 %files vorbis
328 %defattr(644,root,root,755)
329 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
330 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.la
331
332 %files mad
333 %defattr(644,root,root,755)
334 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
335 %attr(755,root,root) %{_libdir}/avifile*/mad*.la
336
337 %files lame_audioenc
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
340 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.la
341
342 %ifarch %{ix86} ppc sparc sparc64 sparcv9
343 %files xvid
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
346 %attr(755,root,root) %{_libdir}/avifile*/xvid.la
347 %endif
This page took 0.054183 seconds and 4 git commands to generate.