]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- added home_etc.patch
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 #
3 # Conditional build:
4 # _without_qt           - disables QT support
5 # _with_divx            - enables divx4linux support (proprietary, binary-only
6 #                         lib)  note: if disabled, divx is decoded by ffmpeg
7 #
8 %define         _snapver        20030219
9 %define         _snap           %{_snapver}
10 Summary:        Library for playing AVI files
11 Summary(pl):    Biblioteka do odtwarzania plików AVI
12 Summary(pt_BR): Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
13 Name:           avifile
14 Version:        0.7.32
15 Release:        0.%{_snap}%{?_with_divx:+divx}
16 Epoch:          3
17 License:        GPL
18 Group:          X11/Libraries
19 Source0:        http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
20 Source1:        %{name}.desktop
21 Patch0:         %{name}-shareware.patch
22 Patch1:         %{name}-no_libnsl.patch
23 Patch2:         %{name}-fix-keys.patch
24 Patch3:         %{name}-home_etc.patch
25 URL:            http://avifile.sourceforge.net/
26 BuildRequires:  SDL-devel >= 1.2.0
27 BuildRequires:  XFree86-devel
28 BuildRequires:  a52dec-libs-devel
29 BuildRequires:  audiofile-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %{?_with_divx:BuildRequires:    divx4linux-devel}
33 BuildRequires:  lame-libs-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libogg-devel
36 BuildRequires:  libtool >= 0:1.4.2-9
37 BuildRequires:  libvorbis-devel >= 1:1.0
38 BuildRequires:  nas-devel
39 %{?!_without_qt:BuildRequires:  qt-devel >= 2.0.0}
40 BuildRequires:  unzip
41 %ifarch %{ix86} ppc
42 BuildRequires:  xvid-devel
43 %endif
44 BuildConflicts: wine-devel
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Avifile is a library that allow programs to read and write compressed
49 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
50 (De)compression is performed with various plugins (Win32, FFMpeg,...)
51
52 %description -l pl
53 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
54 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
55 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
56
57 %description -l pt_BR
58 Avifile busca criar uma biblioteca usável de suporte a arquivos AVI e
59 um conjunto básico de utilitários (para reprodução, captura e edição)
60 para o Linux. Contém classes C++ para leitura e criação de AVIs e
61 interfaces para compressores e descompresseores de áudio e vídeo.
62
63 %package devel
64 Summary:        Header file required to build programs using libavifile
65 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
66 Summary(pt_BR): Componentes para desenvolvimento com a avifile
67 Group:          X11/Development/Libraries
68 Requires:       XFree86-devel
69 Requires:       %{name} = %{version}
70
71 %description devel
72 Header files required to build programs using libavifile.
73
74 %description devel -l pl
75 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
76 libavifile.
77
78 %description devel -l pt_BR
79 Componentes para desenvolvimento com a avifile.
80
81 %package aviplay
82 Summary:        Player for AVI/ASF/WMF files
83 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
84 Group:          X11/Applications/Multimedia
85 Requires:       %{name} = %{version}
86
87 %description aviplay
88 Sample player for AVI, ASF, WFM (with straming support) files.
89
90 %description aviplay -l pl
91 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
92 odtwarzania z sieci.)
93
94 %package utils
95 Summary:        Sample programs using the avifile library
96 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
97 Group:          X11/Applications/Multimedia
98 Requires:       %{name} = %{version}
99
100 %description utils
101 Qt-based AVI utilities with few other useful supporting tools for TV
102 capturing, AVI recompression, benchmarking, joining AVI files. These
103 programs have more bugs as they are not as extensively developed as
104 player.
105
106 %description utils -l pl
107 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
108 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
109 s± tak intensywnie rozwijane jak odtwarzacz.
110
111 %package win32
112 Summary:        Win32 audio/video plugin
113 Summary(pl):    Plugin audio/video win32
114 Group:          X11/Libraries
115 Requires:       %{name} = %{version}
116 Requires:       w32codec
117
118 %description win32
119 Plugin for using Win32 DLL libraries in avifile located in
120 /usr/lib/win32.
121
122 %description win32 -l pl
123 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
124 bibliotek DLL Win32.
125
126 %package ffmpeg
127 Summary:        GPL MPEG4 codec
128 Summary(pl):    Kodek MPEG4 na licencji GPL
129 Group:          X11/Libraries
130 Requires:       %{name} = %{version}
131
132 %description ffmpeg
133 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
134 server and a generic audio and video file converter.
135
136 It can grab from a standard Video4Linux video source and convert it
137 into several file formats based on DCT/motion compensation encoding.
138 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
139 stream.
140
141 %description ffmpeg -l pl
142 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
143 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
144
145 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
146 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
147 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
148 kompatybilnego z AC3 strumienia.
149
150 %package divx
151 Summary:        Fast MPEG4 codec
152 Summary(pl):    Szybki kodek MPEG4
153 Group:          X11/Libraries
154 Requires:       %{name} = %{version}
155 Requires:       divx4linux
156 Obsoletes:      avifile-divx4
157
158 %description divx
159 DivX MPEG-4 decoder and encoder.
160
161 %description divx -l pl
162 Dekoder i koder MPEG-4 DivX.
163
164 %package vorbis
165 Summary:        Vorbis audio plugin
166 Summary(pl):    Plugin vorbis audio
167 Group:          X11/Libraries
168 Requires:       %{name} = %{version}
169
170 %description vorbis
171 Plugin for decompression of Vorbis audio streams.
172
173 %description vorbis -l pl
174 Plugin do dekompresji strumieni audio Vorbis.
175
176 %package mad
177 Summary:        MAD - MPEG audio plugin
178 Summary(pl):    MAD - plugin MPEG audio
179 Group:          X11/Libraries
180 Requires:       %{name} = %{version}
181
182 %description mad
183 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
184
185 %description mad -l pl
186 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
187
188 %package lame_audioenc
189 Summary:        MP3 audio encoder plugin
190 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
191 Group:          X11/Libraries
192 Requires:       %{name} = %{version}
193
194 %description lame_audioenc
195 Plugin for mp3 encoding capability of avirecompress tool.
196
197 %description lame_audioenc -l pl
198 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
199
200 %package xvid
201 Summary:        XVID codec
202 Summary(pl):    Kodek XVID
203 Group:          X11/Libraries
204 Requires:       %{name} = %{version}
205 Requires:       xvid
206
207 %description xvid
208 XVID decoder and encoder.
209
210 %description xvid -l pl
211 Dekoder i koder XVID.
212
213 %package vidix-driver-fb
214 Summary:        VIDIX driver for generic FrameBuffer
215 Summary(pl):    Sterownik VIDIX dla zwyk³ego FrameBuffera
216 Group:          X11/Libraries
217 Requires:       %{name} = %{version}
218
219 %description vidix-driver-fb
220 VIDIX driver for generic FrameBuffer.
221
222 %description vidix-driver-fb -l pl
223 Sterownik VIDIX dla zwyk³ego FrameBuffera.
224
225 %package vidix-driver-mach64
226 Summary:        VIDIX driver for ATI Mach64 video adapters
227 Summary(pl):    Sterownik VIDIX dla kart graficznych ATI Mach64
228 Group:          X11/Libraries
229 Requires:       %{name} = %{version}
230
231 %description vidix-driver-mach64
232 VIDIX driver for ATI Mach64 adapters.
233
234 %description vidix-driver-mach64 -l pl
235 Sterownik vidix dla kart graficznych ATI Mach64.
236
237 %package vidix-driver-rage128
238 Summary:        VIDIX driver for ATI Rage128 video adapters
239 Summary(pl):    Sterownik VIDIX dla kart graficznych ATI Rage128
240 Group:          X11/Libraries
241 Requires:       %{name} = %{version}
242
243 %description vidix-driver-rage128
244 VIDIX driver for ATI Rage128 video adapters.
245
246 %description vidix-driver-rage128 -l pl
247 Sterownik VIDIX dla kart graficznych ATI Rage128.
248
249 %package vidix-driver-radeon
250 Summary:        VIDIX driver for ATI Radeon video adapters
251 Summary(pl):    Sterownik VIDIX dla kart graficznych ATI Radeon
252 Group:          X11/Libraries
253 Requires:       %{name} = %{version}
254
255 %description vidix-driver-radeon
256 VIDIX driver for ATI Radeon video adapters.
257
258 %description vidix-driver-radeon -l pl
259 Sterownik VIDIX dla kart graficznych ATI Radeon.
260
261 %package vidix-driver-mga
262 Summary:        VIDIX driver for MGA (Matrox) video adapters
263 Summary(pl):    Sterownik VIDIX dla kart graficznych MGA (Matrox)
264 Group:          X11/Libraries
265 Requires:       %{name} = %{version}
266
267 %description vidix-driver-mga
268 VIDIX driver for MGA (Matrox) video adapters.
269
270 %description vidix-driver-mga -l pl
271 Sterownik VIDIX dla kart graficznych MGA (Matrox).
272
273 %package vidix-driver-nvidia
274 Summary:        VIDIX driver for NVidia video adapters
275 Summary(pl):    Sterownik VIDIX dla kart graficznych NVidia
276 Group:          X11/Libraries
277 Requires:       %{name} = %{version}
278
279 %description vidix-driver-nvidia
280 VIDIX driver for NVidia video adapters.
281
282 %description vidix-driver-nvidia -l pl
283 Sterownik VIDIX dla kart graficznych NVidia.
284
285 %package vidix-driver-permedia
286 Summary:        VIDIX driver for Permedia video adapters
287 Summary(pl):    Sterownik VIDIX dla kart graficznych Permedia
288 Group:          X11/Libraries
289 Requires:       %{name} = %{version}
290
291 %description vidix-driver-permedia
292 VIDIX driver for Permedia video adapters.
293
294 %description vidix-driver-permedia -l pl
295 Sterownik VIDIX dla kart graficznych Permedia.
296
297 %prep
298 %setup -q -n avifile0.7-%{version}
299 %patch0 -p1
300 %patch1 -p1
301 %patch2 -p1
302 %patch3 -p1
303
304 %build
305 %{__autoconf}
306
307 cd plugins/libmad/libmad
308 %{__autoconf}
309 cd ../../..
310
311 # This is The WRONG Way (tm)
312 %if %{!?_without_qt:1}%{?_without_qt:0}
313 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
314 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
315 %endif
316
317 %configure \
318         CPPFLAGS="-I/usr/include/divx -I/usr/include/xvid -I/usr/include/freetype2" \
319         AS="%{__cc}" \
320         FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
321         --with-qt-includes=%{_includedir}/qt \
322         --with-qt-libraries=%{_libdir} \
323         --enable-a52 \
324         --enable-release \
325         --enable-ffmpeg \
326         --enable-ffmpeg-a52 \
327         %{?_with_divx:--enable-divx4} \
328 %ifarch i586 i686 athlon
329         --enable-x86opt \
330 %else
331         --disable-x86opt \
332 %endif
333         %{?_without_qt:--without-qt} \
334         %{?_without_qt:--disable-samples}
335
336 touch lib/dummy.cpp
337 %{__make}
338
339 %install
340 rm -rf $RPM_BUILD_ROOT
341 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
342
343 %{__make} install \
344         DESTDIR="$RPM_BUILD_ROOT" \
345         m4datadir="%{_aclocaldir}"
346
347 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
348
349 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
350 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
351
352 %clean
353 rm -rf $RPM_BUILD_ROOT
354
355 %post   -p /sbin/ldconfig
356 %postun -p /sbin/ldconfig
357
358 %files
359 %defattr(644,root,root,755)
360 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
361 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
362 %attr(755,root,root) %{_libdir}/lib*.so.*.*
363 %dir %{_libdir}/avifile*
364 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
365 %{_libdir}/avifile*/audiodec.la
366 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
367 %{_libdir}/avifile*/mpeg_audiodec.la
368 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
369 %{_libdir}/avifile*/ac3pass.la
370 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
371 %{_libdir}/avifile*/mjpeg.la
372 %ifarch %{ix86} ppc
373 %dir %{_libdir}/avifile*/vidix
374 %endif
375
376 %files devel
377 %defattr(644,root,root,755)
378 %doc doc/README-DEVEL*
379 %attr(755,root,root) %{_bindir}/avifile-config
380 %{_libdir}/lib*.la
381 %{_libdir}/lib*.so
382 %{_includedir}/%{name}
383 %{_aclocaldir}/*.m4
384 %{_pkgconfigdir}/%{name}.pc
385 %{_mandir}/man1/avifile-config.1*
386
387 %if %{?_without_qt:0}%{!?_without_qt:1}
388 %files aviplay
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_bindir}/aviplay
391 %{_mandir}/man1/aviplay.1*
392 %{_datadir}/%{name}*
393 %{_applnkdir}/Multimedia/*
394 %{_pixmapsdir}/*
395 %endif
396
397 %files utils
398 %defattr(644,root,root,755)
399 %{?!_without_qt:%attr(755,root,root) %{_bindir}/avicap}
400 %{?!_without_qt:%attr(755,root,root) %{_bindir}/avirecompress}
401 %attr(755,root,root) %{_bindir}/avibench
402 %attr(755,root,root) %{_bindir}/avicat
403 %attr(755,root,root) %{_bindir}/avimake
404 %attr(755,root,root) %{_bindir}/avirec
405 %attr(755,root,root) %{_bindir}/avitype
406 %attr(755,root,root) %{_bindir}/kv4lsetup
407 %{?!_without_qt:%{_mandir}/man1/avicap.1*}
408 %{?!_without_qt:%{_mandir}/man1/avirecompress.1*}
409 %{_mandir}/man1/avibench.1*
410 %{_mandir}/man1/avicat.1*
411 %{_mandir}/man1/avimake.1*
412 %{_mandir}/man1/avirec.1*
413 %{_mandir}/man1/avitype.1*
414 %{_mandir}/man1/kv4lsetup.1*
415
416 %ifarch %{ix86}
417 %files win32
418 %defattr(644,root,root,755)
419 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
420 %{_libdir}/avifile*/win32.la
421 %endif
422
423 %files ffmpeg
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
426 %{_libdir}/avifile*/ffmpeg.la
427
428 %if %{?_with_divx:1}%{!?_with_divx:0}
429 %files divx
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
432 %{_libdir}/avifile*/divx*.la
433 %endif
434
435 %files vorbis
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
438 %{_libdir}/avifile*/vorbis*.la
439
440 %files mad
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
443 %{_libdir}/avifile*/mad*.la
444
445 %files lame_audioenc
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
448 %attr(755,root,root) %{_libdir}/avifile*/mp3lame_audioenc.so*
449 %{_libdir}/avifile*/mp3lamebin_audioenc.la
450 %{_libdir}/avifile*/mp3lame_audioenc.la
451
452 %ifarch %{ix86} ppc
453 %files xvid
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
456 %{_libdir}/avifile*/xvid.la
457 %endif
458
459 %ifnarch ppc
460 %files vidix-driver-fb
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_libdir}/avifile*/vidix/libgenfb.so*
463 %{_libdir}/avifile*/vidix/libgenfb.la
464
465 %files vidix-driver-mach64
466 %defattr(644,root,root,755)
467 %attr(755,root,root) %{_libdir}/avifile*/vidix/libmach64.so*
468 %{_libdir}/avifile*/vidix/libmach64.la
469
470 %files vidix-driver-rage128
471 %defattr(644,root,root,755)
472 %attr(755,root,root) %{_libdir}/avifile*/vidix/librage128.so*
473 %{_libdir}/avifile*/vidix/librage128.la
474
475 %files vidix-driver-radeon
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_libdir}/avifile*/vidix/libradeon.so*
478 %{_libdir}/avifile*/vidix/libradeon.la
479
480 %files vidix-driver-mga
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_libdir}/avifile*/vidix/libmga*.so*
483 %{_libdir}/avifile*/vidix/libmga*.la
484
485 %files vidix-driver-nvidia
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_libdir}/avifile*/vidix/libnvidia.so*
488 %{_libdir}/avifile*/vidix/libnvidia.la
489
490 %files vidix-driver-permedia
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_libdir}/avifile*/vidix/libpm3.so*
493 %{_libdir}/avifile*/vidix/libpm3.la
494 %endif
This page took 0.132183 seconds and 4 git commands to generate.