]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 %define         _snapver        20011220
3 %define         _snapsubver     admin
4 %define         _snap           %{_snapver}%{_snapsubver}
5 %define         _ver    0.6
6 %define         _subver .0
7 Summary:        Library for playing AVI files
8 Summary(pl):    Biblioteka do odtwarzania plików AVI
9 Name:           avifile
10 Version:        %{_ver}%{_subver}
11 Release:        0.%{_snap}.4
12 Epoch:          3
13 License:        GPL
14 Group:          X11/Libraries
15 URL:            http://avifile.sourceforge.net/
16 Source0:        http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
17 Source1:        %{name}.desktop
18 Patch0:         %{name}-shareware.patch
19 Patch1:         %{name}-deplib.patch
20 Patch2:         %{name}-ac3.patch
21 Patch3:         %{name}-size_t.patch
22 Patch4:         %{name}-amfix.patch
23 BuildRequires:  XFree86-devel
24 BuildRequires:  SDL-devel >= 1.2.0
25 BuildRequires:  ac3dec-devel >= 0.6.1
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  unzip
28 BuildRequires:  qt-devel
29 BuildRequires:  divx4linux-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  libtool
33 BuildRequires:  libogg-devel
34 BuildRequires:  libvorbis-devel
35 BuildRequires:  lame-libs-devel
36 BuildConflicts: wine-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _prefix         /usr/X11R6
40 %define         _mandir         %{_prefix}/man
41
42 %description
43 Avifile is a library that allow programs to read and write compressed
44 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
45 (De)compression is performed with various plugins (Win32, FFMpeg,...)
46
47 %description -l pl
48 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
49 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
50 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
51
52 %package devel
53 Summary:        Header file required to build programs using libavifile
54 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
55 Group:          X11/Development/Libraries
56 Requires:       XFree86-devel
57 Requires:       %{name} = %{version}
58
59 %description devel
60 Header files required to build programs using libavifile.
61
62 %description devel -l pl
63 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
64 libavifile.
65
66 %package aviplay
67 Summary:        Player for AVI/ASF/WMF files
68 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
69 Group:          X11/Applications/Multimedia
70 Requires:       %{name} = %{version}
71
72 %description aviplay
73 Sample player for AVI, ASF, WFM (with straming support) files.
74
75 %description aviplay -l pl
76 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
77 odtwarzania z sieci.)
78
79 %package utils
80 Summary:        Sample programs using the avifile library
81 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name} = %{version}
84
85 %description utils
86 Qt-based AVI utilities with few other useful supporting tools for TV
87 capturing, AVI recompression, benchmarking, joining AVI files. These
88 programs have more bugs as they are not as extensively developed as
89 player.
90
91 %description utils -l pl
92 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
93 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
94 s± tak intensywnie rozwijane jak odtwarzacz.
95
96 %package win32
97 Summary:        Win32 audio/video plugin
98 Summary(pl):    Plugin audio/video win32
99 Group:          X11/Libraries
100 Requires:       %{name} = %{version}
101 Requires:       w32codec
102 ExclusiveArch:  %{ix86}
103
104 %description win32
105 Plugin for using Win32 DLL libraries in avifile located in
106 /usr/lib/win32.
107
108 %description win32 -l pl
109 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
110 bibliotek DLL Win32.
111
112 %package ffmpeg
113 Summary:        GPL MPEG4 codec
114 Summary(pl):    Kodek MPEG4 na licencji GPL
115 Group:          X11/Libraries
116 Requires:       %{name} = %{version}
117
118 %description ffmpeg
119 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
120 server and a generic audio and video file converter.
121
122 It can grab from a standard Video4Linux video source and convert it
123 into several file formats based on DCT/motion compensation encoding.
124 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
125 stream.
126
127 %description ffmpeg -l pl
128 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
129 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
130
131 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
132 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
133 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
134 kompatybilnego z AC3 strumienia.
135
136 %package divx4
137 Summary:        Fast MPEG4 codec
138 Summary(pl):    Szybki kodek MPEG4
139 Group:          X11/Libraries
140 Requires:       %{name} = %{version}
141 Requires:       divx4linux
142 ExclusiveArch:  %{ix86}
143
144 %description divx4
145 DivX MPEG-4 decoder and encoder.
146
147 %description divx4 -l pl
148 Dekoder i koder MPEG-4 DivX.
149
150 %package vorbis
151 Summary:        Vorbis audio plugin
152 Summary(pl):    Plugin vorbis audio.
153 Group:          X11/Libraries
154 Requires:       %{name} = %{version}
155
156 %description vorbis
157 Plugin for decompression of Vorbis audio streams.
158
159 %description vorbis -l pl
160 Plugin do dekompresji strumieni audio Vorbis.
161
162 %package mad
163 Summary:        MAD - MPEG audio plugin
164 Summary(pl):    MAD - plugin MPEG audio
165 Group:          X11/Libraries
166 Requires:       %{name} = %{version}
167
168 %description mad
169 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
170
171 %description mad -l pl
172 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
173
174 %package lame_audioenc
175 Summary:        MP3 audio encoder plugin
176 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
177 Group:          X11/Libraries
178 Requires:       %{name} = %{version}
179
180 %description lame_audioenc
181 Plugin for mp3 encoding capability of avirecompress tool.
182
183 %description lame_audioenc -l pl
184 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
185
186 %prep
187 %setup -q -n avifile%{_ver}-%{_snapver}
188 %patch0 -p1
189 # was broken and need fixing; without this xmms and avi plugin is broken
190 %patch1 -p1
191 %patch2 -p1
192 %patch3 -p1
193 %patch4 -p1
194
195 %build
196 rm -f missing aclocal.m4
197 libtoolize --copy --force
198 aclocal
199 autoconf
200 autoheader
201 automake -a -c --foreign
202
203 cd plugins/libmad/libmad
204 autoconf
205 cd ../../..
206
207 cd libmmxnow
208 autoconf
209 cd ..
210
211 # This is The WRONG Way (tm)
212 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
213 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
214
215 %configure CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
216         --with-qt-includes=%{_includedir}/qt \
217         --with-libac3-path=%{_prefix} \
218         --enable-release \
219         --enable-ffmpeg
220
221 touch lib/dummy.cpp
222 %{__make}
223
224 %install
225 rm -rf $RPM_BUILD_ROOT
226 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
227
228 # avoid relinking
229 for f in plugins/*/lib*.la ; do
230         sed -e '/^relink_command/d' $f > $f.new
231         mv -f $f.new $f
232 done
233
234 %{__make} install \
235         DESTDIR="$RPM_BUILD_ROOT"
236
237 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
238
239 gzip -9nf README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING} \
240         doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
241
242 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
243 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
244
245 %clean
246 rm -rf $RPM_BUILD_ROOT
247
248 %post   -p /sbin/ldconfig
249 %postun -p /sbin/ldconfig
250
251 %files
252 %defattr(644,root,root,755)
253 %doc *.gz doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}.gz
254 %doc doc/{TODO,VIDEO-PERFORMANCE,WARNINGS}.gz
255 %attr(755,root,root) %{_libdir}/lib*.so.*.*
256 %dir %{_libdir}/avifile*
257 %attr(755,root,root) %{_libdir}/avifile*/lib*audiodec.so*
258 %attr(755,root,root) %{_libdir}/avifile*/lib*audiodec.la
259 %attr(755,root,root) %{_libdir}/avifile*/libac3pass.so*
260 %attr(755,root,root) %{_libdir}/avifile*/libac3pass.la
261 %attr(755,root,root) %{_libdir}/avifile*/libmjpeg.so*
262 %attr(755,root,root) %{_libdir}/avifile*/libmjpeg.la
263
264 %files devel
265 %defattr(644,root,root,755)
266 %doc doc/README-DEVEL*
267 %attr(755,root,root) %{_bindir}/avifile-config
268 %attr(755,root,root) %{_bindir}/mmxnow-config
269 %attr(755,root,root) %{_libdir}/lib*.la
270 %{_libdir}/lib*.so
271 %{_includedir}/%{name}
272
273 %files aviplay
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_bindir}/aviplay
276 %{_datadir}/%{name}*
277 %{_applnkdir}/Multimedia/*
278 %{_pixmapsdir}/*
279
280 %files utils
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
283 %attr(755,root,root) %{_bindir}/kv4lsetup
284
285 %files win32
286 %defattr(644,root,root,755)
287 %attr(755,root,root) %{_libdir}/avifile*/libwin32.so*
288 %attr(755,root,root) %{_libdir}/avifile*/libwin32.la
289
290 %files ffmpeg
291 %defattr(644,root,root,755)
292 %attr(755,root,root) %{_libdir}/avifile*/libffmpeg.so*
293 %attr(755,root,root) %{_libdir}/avifile*/libffmpeg.la
294
295 %files divx4
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/avifile*/libdivx4.so*
298 %attr(755,root,root) %{_libdir}/avifile*/libdivx4.la
299
300 %files vorbis
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/avifile*/libvorbis*.so*
303 %attr(755,root,root) %{_libdir}/avifile*/libvorbis*.la
304
305 %files mad
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_libdir}/avifile*/libmad*.so*
308 %attr(755,root,root) %{_libdir}/avifile*/libmad*.la
309
310 %files lame_audioenc
311 %defattr(644,root,root,755)
312 %attr(755,root,root) %{_libdir}/avifile*/libmp3lamebin_audioenc.so*
313 %attr(755,root,root) %{_libdir}/avifile*/libmp3lamebin_audioenc.la
This page took 0.130033 seconds and 4 git commands to generate.