]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- One more cppflag (for nev xvid)
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 #
3 # Conditional build:
4 # _without_qt           - disables QT support
5 # _with_divx            - enables divx4linux support (proprietary, binary-only
6 #                         lib)  note: if disabled, divx is decoded by ffmpeg
7 #
8 %define         _snapver        20020913
9 %define         _snap           %{_snapver}
10 Summary:        Library for playing AVI files
11 Summary(pl):    Biblioteka do odtwarzania plików AVI
12 Summary(pt_BR): Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
13 Name:           avifile
14 Version:        0.7.16
15 Release:        0.%{_snap}.4%{?_with_divx:+divx}
16 Epoch:          3
17 License:        GPL
18 Group:          X11/Libraries
19 Source0:        http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
20 Source1:        %{name}.desktop
21 Patch0:         %{name}-shareware.patch
22 Patch1:         %{name}-no_libnsl.patch
23 Patch2:         %{name}-vidix.patch
24 Patch3:         %{name}-configure.patch
25 Patch4:         %{name}-compilation.patch
26 Patch5:         %{name}-fix-keys.patch
27 URL:            http://avifile.sourceforge.net/
28 BuildRequires:  SDL-devel >= 1.2.0
29 BuildRequires:  XFree86-devel
30 BuildRequires:  a52dec-libs-devel
31 BuildRequires:  audiofile-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 %{?_with_divx:BuildRequires:    divx4linux-devel}
35 BuildRequires:  lame-libs-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libogg-devel
38 BuildRequires:  libtool >= 0:1.4.2-9
39 BuildRequires:  libvorbis-devel >= 1:1.0
40 BuildRequires:  nas-devel
41 %{?!_without_qt:BuildRequires:  qt-devel >= 2.0.0}
42 BuildRequires:  unzip
43 %ifarch %{ix86} ppc
44 BuildRequires:  xvid-devel
45 %endif
46 BuildConflicts: wine-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _prefix         /usr/X11R6
50 %define         _mandir         %{_prefix}/man
51
52 %description
53 Avifile is a library that allow programs to read and write compressed
54 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
55 (De)compression is performed with various plugins (Win32, FFMpeg,...)
56
57 %description -l pl
58 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
59 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
60 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
61
62 %description -l pt_BR
63 Avifile busca criar uma biblioteca usável de suporte a arquivos AVI e
64 um conjunto básico de utilitários (para reprodução, captura e edição)
65 para o Linux. Contém classes C++ para leitura e criação de AVIs e
66 interfaces para compressores e descompresseores de áudio e vídeo.
67
68 %package devel
69 Summary:        Header file required to build programs using libavifile
70 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
71 Summary(pt_BR): Componentes para desenvolvimento com a avifile
72 Group:          X11/Development/Libraries
73 Requires:       XFree86-devel
74 Requires:       %{name} = %{version}
75
76 %description devel
77 Header files required to build programs using libavifile.
78
79 %description devel -l pl
80 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
81 libavifile.
82
83 %description devel -l pt_BR
84 Componentes para desenvolvimento com a avifile.
85
86 %package aviplay
87 Summary:        Player for AVI/ASF/WMF files
88 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
89 Group:          X11/Applications/Multimedia
90 Requires:       %{name} = %{version}
91
92 %description aviplay
93 Sample player for AVI, ASF, WFM (with straming support) files.
94
95 %description aviplay -l pl
96 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
97 odtwarzania z sieci.)
98
99 %package utils
100 Summary:        Sample programs using the avifile library
101 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
102 Group:          X11/Applications/Multimedia
103 Requires:       %{name} = %{version}
104
105 %description utils
106 Qt-based AVI utilities with few other useful supporting tools for TV
107 capturing, AVI recompression, benchmarking, joining AVI files. These
108 programs have more bugs as they are not as extensively developed as
109 player.
110
111 %description utils -l pl
112 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
113 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
114 s± tak intensywnie rozwijane jak odtwarzacz.
115
116 %package win32
117 Summary:        Win32 audio/video plugin
118 Summary(pl):    Plugin audio/video win32
119 Group:          X11/Libraries
120 Requires:       %{name} = %{version}
121 Requires:       w32codec
122
123 %description win32
124 Plugin for using Win32 DLL libraries in avifile located in
125 /usr/lib/win32.
126
127 %description win32 -l pl
128 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
129 bibliotek DLL Win32.
130
131 %package ffmpeg
132 Summary:        GPL MPEG4 codec
133 Summary(pl):    Kodek MPEG4 na licencji GPL
134 Group:          X11/Libraries
135 Requires:       %{name} = %{version}
136
137 %description ffmpeg
138 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
139 server and a generic audio and video file converter.
140
141 It can grab from a standard Video4Linux video source and convert it
142 into several file formats based on DCT/motion compensation encoding.
143 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
144 stream.
145
146 %description ffmpeg -l pl
147 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
148 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
149
150 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
151 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
152 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
153 kompatybilnego z AC3 strumienia.
154
155 %package divx
156 Summary:        Fast MPEG4 codec
157 Summary(pl):    Szybki kodek MPEG4
158 Group:          X11/Libraries
159 Requires:       %{name} = %{version}
160 Requires:       divx4linux
161 Obsoletes:      avifile-divx4
162
163 %description divx
164 DivX MPEG-4 decoder and encoder.
165
166 %description divx -l pl
167 Dekoder i koder MPEG-4 DivX.
168
169 %package vorbis
170 Summary:        Vorbis audio plugin
171 Summary(pl):    Plugin vorbis audio
172 Group:          X11/Libraries
173 Requires:       %{name} = %{version}
174
175 %description vorbis
176 Plugin for decompression of Vorbis audio streams.
177
178 %description vorbis -l pl
179 Plugin do dekompresji strumieni audio Vorbis.
180
181 %package mad
182 Summary:        MAD - MPEG audio plugin
183 Summary(pl):    MAD - plugin MPEG audio
184 Group:          X11/Libraries
185 Requires:       %{name} = %{version}
186
187 %description mad
188 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
189
190 %description mad -l pl
191 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
192
193 %package lame_audioenc
194 Summary:        MP3 audio encoder plugin
195 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
196 Group:          X11/Libraries
197 Requires:       %{name} = %{version}
198
199 %description lame_audioenc
200 Plugin for mp3 encoding capability of avirecompress tool.
201
202 %description lame_audioenc -l pl
203 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
204
205 %package xvid
206 Summary:        XVID codec
207 Summary(pl):    Kodek XVID
208 Group:          X11/Libraries
209 Requires:       %{name} = %{version}
210 Requires:       xvid
211
212 %description xvid
213 XVID decoder and encoder.
214
215 %description xvid -l pl
216 Dekoder i koder XVID.
217
218 %prep
219 %setup -q -n avifile0.7-%{version}
220 %patch0 -p1
221 %patch1 -p1
222 %patch2 -p1
223 %patch3 -p1
224 %patch4 -p0
225 %patch5 -p1
226
227 %build
228 rm -f missing aclocal.m4
229 %{__libtoolize}
230 %{__aclocal}
231 %{__autoheader}
232 %{__autoconf}
233 %{__automake}
234
235 cd plugins/libmad/libmad
236 %{__autoconf}
237 cd ../../..
238
239 cd libmmxnow
240 %{__autoconf}
241 cd ..
242
243 # This is The WRONG Way (tm)
244 %if %{!?_without_qt:1}%{?_without_qt:0}
245 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
246 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
247 %endif
248
249 %configure \
250         CPPFLAGS="-I/usr/include/divx -I/usr/include/xvid" AS="%{__cc}" \
251         FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
252         --with-qt-includes=%{_includedir}/qt \
253         --with-qt-libraries=%{_libdir} \
254         --enable-a52 \
255         --enable-release \
256         --enable-ffmpeg \
257         --enable-ffmpeg-a52 \
258         %{?_with_divx:--enable-divx4} \
259 %ifarch i586 i686 athlon
260         --enable-x86opt \
261 %else
262         --disable-x86opt \
263 %endif
264         %{?_without_qt:--without-qt} \
265         %{?_without_qt:--disable-samples}
266
267 touch lib/dummy.cpp
268 %{__make}
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
273
274 %{__make} install \
275         DESTDIR="$RPM_BUILD_ROOT" \
276         m4datadir="%{_aclocaldir}"
277
278 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
279
280 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
281 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
282
283 %clean
284 rm -rf $RPM_BUILD_ROOT
285
286 %post   -p /sbin/ldconfig
287 %postun -p /sbin/ldconfig
288
289 %files
290 %defattr(644,root,root,755)
291 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
292 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
293 %attr(755,root,root) %{_libdir}/lib*.so.*.*
294 %dir %{_libdir}/avifile*
295 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
296 %{_libdir}/avifile*/audiodec.la
297 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
298 %{_libdir}/avifile*/mpeg_audiodec.la
299 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
300 %{_libdir}/avifile*/ac3pass.la
301 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
302 %{_libdir}/avifile*/mjpeg.la
303
304 %files devel
305 %defattr(644,root,root,755)
306 %doc doc/README-DEVEL*
307 %attr(755,root,root) %{_bindir}/avifile-config
308 %attr(755,root,root) %{_bindir}/mmxnow-config
309 %{_libdir}/lib*.la
310 %{_libdir}/lib*.so
311 %{_includedir}/%{name}
312 %{_includedir}/*.h
313 %{_aclocaldir}/*.m4
314
315 %if %{?_without_qt:0}%{!?_without_qt:1}
316 %files aviplay
317 %defattr(644,root,root,755)
318 %attr(755,root,root) %{_bindir}/aviplay
319 %{_mandir}/man1/aviplay.1*
320 %{_datadir}/%{name}*
321 %{_applnkdir}/Multimedia/*
322 %{_pixmapsdir}/*
323
324 %files utils
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
327 %attr(755,root,root) %{_bindir}/kv4lsetup
328 %endif
329
330 %ifarch %{ix86}
331 %files win32
332 %defattr(644,root,root,755)
333 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
334 %{_libdir}/avifile*/win32.la
335 %endif
336
337 %files ffmpeg
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
340 %{_libdir}/avifile*/ffmpeg.la
341
342 %if %{?_with_divx:1}%{!?_with_divx:0}
343 %files divx
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
346 %{_libdir}/avifile*/divx*.la
347 %endif
348
349 %files vorbis
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
352 %{_libdir}/avifile*/vorbis*.la
353
354 %files mad
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
357 %{_libdir}/avifile*/mad*.la
358
359 %files lame_audioenc
360 %defattr(644,root,root,755)
361 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
362 %{_libdir}/avifile*/mp3lamebin_audioenc.la
363
364 %ifarch %{ix86} ppc
365 %files xvid
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
368 %{_libdir}/avifile*/xvid.la
369 %endif
This page took 0.058553 seconds and 4 git commands to generate.