]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- freetype2 is back thanks to qboosh for xft patch
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 #
3 # Conditional build:
4 # _without_qt           - disables QT support
5 # _with_divx            - enables divx4linux support (proprietary, binary-only
6 #                         lib)  note: if disabled, divx is decoded by ffmpeg
7 #
8 %define         _snapver        20030107
9 %define         _snap           %{_snapver}
10 Summary:        Library for playing AVI files
11 Summary(pl):    Biblioteka do odtwarzania plików AVI
12 Summary(pt_BR): Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
13 Name:           avifile
14 Version:        0.7.24
15 Release:        0.%{_snap}.%{?_with_divx:+divx}
16 Epoch:          3
17 License:        GPL
18 Group:          X11/Libraries
19 Source0:        %{name}0.7-%{version}-%{_snap}.tar.bz2
20 Source1:        %{name}.desktop
21 Patch0:         %{name}-shareware.patch
22 Patch1:         %{name}-no_libnsl.patch
23 Patch2:         %{name}-configure.patch
24 Patch3:         %{name}-fix-keys.patch
25 Patch4:         %{name}-xft.patch
26 URL:            http://avifile.sourceforge.net/
27 BuildRequires:  SDL-devel >= 1.2.0
28 BuildRequires:  XFree86-devel
29 BuildRequires:  a52dec-libs-devel
30 BuildRequires:  audiofile-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 %{?_with_divx:BuildRequires:    divx4linux-devel}
34 BuildRequires:  lame-libs-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libogg-devel
37 BuildRequires:  libtool >= 0:1.4.2-9
38 BuildRequires:  libvorbis-devel >= 1:1.0
39 BuildRequires:  nas-devel
40 %{?!_without_qt:BuildRequires:  qt-devel >= 2.0.0}
41 BuildRequires:  unzip
42 %ifarch %{ix86} ppc
43 BuildRequires:  xvid-devel
44 %endif
45 BuildConflicts: wine-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _prefix         /usr/X11R6
49 %define         _mandir         %{_prefix}/man
50
51 %description
52 Avifile is a library that allow programs to read and write compressed
53 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
54 (De)compression is performed with various plugins (Win32, FFMpeg,...)
55
56 %description -l pl
57 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
58 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
59 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
60
61 %description -l pt_BR
62 Avifile busca criar uma biblioteca usável de suporte a arquivos AVI e
63 um conjunto básico de utilitários (para reprodução, captura e edição)
64 para o Linux. Contém classes C++ para leitura e criação de AVIs e
65 interfaces para compressores e descompresseores de áudio e vídeo.
66
67 %package devel
68 Summary:        Header file required to build programs using libavifile
69 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
70 Summary(pt_BR): Componentes para desenvolvimento com a avifile
71 Group:          X11/Development/Libraries
72 Requires:       XFree86-devel
73 Requires:       %{name} = %{version}
74
75 %description devel
76 Header files required to build programs using libavifile.
77
78 %description devel -l pl
79 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
80 libavifile.
81
82 %description devel -l pt_BR
83 Componentes para desenvolvimento com a avifile.
84
85 %package aviplay
86 Summary:        Player for AVI/ASF/WMF files
87 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
88 Group:          X11/Applications/Multimedia
89 Requires:       %{name} = %{version}
90
91 %description aviplay
92 Sample player for AVI, ASF, WFM (with straming support) files.
93
94 %description aviplay -l pl
95 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
96 odtwarzania z sieci.)
97
98 %package utils
99 Summary:        Sample programs using the avifile library
100 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
101 Group:          X11/Applications/Multimedia
102 Requires:       %{name} = %{version}
103
104 %description utils
105 Qt-based AVI utilities with few other useful supporting tools for TV
106 capturing, AVI recompression, benchmarking, joining AVI files. These
107 programs have more bugs as they are not as extensively developed as
108 player.
109
110 %description utils -l pl
111 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
112 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
113 s± tak intensywnie rozwijane jak odtwarzacz.
114
115 %package win32
116 Summary:        Win32 audio/video plugin
117 Summary(pl):    Plugin audio/video win32
118 Group:          X11/Libraries
119 Requires:       %{name} = %{version}
120 Requires:       w32codec
121
122 %description win32
123 Plugin for using Win32 DLL libraries in avifile located in
124 /usr/lib/win32.
125
126 %description win32 -l pl
127 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
128 bibliotek DLL Win32.
129
130 %package ffmpeg
131 Summary:        GPL MPEG4 codec
132 Summary(pl):    Kodek MPEG4 na licencji GPL
133 Group:          X11/Libraries
134 Requires:       %{name} = %{version}
135
136 %description ffmpeg
137 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
138 server and a generic audio and video file converter.
139
140 It can grab from a standard Video4Linux video source and convert it
141 into several file formats based on DCT/motion compensation encoding.
142 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
143 stream.
144
145 %description ffmpeg -l pl
146 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
147 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
148
149 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
150 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
151 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
152 kompatybilnego z AC3 strumienia.
153
154 %package divx
155 Summary:        Fast MPEG4 codec
156 Summary(pl):    Szybki kodek MPEG4
157 Group:          X11/Libraries
158 Requires:       %{name} = %{version}
159 Requires:       divx4linux
160 Obsoletes:      avifile-divx4
161
162 %description divx
163 DivX MPEG-4 decoder and encoder.
164
165 %description divx -l pl
166 Dekoder i koder MPEG-4 DivX.
167
168 %package vorbis
169 Summary:        Vorbis audio plugin
170 Summary(pl):    Plugin vorbis audio
171 Group:          X11/Libraries
172 Requires:       %{name} = %{version}
173
174 %description vorbis
175 Plugin for decompression of Vorbis audio streams.
176
177 %description vorbis -l pl
178 Plugin do dekompresji strumieni audio Vorbis.
179
180 %package mad
181 Summary:        MAD - MPEG audio plugin
182 Summary(pl):    MAD - plugin MPEG audio
183 Group:          X11/Libraries
184 Requires:       %{name} = %{version}
185
186 %description mad
187 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
188
189 %description mad -l pl
190 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
191
192 %package lame_audioenc
193 Summary:        MP3 audio encoder plugin
194 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
195 Group:          X11/Libraries
196 Requires:       %{name} = %{version}
197
198 %description lame_audioenc
199 Plugin for mp3 encoding capability of avirecompress tool.
200
201 %description lame_audioenc -l pl
202 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
203
204 %package xvid
205 Summary:        XVID codec
206 Summary(pl):    Kodek XVID
207 Group:          X11/Libraries
208 Requires:       %{name} = %{version}
209 Requires:       xvid
210
211 %description xvid
212 XVID decoder and encoder.
213
214 %description xvid -l pl
215 Dekoder i koder XVID.
216
217 %prep
218 %setup -q -n avifile0.7-%{version}
219 %patch0 -p1
220 %patch1 -p1
221 %patch2 -p1
222 %patch3 -p1
223 %patch4 -p1
224
225 %build
226 #rm -f missing aclocal.m4
227 #%%{__libtoolize}
228 #%%{__aclocal} -I m4
229 #%%{__autoheader}
230 #%%{__autoconf}
231 #%%{__automake}
232
233 #cd plugins/libmad/libmad
234 #%%{__autoconf}
235 #cd ../../..
236
237 #cd libmmxnow
238 #%%{__autoconf}
239 #cd ..
240
241 ./autogen.sh
242
243 # This is The WRONG Way (tm)
244 %if %{!?_without_qt:1}%{?_without_qt:0}
245 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
246 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
247 %endif
248
249 #Temporary removed -I/usr/include/freetype2 cause it break build, I don't know why :(
250
251 %configure \
252         CPPFLAGS="-I/usr/include/divx -I/usr/include/xvid -I/usr/include/freetype2" \
253         AS="%{__cc}" \
254         FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
255         --with-qt-includes=%{_includedir}/qt \
256         --with-qt-libraries=%{_libdir} \
257         --enable-a52 \
258         --enable-release \
259         --enable-ffmpeg \
260         --enable-ffmpeg-a52 \
261         %{?_with_divx:--enable-divx4} \
262 %ifarch i586 i686 athlon
263         --enable-x86opt \
264 %else
265         --disable-x86opt \
266 %endif
267         %{?_without_qt:--without-qt} \
268         %{?_without_qt:--disable-samples}
269
270 touch lib/dummy.cpp
271 %{__make}
272
273 %install
274 rm -rf $RPM_BUILD_ROOT
275 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
276
277 %{__make} install \
278         DESTDIR="$RPM_BUILD_ROOT" \
279         m4datadir="%{_aclocaldir}"
280
281 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
282
283 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
284 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
285
286 %clean
287 rm -rf $RPM_BUILD_ROOT
288
289 %post   -p /sbin/ldconfig
290 %postun -p /sbin/ldconfig
291
292 %files
293 %defattr(644,root,root,755)
294 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
295 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
296 %attr(755,root,root) %{_libdir}/lib*.so.*.*
297 %dir %{_libdir}/avifile*
298 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
299 %{_libdir}/avifile*/audiodec.la
300 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
301 %{_libdir}/avifile*/mpeg_audiodec.la
302 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
303 %{_libdir}/avifile*/ac3pass.la
304 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
305 %{_libdir}/avifile*/mjpeg.la
306
307 %files devel
308 %defattr(644,root,root,755)
309 %doc doc/README-DEVEL*
310 %attr(755,root,root) %{_bindir}/avifile-config
311 %attr(755,root,root) %{_bindir}/mmxnow-config
312 %{_libdir}/lib*.la
313 %{_libdir}/lib*.so
314 %{_includedir}/%{name}
315 %{_includedir}/*.h
316 %{_aclocaldir}/*.m4
317
318 %if %{?_without_qt:0}%{!?_without_qt:1}
319 %files aviplay
320 %defattr(644,root,root,755)
321 %attr(755,root,root) %{_bindir}/aviplay
322 %{_mandir}/man1/aviplay.1*
323 %{_datadir}/%{name}*
324 %{_applnkdir}/Multimedia/*
325 %{_pixmapsdir}/*
326
327 %files utils
328 %defattr(644,root,root,755)
329 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
330 %attr(755,root,root) %{_bindir}/kv4lsetup
331 %endif
332
333 %ifarch %{ix86}
334 %files win32
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
337 %{_libdir}/avifile*/win32.la
338 %endif
339
340 %files ffmpeg
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
343 %{_libdir}/avifile*/ffmpeg.la
344
345 %if %{?_with_divx:1}%{!?_with_divx:0}
346 %files divx
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
349 %{_libdir}/avifile*/divx*.la
350 %endif
351
352 %files vorbis
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
355 %{_libdir}/avifile*/vorbis*.la
356
357 %files mad
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
360 %{_libdir}/avifile*/mad*.la
361
362 %files lame_audioenc
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
365 %{_libdir}/avifile*/mp3lamebin_audioenc.la
366
367 %ifarch %{ix86} ppc
368 %files xvid
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
371 %{_libdir}/avifile*/xvid.la
372 %endif
This page took 0.062788 seconds and 4 git commands to generate.