]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
- changes amfix to allow building avifile using ac2.53/am1.6.1
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 %define         _snapver        20020412
3 %define         _snap           %{_snapver}
4 %define         _ver    0.7
5 Summary:        Library for playing AVI files
6 Summary(pl):    Biblioteka do odtwarzania plików AVI
7 Name:           avifile
8 Version:        %{_ver}
9 Release:        0.%{_snap}.3
10 Epoch:          3
11 License:        GPL
12 Group:          X11/Libraries
13 URL:            http://avifile.sourceforge.net/
14 Source0:        http://avifile.sourceforge.net/%{name}%{version}-%{_snap}.tar.gz
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-shareware.patch
17 Patch1:         %{name}-deplib.patch
18 Patch2:         %{name}-ac3.patch
19 Patch3:         %{name}-size_t.patch
20 Patch4:         %{name}-amfix.patch
21 BuildRequires:  XFree86-devel
22 BuildRequires:  SDL-devel >= 1.2.0
23 BuildRequires:  ac3dec-devel >= 0.6.1
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  unzip
26 BuildRequires:  qt-devel
27 %ifarch %{ix86}
28 BuildRequires:  divx4linux-devel
29 %endif
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  libtool
33 BuildRequires:  libogg-devel
34 BuildRequires:  libvorbis-devel
35 BuildRequires:  lame-libs-devel
36 %ifarch %{ix86}
37 BuildRequires:  xvid-devel
38 %endif
39 BuildConflicts: wine-devel
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _prefix         /usr/X11R6
43 %define         _mandir         %{_prefix}/man
44
45 %description
46 Avifile is a library that allow programs to read and write compressed
47 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
48 (De)compression is performed with various plugins (Win32, FFMpeg,...)
49
50 %description -l pl
51 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
52 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
53 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
54
55 %package devel
56 Summary:        Header file required to build programs using libavifile
57 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
58 Group:          X11/Development/Libraries
59 Requires:       XFree86-devel
60 Requires:       %{name} = %{version}
61
62 %description devel
63 Header files required to build programs using libavifile.
64
65 %description devel -l pl
66 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
67 libavifile.
68
69 %package aviplay
70 Summary:        Player for AVI/ASF/WMF files
71 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
72 Group:          X11/Applications/Multimedia
73 Requires:       %{name} = %{version}
74
75 %description aviplay
76 Sample player for AVI, ASF, WFM (with straming support) files.
77
78 %description aviplay -l pl
79 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
80 odtwarzania z sieci.)
81
82 %package utils
83 Summary:        Sample programs using the avifile library
84 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
85 Group:          X11/Applications/Multimedia
86 Requires:       %{name} = %{version}
87
88 %description utils
89 Qt-based AVI utilities with few other useful supporting tools for TV
90 capturing, AVI recompression, benchmarking, joining AVI files. These
91 programs have more bugs as they are not as extensively developed as
92 player.
93
94 %description utils -l pl
95 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
96 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
97 s± tak intensywnie rozwijane jak odtwarzacz.
98
99 %package win32
100 Summary:        Win32 audio/video plugin
101 Summary(pl):    Plugin audio/video win32
102 Group:          X11/Libraries
103 Requires:       %{name} = %{version}
104 Requires:       w32codec
105
106 %description win32
107 Plugin for using Win32 DLL libraries in avifile located in
108 /usr/lib/win32.
109
110 %description win32 -l pl
111 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
112 bibliotek DLL Win32.
113
114 %package ffmpeg
115 Summary:        GPL MPEG4 codec
116 Summary(pl):    Kodek MPEG4 na licencji GPL
117 Group:          X11/Libraries
118 Requires:       %{name} = %{version}
119
120 %description ffmpeg
121 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
122 server and a generic audio and video file converter.
123
124 It can grab from a standard Video4Linux video source and convert it
125 into several file formats based on DCT/motion compensation encoding.
126 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
127 stream.
128
129 %description ffmpeg -l pl
130 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
131 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
132
133 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
134 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
135 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
136 kompatybilnego z AC3 strumienia.
137
138 %package divx4
139 Summary:        Fast MPEG4 codec
140 Summary(pl):    Szybki kodek MPEG4
141 Group:          X11/Libraries
142 Requires:       %{name} = %{version}
143 Requires:       divx4linux
144 ExclusiveArch:  %{ix86}
145
146 %description divx4
147 DivX MPEG-4 decoder and encoder.
148
149 %description divx4 -l pl
150 Dekoder i koder MPEG-4 DivX.
151
152 %package vorbis
153 Summary:        Vorbis audio plugin
154 Summary(pl):    Plugin vorbis audio.
155 Group:          X11/Libraries
156 Requires:       %{name} = %{version}
157
158 %description vorbis
159 Plugin for decompression of Vorbis audio streams.
160
161 %description vorbis -l pl
162 Plugin do dekompresji strumieni audio Vorbis.
163
164 %package mad
165 Summary:        MAD - MPEG audio plugin
166 Summary(pl):    MAD - plugin MPEG audio
167 Group:          X11/Libraries
168 Requires:       %{name} = %{version}
169
170 %description mad
171 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
172
173 %description mad -l pl
174 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
175
176 %package lame_audioenc
177 Summary:        MP3 audio encoder plugin
178 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
179 Group:          X11/Libraries
180 Requires:       %{name} = %{version}
181
182 %description lame_audioenc
183 Plugin for mp3 encoding capability of avirecompress tool.
184
185 %description lame_audioenc -l pl
186 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
187
188 %package xvid
189 Summary:        XVID codec
190 Summary(pl):    Kodek XVID
191 Group:          X11/Libraries
192 Requires:       %{name} = %{version}
193 Requires:       xvid
194 ExclusiveArch:  %{ix86}
195
196 %description xvid
197 XVID decoder and encoder.
198
199 %description xvid -l pl
200 Dekoder i koder XVID.
201
202 %prep
203 %setup -q -n avifile%{_ver}-%{_snapver}
204 %patch0 -p1
205 # was broken and need fixing; without this xmms and avi plugin is broken
206 %patch1 -p1
207 %patch2 -p1
208 %patch3 -p1
209 %patch4 -p1
210
211 %build
212 rm -f missing aclocal.m4
213 libtoolize --copy --force
214 aclocal
215 autoheader
216 autoconf
217 automake -a -c --foreign
218
219 cd plugins/libmad/libmad
220 autoconf
221 cd ../../..
222
223 cd libmmxnow
224 autoconf
225 cd ..
226
227 # This is The WRONG Way (tm)
228 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
229 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
230
231 %configure CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
232         --with-qt-includes=%{_includedir}/qt \
233         --with-libac3-path=%{_prefix} \
234         --enable-release \
235         --enable-ffmpeg \
236         --disable-x86opt
237
238 touch lib/dummy.cpp
239 %{__make}
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
244
245 # avoid relinking
246 for f in plugins/*/lib*.la ; do
247         sed -e '/^relink_command/d' $f > $f.new
248         mv -f $f.new $f
249 done
250
251 %{__make} install \
252         DESTDIR="$RPM_BUILD_ROOT"
253
254 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
255
256 gzip -9nf README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING} \
257         doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
258
259 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
260 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post   -p /sbin/ldconfig
266 %postun -p /sbin/ldconfig
267
268 %files
269 %defattr(644,root,root,755)
270 %doc *.gz doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}.gz
271 %doc doc/{TODO,VIDEO-PERFORMANCE,WARNINGS}.gz
272 %attr(755,root,root) %{_libdir}/lib*.so.*.*
273 %dir %{_libdir}/avifile*
274 %attr(755,root,root) %{_libdir}/avifile*/libaudiodec.so*
275 %attr(755,root,root) %{_libdir}/avifile*/libaudiodec.la
276 %attr(755,root,root) %{_libdir}/avifile*/libmpeg_audiodec.so*
277 %attr(755,root,root) %{_libdir}/avifile*/libmpeg_audiodec.la
278 %attr(755,root,root) %{_libdir}/avifile*/libac3pass.so*
279 %attr(755,root,root) %{_libdir}/avifile*/libac3pass.la
280 %attr(755,root,root) %{_libdir}/avifile*/libmjpeg.so*
281 %attr(755,root,root) %{_libdir}/avifile*/libmjpeg.la
282
283 %files devel
284 %defattr(644,root,root,755)
285 %doc doc/README-DEVEL*
286 %attr(755,root,root) %{_bindir}/avifile-config
287 %attr(755,root,root) %{_bindir}/mmxnow-config
288 %attr(755,root,root) %{_libdir}/lib*.la
289 %{_libdir}/lib*.so
290 %{_includedir}/%{name}
291
292 %files aviplay
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_bindir}/aviplay
295 %{_datadir}/%{name}*
296 %{_applnkdir}/Multimedia/*
297 %{_pixmapsdir}/*
298
299 %files utils
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
302 %attr(755,root,root) %{_bindir}/kv4lsetup
303
304 %ifarch %{ix86}
305 %files win32
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_libdir}/avifile*/libwin32.so*
308 %attr(755,root,root) %{_libdir}/avifile*/libwin32.la
309 %endif
310
311 %files ffmpeg
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_libdir}/avifile*/libffmpeg.so*
314 %attr(755,root,root) %{_libdir}/avifile*/libffmpeg.la
315
316 %ifarch %{ix86}
317 %files divx4
318 %defattr(644,root,root,755)
319 %attr(755,root,root) %{_libdir}/avifile*/libdivx4.so*
320 %attr(755,root,root) %{_libdir}/avifile*/libdivx4.la
321 %endif
322
323 %files vorbis
324 %defattr(644,root,root,755)
325 %attr(755,root,root) %{_libdir}/avifile*/libvorbis*.so*
326 %attr(755,root,root) %{_libdir}/avifile*/libvorbis*.la
327
328 %files mad
329 %defattr(644,root,root,755)
330 %attr(755,root,root) %{_libdir}/avifile*/libmad*.so*
331 %attr(755,root,root) %{_libdir}/avifile*/libmad*.la
332
333 %files lame_audioenc
334 %defattr(644,root,root,755)
335 %attr(755,root,root) %{_libdir}/avifile*/libmp3lamebin_audioenc.so*
336 %attr(755,root,root) %{_libdir}/avifile*/libmp3lamebin_audioenc.la
337
338 %ifarch %{ix86}
339 %files xvid
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/avifile*/libxvid.so*
342 %attr(755,root,root) %{_libdir}/avifile*/libxvid.la
343 %endif
This page took 0.048969 seconds and 4 git commands to generate.