]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
ff0882e3fe56639e72440478c377218f6b09319f
[packages/avifile.git] / avifile.spec
1 # It's sick.
2 #
3 # Conditional build:
4 # _without_qt           - disables QT support
5 # _with_divx            - enables divx4linux support (proprietary, binary-only
6 #                         lib)  note: if disabled, divx is decoded by ffmpeg
7 #
8 %define         _snapver        20030107
9 %define         _snap           %{_snapver}
10 Summary:        Library for playing AVI files
11 Summary(pl):    Biblioteka do odtwarzania plików AVI
12 Summary(pt_BR): Biblioteca para reproduzir formatos de áudio e vídeo usando binários win32
13 Name:           avifile
14 Version:        0.7.24
15 Release:        0.%{_snap}%{?_with_divx:+divx}
16 Epoch:          3
17 License:        GPL
18 Group:          X11/Libraries
19 Source0:        %{name}0.7-%{version}-%{_snap}.tar.bz2
20 Source1:        %{name}.desktop
21 Patch0:         %{name}-shareware.patch
22 Patch1:         %{name}-no_libnsl.patch
23 Patch2:         %{name}-configure.patch
24 Patch3:         %{name}-fix-keys.patch
25 Patch4:         %{name}-xft.patch
26 URL:            http://avifile.sourceforge.net/
27 BuildRequires:  SDL-devel >= 1.2.0
28 BuildRequires:  XFree86-devel
29 BuildRequires:  a52dec-libs-devel
30 BuildRequires:  audiofile-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 %{?_with_divx:BuildRequires:    divx4linux-devel}
34 BuildRequires:  lame-libs-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libogg-devel
37 BuildRequires:  libtool >= 0:1.4.2-9
38 BuildRequires:  libvorbis-devel >= 1:1.0
39 BuildRequires:  nas-devel
40 %{?!_without_qt:BuildRequires:  qt-devel >= 2.0.0}
41 BuildRequires:  unzip
42 %ifarch %{ix86} ppc
43 BuildRequires:  xvid-devel
44 %endif
45 BuildConflicts: wine-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _prefix         /usr/X11R6
49 %define         _mandir         %{_prefix}/man
50
51 %description
52 Avifile is a library that allow programs to read and write compressed
53 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
54 (De)compression is performed with various plugins (Win32, FFMpeg,...)
55
56 %description -l pl
57 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
58 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
59 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
60
61 %description -l pt_BR
62 Avifile busca criar uma biblioteca usável de suporte a arquivos AVI e
63 um conjunto básico de utilitários (para reprodução, captura e edição)
64 para o Linux. Contém classes C++ para leitura e criação de AVIs e
65 interfaces para compressores e descompresseores de áudio e vídeo.
66
67 %package devel
68 Summary:        Header file required to build programs using libavifile
69 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
70 Summary(pt_BR): Componentes para desenvolvimento com a avifile
71 Group:          X11/Development/Libraries
72 Requires:       XFree86-devel
73 Requires:       %{name} = %{version}
74
75 %description devel
76 Header files required to build programs using libavifile.
77
78 %description devel -l pl
79 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
80 libavifile.
81
82 %description devel -l pt_BR
83 Componentes para desenvolvimento com a avifile.
84
85 %package aviplay
86 Summary:        Player for AVI/ASF/WMF files
87 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
88 Group:          X11/Applications/Multimedia
89 Requires:       %{name} = %{version}
90
91 %description aviplay
92 Sample player for AVI, ASF, WFM (with straming support) files.
93
94 %description aviplay -l pl
95 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
96 odtwarzania z sieci.)
97
98 %package utils
99 Summary:        Sample programs using the avifile library
100 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
101 Group:          X11/Applications/Multimedia
102 Requires:       %{name} = %{version}
103
104 %description utils
105 Qt-based AVI utilities with few other useful supporting tools for TV
106 capturing, AVI recompression, benchmarking, joining AVI files. These
107 programs have more bugs as they are not as extensively developed as
108 player.
109
110 %description utils -l pl
111 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
112 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
113 s± tak intensywnie rozwijane jak odtwarzacz.
114
115 %package win32
116 Summary:        Win32 audio/video plugin
117 Summary(pl):    Plugin audio/video win32
118 Group:          X11/Libraries
119 Requires:       %{name} = %{version}
120 Requires:       w32codec
121
122 %description win32
123 Plugin for using Win32 DLL libraries in avifile located in
124 /usr/lib/win32.
125
126 %description win32 -l pl
127 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
128 bibliotek DLL Win32.
129
130 %package ffmpeg
131 Summary:        GPL MPEG4 codec
132 Summary(pl):    Kodek MPEG4 na licencji GPL
133 Group:          X11/Libraries
134 Requires:       %{name} = %{version}
135
136 %description ffmpeg
137 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
138 server and a generic audio and video file converter.
139
140 It can grab from a standard Video4Linux video source and convert it
141 into several file formats based on DCT/motion compensation encoding.
142 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
143 stream.
144
145 %description ffmpeg -l pl
146 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
147 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
148
149 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
150 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
151 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
152 kompatybilnego z AC3 strumienia.
153
154 %package divx
155 Summary:        Fast MPEG4 codec
156 Summary(pl):    Szybki kodek MPEG4
157 Group:          X11/Libraries
158 Requires:       %{name} = %{version}
159 Requires:       divx4linux
160 Obsoletes:      avifile-divx4
161
162 %description divx
163 DivX MPEG-4 decoder and encoder.
164
165 %description divx -l pl
166 Dekoder i koder MPEG-4 DivX.
167
168 %package vorbis
169 Summary:        Vorbis audio plugin
170 Summary(pl):    Plugin vorbis audio
171 Group:          X11/Libraries
172 Requires:       %{name} = %{version}
173
174 %description vorbis
175 Plugin for decompression of Vorbis audio streams.
176
177 %description vorbis -l pl
178 Plugin do dekompresji strumieni audio Vorbis.
179
180 %package mad
181 Summary:        MAD - MPEG audio plugin
182 Summary(pl):    MAD - plugin MPEG audio
183 Group:          X11/Libraries
184 Requires:       %{name} = %{version}
185
186 %description mad
187 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
188
189 %description mad -l pl
190 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
191
192 %package lame_audioenc
193 Summary:        MP3 audio encoder plugin
194 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
195 Group:          X11/Libraries
196 Requires:       %{name} = %{version}
197
198 %description lame_audioenc
199 Plugin for mp3 encoding capability of avirecompress tool.
200
201 %description lame_audioenc -l pl
202 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
203
204 %package xvid
205 Summary:        XVID codec
206 Summary(pl):    Kodek XVID
207 Group:          X11/Libraries
208 Requires:       %{name} = %{version}
209 Requires:       xvid
210
211 %description xvid
212 XVID decoder and encoder.
213
214 %description xvid -l pl
215 Dekoder i koder XVID.
216
217 %package xvid-driver-fb
218 Summary:        XVID FB Driver
219 Summary(pl):    Sterownik XVID dla FB
220 Group:          X11/Libraries
221 Requires:       xvid
222
223 %description xvid-driver-fb
224 XVID FB Driver.
225
226 %description xvid-driver-fb -l pl
227 Sterownik XVID dla FB.
228
229 %package xvid-driver-mach64
230 Summary:        XVID mach64 Driver
231 Summary(pl):    Sterownik XVID dla mach64
232 Group:          X11/Libraries
233 Requires:       xvid
234
235 %description xvid-driver-mach64
236 XVID mach64 Driver.
237
238 %description xvid-driver-mach64 -l pl
239 Sterownik XVID dla mach64.
240
241 %package xvid-driver-rage128
242 Summary:        XVID rage128 Driver
243 Summary(pl):    Sterownik XVID dla rage128
244 Group:          X11/Libraries
245 Requires:       xvid
246
247 %description xvid-driver-rage128
248 XVID rage128 Driver.
249
250 %description xvid-driver-rage128 -l pl
251 Sterownik XVID dla rage128.
252
253 %package xvid-driver-radeon
254 Summary:        XVID radeon Driver
255 Summary(pl):    Sterownik XVID dla radeon
256 Group:          X11/Libraries
257 Requires:       xvid
258
259 %description xvid-driver-radeon
260 XVID radeon Driver.
261
262 %description xvid-driver-radeon -l pl
263 Sterownik XVID dla radeon.
264
265 %package xvid-driver-mga
266 Summary:        XVID MGA Driver
267 Summary(pl):    Sterownik XVID dla MGA
268 Group:          X11/Libraries
269 Requires:       xvid
270
271 %description xvid-driver-mga
272 XVID MGA Driver.
273
274 %description xvid-driver-mga -l pl
275 Sterownik XVID dla MGA.
276
277 %package xvid-driver-nvidia
278 Summary:        XVID nvidia Driver
279 Summary(pl):    Sterownik XVID dla nvidia
280 Group:          X11/Libraries
281 Requires:       xvid
282
283 %description xvid-driver-nvidia
284 XVID nvidia Driver.
285
286 %description xvid-driver-nvidia -l pl
287 Sterownik XVID dla nvidia.
288
289 %package xvid-driver-permedia
290 Summary:        XVID permedia Driver
291 Summary(pl):    Sterownik XVID dla permedia
292 Group:          X11/Libraries
293 Requires:       xvid
294
295 %description xvid-driver-permedia
296 XVID permedia Driver.
297
298 %description xvid-driver-permedia -l pl
299 Sterownik XVID dla permedia.
300
301 %prep
302 %setup -q -n avifile0.7-%{version}
303 %patch0 -p1
304 %patch1 -p1
305 %patch2 -p1
306 %patch3 -p1
307 %patch4 -p1
308
309 %build
310 #rm -f missing aclocal.m4
311 #%%{__libtoolize}
312 #%%{__aclocal} -I m4
313 #%%{__autoheader}
314 #%%{__autoconf}
315 #%%{__automake}
316
317 #cd plugins/libmad/libmad
318 #%%{__autoconf}
319 #cd ../../..
320
321 #cd libmmxnow
322 #%%{__autoconf}
323 #cd ..
324
325 ./autogen.sh
326
327 # This is The WRONG Way (tm)
328 %if %{!?_without_qt:1}%{?_without_qt:0}
329 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
330 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
331 %endif
332
333 %configure \
334         CPPFLAGS="-I/usr/include/divx -I/usr/include/xvid -I/usr/include/freetype2" \
335         AS="%{__cc}" \
336         FFMPEG_CFLAGS="%{rpmcflags} -ffast-math %{!?debug:-fomit-frame-pointer}" \
337         --with-qt-includes=%{_includedir}/qt \
338         --with-qt-libraries=%{_libdir} \
339         --enable-a52 \
340         --enable-release \
341         --enable-ffmpeg \
342         --enable-ffmpeg-a52 \
343         %{?_with_divx:--enable-divx4} \
344 %ifarch i586 i686 athlon
345         --enable-x86opt \
346 %else
347         --disable-x86opt \
348 %endif
349         %{?_without_qt:--without-qt} \
350         %{?_without_qt:--disable-samples}
351
352 touch lib/dummy.cpp
353 %{__make}
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
358
359 %{__make} install \
360         DESTDIR="$RPM_BUILD_ROOT" \
361         m4datadir="%{_aclocaldir}"
362
363 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
364
365 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
366 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
367
368 %clean
369 rm -rf $RPM_BUILD_ROOT
370
371 %post   -p /sbin/ldconfig
372 %postun -p /sbin/ldconfig
373
374 %files
375 %defattr(644,root,root,755)
376 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
377 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
378 %attr(755,root,root) %{_libdir}/lib*.so.*.*
379 %dir %{_libdir}/avifile*
380 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
381 %{_libdir}/avifile*/audiodec.la
382 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
383 %{_libdir}/avifile*/mpeg_audiodec.la
384 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
385 %{_libdir}/avifile*/ac3pass.la
386 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
387 %{_libdir}/avifile*/mjpeg.la
388
389 %files devel
390 %defattr(644,root,root,755)
391 %doc doc/README-DEVEL*
392 %attr(755,root,root) %{_bindir}/avifile-config
393 %attr(755,root,root) %{_bindir}/mmxnow-config
394 %{_libdir}/lib*.la
395 %{_libdir}/lib*.so
396 %{_includedir}/%{name}
397 %{_includedir}/*.h
398 %{_aclocaldir}/*.m4
399
400 %if %{?_without_qt:0}%{!?_without_qt:1}
401 %files aviplay
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{_bindir}/aviplay
404 %{_mandir}/man1/aviplay.1*
405 %{_datadir}/%{name}*
406 %{_applnkdir}/Multimedia/*
407 %{_pixmapsdir}/*
408
409 %files utils
410 %defattr(644,root,root,755)
411 %attr(755,root,root) %{_bindir}/avi[bcmrt]*
412 %attr(755,root,root) %{_bindir}/kv4lsetup
413 %endif
414
415 %ifarch %{ix86}
416 %files win32
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
419 %{_libdir}/avifile*/win32.la
420 %endif
421
422 %files ffmpeg
423 %defattr(644,root,root,755)
424 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
425 %{_libdir}/avifile*/ffmpeg.la
426
427 %if %{?_with_divx:1}%{!?_with_divx:0}
428 %files divx
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
431 %{_libdir}/avifile*/divx*.la
432 %endif
433
434 %files vorbis
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
437 %{_libdir}/avifile*/vorbis*.la
438
439 %files mad
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
442 %{_libdir}/avifile*/mad*.la
443
444 %files lame_audioenc
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
447 %attr(755,root,root) %{_libdir}/avifile*/mp3lame_audioenc.so*
448 %{_libdir}/avifile*/mp3lamebin_audioenc.la
449 %{_libdir}/avifile*/mp3lame_audioenc.la
450
451 %ifarch %{ix86} ppc
452 %files xvid
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
455 %{_libdir}/avifile*/xvid.la
456 %endif
457
458 %ifarch %{ix86} ppc
459 %files xvid-driver-fb
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_libdir}/avifile*/vidix/libgenfb.so*
462 %{_libdir}/avifile*/vidix/libgenfb.la
463 %endif
464
465 %ifarch %{ix86} ppc
466 %files xvid-driver-mach64
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_libdir}/avifile*/vidix/libmach64.so*
469 %{_libdir}/avifile*/vidix/libmach64.la
470 %endif
471
472 %ifarch %{ix86} ppc
473 %files xvid-driver-rage128
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_libdir}/avifile*/vidix/librage128.so*
476 %{_libdir}/avifile*/vidix/librage128.la
477 %endif
478
479 %ifarch %{ix86} ppc
480 %files xvid-driver-radeon
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_libdir}/avifile*/vidix/libradeon.so*
483 %{_libdir}/avifile*/vidix/libradeon.la
484 %endif
485
486 %ifarch %{ix86} ppc
487 %files xvid-driver-mga
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/avifile*/vidix/libmga*.so*
490 %{_libdir}/avifile*/vidix/libmga*.la
491 %endif
492
493 %ifarch %{ix86} ppc
494 %files xvid-driver-nvidia
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_libdir}/avifile*/vidix/libnvidia.so*
497 %{_libdir}/avifile*/vidix/libnvidia.la
498 %endif
499
500 %ifarch %{ix86} ppc
501 %files xvid-driver-permedia
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_libdir}/avifile*/vidix/libpm3.so*
504 %{_libdir}/avifile*/vidix/libpm3.la
505 %endif
This page took 0.058307 seconds and 3 git commands to generate.