]> git.pld-linux.org Git - packages/avifile.git/blob - avifile.spec
0494f70931f348a7d807e0a7092229288fdbb594
[packages/avifile.git] / avifile.spec
1 # It's sick.
2
3 # Conditional build:
4 # _without_qt - disables QT support 
5
6 %define         _snapver        20020816
7 %define         _snap           %{_snapver}
8 %define         _ver    0.7.15
9 Summary:        Library for playing AVI files
10 Summary(pl):    Biblioteka do odtwarzania plików AVI
11 Name:           avifile
12 Version:        %{_ver}
13 Release:        0.%{_snap}.1
14 Epoch:          3
15 License:        GPL
16 Group:          X11/Libraries
17 Source0:        http://avifile.sourceforge.net/%{name}-%{version}-%{_snap}.tgz
18 Source1:        %{name}.desktop
19 URL:            http://avifile.sourceforge.net/
20 Patch0:         %{name}-shareware.patch
21 Patch1:         %{name}-deplib.patch
22 Patch2:         %{name}-ac3.patch
23 Patch3:         %{name}-size_t.patch
24 Patch4:         %{name}-amfix.patch
25 Patch5:         %{name}-xvid.patch
26 BuildRequires:  SDL-devel >= 1.2.0
27 BuildRequires:  XFree86-devel
28 BuildRequires:  ac3dec-devel >= 0.6.1
29 BuildRequires:  audiofile-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %ifarch %{ix86}
33 BuildRequires:  divx4linux-devel
34 %endif
35 BuildRequires:  lame-libs-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libogg-devel
38 BuildRequires:  libtool
39 BuildRequires:  libvorbis-devel >= 1:1.0
40 BuildRequires:  nas-devel
41 %{?!_without_qt:BuildRequires:  qt-devel >= 3.0.5}
42 BuildRequires:  unzip
43 %ifarch %{ix86} ppc sparc sparc64 sparcv9
44 BuildRequires:  xvid-devel
45 %endif
46 BuildConflicts: wine-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _prefix         /usr/X11R6
50 %define         _mandir         %{_prefix}/man
51
52 %description
53 Avifile is a library that allow programs to read and write compressed
54 AVI files (Indeo Video, DivX :-), etc.) under x86 Linux.
55 (De)compression is performed with various plugins (Win32, FFMpeg,...)
56
57 %description -l pl
58 Avifile jest bibliotek± s³u¿±c± do odczytywania i zapisywania
59 skompresowanych plików AVI (Indeo Video, DivX :-), etc.) pod Linuksem.
60 Do (de)kompresji u¿ywane s± pluginy (win32, FFMpeg, ...)
61
62 %package devel
63 Summary:        Header file required to build programs using libavifile
64 Summary(pl):    Pliki nag³ówkowe wymagane przez programy u¿ywaj±ce libavifile
65 Group:          X11/Development/Libraries
66 Requires:       XFree86-devel
67 Requires:       %{name} = %{version}
68
69 %description devel
70 Header files required to build programs using libavifile.
71
72 %description devel -l pl
73 Pliki nag³ówkowe niezbêdne do kompilacji programów korzystaj±cych z
74 libavifile.
75
76 %package aviplay
77 Summary:        Player for AVI/ASF/WMF files
78 Summary(pl):    Odtwarzacz plików AVI/ASF/WMF
79 Group:          X11/Applications/Multimedia
80 Requires:       %{name} = %{version}
81
82 %description aviplay
83 Sample player for AVI, ASF, WFM (with straming support) files.
84
85 %description aviplay -l pl
86 Przyk³adowy odtwarzacz plików AVI, ASF, WFM (ze wsparciem dla
87 odtwarzania z sieci.)
88
89 %package utils
90 Summary:        Sample programs using the avifile library
91 Summary(pl):    Przyk³adowe programy u¿ywaj±ce biblioteki avifile
92 Group:          X11/Applications/Multimedia
93 Requires:       %{name} = %{version}
94
95 %description utils
96 Qt-based AVI utilities with few other useful supporting tools for TV
97 capturing, AVI recompression, benchmarking, joining AVI files. These
98 programs have more bugs as they are not as extensively developed as
99 player.
100
101 %description utils -l pl
102 Kilka u¿ytecznych narzêdzi do przechwytywania TV, rekompresji AVI,
103 benchmarkowania, ³±czenia plików AVI. Maj± wiêcej b³êdów, poniewa¿ nie
104 s± tak intensywnie rozwijane jak odtwarzacz.
105
106 %package win32
107 Summary:        Win32 audio/video plugin
108 Summary(pl):    Plugin audio/video win32
109 Group:          X11/Libraries
110 Requires:       %{name} = %{version}
111 Requires:       w32codec
112
113 %description win32
114 Plugin for using Win32 DLL libraries in avifile located in
115 /usr/lib/win32.
116
117 %description win32 -l pl
118 Plugin do u¿ywania w avifile zlokalizowanych w /usr/lib/win32
119 bibliotek DLL Win32.
120
121 %package ffmpeg
122 Summary:        GPL MPEG4 codec
123 Summary(pl):    Kodek MPEG4 na licencji GPL
124 Group:          X11/Libraries
125 Requires:       %{name} = %{version}
126
127 %description ffmpeg
128 ffmpeg is a hyper fast realtime audio/video encoder, a streaming
129 server and a generic audio and video file converter.
130
131 It can grab from a standard Video4Linux video source and convert it
132 into several file formats based on DCT/motion compensation encoding.
133 Sound is compressed in MPEG audio layer 2 or using an AC3 compatible
134 stream.
135
136 %description ffmpeg -l pl
137 ffmpeg jest hiperszybkim koderem audio/wideo czasu rzeczywistego,
138 serwerem strumieni oraz standardowym konwerterem plików audio-wideo.
139
140 Mo¿e pobieraæ ze standardowego Video4Linux ¼ród³o obrazu i konwertowaæ
141 je do kilku formatów plików opartych na kodowaniu DCT/kompensacji
142 ruchu. D¼wiêk jest kompresowany w MPEG audio layer 2 lub u¿ywaj±c
143 kompatybilnego z AC3 strumienia.
144
145 %package divx
146 Summary:        Fast MPEG4 codec
147 Summary(pl):    Szybki kodek MPEG4
148 Group:          X11/Libraries
149 Requires:       %{name} = %{version}
150 Requires:       divx4linux
151 Obsoletes:  avifile-divx4
152
153 %description divx
154 DivX MPEG-4 decoder and encoder.
155
156 %description divx -l pl
157 Dekoder i koder MPEG-4 DivX.
158
159 %package vorbis
160 Summary:        Vorbis audio plugin
161 Summary(pl):    Plugin vorbis audio.
162 Group:          X11/Libraries
163 Requires:       %{name} = %{version}
164
165 %description vorbis
166 Plugin for decompression of Vorbis audio streams.
167
168 %description vorbis -l pl
169 Plugin do dekompresji strumieni audio Vorbis.
170
171 %package mad
172 Summary:        MAD - MPEG audio plugin
173 Summary(pl):    MAD - plugin MPEG audio
174 Group:          X11/Libraries
175 Requires:       %{name} = %{version}
176
177 %description mad
178 Plugin for decompression of MPEG-1 Layer I/II/III audio streams.
179
180 %description mad -l pl
181 Plugin do dekompresji strumieni d¼wiêkowych MPEG-1 Layer I/II/III.
182
183 %package lame_audioenc
184 Summary:        MP3 audio encoder plugin
185 Summary(pl):    Plugin enkoduj±cy d¼wiêk w formacie MP3
186 Group:          X11/Libraries
187 Requires:       %{name} = %{version}
188
189 %description lame_audioenc
190 Plugin for mp3 encoding capability of avirecompress tool.
191
192 %description lame_audioenc -l pl
193 Plugin umo¿liwiaj±cy avirecompressowi kodowanie mp3.
194
195 %package xvid
196 Summary:        XVID codec
197 Summary(pl):    Kodek XVID
198 Group:          X11/Libraries
199 Requires:       %{name} = %{version}
200 Requires:       xvid
201
202 %description xvid
203 XVID decoder and encoder.
204
205 %description xvid -l pl
206 Dekoder i koder XVID.
207
208 %prep
209 %setup -q -n avifile0.7-%{_ver}
210 %patch0 -p1
211 # was broken and need fixing; without this xmms and avi plugin is broken
212 #%patch1 -p1
213 #%patch2 -p1
214 #%patch3 -p1
215 #%patch4 -p1
216 #%patch5 -p1
217
218 %build
219 rm -f missing aclocal.m4
220 %{__libtoolize}
221 aclocal
222 autoheader
223 %{__autoconf}
224 automake -a -c --foreign
225
226 cd plugins/libmad/libmad
227         %{__autoconf}
228 cd ../../..
229
230 cd libmmxnow
231         %{__autoconf}
232 cd ..
233
234 # This is The WRONG Way (tm)
235 GEN_MOC="`grep -Rl '^ *Q_OBJECT$' *`"
236 for f in $GEN_MOC; do moc -o "${f%.[!.]*}.moc" "$f"; done
237
238 %configure CPPFLAGS="-I/usr/include/divx" AS="%{__cc}" \
239         --with-qt-includes=%{_includedir}/qt \
240         --with-libac3-path=%{_prefix} \
241         --enable-release \
242         --enable-ffmpeg \
243         --disable-x86opt \
244         %{?_without_qt:--without-qt}
245
246 touch lib/dummy.cpp
247 %{__make}
248
249 %install
250 rm -rf $RPM_BUILD_ROOT
251 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/usr/lib/win32,%{_pixmapsdir},%{_applnkdir}/Multimedia}
252
253 # avoid relinking
254 for f in plugins/*/*.la ; do
255         sed -e '/^relink_command/d' $f > $f.new
256         mv -f $f.new $f
257 done
258
259 %{__make} install \
260         DESTDIR="$RPM_BUILD_ROOT"
261
262 cp -f include/fourcc.h $RPM_BUILD_ROOT/%{_includedir}/%{name}
263
264 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Multimedia
265 install bin/test.png $RPM_BUILD_ROOT%{_pixmapsdir}/avifile.png
266
267 %clean
268 rm -rf $RPM_BUILD_ROOT
269
270 %post   -p /sbin/ldconfig
271 %postun -p /sbin/ldconfig
272
273 %files
274 %defattr(644,root,root,755)
275 %doc README doc/{CREDITS,EXCEPTIONS,KNOWN_BUGS,LICENSING}
276 %doc doc/{README-DEVEL,TODO,VIDEO-PERFORMANCE,WARNINGS}
277 %attr(755,root,root) %{_libdir}/*.so.*.*
278 %dir %{_libdir}/avifile*
279 %attr(755,root,root) %{_libdir}/avifile*/audiodec.so*
280 %attr(755,root,root) %{_libdir}/avifile*/audiodec.la
281 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.so*
282 %attr(755,root,root) %{_libdir}/avifile*/mpeg_audiodec.la
283 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.so*
284 %attr(755,root,root) %{_libdir}/avifile*/ac3pass.la
285 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.so*
286 %attr(755,root,root) %{_libdir}/avifile*/mjpeg.la
287
288 %files devel
289 %defattr(644,root,root,755)
290 %doc doc/README-DEVEL*
291 %attr(755,root,root) %{_bindir}/avifile-config
292 %attr(755,root,root) %{_bindir}/mmxnow-config
293 %attr(755,root,root) %{_libdir}/lib*.la
294 %{_libdir}/lib*.so
295 %{_includedir}/%{name}
296
297 %{?!_without_qt:%files aviplay}
298 %{?!_without_qt:%defattr(644,root,root,755)}
299 %{?!_without_qt:%attr(755,root,root) %{_bindir}/aviplay}
300 %{?!_without_qt:%{_datadir}/%{name}*}
301 %{?!_without_qt:%{_applnkdir}/Multimedia/*}
302 %{?!_without_qt:%{_pixmapsdir}/*}
303
304 %{?!_without_qt:%files utils}
305 %{?!_without_qt:%defattr(644,root,root,755)}
306 %{?!_without_qt:%attr(755,root,root) %{_bindir}/avi[bcmrt]*}
307 %{?!_without_qt:%attr(755,root,root) %{_bindir}/kv4lsetup}
308
309 %ifarch %{ix86}
310 %files win32
311 %defattr(644,root,root,755)
312 %attr(755,root,root) %{_libdir}/avifile*/win32.so*
313 %attr(755,root,root) %{_libdir}/avifile*/win32.la
314 %endif
315
316 %files ffmpeg
317 %defattr(644,root,root,755)
318 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.so*
319 %attr(755,root,root) %{_libdir}/avifile*/ffmpeg.la
320
321 %ifarch %{ix86}
322 %files divx
323 %defattr(644,root,root,755)
324 %attr(755,root,root) %{_libdir}/avifile*/divx*.so*
325 %attr(755,root,root) %{_libdir}/avifile*/divx*.la
326 %endif
327
328 %files vorbis
329 %defattr(644,root,root,755)
330 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.so*
331 %attr(755,root,root) %{_libdir}/avifile*/vorbis*.la
332
333 %files mad
334 %defattr(644,root,root,755)
335 %attr(755,root,root) %{_libdir}/avifile*/mad*.so*
336 %attr(755,root,root) %{_libdir}/avifile*/mad*.la
337
338 %files lame_audioenc
339 %defattr(644,root,root,755)
340 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.so*
341 %attr(755,root,root) %{_libdir}/avifile*/mp3lamebin_audioenc.la
342
343 %ifarch %{ix86} ppc sparc sparc64 sparcv9
344 %files xvid
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_libdir}/avifile*/xvid.so*
347 %attr(755,root,root) %{_libdir}/avifile*/xvid.la
348 %endif
This page took 0.065054 seconds and 3 git commands to generate.