]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- add selinux BR and R
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 # - autoip subpackage ?
4 # - autoip start script ?
5 #
6 # Conditional build:
7 %bcond_without  dotnet          # build without dotnet bindings
8 %bcond_without  qt              # build without (any) qt bindings
9 %bcond_without  qt3             # build without qt3 bindings
10 %bcond_without  qt4             # build without qt4 bindings
11 #
12 %if !%{with qt}
13 %undefine       with_qt3
14 %undefine       with_qt4
15 %endif
16 %include /usr/lib/rpm/macros.mono
17 #
18 Summary:        Free mDNS/DNS-SD implementation
19 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD
20 Name:           avahi
21 Version:        0.6.20
22 Release:        1
23 License:        LGPL v2.1+
24 Group:          Applications
25 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
26 # Source0-md5:  6acdff79afa2631f765f3bbbc3e25a74
27 Source1:        %{name}-daemon
28 Source2:        %{name}-dnsconfd
29 Source3:        %{name}.png
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-glade.patch
32 Patch2:         %{name}-destdir.patch
33 URL:            http://avahi.org/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  dbus-devel >= 0.92
37 BuildRequires:  doxygen
38 BuildRequires:  expat-devel
39 BuildRequires:  gdbm-devel
40 BuildRequires:  glib2-devel >= 1:2.12.2
41 BuildRequires:  graphviz
42 BuildRequires:  gtk+2-devel >= 2:2.10.2
43 BuildRequires:  libcap-devel
44 BuildRequires:  libdaemon-devel >= 0.11
45 BuildRequires:  libglade2-devel >= 1:2.6.0
46 BuildRequires:  libtool
47 BuildRequires:  libselinux-devel
48 %if %{with dotnet}
49 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
50 BuildRequires:  mono-csharp
51 BuildRequires:  monodoc
52 %endif
53 BuildRequires:  pkgconfig
54 BuildRequires:  python >= 1:2.4
55 BuildRequires:  python-dbus >= 0.71
56 BuildRequires:  python-pygtk-devel >= 2:2.9.6
57 %if %{with qt3}
58 BuildRequires:  qt-devel >= 1:3.0
59 %endif
60 %if %{with qt4}
61 BuildRequires:  QtCore-devel
62 BuildRequires:  qt4-build
63 %endif
64 BuildRequires:  rpmbuild(macros) >= 1.228
65 Requires(post,preun):   /sbin/chkconfig
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       dbus >= 0.92
68 Requires:       libdaemon >= 0.11
69 Provides:       group(avahi)
70 Provides:       user(avahi)
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 Avahi is an implementation the DNS Service Discovery and Multicast DNS
75 specifications for Zeroconf Computing. It uses D-BUS for communication
76 between user applications and a system daemon.
77
78 %description -l pl.UTF-8
79 Avahi jest implementacją specyfikacji DNS Service Discovery i
80 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
81 pomiędzy programami użytkownika a demonem systemowym.
82
83 %package libs
84 Summary:        Avahi client, common and core libraries
85 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
86 Group:          Libraries
87
88 %description libs
89 Avahi client, common and core libraries.
90
91 %description libs -l pl.UTF-8
92 Biblioteki Avahi: klienta, wspólna i główna.
93
94 %package devel
95 Summary:        Header files for Avahi library
96 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
97 Group:          Development/Libraries
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       dbus-devel >= 0.92
100 Requires:       expat-devel
101 Requires:       libselinux-devel
102
103 %description devel
104 This is the package containing the header files for Avahi library.
105
106 %description devel -l pl.UTF-8
107 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
108
109 %package static
110 Summary:        Static Avahi library
111 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 Static Avahi library.
117
118 %description static -l pl.UTF-8
119 Statyczna biblioteka Avahi.
120
121 %package ui
122 Summary:        Avahi UI library
123 Summary(pl.UTF-8):      Biblioteka Avahi UI
124 Group:          X11/Libraries
125 Requires:       %{name}-libs = %{version}-%{release}
126 Requires:       gtk+2 >= 2:2.10.2
127
128 %description ui
129 Common GTK+ UI support library for Avahi.
130
131 %description ui -l pl.UTF-8
132 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
133
134 %package ui-devel
135 Summary:        Header files for Avahi UI library
136 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
137 Group:          X11/Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139 Requires:       %{name}-ui = %{version}-%{release}
140 Requires:       gtk+2-devel >= 2:2.10.2
141
142 %description ui-devel
143 Header files for Avahi UI library.
144
145 %description ui-devel -l pl.UTF-8
146 Pliki nagłówkowe biblioteki Avahi UI.
147
148 %package ui-static
149 Summary:        Static Avahi UI library
150 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
151 Group:          X11/Development/Libraries
152 Requires:       %{name}-ui-devel = %{version}-%{release}
153
154 %description ui-static
155 Static Avahi UI library.
156
157 %description ui-static -l pl.UTF-8
158 Statyczna biblioteka Avahi UI.
159
160 %package compat-libdns_sd
161 Summary:        Avahi Bonjour compat library
162 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
163 Group:          Libraries
164 Provides:       mdns-bonjour
165 Obsoletes:      mDNSResponder-libs
166
167 %description compat-libdns_sd
168 Avahi Bonjour compat library.
169
170 %description compat-libdns_sd -l pl.UTF-8
171 Biblioteka Avahi zgodna z Bonjour.
172
173 %package compat-libdns_sd-devel
174 Summary:        Header files for Avahi Bonjour compat library
175 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
176 Group:          Development/Libraries
177 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
178 Requires:       %{name}-devel = %{version}-%{release}
179 Provides:       mdns-bonjour-devel
180 Obsoletes:      mDNSResponder-devel
181
182 %description compat-libdns_sd-devel
183 Header files for Avahi Bonjour compat library.
184
185 %description compat-libdns_sd-devel -l pl.UTF-8
186 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
187
188 %package compat-libdns_sd-static
189 Summary:        Static Avahi Bonjour compat library
190 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
191 Group:          Development/Libraries
192 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
193 Provides:       mdns-bonjour-static
194
195 %description compat-libdns_sd-static
196 Static Avahi Bonjour compat library.
197
198 %description compat-libdns_sd-static -l pl.UTF-8
199 Statyczna biblioteka Avahi zgodna z Bonjour.
200
201 %package compat-howl
202 Summary:        Avahi Howl compat library
203 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
204 Group:          Libraries
205 Provides:       mdns-howl-libs
206 Obsoletes:      howl-libs
207
208 %description compat-howl
209 Avahi Howl compat library.
210
211 %description compat-howl -l pl.UTF-8
212 Biblioteka Avahi zgodna z Howl.
213
214 %package compat-howl-devel
215 Summary:        Header files for Avahi Howl compat library
216 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
217 Group:          Development/Libraries
218 Requires:       %{name}-compat-howl = %{version}-%{release}
219 Requires:       %{name}-devel = %{version}-%{release}
220 Provides:       mdns-howl-devel
221 Obsoletes:      howl-devel
222
223 %description compat-howl-devel
224 Header files for Avahi Howl compat library.
225
226 %description compat-howl-devel -l pl.UTF-8
227 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
228
229 %package compat-howl-static
230 Summary:        Static Avahi Howl compat library
231 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
232 Group:          Development/Libraries
233 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
234 Provides:       mdns-howl-static
235 Obsoletes:      howl-static
236
237 %description compat-howl-static
238 Static Avahi Howl compat library.
239
240 %description compat-howl-static -l pl.UTF-8
241 Statyczna biblioteka Avahi zgodna z Howl.
242
243 %package glib
244 Summary:        Avahi GLib library bindings
245 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
246 Group:          Libraries
247
248 %description glib
249 Avahi GLib library bindings.
250
251 %description glib -l pl.UTF-8
252 Wiązania Avahi dla bibioteki GLib.
253
254 %package glib-devel
255 Summary:        Header files for Avahi GLib library bindings
256 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
257 Group:          Development/Libraries
258 Requires:       %{name}-devel = %{version}-%{release}
259 Requires:       %{name}-glib = %{version}-%{release}
260 Requires:       glib2-devel >= 1:2.12.2
261
262 %description glib-devel
263 This is the package containing the header files for Avahi-glib
264 library.
265
266 %description glib-devel -l pl.UTF-8
267 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
268
269 %package glib-static
270 Summary:        Static Avahi GLib library
271 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
272 Group:          Development/Libraries
273 Requires:       %{name}-glib-devel = %{version}-%{release}
274
275 %description glib-static
276 Static Avahi GLib library.
277
278 %description glib-static -l pl.UTF-8
279 Statyczna biblioteka Avahi GLib.
280
281 %package qt
282 Summary:        Avahi Qt 3 library bindings
283 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
284 Group:          Libraries
285 Requires:       %{name}-libs = %{version}-%{release}
286 Obsoletes:      avahi-qt3
287
288 %description qt
289 Avahi Qt 3 library bindings.
290
291 %description qt -l pl.UTF-8
292 Wiązania Avahi dla biblioteki Qt 3.
293
294 %package qt-devel
295 Summary:        Header files for Avahi Qt 3 library bindings
296 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
297 Group:          Development/Libraries
298 Requires:       %{name}-devel = %{version}-%{release}
299 Requires:       %{name}-qt = %{version}-%{release}
300 Requires:       qt-devel >= 1:3.0
301 Obsoletes:      avahi-qt3-devel
302
303 %description qt-devel
304 Header files for Avahi Qt 3 library bindings.
305
306 %description qt-devel -l pl.UTF-8
307 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
308
309 %package qt-static
310 Summary:        Static Avahi Qt 3 library
311 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
312 Group:          Development/Libraries
313 Requires:       %{name}-qt-devel = %{version}-%{release}
314 Obsoletes:      avahi-qt3-static
315
316 %description qt-static
317 Static Avahi Qt 3 library.
318
319 %description qt-static -l pl.UTF-8
320 Statyczna biblioteka Avahi Qt 3.
321
322 %package Qt
323 Summary:        Avahi Qt 4 library bindings
324 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
325 Group:          Libraries
326 Requires:       %{name}-libs = %{version}-%{release}
327
328 %description Qt
329 Avahi Qt 4 library bindings.
330
331 %description Qt -l pl.UTF-8
332 Wiązania Avahi dla biblioteki Qt 4.
333
334 %package Qt-devel
335 Summary:        Header files for Avahi Qt 4 library bindings
336 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
337 Group:          Development/Libraries
338 Requires:       %{name}-devel = %{version}-%{release}
339 Requires:       %{name}-Qt = %{version}-%{release}
340
341 %description Qt-devel
342 Header files for Avahi Qt 4 library bindings.
343
344 %description Qt-devel -l pl.UTF-8
345 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
346
347 %package Qt-static
348 Summary:        Static Avahi Qt 4 library
349 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
350 Group:          Development/Libraries
351 Requires:       %{name}-Qt-devel = %{version}-%{release}
352
353 %description Qt-static
354 Static Avahi Qt 4 library.
355
356 %description Qt-static -l pl.UTF-8
357 Statyczna biblioteka Avahi Qt 4.
358
359 %package -n python-avahi
360 Summary:        Avahi Python bindings
361 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
362 Group:          Development/Languages/Python
363 Requires:       %{name}-libs = %{version}-%{release}
364 Requires:       python-dbus >= 0.71
365
366 %description -n python-avahi
367 Avahi Python bindings.
368
369 %description -n python-avahi -l pl.UTF-8
370 Wiązania Avahi dla Pythona.
371
372 %package -n dotnet-avahi
373 Summary:        Avahi MONO bindings
374 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
375 Group:          Libraries
376 Requires:       %{name}-libs = %{version}-%{release}
377
378 %description -n dotnet-avahi
379 Avahi MONO bindings.
380
381 %description -n dotnet-avahi -l pl.UTF-8
382 Wiązania Avahi dla MONO.
383
384 %package -n dotnet-avahi-devel
385 Summary:        Development files for MONO Avahi bindings
386 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
387 Group:          Development/Libraries
388 Requires:       dotnet-avahi = %{version}-%{release}
389 Requires:       monodoc
390
391 %description -n dotnet-avahi-devel
392 Development files for MONO Avahi bindings.
393
394 %description -n dotnet-avahi-devel -l pl.UTF-8
395 Pliki rozwojowe wiązań Avahi dla MONO.
396
397 %package -n dotnet-avahi-ui
398 Summary:        Avahi UI MONO bindings
399 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
400 Group:          X11/Libraries
401 Requires:       %{name}-ui = %{version}-%{release}
402 Requires:       dotnet-avahi = %{version}-%{release}
403
404 %description -n dotnet-avahi-ui
405 Avahi UI MONO bindings.
406
407 %description -n dotnet-avahi-ui -l pl.UTF-8
408 Wiązania Avahi UI dla MONO.
409
410 %package -n dotnet-avahi-ui-devel
411 Summary:        Development files for MONO Avahi UI bindings
412 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
413 Group:          X11/Development/Libraries
414 Requires:       dotnet-avahi-ui = %{version}-%{release}
415 Requires:       monodoc
416
417 %description -n dotnet-avahi-ui-devel
418 Development files for MONO Avahi UI bindings.
419
420 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
421 Pliki rozwojowe wiązań Avahi UI dla MONO.
422
423 %package bookmarks
424 Summary:        Miniature web server
425 Summary(pl.UTF-8):      Miniaturowy serwer web
426 Group:          Applications
427
428 %description bookmarks
429 A Python based miniature web server that browses for mDNS/DNS-SD
430 services of type '_http._tcp' (i.e. web sites) and makes them
431 available as HTML links on http://localhost:8080/.
432
433 %description bookmarks -l pl.UTF-8
434 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
435 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
436 je jako odnośniki HTML na http://localhost:8080/.
437
438 %package discover
439 Summary:        Avahi Zeroconf browser
440 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
441 Group:          Applications
442 Requires:       %{name} = %{version}-%{release}
443 Requires:       python-avahi = %{version}-%{release}
444 Requires:       python-pygtk-glade >= 2:2.9.6
445
446 %description discover
447 A tool for enumerating all available services on the local LAN
448 (python-pygtk implementation).
449
450 %description discover -l pl.UTF-8
451 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
452 (implementacja w python-pygtk).
453
454 %package discover-standalone
455 Summary:        Avahi Zeroconf browser
456 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
457 Group:          Applications
458 Requires:       %{name} = %{version}-%{release}
459 Requires:       python-dbus >= 0.71
460 Requires:       python-pygtk-glade >= 2:2.9.6
461
462 %description discover-standalone
463 GTK+ tool for enumerating all available services on the local LAN.
464
465 %description discover-standalone -l pl.UTF-8
466 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
467 LAN.
468
469 %package utils
470 Summary:        Avahi CLI utilities
471 Summary(pl.UTF-8):      Narzędzia CLI Avahi
472 Group:          Applications
473
474 %description utils
475 Command line utilities using avahi-client.
476
477 %description utils -l pl.UTF-8
478 Narzędzia linii poleceń korzystające z avahi-client.
479
480 %prep
481 %setup -q
482 %patch0 -p1
483 %patch1 -p1
484 %patch2 -p1
485
486 %build
487 %{__libtoolize}
488 %{__aclocal} -I common
489 %{__autoconf}
490 %{__autoheader}
491 %{__automake}
492 %configure \
493         --enable-compat-libdns_sd \
494         --enable-compat-howl \
495         --with-distro=none \
496         %{!?with_qt3:--disable-qt3} \
497         %{!?with_qt4:--disable-qt4} \
498         %{!?with_dotnet:--disable-mono} \
499         %{!?with_dotnet:--disable-monodoc}
500 %{__make}
501
502 %install
503 rm -rf $RPM_BUILD_ROOT
504 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d}
505
506 %{__make} install \
507         DESTDIR=$RPM_BUILD_ROOT \
508         pythondir=%{py_sitedir}
509
510 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
511 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
512
513 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
514         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
515
516 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
517         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
518
519 rm -f $RPM_BUILD_ROOT%{py_sitedir}/avahi/{__init__,SimpleGladeApp}.py
520
521 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
522 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
523 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
524 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
525 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
526 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
527 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
528
529 %clean
530 rm -rf $RPM_BUILD_ROOT
531
532 %pre
533 %groupadd -g 165 -r -f avahi
534 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
535
536 %post
537 /sbin/chkconfig --add %{name}-daemon
538 %service %{name}-daemon restart
539 /sbin/chkconfig --add %{name}-dnsconfd
540 %service %{name}-dnsconfd restart
541
542 %preun
543 if [ "$1" = "0" ]; then
544         %service -q %{name}-dnsconfd stop
545         /sbin/chkconfig --del %{name}-dnsconfd
546         %service -q %{name}-daemon stop
547         /sbin/chkconfig --del %{name}-daemon
548 fi
549
550 %postun
551 if [ "$1" = "0" ]; then
552         %userremove avahi
553         %groupremove avahi
554 fi
555
556 %post   libs -p /sbin/ldconfig
557 %postun libs -p /sbin/ldconfig
558
559 %post   ui -p /sbin/ldconfig
560 %postun ui -p /sbin/ldconfig
561
562 %post   compat-libdns_sd -p /sbin/ldconfig
563 %postun compat-libdns_sd -p /sbin/ldconfig
564
565 %post   compat-howl -p /sbin/ldconfig
566 %postun compat-howl -p /sbin/ldconfig
567
568 %post   glib -p /sbin/ldconfig
569 %postun glib -p /sbin/ldconfig
570
571 %post   qt -p /sbin/ldconfig
572 %postun qt -p /sbin/ldconfig
573
574 %post   Qt -p /sbin/ldconfig
575 %postun Qt -p /sbin/ldconfig
576
577 %files
578 %defattr(644,root,root,755)
579 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
580
581 %dir %{_sysconfdir}/avahi
582 %dir %{_sysconfdir}/avahi/services
583 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
584 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
585 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
586 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
587 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
588 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*
589
590 %attr(755,root,root) %{_bindir}/avahi-set-host-name
591
592 %attr(755,root,root) %{_sbindir}/avahi-daemon
593 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
594
595 %dir %{_datadir}/%{name}
596 %dir %{_datadir}/%{name}/introspection
597 %{_datadir}/%{name}/introspection/*.introspect
598 %{_datadir}/%{name}/avahi-service.dtd
599 %{_datadir}/%{name}/service-types
600 %{_datadir}/%{name}/service-types.db
601
602 %{_mandir}/man*/*
603
604 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
605 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
606
607 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
608 %attr(755,root,root) %{_sbindir}/avahi-autoipd
609
610 %files libs
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
613 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
614 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
615
616 %files devel
617 %defattr(644,root,root,755)
618 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
619 %attr(755,root,root) %{_libdir}/libavahi-client.so
620 %attr(755,root,root) %{_libdir}/libavahi-common.so
621 %attr(755,root,root) %{_libdir}/libavahi-core.so
622 %{_libdir}/libavahi-client.la
623 %{_libdir}/libavahi-common.la
624 %{_libdir}/libavahi-core.la
625 %{_includedir}/avahi-client
626 %{_includedir}/avahi-common
627 %{_includedir}/avahi-core
628 %{_pkgconfigdir}/avahi-client.pc
629 %{_pkgconfigdir}/avahi-core.pc
630
631 %files static
632 %defattr(644,root,root,755)
633 %{_libdir}/libavahi-client.a
634 %{_libdir}/libavahi-common.a
635 %{_libdir}/libavahi-core.a
636
637 %files ui
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_bindir}/bssh
640 %attr(755,root,root) %{_bindir}/bvnc
641 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
642 %{_desktopdir}/bssh.desktop
643 %{_desktopdir}/bvnc.desktop
644
645 %files ui-devel
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/libavahi-ui.so
648 %{_libdir}/libavahi-ui.la
649 %{_includedir}/avahi-ui
650 %{_pkgconfigdir}/avahi-ui.pc
651
652 %files ui-static
653 %defattr(644,root,root,755)
654 %{_libdir}/libavahi-ui.a
655
656 %files compat-libdns_sd
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
659
660 %files compat-libdns_sd-devel
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/libdns_sd.so
663 %{_libdir}/libdns_sd.la
664 %{_includedir}/avahi-compat-libdns_sd
665 %{_includedir}/dns_sd.h
666 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
667
668 %files compat-libdns_sd-static
669 %defattr(644,root,root,755)
670 %{_libdir}/libdns_sd.a
671
672 %files compat-howl
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
675
676 %files compat-howl-devel
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libhowl.so
679 %{_libdir}/libhowl.la
680 %{_includedir}/avahi-compat-howl
681 %{_pkgconfigdir}/avahi-compat-howl.pc
682 %{_pkgconfigdir}/howl.pc
683
684 %files compat-howl-static
685 %defattr(644,root,root,755)
686 %{_libdir}/libhowl.a
687
688 %files -n python-avahi
689 %defattr(644,root,root,755)
690 %{py_sitedir}/avahi
691
692 %if %{with dotnet}
693 %files -n dotnet-avahi
694 %defattr(644,root,root,755)
695 %{_prefix}/lib/mono/gac/avahi-sharp
696
697 %files -n dotnet-avahi-devel
698 %defattr(644,root,root,755)
699 %{_libdir}/monodoc/sources/avahi-sharp-docs.*
700 %{_prefix}/lib/mono/avahi-sharp
701 %{_pkgconfigdir}/avahi-sharp.pc
702
703 %files -n dotnet-avahi-ui
704 %defattr(644,root,root,755)
705 %{_prefix}/lib/mono/gac/avahi-ui-sharp
706
707 %files -n dotnet-avahi-ui-devel
708 %defattr(644,root,root,755)
709 %{_libdir}/monodoc/sources/avahi-ui-sharp-docs.*
710 %{_prefix}/lib/mono/avahi-ui-sharp
711 %{_pkgconfigdir}/avahi-ui-sharp.pc
712 %endif
713
714 %files glib
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
717
718 %files glib-devel
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/libavahi-glib.so
721 %{_libdir}/libavahi-glib.la
722 %{_includedir}/avahi-glib
723 %{_pkgconfigdir}/avahi-glib.pc
724
725 %files glib-static
726 %defattr(644,root,root,755)
727 %{_libdir}/libavahi-glib.a
728
729 %if %{with qt3}
730 %files qt
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
733
734 %files qt-devel
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
737 %{_libdir}/libavahi-qt3.la
738 %{_includedir}/avahi-qt3
739 %{_pkgconfigdir}/avahi-qt3.pc
740
741 %files qt-static
742 %defattr(644,root,root,755)
743 %{_libdir}/libavahi-qt3.a
744 %endif
745
746 %if %{with qt4}
747 %files Qt
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
750
751 %files Qt-devel
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
754 %{_libdir}/libavahi-qt4.la
755 %{_includedir}/avahi-qt4
756 %{_pkgconfigdir}/avahi-qt4.pc
757
758 %files Qt-static
759 %defattr(644,root,root,755)
760 %{_libdir}/libavahi-qt4.a
761 %endif
762
763 %files bookmarks
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_bindir}/avahi-bookmarks
766
767 %files discover
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_bindir}/avahi-discover
770 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
771 %dir %{_datadir}/%{name}/interfaces
772 %{_datadir}/%{name}/interfaces/avahi-discover.glade
773 %{_desktopdir}/avahi-discover.desktop
774 %{_pixmapsdir}/avahi.png
775
776 %files discover-standalone
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
779 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
780 %dir %{_datadir}/%{name}/interfaces
781 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
782
783 %files utils
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_bindir}/avahi-browse
786 %attr(755,root,root) %{_bindir}/avahi-publish
787 %attr(755,root,root) %{_bindir}/avahi-resolve
This page took 0.084255 seconds and 4 git commands to generate.