]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- wants python >= 2.4
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 # - autoip subpackage ?
4 # - autoip start script ?
5 #
6 # Conditional build:
7 %bcond_without  dotnet          # build without dotnet bindings
8 %bcond_without  qt              # build without (any) qt bindings
9 %bcond_without  qt3             # build without qt3 bindings
10 %bcond_without  qt4             # build without qt4 bindings
11 #
12 %if %{without qt}
13 %undefine       with_qt3
14 %undefine       with_qt4
15 %endif
16 %include /usr/lib/rpm/macros.mono
17 #
18 Summary:        Free mDNS/DNS-SD implementation
19 Summary(pl):    Wolna implementacja mDNS/DNS-SD
20 Name:           avahi
21 Version:        0.6.14
22 Release:        1
23 License:        GPL v.2/LGPL
24 Group:          Applications
25 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
26 # Source0-md5:  6abad76bbc2ac0f51a8869b3a2e5c238
27 Source1:        %{name}-daemon
28 Source2:        %{name}-dnsconfd
29 Source3:        %{name}.png
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-glade.patch
32 Patch2:         %{name}-destdir.patch
33 URL:            http://avahi.org/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  dbus-devel >= 0.92
37 BuildRequires:  doxygen
38 BuildRequires:  expat-devel
39 BuildRequires:  gdbm-devel
40 BuildRequires:  glib2-devel >= 1:2.12.2
41 BuildRequires:  graphviz
42 BuildRequires:  gtk+2-devel >= 2:2.10.2
43 BuildRequires:  libdaemon-devel >= 0.5
44 BuildRequires:  libglade2-devel >= 1:2.6.0
45 BuildRequires:  libtool
46 %if %{with dotnet}
47 BuildRequires:  mono-csharp
48 BuildRequires:  monodoc
49 %endif
50 BuildRequires:  pkgconfig
51 BuildRequires:  python >= 1:2.4
52 BuildRequires:  python-dbus >= 0.71
53 BuildRequires:  python-pygtk-devel >= 2:2.9.6
54 %if %{with qt3}
55 BuildRequires:  qt-devel >= 3.0
56 %endif
57 %if %{with qt4}
58 BuildRequires:  QtCore-devel
59 BuildRequires:  qt4-build
60 %endif
61 BuildRequires:  rpmbuild(macros) >= 1.228
62 Requires(post,preun):   /sbin/chkconfig
63 Requires:       dbus >= 0.92
64 Requires:       %{name}-libs = %{version}-%{release}
65 Provides:       group(avahi)
66 Provides:       user(avahi)
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Avahi is an implementation the DNS Service Discovery and Multicast DNS
71 specifications for Zeroconf Computing. It uses D-BUS for communication
72 between user applications and a system daemon.
73
74 %description -l pl
75 Avahi jest implementacj± specyfikacji DNS Service Discovery i
76 Multicast DNS dla Zeroconf Computing. U¿ywa D-BUSa dla komunikacji
77 pomiêdzy programami u¿ytkownika a demonem systemowym.
78
79 %package libs
80 Summary:        Avahi client, common and core libraries
81 Summary(pl):    Biblioteki Avahi: klienta, wspólna i g³ówna
82 Group:          Libraries
83
84 %description libs
85 Avahi client, common and core libraries.
86
87 %description libs -l pl
88 Biblioteki Avahi: klienta, wspólna i g³ówna.
89
90 %package devel
91 Summary:        Header files for Avahi library
92 Summary(pl):    Pliki nag³ówkowe biblioteki Avahi
93 Group:          Development/Libraries
94 Requires:       %{name}-libs = %{version}-%{release}
95 Requires:       dbus-devel >= 0.92
96 Requires:       expat-devel
97 Requires:       libdaemon-devel >= 0.5
98
99 %description devel
100 This is the package containing the header files for Avahi library.
101
102 %description devel -l pl
103 Ten pakiet zawiera pliki nag³ówkowe biblioteki Avahi.
104
105 %package static
106 Summary:        Static Avahi library
107 Summary(pl):    Statyczna biblioteka Avahi
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Static Avahi library.
113
114 %description static -l pl
115 Statyczna biblioteka Avahi.
116
117 %package compat-libdns_sd
118 Summary:        Avahi Bonjour compat library
119 Summary(pl):    Biblioteka Avahi zgodna z Bonjour
120 Group:          Libraries
121 Provides:       mdns-bonjour
122 Obsoletes:      mDNSResponder-libs
123
124 %description compat-libdns_sd
125 Avahi Bonjour compat library.
126
127 %description compat-libdns_sd -l pl
128 Biblioteka Avahi zgodna z Bonjour.
129
130 %package compat-libdns_sd-devel
131 Summary:        Header files for Avahi Bonjour compat library
132 Summary(pl):    Pliki nag³ówkowe wi±zañ Avahi dla biblioteki zgodnej z Bonjour
133 Group:          Development/Libraries
134 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
135 Requires:       %{name}-devel = %{version}-%{release}
136 Provides:       mdns-bonjour-devel
137 Obsoletes:      mDNSResponder-devel
138
139 %description compat-libdns_sd-devel
140 Header files for Avahi Bonjour compat library.
141
142 %description compat-libdns_sd-devel -l pl
143 Pliki nag³ówkowe wi±zañ Avahi dla biblioteki zgodnej z Bonjour.
144
145 %package compat-libdns_sd-static
146 Summary:        Static Avahi Bonjour compat library
147 Summary(pl):    Statyczna biblioteka Avahi zgodna z Bonjour
148 Group:          Development/Libraries
149 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
150 Provides:       mdns-bonjour-static
151
152 %description compat-libdns_sd-static
153 Static Avahi Bonjour compat library.
154
155 %description compat-libdns_sd-static -l pl
156 Statyczna biblioteka Avahi zgodna z Bonjour.
157
158 %package compat-howl
159 Summary:        Avahi Howl compat library
160 Summary(pl):    Biblioteka Avahi zgodna z Howl
161 Group:          Libraries
162 Provides:       mdns-howl-libs
163 Obsoletes:      howl-libs
164
165 %description compat-howl
166 Avahi Howl compat library.
167
168 %description compat-howl -l pl
169 Biblioteka Avahi zgodna z Howl.
170
171 %package compat-howl-devel
172 Summary:        Header files for Avahi Howl compat library
173 Summary(pl):    Pliki nag³ówkowe wi±zañ Avahi dla biblioteki zgodnej z Howl
174 Group:          Development/Libraries
175 Requires:       %{name}-compat-howl = %{version}-%{release}
176 Requires:       %{name}-devel = %{version}-%{release}
177 Provides:       mdns-howl-devel
178 Obsoletes:      howl-devel
179
180 %description compat-howl-devel
181 Header files for Avahi Howl compat library.
182
183 %description compat-howl-devel -l pl
184 Pliki nag³ówkowe wi±zañ Avahi dla biblioteki zgodnej z Howl.
185
186 %package compat-howl-static
187 Summary:        Static Avahi Howl compat library
188 Summary(pl):    Statyczna biblioteka Avahi zgodna z Howl
189 Group:          Development/Libraries
190 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
191 Provides:       mdns-howl-static
192 Obsoletes:      howl-static
193
194 %description compat-howl-static
195 Static Avahi Howl compat library.
196
197 %description compat-howl-static -l pl
198 Statyczna biblioteka Avahi zgodna z Howl.
199
200 %package glib
201 Summary:        Avahi GLib library bindings
202 Summary(pl):    Wi±zania Avahi dla bibioteki GLib
203 Group:          Libraries
204
205 %description glib
206 Avahi GLib library bindings.
207
208 %description glib -l pl
209 Wi±zania Avahi dla bibioteki GLib.
210
211 %package glib-devel
212 Summary:        Header files for Avahi GLib library bindings
213 Summary(pl):    Pliki nag³ówkowe wi±zañ Avahi dla biblioteki GLib
214 Group:          Development/Libraries
215 Requires:       %{name}-devel = %{version}-%{release}
216 Requires:       %{name}-glib = %{version}-%{release}
217 Requires:       glib2-devel >= 1:2.12.2
218
219 %description glib-devel
220 This is the package containing the header files for Avahi-glib
221 library.
222
223 %description glib-devel -l pl
224 Ten pakiet zawiera pliki nag³ówkowe biblioteki Avahi-glib.
225
226 %package glib-static
227 Summary:        Static Avahi GLib library
228 Summary(pl):    Statyczna biblioteka Avahi GLib
229 Group:          Development/Libraries
230 Requires:       %{name}-glib-devel = %{version}-%{release}
231
232 %description glib-static
233 Static Avahi GLib library.
234
235 %description glib-static -l pl
236 Statyczna biblioteka Avahi GLib.
237
238 %package qt
239 Summary:        Avahi Qt 3 library bindings
240 Summary(pl):    Wi±zania Avahi dla biblioteki Qt 3
241 Group:          Libraries
242 Requires:       %{name}-libs = %{version}-%{release}
243 Obsoletes:      avahi-qt3
244
245 %description qt
246 Avahi Qt 3 library bindings.
247
248 %description qt -l pl
249 Wi±zania Avahi dla biblioteki Qt 3.
250
251 %package qt-devel
252 Summary:        Header files for Avahi Qt 3 library bindings
253 Summary(pl):    Pliki nag³ówkowe wi±zañ Avahi dla biblioteki Qt 3
254 Group:          Development/Libraries
255 Requires:       %{name}-devel = %{version}-%{release}
256 Requires:       %{name}-qt = %{version}-%{release}
257 Requires:       qt-devel >= 3.0
258 Obsoletes:      avahi-qt3-devel
259
260 %description qt-devel
261 Header files for Avahi Qt 3 library bindings.
262
263 %description qt-devel -l pl
264 Pliki nag³ówkowe wi±zañ Avahi dla biblioteki Qt 3.
265
266 %package qt-static
267 Summary:        Static Avahi Qt 3 library
268 Summary(pl):    Statyczna biblioteka Avahi Qt 3
269 Group:          Development/Libraries
270 Requires:       %{name}-qt-devel = %{version}-%{release}
271 Obsoletes:      avahi-qt3-static
272
273 %description qt-static
274 Static Avahi Qt 3 library.
275
276 %description qt-static -l pl
277 Statyczna biblioteka Avahi Qt 3.
278
279 %package Qt
280 Summary:        Avahi Qt 4 library bindings
281 Summary(pl):    Wi±zania Avahi dla biblioteki Qt 4
282 Group:          Libraries
283 Requires:       %{name}-libs = %{version}-%{release}
284
285 %description Qt
286 Avahi Qt 4 library bindings.
287
288 %description Qt -l pl
289 Wi±zania Avahi dla biblioteki Qt 4.
290
291 %package Qt-devel
292 Summary:        Header files for Avahi Qt 3 library bindings
293 Summary(pl):    Pliki nag³ówkowe wi±zañ Avahi dla biblioteki Qt 3
294 Group:          Development/Libraries
295 Requires:       %{name}-devel = %{version}-%{release}
296 Requires:       %{name}-Qt = %{version}-%{release}
297
298 %description Qt-devel
299 Header files for Avahi Qt 4 library bindings.
300
301 %description Qt-devel -l pl
302 Pliki nag³ówkowe wi±zañ Avahi dla biblioteki Qt 4.
303
304 %package Qt-static
305 Summary:        Static Avahi Qt 4 library
306 Summary(pl):    Statyczna biblioteka Avahi Qt 4
307 Group:          Development/Libraries
308 Requires:       %{name}-Qt-devel = %{version}-%{release}
309
310 %description Qt-static
311 Static Avahi Qt 4 library.
312
313 %description Qt-static -l pl
314 Statyczna biblioteka Avahi Qt 4.
315
316 %package -n dotnet-avahi
317 Summary:        Avahi MONO bindings
318 Summary(pl):    Wi±zania Avahi dla MONO
319 Group:          Libraries
320
321 %description -n dotnet-avahi
322 Avahi MONO bindings.
323
324 %description -n dotnet-avahi -l pl
325 Wi±zania Avahi dla MONO.
326
327 %package -n dotnet-avahi-devel
328 Summary:        Development files for MONO Avahi bindings
329 Summary(pl):    Pliki rozwojowe wi±zañ Avahi dla MONO
330 Group:          Development/Libraries
331 Requires:       dotnet-avahi = %{version}-%{release}
332 Requires:       monodoc
333
334 %description -n dotnet-avahi-devel
335 Development files for MONO Avahi bindings.
336
337 %description -n dotnet-avahi-devel -l pl
338 Pliki rozwojowe wi±zañ Avahi dla MONO.
339
340 %package bookmarks
341 Summary:        Miniature web server
342 Summary(pl):    Miniaturowy serwer web
343 Group:          Applications
344
345 %description bookmarks
346 A Python based miniature web server that browses for mDNS/DNS-SD
347 services of type '_http._tcp' (i.e. web sites) and makes them
348 available as HTML links on http://localhost:8080/.
349
350 %description bookmarks -l pl
351 Napisany w Pythonie miniaturowy serwer WWW, pozwalaj±cy na
352 przegl±danie us³ug typu '_http._tcp' (np. stron WWW) i udostêpniaj±cy
353 je jako odno¶niki HTML na http://localhost:8080/.
354
355 %package discover
356 Summary:        Avahi Zeroconf browser
357 Summary(pl):    Przegl±darka Zeroconf Avahi
358 Group:          Applications
359 Requires:       %{name} = %{version}-%{release}
360 Requires:       python-dbus >= 0.71
361 Requires:       python-pygtk-glade >= 2:2.9.6
362
363 %description discover
364 A tool for enumerating all available services on the local LAN
365 (python-pygtk implementation).
366
367 %description discover -l pl
368 Narzêdzie wymieniaj±ce wszystkie dostêpne us³ugi w sieci lokalnej LAN
369 (implementacja w python-pygtk).
370
371 %package discover-standalone
372 Summary:        Avahi Zeroconf browser
373 Summary(pl):    Przegl±darka Zeroconf Avahi
374 Group:          Applications
375 Requires:       %{name} = %{version}-%{release}
376 Requires:       python-dbus >= 0.71
377 Requires:       python-pygtk-glade >= 2:2.9.6
378
379 %description discover-standalone
380 GTK+ tool for enumerating all available services on the local LAN.
381
382 %description discover-standalone -l pl
383 Narzêdzie GTK+ wymieniaj±ce wszystkie dostêpne us³ugi w sieci lokalnej
384 LAN.
385
386 %package utils
387 Summary:        Avahi CLI utilities
388 Summary(pl):    Narzêdzia CLI Avahi
389 Group:          Applications
390
391 %description utils
392 Command line utilities using avahi-client.
393
394 %description utils -l pl
395 Narzêdzia linii poleceñ korzystaj±ce z avahi-client.
396
397 %prep
398 %setup -q
399 %patch0 -p1
400 %patch1 -p1
401 %patch2 -p1
402
403 %build
404 %{__libtoolize}
405 %{__aclocal} -I common
406 %{__autoconf}
407 %{__autoheader}
408 %{__automake}
409 %configure \
410         --enable-compat-libdns_sd \
411         --enable-compat-howl \
412         --with-distro=none \
413         %{!?with_qt3:--disable-qt3} \
414         %{!?with_qt4:--disable-qt4} \
415         %{!?with_dotnet:--disable-mono} \
416         %{!?with_dotnet:--disable-monodoc}
417 %{__make}
418
419 %install
420 rm -rf $RPM_BUILD_ROOT
421 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d}
422
423 %{__make} install \
424         DESTDIR=$RPM_BUILD_ROOT \
425         pythondir=%{py_sitedir}
426
427 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
428 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
429
430 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
431         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
432
433 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
434         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
435
436 rm -f $RPM_BUILD_ROOT%{py_sitedir}/avahi/{__init__,SimpleGladeApp}.py
437
438 %clean
439 rm -rf $RPM_BUILD_ROOT
440
441 %pre
442 %groupadd -g 165 -r -f avahi
443 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
444
445 %post
446 /sbin/chkconfig --add %{name}-daemon
447 %service %{name}-daemon restart
448 /sbin/chkconfig --add %{name}-dnsconfd
449 %service %{name}-dnsconfd restart
450
451 %preun
452 if [ "$1" = "0" ]; then
453         %service -q %{name}-dnsconfd stop
454         /sbin/chkconfig --del %{name}-dnsconfd
455         %service -q %{name}-daemon stop
456         /sbin/chkconfig --del %{name}-daemon
457 fi
458
459 %postun
460 if [ "$1" = "0" ]; then
461         %userremove avahi
462         %groupremove avahi
463 fi
464
465 %post   libs -p /sbin/ldconfig
466 %postun libs -p /sbin/ldconfig
467
468 %post   compat-libdns_sd -p /sbin/ldconfig
469 %postun compat-libdns_sd -p /sbin/ldconfig
470
471 %post   compat-howl -p /sbin/ldconfig
472 %postun compat-howl -p /sbin/ldconfig
473
474 %post   glib -p /sbin/ldconfig
475 %postun glib -p /sbin/ldconfig
476
477 %post   qt -p /sbin/ldconfig
478 %postun qt -p /sbin/ldconfig
479
480 %post   Qt -p /sbin/ldconfig
481 %postun Qt -p /sbin/ldconfig
482
483 %files
484 %defattr(644,root,root,755)
485 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
486
487 %dir %{_sysconfdir}/avahi
488 %dir %{_sysconfdir}/avahi/services
489 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
490 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
491 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
492 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
493 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
494 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*
495
496 %attr(755,root,root) %{_bindir}/avahi-set-host-name
497
498 %attr(755,root,root) %{_sbindir}/avahi-daemon
499 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
500
501 %dir %{_datadir}/%{name}
502 %dir %{_datadir}/%{name}/introspection
503 %{_datadir}/%{name}/introspection/*.introspect
504 %{_datadir}/%{name}/avahi-service.dtd
505 %{_datadir}/%{name}/service-types
506 %{_datadir}/%{name}/service-types.db
507
508 %{_mandir}/man*/*
509
510 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
511 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
512
513 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
514 %attr(755,root,root) %{_sbindir}/avahi-autoipd
515
516 %files libs
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
519 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
520 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
521
522 %files devel
523 %defattr(644,root,root,755)
524 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
525 %attr(755,root,root) %{_libdir}/libavahi-client.so
526 %attr(755,root,root) %{_libdir}/libavahi-common.so
527 %attr(755,root,root) %{_libdir}/libavahi-core.so
528 %{_libdir}/libavahi-client.la
529 %{_libdir}/libavahi-common.la
530 %{_libdir}/libavahi-core.la
531 %{_includedir}/avahi-client
532 %{_includedir}/avahi-common
533 %{_includedir}/avahi-core
534 %{_pkgconfigdir}/avahi-client.pc
535 %{_pkgconfigdir}/avahi-core.pc
536
537 %files static
538 %defattr(644,root,root,755)
539 %{_libdir}/libavahi-client.a
540 %{_libdir}/libavahi-common.a
541 %{_libdir}/libavahi-core.a
542
543 %files compat-libdns_sd
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
546
547 %files compat-libdns_sd-devel
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/libdns_sd.so
550 %{_libdir}/libdns_sd.la
551 %{_includedir}/avahi-compat-libdns_sd
552 %{_includedir}/dns_sd.h
553 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
554
555 %files compat-libdns_sd-static
556 %defattr(644,root,root,755)
557 %{_libdir}/libdns_sd.a
558
559 %files compat-howl
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
562
563 %files compat-howl-devel
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/libhowl.so
566 %{_libdir}/libhowl.la
567 %{_includedir}/avahi-compat-howl
568 %{_pkgconfigdir}/avahi-compat-howl.pc
569 %{_pkgconfigdir}/howl.pc
570
571 %files compat-howl-static
572 %defattr(644,root,root,755)
573 %{_libdir}/libhowl.a
574
575 %if %{with dotnet}
576 %files -n dotnet-avahi
577 %defattr(644,root,root,755)
578 %{_prefix}/lib/mono/gac/avahi-sharp
579
580 %files -n dotnet-avahi-devel
581 %defattr(644,root,root,755)
582 %{_libdir}/monodoc/sources/avahi-*
583 %{_prefix}/lib/mono/avahi-sharp
584 %{_pkgconfigdir}/avahi-sharp.pc
585 %endif
586
587 %files glib
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
590
591 %files glib-devel
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/libavahi-glib.so
594 %{_libdir}/libavahi-glib.la
595 %{_includedir}/avahi-glib
596 %{_pkgconfigdir}/avahi-glib.pc
597
598 %files glib-static
599 %defattr(644,root,root,755)
600 %{_libdir}/libavahi-glib.a
601
602 %if %{with qt3}
603 %files qt
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
606
607 %files qt-devel
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
610 %{_libdir}/libavahi-qt3.la
611 %{_includedir}/avahi-qt3
612 %{_pkgconfigdir}/avahi-qt3.pc
613
614 %files qt-static
615 %defattr(644,root,root,755)
616 %{_libdir}/libavahi-qt3.a
617 %endif
618
619 %if %{with qt4}
620 %files Qt
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
623
624 %files Qt-devel
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
627 %{_libdir}/libavahi-qt4.la
628 %{_includedir}/avahi-qt4
629 %{_pkgconfigdir}/avahi-qt4.pc
630
631 %files Qt-static
632 %defattr(644,root,root,755)
633 %{_libdir}/libavahi-qt4.a
634 %endif
635
636 %files bookmarks
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_bindir}/avahi-bookmarks
639
640 %files discover
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_bindir}/avahi-discover
643 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
644 %dir %{_datadir}/%{name}/interfaces
645 %{_datadir}/%{name}/interfaces/avahi-discover.glade
646 %{py_sitedir}/avahi
647 %{_desktopdir}/*.desktop
648 %{_pixmapsdir}/avahi.png
649
650 %files discover-standalone
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
653 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
654 %dir %{_datadir}/%{name}/interfaces
655 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
656
657 %files utils
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_bindir}/avahi-browse
660 %attr(755,root,root) %{_bindir}/avahi-publish
661 %attr(755,root,root) %{_bindir}/avahi-resolve
This page took 0.0893 seconds and 4 git commands to generate.