]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- proper subpackage split
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 # - autoip subpackage ?
4 # - autoip start script ?
5 #
6 # Conditional build:
7 %bcond_without  dotnet          # build without dotnet bindings
8 %bcond_without  qt              # build without (any) qt bindings
9 %bcond_without  qt3             # build without qt3 bindings
10 %bcond_without  qt4             # build without qt4 bindings
11 #
12 %if !%{with qt}
13 %undefine       with_qt3
14 %undefine       with_qt4
15 %endif
16 %include /usr/lib/rpm/macros.mono
17 #
18 Summary:        Free mDNS/DNS-SD implementation
19 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD
20 Name:           avahi
21 Version:        0.6.19
22 Release:        3
23 License:        GPL v.2/LGPL
24 Group:          Applications
25 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
26 # Source0-md5:  a06782435d1c994ecd00a66e95a5d9d4
27 Source1:        %{name}-daemon
28 Source2:        %{name}-dnsconfd
29 Source3:        %{name}.png
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-glade.patch
32 Patch2:         %{name}-destdir.patch
33 Patch3:         %{name}-dotnet.patch
34 URL:            http://avahi.org/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  dbus-devel >= 0.92
38 BuildRequires:  doxygen
39 BuildRequires:  expat-devel
40 BuildRequires:  gdbm-devel
41 BuildRequires:  glib2-devel >= 1:2.12.2
42 BuildRequires:  graphviz
43 BuildRequires:  gtk+2-devel >= 2:2.10.2
44 BuildRequires:  libcap-devel
45 BuildRequires:  libdaemon-devel >= 0.5
46 BuildRequires:  libglade2-devel >= 1:2.6.0
47 BuildRequires:  libtool
48 %if %{with dotnet}
49 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
50 BuildRequires:  mono-csharp
51 BuildRequires:  monodoc
52 %endif
53 BuildRequires:  pkgconfig
54 BuildRequires:  python >= 1:2.4
55 BuildRequires:  python-dbus >= 0.71
56 BuildRequires:  python-pygtk-devel >= 2:2.9.6
57 %if %{with qt3}
58 BuildRequires:  qt-devel >= 1:3.0
59 %endif
60 %if %{with qt4}
61 BuildRequires:  QtCore-devel
62 BuildRequires:  qt4-build
63 %endif
64 BuildRequires:  rpmbuild(macros) >= 1.228
65 Requires(post,preun):   /sbin/chkconfig
66 Requires:       dbus >= 0.92
67 Requires:       %{name}-libs = %{version}-%{release}
68 Provides:       group(avahi)
69 Provides:       user(avahi)
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 Avahi is an implementation the DNS Service Discovery and Multicast DNS
74 specifications for Zeroconf Computing. It uses D-BUS for communication
75 between user applications and a system daemon.
76
77 %description -l pl.UTF-8
78 Avahi jest implementacją specyfikacji DNS Service Discovery i
79 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
80 pomiędzy programami użytkownika a demonem systemowym.
81
82 %package libs
83 Summary:        Avahi client, common and core libraries
84 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
85 Group:          Libraries
86
87 %description libs
88 Avahi client, common and core libraries.
89
90 %description libs -l pl.UTF-8
91 Biblioteki Avahi: klienta, wspólna i główna.
92
93 %package devel
94 Summary:        Header files for Avahi library
95 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
96 Group:          Development/Libraries
97 Requires:       %{name}-libs = %{version}-%{release}
98 Requires:       dbus-devel >= 0.92
99 Requires:       expat-devel
100 Requires:       libdaemon-devel >= 0.5
101
102 %description devel
103 This is the package containing the header files for Avahi library.
104
105 %description devel -l pl.UTF-8
106 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
107
108 %package static
109 Summary:        Static Avahi library
110 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Static Avahi library.
116
117 %description static -l pl.UTF-8
118 Statyczna biblioteka Avahi.
119
120 %package ui
121 Summary:        Avahi UI library
122 Summary(pl.UTF-8):      Biblioteka Avahi UI
123 Group:          X11/Libraries
124 Requires:       %{name}-libs = %{version}-%{release}
125 Requires:       gtk+2 >= 2:2.10.2
126
127 %description ui
128 Common GTK+ UI support library for Avahi.
129
130 %description ui -l pl.UTF-8
131 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
132
133 %package ui-devel
134 Summary:        Header files for Avahi UI library
135 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
136 Group:          X11/Development/Libraries
137 Requires:       %{name}-devel = %{version}-%{release}
138 Requires:       %{name}-ui = %{version}-%{release}
139 Requires:       gtk+2-devel >= 2:2.10.2
140
141 %description ui-devel
142 Header files for Avahi UI library.
143
144 %description ui-devel -l pl.UTF-8
145 Pliki nagłówkowe biblioteki Avahi UI.
146
147 %package ui-static
148 Summary:        Static Avahi UI library
149 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
150 Group:          X11/Development/Libraries
151 Requires:       %{name}-ui-devel = %{version}-%{release}
152
153 %description ui-static
154 Static Avahi UI library.
155
156 %description ui-static -l pl.UTF-8
157 Statyczna biblioteka Avahi UI.
158
159 %package compat-libdns_sd
160 Summary:        Avahi Bonjour compat library
161 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
162 Group:          Libraries
163 Provides:       mdns-bonjour
164 Obsoletes:      mDNSResponder-libs
165
166 %description compat-libdns_sd
167 Avahi Bonjour compat library.
168
169 %description compat-libdns_sd -l pl.UTF-8
170 Biblioteka Avahi zgodna z Bonjour.
171
172 %package compat-libdns_sd-devel
173 Summary:        Header files for Avahi Bonjour compat library
174 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
175 Group:          Development/Libraries
176 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
177 Requires:       %{name}-devel = %{version}-%{release}
178 Provides:       mdns-bonjour-devel
179 Obsoletes:      mDNSResponder-devel
180
181 %description compat-libdns_sd-devel
182 Header files for Avahi Bonjour compat library.
183
184 %description compat-libdns_sd-devel -l pl.UTF-8
185 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
186
187 %package compat-libdns_sd-static
188 Summary:        Static Avahi Bonjour compat library
189 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
190 Group:          Development/Libraries
191 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
192 Provides:       mdns-bonjour-static
193
194 %description compat-libdns_sd-static
195 Static Avahi Bonjour compat library.
196
197 %description compat-libdns_sd-static -l pl.UTF-8
198 Statyczna biblioteka Avahi zgodna z Bonjour.
199
200 %package compat-howl
201 Summary:        Avahi Howl compat library
202 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
203 Group:          Libraries
204 Provides:       mdns-howl-libs
205 Obsoletes:      howl-libs
206
207 %description compat-howl
208 Avahi Howl compat library.
209
210 %description compat-howl -l pl.UTF-8
211 Biblioteka Avahi zgodna z Howl.
212
213 %package compat-howl-devel
214 Summary:        Header files for Avahi Howl compat library
215 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
216 Group:          Development/Libraries
217 Requires:       %{name}-compat-howl = %{version}-%{release}
218 Requires:       %{name}-devel = %{version}-%{release}
219 Provides:       mdns-howl-devel
220 Obsoletes:      howl-devel
221
222 %description compat-howl-devel
223 Header files for Avahi Howl compat library.
224
225 %description compat-howl-devel -l pl.UTF-8
226 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
227
228 %package compat-howl-static
229 Summary:        Static Avahi Howl compat library
230 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
231 Group:          Development/Libraries
232 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
233 Provides:       mdns-howl-static
234 Obsoletes:      howl-static
235
236 %description compat-howl-static
237 Static Avahi Howl compat library.
238
239 %description compat-howl-static -l pl.UTF-8
240 Statyczna biblioteka Avahi zgodna z Howl.
241
242 %package glib
243 Summary:        Avahi GLib library bindings
244 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
245 Group:          Libraries
246
247 %description glib
248 Avahi GLib library bindings.
249
250 %description glib -l pl.UTF-8
251 Wiązania Avahi dla bibioteki GLib.
252
253 %package glib-devel
254 Summary:        Header files for Avahi GLib library bindings
255 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
256 Group:          Development/Libraries
257 Requires:       %{name}-devel = %{version}-%{release}
258 Requires:       %{name}-glib = %{version}-%{release}
259 Requires:       glib2-devel >= 1:2.12.2
260
261 %description glib-devel
262 This is the package containing the header files for Avahi-glib
263 library.
264
265 %description glib-devel -l pl.UTF-8
266 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
267
268 %package glib-static
269 Summary:        Static Avahi GLib library
270 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
271 Group:          Development/Libraries
272 Requires:       %{name}-glib-devel = %{version}-%{release}
273
274 %description glib-static
275 Static Avahi GLib library.
276
277 %description glib-static -l pl.UTF-8
278 Statyczna biblioteka Avahi GLib.
279
280 %package qt
281 Summary:        Avahi Qt 3 library bindings
282 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
283 Group:          Libraries
284 Requires:       %{name}-libs = %{version}-%{release}
285 Obsoletes:      avahi-qt3
286
287 %description qt
288 Avahi Qt 3 library bindings.
289
290 %description qt -l pl.UTF-8
291 Wiązania Avahi dla biblioteki Qt 3.
292
293 %package qt-devel
294 Summary:        Header files for Avahi Qt 3 library bindings
295 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
296 Group:          Development/Libraries
297 Requires:       %{name}-devel = %{version}-%{release}
298 Requires:       %{name}-qt = %{version}-%{release}
299 Requires:       qt-devel >= 1:3.0
300 Obsoletes:      avahi-qt3-devel
301
302 %description qt-devel
303 Header files for Avahi Qt 3 library bindings.
304
305 %description qt-devel -l pl.UTF-8
306 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
307
308 %package qt-static
309 Summary:        Static Avahi Qt 3 library
310 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
311 Group:          Development/Libraries
312 Requires:       %{name}-qt-devel = %{version}-%{release}
313 Obsoletes:      avahi-qt3-static
314
315 %description qt-static
316 Static Avahi Qt 3 library.
317
318 %description qt-static -l pl.UTF-8
319 Statyczna biblioteka Avahi Qt 3.
320
321 %package Qt
322 Summary:        Avahi Qt 4 library bindings
323 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
324 Group:          Libraries
325 Requires:       %{name}-libs = %{version}-%{release}
326
327 %description Qt
328 Avahi Qt 4 library bindings.
329
330 %description Qt -l pl.UTF-8
331 Wiązania Avahi dla biblioteki Qt 4.
332
333 %package Qt-devel
334 Summary:        Header files for Avahi Qt 4 library bindings
335 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
336 Group:          Development/Libraries
337 Requires:       %{name}-devel = %{version}-%{release}
338 Requires:       %{name}-Qt = %{version}-%{release}
339
340 %description Qt-devel
341 Header files for Avahi Qt 4 library bindings.
342
343 %description Qt-devel -l pl.UTF-8
344 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
345
346 %package Qt-static
347 Summary:        Static Avahi Qt 4 library
348 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
349 Group:          Development/Libraries
350 Requires:       %{name}-Qt-devel = %{version}-%{release}
351
352 %description Qt-static
353 Static Avahi Qt 4 library.
354
355 %description Qt-static -l pl.UTF-8
356 Statyczna biblioteka Avahi Qt 4.
357
358 %package -n python-avahi
359 Summary:        Avahi Python bindings
360 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
361 Group:          Development/Languages/Python
362 Requires:       %{name}-libs = %{version}-%{release}
363 Requires:       python-dbus >= 0.71
364
365 %description -n python-avahi
366 Avahi Python bindings.
367
368 %description -n python-avahi -l pl.UTF-8
369 Wiązania Avahi dla Pythona.
370
371 %package -n dotnet-avahi
372 Summary:        Avahi MONO bindings
373 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
374 Group:          Libraries
375 Requires:       %{name}-libs = %{version}-%{release}
376
377 %description -n dotnet-avahi
378 Avahi MONO bindings.
379
380 %description -n dotnet-avahi -l pl.UTF-8
381 Wiązania Avahi dla MONO.
382
383 %package -n dotnet-avahi-devel
384 Summary:        Development files for MONO Avahi bindings
385 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
386 Group:          Development/Libraries
387 Requires:       dotnet-avahi = %{version}-%{release}
388 Requires:       monodoc
389
390 %description -n dotnet-avahi-devel
391 Development files for MONO Avahi bindings.
392
393 %description -n dotnet-avahi-devel -l pl.UTF-8
394 Pliki rozwojowe wiązań Avahi dla MONO.
395
396 %package -n dotnet-avahi-ui
397 Summary:        Avahi UI MONO bindings
398 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
399 Group:          X11/Libraries
400 Requires:       %{name}-ui = %{version}-%{release}
401 Requires:       dotnet-avahi = %{version}-%{release}
402
403 %description -n dotnet-avahi-ui
404 Avahi UI MONO bindings.
405
406 %description -n dotnet-avahi-ui -l pl.UTF-8
407 Wiązania Avahi UI dla MONO.
408
409 %package -n dotnet-avahi-ui-devel
410 Summary:        Development files for MONO Avahi UI bindings
411 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
412 Group:          X11/Development/Libraries
413 Requires:       dotnet-avahi-ui = %{version}-%{release}
414 Requires:       monodoc
415
416 %description -n dotnet-avahi-ui-devel
417 Development files for MONO Avahi UI bindings.
418
419 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
420 Pliki rozwojowe wiązań Avahi UI dla MONO.
421
422 %package bookmarks
423 Summary:        Miniature web server
424 Summary(pl.UTF-8):      Miniaturowy serwer web
425 Group:          Applications
426
427 %description bookmarks
428 A Python based miniature web server that browses for mDNS/DNS-SD
429 services of type '_http._tcp' (i.e. web sites) and makes them
430 available as HTML links on http://localhost:8080/.
431
432 %description bookmarks -l pl.UTF-8
433 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
434 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
435 je jako odnośniki HTML na http://localhost:8080/.
436
437 %package discover
438 Summary:        Avahi Zeroconf browser
439 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
440 Group:          Applications
441 Requires:       %{name} = %{version}-%{release}
442 Requires:       python-avahi = %{version}-%{release}
443 Requires:       python-pygtk-glade >= 2:2.9.6
444
445 %description discover
446 A tool for enumerating all available services on the local LAN
447 (python-pygtk implementation).
448
449 %description discover -l pl.UTF-8
450 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
451 (implementacja w python-pygtk).
452
453 %package discover-standalone
454 Summary:        Avahi Zeroconf browser
455 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
456 Group:          Applications
457 Requires:       %{name} = %{version}-%{release}
458 Requires:       python-dbus >= 0.71
459 Requires:       python-pygtk-glade >= 2:2.9.6
460
461 %description discover-standalone
462 GTK+ tool for enumerating all available services on the local LAN.
463
464 %description discover-standalone -l pl.UTF-8
465 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
466 LAN.
467
468 %package utils
469 Summary:        Avahi CLI utilities
470 Summary(pl.UTF-8):      Narzędzia CLI Avahi
471 Group:          Applications
472
473 %description utils
474 Command line utilities using avahi-client.
475
476 %description utils -l pl.UTF-8
477 Narzędzia linii poleceń korzystające z avahi-client.
478
479 %prep
480 %setup -q
481 %patch0 -p1
482 %patch1 -p1
483 %patch2 -p1
484 %patch3 -p1
485
486 %build
487 %{__libtoolize}
488 %{__aclocal} -I common
489 %{__autoconf}
490 %{__autoheader}
491 %{__automake}
492 %configure \
493         --enable-compat-libdns_sd \
494         --enable-compat-howl \
495         --with-distro=none \
496         %{!?with_qt3:--disable-qt3} \
497         %{!?with_qt4:--disable-qt4} \
498         %{!?with_dotnet:--disable-mono} \
499         %{!?with_dotnet:--disable-monodoc}
500 %{__make}
501
502 %install
503 rm -rf $RPM_BUILD_ROOT
504 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d}
505
506 %{__make} install \
507         DESTDIR=$RPM_BUILD_ROOT \
508         pythondir=%{py_sitedir}
509
510 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
511 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
512
513 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
514         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
515
516 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
517         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
518
519 rm -f $RPM_BUILD_ROOT%{py_sitedir}/avahi/{__init__,SimpleGladeApp}.py
520
521 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name}.1
522 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
523 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
524 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
525 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
526 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
527
528 %clean
529 rm -rf $RPM_BUILD_ROOT
530
531 %pre
532 %groupadd -g 165 -r -f avahi
533 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
534
535 %post
536 /sbin/chkconfig --add %{name}-daemon
537 %service %{name}-daemon restart
538 /sbin/chkconfig --add %{name}-dnsconfd
539 %service %{name}-dnsconfd restart
540
541 %preun
542 if [ "$1" = "0" ]; then
543         %service -q %{name}-dnsconfd stop
544         /sbin/chkconfig --del %{name}-dnsconfd
545         %service -q %{name}-daemon stop
546         /sbin/chkconfig --del %{name}-daemon
547 fi
548
549 %postun
550 if [ "$1" = "0" ]; then
551         %userremove avahi
552         %groupremove avahi
553 fi
554
555 %post   libs -p /sbin/ldconfig
556 %postun libs -p /sbin/ldconfig
557
558 %post   ui -p /sbin/ldconfig
559 %postun ui -p /sbin/ldconfig
560
561 %post   compat-libdns_sd -p /sbin/ldconfig
562 %postun compat-libdns_sd -p /sbin/ldconfig
563
564 %post   compat-howl -p /sbin/ldconfig
565 %postun compat-howl -p /sbin/ldconfig
566
567 %post   glib -p /sbin/ldconfig
568 %postun glib -p /sbin/ldconfig
569
570 %post   qt -p /sbin/ldconfig
571 %postun qt -p /sbin/ldconfig
572
573 %post   Qt -p /sbin/ldconfig
574 %postun Qt -p /sbin/ldconfig
575
576 %files
577 %defattr(644,root,root,755)
578 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
579
580 %dir %{_sysconfdir}/avahi
581 %dir %{_sysconfdir}/avahi/services
582 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
583 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
584 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
585 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
586 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
587 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/*
588
589 %attr(755,root,root) %{_bindir}/avahi-set-host-name
590
591 %attr(755,root,root) %{_sbindir}/avahi-daemon
592 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
593
594 %dir %{_datadir}/%{name}
595 %dir %{_datadir}/%{name}/introspection
596 %{_datadir}/%{name}/introspection/*.introspect
597 %{_datadir}/%{name}/avahi-service.dtd
598 %{_datadir}/%{name}/service-types
599 %{_datadir}/%{name}/service-types.db
600
601 %{_mandir}/man*/*
602
603 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
604 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
605
606 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
607 %attr(755,root,root) %{_sbindir}/avahi-autoipd
608
609 %files libs
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
612 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
613 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
614
615 %files devel
616 %defattr(644,root,root,755)
617 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
618 %attr(755,root,root) %{_libdir}/libavahi-client.so
619 %attr(755,root,root) %{_libdir}/libavahi-common.so
620 %attr(755,root,root) %{_libdir}/libavahi-core.so
621 %{_libdir}/libavahi-client.la
622 %{_libdir}/libavahi-common.la
623 %{_libdir}/libavahi-core.la
624 %{_includedir}/avahi-client
625 %{_includedir}/avahi-common
626 %{_includedir}/avahi-core
627 %{_pkgconfigdir}/avahi-client.pc
628 %{_pkgconfigdir}/avahi-core.pc
629
630 %files static
631 %defattr(644,root,root,755)
632 %{_libdir}/libavahi-client.a
633 %{_libdir}/libavahi-common.a
634 %{_libdir}/libavahi-core.a
635
636 %files ui
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_bindir}/bssh
639 %attr(755,root,root) %{_bindir}/bvnc
640 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
641 %{_desktopdir}/bssh.desktop
642 %{_desktopdir}/bvnc.desktop
643
644 %files ui-devel
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libavahi-ui.so
647 %{_libdir}/libavahi-ui.la
648 %{_includedir}/avahi-ui
649 %{_pkgconfigdir}/avahi-ui.pc
650
651 %files ui-static
652 %defattr(644,root,root,755)
653 %{_libdir}/libavahi-ui.a
654
655 %files compat-libdns_sd
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
658
659 %files compat-libdns_sd-devel
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/libdns_sd.so
662 %{_libdir}/libdns_sd.la
663 %{_includedir}/avahi-compat-libdns_sd
664 %{_includedir}/dns_sd.h
665 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
666
667 %files compat-libdns_sd-static
668 %defattr(644,root,root,755)
669 %{_libdir}/libdns_sd.a
670
671 %files compat-howl
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
674
675 %files compat-howl-devel
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/libhowl.so
678 %{_libdir}/libhowl.la
679 %{_includedir}/avahi-compat-howl
680 %{_pkgconfigdir}/avahi-compat-howl.pc
681 %{_pkgconfigdir}/howl.pc
682
683 %files compat-howl-static
684 %defattr(644,root,root,755)
685 %{_libdir}/libhowl.a
686
687 %files -n python-avahi
688 %defattr(644,root,root,755)
689 %{py_sitedir}/avahi
690
691 %if %{with dotnet}
692 %files -n dotnet-avahi
693 %defattr(644,root,root,755)
694 %{_prefix}/lib/mono/gac/avahi-sharp
695
696 %files -n dotnet-avahi-devel
697 %defattr(644,root,root,755)
698 %{_libdir}/monodoc/sources/avahi-sharp-docs.*
699 %{_prefix}/lib/mono/avahi-sharp
700 %{_pkgconfigdir}/avahi-sharp.pc
701
702 %files -n dotnet-avahi-ui
703 %defattr(644,root,root,755)
704 %{_prefix}/lib/mono/gac/avahi-ui-sharp
705
706 %files -n dotnet-avahi-ui-devel
707 %defattr(644,root,root,755)
708 %{_libdir}/monodoc/sources/avahi-ui-sharp-docs.*
709 %{_prefix}/lib/mono/avahi-ui-sharp
710 %{_pkgconfigdir}/avahi-ui-sharp.pc
711 %endif
712
713 %files glib
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
716
717 %files glib-devel
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libavahi-glib.so
720 %{_libdir}/libavahi-glib.la
721 %{_includedir}/avahi-glib
722 %{_pkgconfigdir}/avahi-glib.pc
723
724 %files glib-static
725 %defattr(644,root,root,755)
726 %{_libdir}/libavahi-glib.a
727
728 %if %{with qt3}
729 %files qt
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
732
733 %files qt-devel
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
736 %{_libdir}/libavahi-qt3.la
737 %{_includedir}/avahi-qt3
738 %{_pkgconfigdir}/avahi-qt3.pc
739
740 %files qt-static
741 %defattr(644,root,root,755)
742 %{_libdir}/libavahi-qt3.a
743 %endif
744
745 %if %{with qt4}
746 %files Qt
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
749
750 %files Qt-devel
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
753 %{_libdir}/libavahi-qt4.la
754 %{_includedir}/avahi-qt4
755 %{_pkgconfigdir}/avahi-qt4.pc
756
757 %files Qt-static
758 %defattr(644,root,root,755)
759 %{_libdir}/libavahi-qt4.a
760 %endif
761
762 %files bookmarks
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_bindir}/avahi-bookmarks
765
766 %files discover
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_bindir}/avahi-discover
769 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
770 %dir %{_datadir}/%{name}/interfaces
771 %{_datadir}/%{name}/interfaces/avahi-discover.glade
772 %{_desktopdir}/avahi-discover.desktop
773 %{_pixmapsdir}/avahi.png
774
775 %files discover-standalone
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
778 # XXX: possibly missing %{_datadir}/%{name} dir, shared subdir
779 %dir %{_datadir}/%{name}/interfaces
780 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
781
782 %files utils
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_bindir}/avahi-browse
785 %attr(755,root,root) %{_bindir}/avahi-publish
786 %attr(755,root,root) %{_bindir}/avahi-resolve
This page took 0.155727 seconds and 4 git commands to generate.