]> git.pld-linux.org Git - packages/autopsy.git/blob - autopsy.spec
- br not needed - we do not use the interactive configure/Makefile scripts.
[packages/autopsy.git] / autopsy.spec
1 #
2 # TODO  - %service stuff
3 #       - add user autopsy with proper homedir rights
4 #       - pl desc
5 #
6 Summary:        The Autopsy Forensic Browser is a graphical interface to The Sleuth Kit utilities
7 Summary(pl):    Autopsy Forensic Browser jest graficznym interfejsem do narzêdzi z The Sleuth Kit
8 Name:           autopsy
9 Version:        2.08
10 Release:        0.1
11 #Epoch:         -
12 License:        GPL
13 Group:          Applications
14 Source0:        http://mesh.dl.sourceforge.net/sourceforge/autopsy/%{name}-%{version}.tar.gz
15 # Source0-md5:  0ac9db9acf66742f8f01f3d8b0cf2f90
16 URL:            http://www.sleuthkit.org/autopsy
17 Requires:       coreutils
18 Requires:       perl-Date-Manip
19 Requires:       openssl
20 Requires:       libmagic
21 Requires:       sleuthkit
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Autopsy Forensic Browser is a graphical interface to utilities
26 found in The Sleuth Kit (TSK).  TSK is a collection of command line
27 tools that allow you to investigate a Windows or Unix system by
28 examining the hard disk contents.  TSK and Autopsy will show you
29 the files, data units, and metadata of NTFS, FAT, EXTxFS, and UFS
30 file system images in a read-only environment.  Autopsy allows you
31 to search for specific types of evidence based on keywords, MAC
32 times, hash values, and file types.
33
34 %prep
35 %setup -q
36
37 %build
38
39 echo "#!/usr/bin/perl -wT" > autopsy
40 echo "use lib qw(/usr/share/perl5/vendor_perl/Autopsy);" >> autopsy
41 echo "use lib qw(/usr/share/perl5/vendor_perl/Autopsy/lib);" >> autopsy
42 cat base/autopsy.base >> autopsy
43
44 cat > conf.pl <<-EOF
45         # Autopsy configuration settings
46         
47         # when set to 1, the server will stop after it receives no
48         # connections for STIMEOUT seconds. 
49         \$USE_STIMEOUT = 0;
50         \$STIMEOUT = 3600;
51         
52         # number of seconds that child waits for input from client
53         \$CTIMEOUT = 15;
54         
55         # set to 1 to save the cookie value in a file (for scripting)
56         \$SAVE_COOKIE = 1;
57         
58         \$INSTALLDIR = '/usr/share/perl5/vendor_perl/Autopsy/';
59         
60         # System Utilities
61         \$GREP_EXE = '/bin/grep';
62         
63         # Directories
64         \$TSKDIR = '/usr/bin';
65         \$FILE_EXE = '/usr/bin/file';
66         \$NSRLDB = '';
67         \$LOCKDIR = '/home/services/autopsy';
68 EOF
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 install -d $RPM_BUILD_ROOT%{_bindir}
74 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
75 install -d $RPM_BUILD_ROOT%{_mandir}/man1
76 install -d $RPM_BUILD_ROOT/home/services/autopsy
77 install -d $RPM_BUILD_ROOT/usr/share/perl5/vendor_perl/Autopsy/{lib,pict}
78
79 install autopsy $RPM_BUILD_ROOT%{_bindir}
80 install conf.pl $RPM_BUILD_ROOT/usr/share/perl5/vendor_perl/Autopsy/
81 install lib/* $RPM_BUILD_ROOT/usr/share/perl5/vendor_perl/Autopsy/lib
82 install pict/* $RPM_BUILD_ROOT/usr/share/perl5/vendor_perl/Autopsy/pict
83
84 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %pre
90
91 %post
92
93 %preun
94
95 %postun
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README.txt docs/sleuthkit-informer-13.txt
100 %attr(755,root,root) %{_bindir}/*
101 /usr/share/perl5/vendor_perl/Autopsy/conf.pl
102 /usr/share/perl5/vendor_perl/Autopsy/lib/*
103 /usr/share/perl5/vendor_perl/Autopsy/pict/*
104 %{_mandir}/man1/*
105 /home/services/autopsy
This page took 0.531328 seconds and 3 git commands to generate.