]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- R: perl(threads)
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_without  regeneration    # without full regeneration
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.11
18 Release:        1
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
23 # Source0-md5:  4db4efe027e26b33930a7e151de19d0f
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 URL:            http://sources.redhat.com/automake/
29 %if %{with regeneration}
30 BuildRequires:  autoconf >= 2.60
31 BuildRequires:  automake >= 1:1.10a
32 %else
33 BuildRequires:  autoconf >= 2.63
34 %endif
35 BuildRequires:  rpm-perlprov
36 BuildRequires:  texinfo >= 4.7
37 Requires(pre):  fileutils
38 Requires:       filesystem >= 3.0-2
39 Requires:       perl(File::Glob)
40 Requires:       perl(threads)
41 Conflicts:      autoconf < 2.60
42 Conflicts:      libtool < 2:1.5-11
43 #BuildArch:     noarch -- autoconf doesn't allow
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Automake is an experimental Makefile generator. Automake was inspired
48 by the 4.4BSD make and include files, but aims to be portable and to
49 conform to the GNU standards for Makefile variables and targets.
50
51 %description -l de.UTF-8
52 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
53 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
54 Konformität mit den GNU-Standards für Makefile-Variable und Targets
55 abzielt.
56
57 %description -l es.UTF-8
58 Automake es un creador experimental de Makefiles. Fue inspirado en el
59 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
60 con los padrones GNU para variables y dianas de Makefile.
61
62 %description -l fr.UTF-8
63 automake est un générateur expérimental de makefiles. Il a été inspiré
64 par le make de BSD 4.4, mais se veut portable et conforme aux
65 standards GNU pour les variables et les cibles des makefiles.
66
67 %description -l pl.UTF-8
68 Automake jest eksperymentalnym generatorem plików Makefile'a.
69 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
70 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
71 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
72
73 %description -l pt_BR.UTF-8
74 Automake é um gerador experimental de Makefiles. Ele foi inspirado
75 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
76 com os padrões GNU para variáveis e alvos de Makefile.
77
78 %description -l ru.UTF-8
79 Automake - это экспериментальный генератор Makefile'ов. Идея была
80 навеяна программой make и хедерами из 4.4BSD, но automake претендует
81 на то, чтобы быть портабельной и соответствовать стандартам GNU на
82 переменные и цели Makefile'ов.
83
84 %description -l tr.UTF-8
85 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
86 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
87 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
88
89 %description -l uk.UTF-8
90 Automake - це експериментальний генератор Makefile'ів. Ідея була
91 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
92 мобільність та відповідність стандартам GNU на змінні ті цілі
93 Makefile'ів.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100 %patch3 -p1
101
102 %if %{with regeneration}
103 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
104 mkdir m4-tmp
105 cd m4-tmp
106 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
107 %endif
108
109 %build
110 %if %{with regeneration}
111 %{__aclocal} -I m4-tmp
112 %endif
113 %{__autoconf}
114 %if %{with regeneration}
115 %{__automake}
116 %endif
117 %configure
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT%{_mandir}/man1
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT \
126         pkgvdatadir=%{_datadir}/automake
127
128 install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
129
130 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p      /sbin/postshell
136 -/usr/sbin/fix-info-dir -c %{_infodir}
137
138 %postun -p      /sbin/postshell
139 -/usr/sbin/fix-info-dir -c %{_infodir}
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README THANKS TODO
144 %attr(755,root,root) %{_bindir}/aclocal*
145 %attr(755,root,root) %{_bindir}/automake*
146 %{_infodir}/automake.info*
147 %{_mandir}/man1/aclocal.1*
148 %{_mandir}/man1/aclocal-1.11.1*
149 %{_mandir}/man1/automake.1*
150 %{_mandir}/man1/automake-1.11.1*
151
152 %{_datadir}/aclocal-*
153 %dir %{_datadir}/automake
154 %{_datadir}/automake/am
155 %{_datadir}/automake/Automake
156 %{_datadir}/automake/COPYING
157 %{_datadir}/automake/INSTALL
158 %{_datadir}/automake/texinfo.tex
159 %{_datadir}/automake/ansi2knr*
160 %attr(755,root,root) %{_datadir}/automake/acinstall
161 %attr(755,root,root) %{_datadir}/automake/compile
162 %attr(755,root,root) %{_datadir}/automake/config.guess
163 %attr(755,root,root) %{_datadir}/automake/config.sub
164 %attr(755,root,root) %{_datadir}/automake/config-ml.in
165 %attr(755,root,root) %{_datadir}/automake/depcomp
166 %attr(755,root,root) %{_datadir}/automake/elisp-comp
167 %attr(755,root,root) %{_datadir}/automake/install-sh
168 %attr(755,root,root) %{_datadir}/automake/mdate-sh
169 %attr(755,root,root) %{_datadir}/automake/missing
170 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
171 %attr(755,root,root) %{_datadir}/automake/py-compile
172 %attr(755,root,root) %{_datadir}/automake/symlink-tree
173 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.116824 seconds and 4 git commands to generate.