]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- updated to 1.10.1
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_without  regeneration    # without full regeneration
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.10.1
18 Release:        1
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
23 # Source0-md5:  4510391e6b3edaa4cffb3ced87c9560c
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 URL:            http://sources.redhat.com/automake/
29 %if %{with regeneration}
30 BuildRequires:  autoconf >= 2.60
31 BuildRequires:  automake >= 1:1.8a
32 %else
33 BuildRequires:  autoconf = 2.60
34 %endif
35 BuildRequires:  rpm-perlprov
36 BuildRequires:  texinfo >= 4.7
37 Requires(pre):  fileutils
38 Requires:       filesystem >= 3.0-2
39 Requires:       perl(File::Glob)
40 Conflicts:      autoconf < 2.60
41 Conflicts:      libtool < 2:1.5-11
42 #BuildArch:     noarch -- autoconf doesn't allow
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Automake is an experimental Makefile generator. Automake was inspired
47 by the 4.4BSD make and include files, but aims to be portable and to
48 conform to the GNU standards for Makefile variables and targets.
49
50 %description -l de.UTF-8
51 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
52 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
53 Konformität mit den GNU-Standards für Makefile-Variable und Targets
54 abzielt.
55
56 %description -l es.UTF-8
57 Automake es un creador experimental de Makefiles. Fue inspirado en el
58 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
59 con los padrones GNU para variables y dianas de Makefile.
60
61 %description -l fr.UTF-8
62 automake est un générateur expérimental de makefiles. Il a été inspiré
63 par le make de BSD 4.4, mais se veut portable et conforme aux
64 standards GNU pour les variables et les cibles des makefiles.
65
66 %description -l pl.UTF-8
67 Automake jest eksperymentalnym generatorem plików Makefile'a.
68 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
69 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
70 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
71
72 %description -l pt_BR.UTF-8
73 Automake é um gerador experimental de Makefiles. Ele foi inspirado
74 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
75 com os padrões GNU para variáveis e alvos de Makefile.
76
77 %description -l ru.UTF-8
78 Automake - это экспериментальный генератор Makefile'ов. Идея была
79 навеяна программой make и хедерами из 4.4BSD, но automake претендует
80 на то, чтобы быть портабельной и соответствовать стандартам GNU на
81 переменные и цели Makefile'ов.
82
83 %description -l tr.UTF-8
84 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
85 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
86 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
87
88 %description -l uk.UTF-8
89 Automake - це експериментальний генератор Makefile'ів. Ідея була
90 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
91 мобільність та відповідність стандартам GNU на змінні ті цілі
92 Makefile'ів.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99 %patch3 -p1
100
101 %if %{with regeneration}
102 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
103 mkdir m4-tmp
104 cd m4-tmp
105 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
106 %endif
107
108 %build
109 %if %{with regeneration}
110 %{__aclocal} -I m4-tmp
111 %endif
112 %{__autoconf}
113 %if %{with regeneration}
114 %{__automake}
115 %endif
116 %configure
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_mandir}/man1
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         pkgvdatadir=%{_datadir}/automake
126
127 install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
128
129 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
136
137 %postun
138 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README THANKS TODO
143 %attr(755,root,root) %{_bindir}/aclocal*
144 %attr(755,root,root) %{_bindir}/automake*
145 %{_infodir}/automake.info*
146 %{_mandir}/man1/aclocal.1*
147 %{_mandir}/man1/automake.1*
148
149 %{_datadir}/aclocal-*
150 %dir %{_datadir}/automake
151 %{_datadir}/automake/am
152 %{_datadir}/automake/Automake
153 %{_datadir}/automake/COPYING
154 %{_datadir}/automake/INSTALL
155 %{_datadir}/automake/texinfo.tex
156 %{_datadir}/automake/ansi2knr*
157 %attr(755,root,root) %{_datadir}/automake/acinstall
158 %attr(755,root,root) %{_datadir}/automake/compile
159 %attr(755,root,root) %{_datadir}/automake/config.guess
160 %attr(755,root,root) %{_datadir}/automake/config.sub
161 %attr(755,root,root) %{_datadir}/automake/config-ml.in
162 %attr(755,root,root) %{_datadir}/automake/depcomp
163 %attr(755,root,root) %{_datadir}/automake/elisp-comp
164 %attr(755,root,root) %{_datadir}/automake/install-sh
165 %attr(755,root,root) %{_datadir}/automake/mdate-sh
166 %attr(755,root,root) %{_datadir}/automake/missing
167 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
168 %attr(755,root,root) %{_datadir}/automake/py-compile
169 %attr(755,root,root) %{_datadir}/automake/symlink-tree
170 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.069061 seconds and 4 git commands to generate.