]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- s-/usr/bin-%{_bindir}-
[packages/automake.git] / automake.spec
1 Summary:        GNU automake - Makefile configuration tools
2 Summary(de):    GNU automake - Makefile-Konfigurationstools
3 Summary(fr):    automake de GNU - Outils de configuration des makefiles
4 Summary(pl):    GNU Automake - generator plików Makefile
5 Summary(tr):    Makefile yapýlandýrma araçlarý
6 Name:           automake
7 Version:        1.4
8 Release:        5
9 Copyright:      GPL
10 Group:          Development/Building
11 Group(pl):      Programowanie/Budowanie
12 Source:         ftp://ftp.cygnus.com/pub/tromey/%{name}-%{version}.tar.gz
13 Patch0:         automake-info.patch
14 Patch1:         automake-armnetwinder.patch
15 Patch2:         automake-1.4-19980208.patch
16 Patch3:         automake-man.patch
17 URL:            http://sourceware.cygnus.com/automake/
18 Requires:       perl
19 Prereq:         /sbin/install-info
20 Buildroot:      /tmp/%{name}-%{version}-root
21 BuildArch:      noarch
22
23 %description
24 Automake is an experimental Makefile generator. It was inspired by the
25 4.4BSD make and include files, but aims to be portable and to conform to the
26 GNU standards for Makefile variables and targets.
27
28 %description -l de
29 Automake ist ein experimenteller Makefile-Generator, inspiriert durch die
30 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und Konformität
31 mit den GNU-Standards für Makefile-Variable und Targets abzielt.
32
33 %description -l fr
34 automake est un générateur expérimental de makefiles. Il a été inspiré par
35 le make de BSD 4.4, mais se veut portable et conforme aux standards GNU pour
36 les variables et les cibles des makefiles.
37
38 %description -l pl
39 Automake jest eksperymentalnym generatorem plików Makefile'a. Narzêdzie to
40 jest wzorowane na make i plikach nag³ówków z systemu 4.4BSD. Umo¿liwia ono
41 generowanie plików Makefile w oderwaniu od platformy systemowej bêd±c
42 jednoce¶nie zgodnym ze standardami GNU.
43
44 %description -l tr
45 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
46 dosyalarýndan esinlenilmistir, ama amaç taþýnabilir olmak ve Makefile
47 deðiþkenleri ve hedefleri için GNU standartlarýna uyum göstermektir.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52 %patch1 -p1
53 %patch2 -p0
54 %patch3 -p1
55
56 %build
57 ./configure \
58         --prefix=/usr
59 make
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 make install prefix=$RPM_BUILD_ROOT/usr
64
65 gzip -9nf $RPM_BUILD_ROOT/usr/{info/*info*,man/man1/*} \
66         AUTHORS ChangeLog NEWS README THANKS TODO
67
68 %post
69 /sbin/install-info %{_infodir}/automake.info.gz /etc/info-dir
70
71 %preun
72 if [ "$1" = "0" ]; then
73         /sbin/install-info --delete %{_infodir}/automake.info.gz /etc/info-dir
74 fi
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc {AUTHORS,ChangeLog,NEWS,README,THANKS,TODO}.gz
82 %attr(755,root,root) %{_bindir}/*
83 %{_infodir}/automake*
84
85 %{_datadir}/aclocal
86 %{_mandir}/man1/*
87
88 %dir %{_datadir}/automake
89 %{_datadir}/automake/*.am
90 %{_datadir}/automake/texinfo.tex
91 %attr(755,root,root) %{_datadir}/automake/config.guess
92 %attr(755,root,root) %{_datadir}/automake/config.sub
93 %attr(755,root,root) %{_datadir}/automake/install-sh
94 %attr(755,root,root) %{_datadir}/automake/mdate-sh
95 %attr(755,root,root) %{_datadir}/automake/elisp-comp
96 %attr(755,root,root) %{_datadir}/automake/acinstall
97 %attr(755,root,root) %{_datadir}/automake/ylwrap
98 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
99 %attr(755,root,root) %{_datadir}/automake/missing
100
101 %changelog
102 * Wed Apr 28 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
103   [1.4-5]
104 - added patches for snapshot 19980208 and armnetwinder (from RH 6.0),
105 - added patch with man pages for automake (from Debian),
106 - recompiled on new rpm.
107
108 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
109   [1.4-4]
110 - full %attr description for files in %{_datadir}.
111
112 * Wed Jan 26 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
113   [1.4-1d]
114 - added Group(pl).
115
116 * Tue Dec 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
117   [1.3d-3]
118 - standarized {un}registering info pages (second try .. added
119   automake-info.patch).
120
121 * Wed Dec 23 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
122   [1.3d-2]
123 - (waiting for new autoconf): fixed @SHELL@ bug.
124
125 * Sat Dec 19 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
126   [1.3d-1]
127 - updated URL,
128 - standarized {un}registering info pages.
129
130 * Sat Nov 21 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
131   [1.3b-1]
132 - changed base Source url,
133 - cosmetic changes in %post, %preun in {un}registering autoame info page,
134 - added URL.
135
136 * Sat Aug  1 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
137   [1.3-5]
138 - modified pl translation,
139 - added -q %setup parameter,
140 - removed INSTALL and COPING from %doc (copyright statment is in Copyright
141   field),
142 - Buildroot changed to /tmp/%%{name}-%%{version}-root,
143 - fixed %defattr macro,
144 - added using %%{name} and %%{version} macro in Source.
145
146 * Mon Jun 29 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
147   [1.3-4]
148 - added pl translation,
149 - build from non root's account,
150 - added %defattr support.
151
152 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
153 - translations modified for de, fr, tr
154
155 * Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
156 - updated to 1.3
157
158 * Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
159 - added BuildRoot; added aclocal files
160
161 * Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
162 - made it a noarch package
163
164 * Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
165 - Fixed some tag lines to conform to 5.0 guidelines.
166
167 * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
168 - updated to 1.2
169
170 * Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
171 - first version (1.0)
This page took 0.077943 seconds and 4 git commands to generate.