]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
- updated to 1.11.2
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_with             bootstrap       # without full regeneration
4
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.11.2
18 Release:        1
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
23 # Source0-md5:  18194e804d415767bae8f703c963d456
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 URL:            http://sources.redhat.com/automake/
29 %if %{with bootstrap}
30 BuildRequires:  autoconf >= 2.63
31 %else
32 BuildRequires:  autoconf >= 2.62
33 BuildRequires:  automake >= 1:1.10a
34 %endif
35 BuildRequires:  help2man
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  texinfo >= 4.7
38 Requires(pre):  fileutils
39 Requires:       filesystem >= 3.0-2
40 Requires:       perl(File::Glob)
41 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
42 # required only if perl was built with threads
43 Requires:       perl(Thread::Queue)
44 Requires:       perl(threads)
45 %endif
46 Conflicts:      autoconf < 2.60
47 Conflicts:      libtool < 2:1.5-11
48 BuildArch:      noarch
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _enable_debug_packages  0
52
53 %description
54 Automake is an experimental Makefile generator. Automake was inspired
55 by the 4.4BSD make and include files, but aims to be portable and to
56 conform to the GNU standards for Makefile variables and targets.
57
58 %description -l de.UTF-8
59 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
60 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
61 Konformität mit den GNU-Standards für Makefile-Variable und Targets
62 abzielt.
63
64 %description -l es.UTF-8
65 Automake es un creador experimental de Makefiles. Fue inspirado en el
66 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
67 con los padrones GNU para variables y dianas de Makefile.
68
69 %description -l fr.UTF-8
70 automake est un générateur expérimental de makefiles. Il a été inspiré
71 par le make de BSD 4.4, mais se veut portable et conforme aux
72 standards GNU pour les variables et les cibles des makefiles.
73
74 %description -l pl.UTF-8
75 Automake jest eksperymentalnym generatorem plików Makefile'a.
76 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
77 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
78 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
79
80 %description -l pt_BR.UTF-8
81 Automake é um gerador experimental de Makefiles. Ele foi inspirado
82 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
83 com os padrões GNU para variáveis e alvos de Makefile.
84
85 %description -l ru.UTF-8
86 Automake - это экспериментальный генератор Makefile'ов. Идея была
87 навеяна программой make и хедерами из 4.4BSD, но automake претендует
88 на то, чтобы быть портабельной и соответствовать стандартам GNU на
89 переменные и цели Makefile'ов.
90
91 %description -l tr.UTF-8
92 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
93 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
94 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
95
96 %description -l uk.UTF-8
97 Automake - це експериментальний генератор Makefile'ів. Ідея була
98 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
99 мобільність та відповідність стандартам GNU на змінні ті цілі
100 Makefile'ів.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108
109 %if %{without bootstrap}
110 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
111 mkdir m4-tmp
112 cd m4-tmp
113 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
114 %endif
115
116 %build
117 %if %{without bootstrap}
118 %{__aclocal} -I m4-tmp
119 %endif
120 %{__autoconf}
121 %if %{without bootstrap}
122 %{__automake}
123 %endif
124
125 # NOTE: _target macro becames "noarch" if ./builder passes --target=noarch, so
126 # be sure use plain /usr/bin/rpmbuild.
127 %configure \
128         --host=%{_host} \
129         --build=%{_host}
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_mandir}/man1
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT \
138         pkgvdatadir=%{_datadir}/automake
139
140 cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
141
142 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p      /sbin/postshell
148 -/usr/sbin/fix-info-dir -c %{_infodir}
149
150 %postun -p      /sbin/postshell
151 -/usr/sbin/fix-info-dir -c %{_infodir}
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README THANKS TODO
156 %attr(755,root,root) %{_bindir}/aclocal*
157 %attr(755,root,root) %{_bindir}/automake*
158 %{_infodir}/automake.info*
159 %{_mandir}/man1/aclocal.1*
160 %{_mandir}/man1/aclocal-1.11.1*
161 %{_mandir}/man1/automake.1*
162 %{_mandir}/man1/automake-1.11.1*
163
164 %{_datadir}/aclocal-*
165 %dir %{_datadir}/automake
166 %{_datadir}/automake/am
167 %{_datadir}/automake/Automake
168 %{_datadir}/automake/COPYING
169 %{_datadir}/automake/INSTALL
170 %{_datadir}/automake/texinfo.tex
171 %{_datadir}/automake/ansi2knr*
172 %attr(755,root,root) %{_datadir}/automake/ar-lib
173 %attr(755,root,root) %{_datadir}/automake/acinstall
174 %attr(755,root,root) %{_datadir}/automake/compile
175 %attr(755,root,root) %{_datadir}/automake/config.guess
176 %attr(755,root,root) %{_datadir}/automake/config.sub
177 %attr(755,root,root) %{_datadir}/automake/config-ml.in
178 %attr(755,root,root) %{_datadir}/automake/depcomp
179 %attr(755,root,root) %{_datadir}/automake/elisp-comp
180 %attr(755,root,root) %{_datadir}/automake/install-sh
181 %attr(755,root,root) %{_datadir}/automake/mdate-sh
182 %attr(755,root,root) %{_datadir}/automake/missing
183 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
184 %attr(755,root,root) %{_datadir}/automake/py-compile
185 %attr(755,root,root) %{_datadir}/automake/symlink-tree
186 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.05601 seconds and 4 git commands to generate.