]> git.pld-linux.org Git - packages/aufs.git/blob - aufs.spec
07e765a6b5a4f6dd717fc5304edf0db5ca3a151f
[packages/aufs.git] / aufs.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace programs
6 %bcond_with     verbose         # verbose build (V=1)
7 %bcond_without  vserver         # kernel build without vserver & grsecurity
8
9 %if %{without kernel}
10 %undefine       with_dist_kernel
11 %endif
12
13 %define         subver          20071017
14 %define         prel            0.%{subver}.%{rel}
15
16 %define         rel             10
17 Summary:        aufs - Another Unionfs
18 Summary(pl.UTF-8):      aufs (Another Unionfs) - inny unionfs
19 Name:           aufs
20 Version:        0
21 Release:        %{prel}
22 License:        GPL v2
23 Group:          Base/Kernel
24 Source0:        %{name}-%{subver}.tar.bz2
25 # Source0-md5:  dee001829acbf3a4fa857a752527b385
26 Patch0:         %{name}-vserver.patch
27 URL:            http://aufs.sourceforge.net/
28 %if %{with kernel}
29 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
30 BuildRequires:  rpmbuild(macros) >= 1.379
31 %endif
32 BuildRequires:  sed >= 4.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 In the early days, aufs was entirely re-designed and re-implemented
37 Unionfs. After many original ideas, approaches, improvements and
38 implementations, it becomes totally different from Unionfs while
39 keeping the basic features. Unionfs is being developed by Professor
40 Erez Zadok at Stony Brook University and his team. If you don't know
41 Unionfs, I recommend you to try and know it before using aufs. Some
42 terminology in aufs follows Unionfs's.
43
44 %description -l pl.UTF-8
45 Początkowo aufs był całkowicie przeprojektowanym i od nowa
46 zaimplementowanym unionfs-em. Po wielu oryginalnych pomysłach,
47 podejściach, poprawkach i implementacjach stał sie całkowicie innym
48 niż unionfs zachowując podstawowe możliwości. unionfs jest rozwijany
49 przez profesora Ereza Zadoka w Stony Brook University i jego zespół.
50 Nie znający unionfs-a powinni spróbować go i poznać przed używaniem
51 aufs-a. Część terminologii wywodzi się z unionfs-a.
52
53 %package -n kernel%{_alt_kernel}-fs-aufs
54 Summary:        Linux driver for aufs
55 Summary(pl.UTF-8):      Sterownik dla Linuksa do aufs
56 Release:        %{prel}@%{_kernel_ver_str}
57 Group:          Base/Kernel
58 Requires(post,postun):  /sbin/depmod
59 %if %{with dist_kernel}
60 %requires_releq_kernel
61 Requires(postun):       %releq_kernel
62 %endif
63
64 %description -n kernel%{_alt_kernel}-fs-aufs
65 This is driver for aufs for Linux.
66
67 This package contains Linux module.
68
69 %description -n kernel%{_alt_kernel}-fs-aufs -l pl.UTF-8
70 Sterownik dla Linuksa do aufs.
71
72 Ten pakiet zawiera moduł jądra Linuksa.
73
74 %prep
75 %setup -qn %{name}
76 %if %{with vserver}
77 %patch0 -p1
78 %endif
79
80 sed '
81         s/$(CONFIG_AUFS)/m/; 
82         %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/}; 
83         s/$(CONFIG_AUFS_HINOTIFY)/n/;
84         s/$(CONFIG_AUFS_EXPORT)/y/;
85         s/$(CONFIG_AUFS_SYSAUFS)/n/
86 ' -i fs/aufs/Makefile
87 cp -a include/linux fs/aufs
88
89 %build
90 %if %{with kernel}
91 %build_kernel_modules -C fs/aufs -m aufs \
92         EXTRA_CFLAGS=" \
93                 -DCONFIG_AUFS_BRANCH_MAX_127 \
94                 -DCONFIG_AUFS_BRANCH_MAX_CHAR \
95                 -DCONFIG_AUFS_FAKE_DM \
96                 -DCONFIG_AUFS_MODULE \
97                 -UCONFIG_AUFS_KSIZE_PATCH \
98                 %{?debug:-DCONFIG_AUFS_DEBUG} \
99                 %{?with_vserver:-DVSERVER} \
100         "
101 %endif
102
103 %if %{with userspace}
104 %{__make} -C util \
105         CC="%{__cc}" \
106         CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
107 %endif
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %if %{with userspace}
113 install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
114 install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
115 install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
116 %endif
117
118 %if %{with kernel}
119 %install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
120 %endif
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -n kernel%{_alt_kernel}-fs-aufs
126 %depmod %{_kernel_ver}
127
128 %postun -n kernel%{_alt_kernel}-fs-aufs
129 %depmod %{_kernel_ver}
130
131 %if %{with kernel}
132 %files -n kernel%{_alt_kernel}-fs-aufs
133 %defattr(644,root,root,755)
134 %dir /lib/modules/%{_kernel_ver}/kernel/fs/aufs
135 /lib/modules/%{_kernel_ver}/kernel/fs/aufs/*.ko*
136 %endif
137
138 %if %{with userspace}
139 %files
140 %defattr(644,root,root,755)
141 %doc README History
142 %attr(755,root,root) %{_sbindir}/*
143 %{_mandir}/man5/*
144 %endif
This page took 0.053512 seconds and 3 git commands to generate.