]> git.pld-linux.org Git - packages/audit.git/blob - audit.spec
496dffbe9351758fb6ffe819362dd327f92a950a
[packages/audit.git] / audit.spec
1 Summary:        User space tools for 2.6 kernel auditing
2 Summary(pl):    Narzêdzia przestrzeni u¿ytkownika do audytu j±der 2.6
3 Name:           audit
4 Version:        1.0.3
5 Release:        0.1
6 License:        GPL
7 Group:          Daemons
8 Source0:        http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
9 # Source0-md5:  950daad97adfa3134289aa5b4e885f8f
10 # http://people.redhat.com/sgrubb/audit/audit.h
11 Source1:        audit.h
12 URL:            http://people.redhat.com/sgrubb/audit/
13 BuildRequires:  autoconf >= 2.59
14 BuildRequires:  automake >= 1.9
15 BuildRequires:  libtool
16 BuildRequires:  linux-libc-headers >= 2.6.11
17 PreReq:         rc-scripts
18 Requires(post,preun):   /sbin/chkconfig
19 Requires:       %{name}-libs = %{version}-%{release}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sbindir        /sbin
23
24 %description
25 The audit package contains the user space utilities for storing and
26 processing the audit records generate by the audit subsystem in the
27 Linux 2.6 kernel.
28
29 %description -l pl
30 Ten pakiet zawiera narzêdzia przestrzeni u¿ytkownika do przechowywania
31 i przetwarzania rekordów audytu generowanych przez podsystem audytu w
32 j±drach Linuksa 2.6.
33
34 %package libs
35 Summary:        Dynamic libaudit library
36 Summary(pl):    Biblioteka dynamiczna libaudit
37 License:        LGPL
38 Group:          Libraries
39
40 %description libs
41 The audit-libs package contains the dynamic library needed for
42 applications to use the audit framework.
43
44 %description libs -l pl
45 Ten pakiet zawiera bibliotekê dynamiczn± potrzebn± dla aplikacji
46 u¿ywaj±cych ¶rodowiska audytu.
47
48 %package libs-devel
49 Summary:        Header files for libaudit library
50 Summary(pl):    Pliki nag³ówkowe biblioteki libaudio
51 License:        LGPL
52 Group:          Development/Libraries
53 Requires:       %{name}-libs = %{version}-%{release}
54
55 %description libs-devel
56 The audit-libs-devel package contains the header files needed for
57 developing applications that need to use the audit framework library.
58
59 %description libs-devel -l pl
60 Ten pakiet zawiera pliki nag³ówkowe potrzebne do tworzenia aplikacji
61 u¿ywaj±cych biblioteki ¶rodowiska audytu.
62
63 %package libs-static
64 Summary:        Static libaudit library
65 Summary(pl):    Statyczna biblioteka libaudit
66 License:        LGPL
67 Group:          Development/Libraries
68 Requires:       %{name}-libs-devel = %{version}-%{release}
69
70 %description libs-static
71 The audit-libs-static package contains the static library for
72 developing applications that need to use the audit framework library.
73
74 %description libs-static -l pl
75 Ten pakiet zawiera statyczn± bibliotekê do tworzenia aplikacji
76 u¿ywaj±cych ¶rodowiska audytu.
77
78 %prep
79 %setup -q
80
81 install -D %{SOURCE1} lib/linux/audit.h
82 install -D %{SOURCE1} src/mt/linux/audit.h
83
84 %build
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure
91 # override auditd_CFLAGS to avoid -fPIE unsupported by gcc 3.3
92 %{__make} \
93         auditd_CFLAGS=
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_var}/log/audit
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT/%{_lib}
103 mv -f $RPM_BUILD_ROOT%{_libdir}/libaudit.so.* $RPM_BUILD_ROOT/%{_lib}
104 ln -sf $(cd $RPM_BUILD_ROOT/%{_lib} ; echo libaudit.so.*.*.*) \
105         $RPM_BUILD_ROOT%{_libdir}/libaudit.so
106
107 # We manually install this since Makefile doesn't
108 install -d $RPM_BUILD_ROOT%{_includedir}
109 install lib/libaudit.h $RPM_BUILD_ROOT%{_includedir}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   libs -p /sbin/ldconfig
115 %postun libs -p /sbin/ldconfig
116
117 %post
118 /sbin/chkconfig --add auditd
119 if [ -f /var/lock/subsys/auditd ]; then
120         /etc/rc.d/init.d/auditd restart >&2
121 else
122         echo "Run \"/etc/rc.d/init.d/auditd start\" to start audit daemon." >&2
123 fi
124
125 %preun
126 if [ "$1" = "0" ]; then
127         if [ -f /var/lock/subsys/auditd ]; then
128                 /etc/rc.d/init.d/auditd stop >&2
129         fi
130         /sbin/chkconfig --del auditd
131 fi
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog README THANKS TODO sample.rules
136 %attr(750,root,root) %{_sbindir}/auditctl
137 %attr(750,root,root) %{_sbindir}/auditd
138 %attr(750,root,root) %{_sbindir}/ausearch
139 %attr(750,root,root) %{_sbindir}/autrace
140 %attr(754,root,root) /etc/rc.d/init.d/auditd
141 %config(noreplace) %attr(640,root,root) %{_sysconfdir}/auditd.conf
142 %config(noreplace) %attr(640,root,root) %{_sysconfdir}/audit.rules
143 %config(noreplace) %attr(640,root,root) %verify(not md5 mtime size) /etc/sysconfig/auditd
144 %attr(750,root,root) %dir %{_var}/log/audit
145 %{_mandir}/man8/*
146
147 %files libs
148 %defattr(644,root,root,755)
149 %attr(755,root,root) /%{_lib}/libaudit.so.*.*.*
150
151 %files libs-devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libaudit.so
154 %{_libdir}/libaudit.la
155 %{_includedir}/libaudit.h
156 %{_mandir}/man3/*
157
158 %files libs-static
159 %defattr(644,root,root,755)
160 %{_libdir}/libaudit.a
This page took 0.057798 seconds and 3 git commands to generate.