]> git.pld-linux.org Git - packages/aubio.git/blob - aubio.spec
- fix bashism in configure.ac
[packages/aubio.git] / aubio.spec
1 # TODO:
2 #       - package doc and create audacity-plugin
3 #
4 # Conditional build:
5 %bcond_without  python  # python bindings
6 #
7 Summary:        aubio - library for audio labelling
8 Summary(pl.UTF-8):      aubio - biblioteka do oznaczania dźwięku
9 Name:           aubio
10 Version:        0.3.2
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        http://aubio.piem.org/pub/%{name}-%{version}.tar.gz
15 # Source0-md5:  ffc3e5e4880fec67064f043252263a44
16 Patch0:         %{name}-python.patch
17 URL:            http://aubio.piem.org/
18 BuildRequires:  alsa-lib-devel >= 0.9.0
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  docbook-to-man
22 BuildRequires:  fftw3-single-devel >= 3.0.0
23 BuildRequires:  jack-audio-connection-kit-devel >= 0.15.0
24 BuildRequires:  lash-devel >= 0.5.0
25 BuildRequires:  libsamplerate-devel >= 0.0.15
26 BuildRequires:  libsndfile-devel >= 1.0.4
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 #BuildRequires: puredata-devel (m_pd.h)
30 %if %{with python}
31 BuildRequires:  python-devel
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.219
34 BuildRequires:  swig-python
35 %endif
36 BuildRequires:  sed >= 4.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 aubio is a library for audio labelling.
41
42 %description -l pl.UTF-8
43 aubio to biblioteka do oznaczania dźwięku.
44
45 %package devel
46 Summary:        Header files for aubio library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki aubio
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       fftw3-single-devel >= 3.0.0
51 Requires:       libsamplerate-devel >= 0.0.15
52 # for libaubioext:
53 # alsa-lib-devel >= 0.9.0
54 # jack-audio-connection-kit-devel >= 0.15.0
55 # libsndfile-devel >= 1.0.4
56
57 %description devel
58 Header files for aubio library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki aubio.
62
63 %package static
64 Summary:        Static aubio library
65 Summary(pl.UTF-8):      Statyczna biblioteka aubio
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static aubio library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka aubio.
74
75 %package progs
76 Summary:        Example applications using aubio library
77 Summary(pl.UTF-8):      Przykładowe programy korzystajace z biblioteki aubio
78 Group:          Applications/Sound
79 Requires:       %{name} = %{version}-%{release}
80
81 %description progs
82 A few examples of applications using aubio library:
83 - aubioonset: outputs the onset detected.
84 - aubionotes: uses both onset and pitch to extract symbolic music data
85     from an audio source and emit MIDI like data.
86 - aubiocut: a Python script that takes an input sound and creates one
87     new sample at each detected onset or beat. The slices produced by
88     aubiocut are useful for use with a sequencer such as Hydrogen.
89 - aubiopitch: a Python script to extract pitch tracks from sound
90   files.
91
92 %description progs -l pl.UTF-8
93 Kilka przykładowych aplikacji korzystających z biblioteki dubio:
94 - aubioonset - wypisuje wykryty początek.
95 - aubionotes - wykorzystuje początek i wysokość do wyciągnięcia
96   symbolicznych danych muzycznych ze źródła dźwięku i stworzenia
97   danych typu MIDI.
98 - aubiocut - skrypt Pythona pobierający dźwięk wejściowy i tworzący
99   nową próbkę dla każdego wykrytego początku lub taktu. Fragmenty
100   tworzone przez aubiocut są przydatne do wykorzystania przez
101   sekwencer, jak np. Hydrogen.
102 - aubiopitch - skrypt Pythona do wyciągania ścieżek wysokości z
103   plików dźwiękowych.
104
105 %package -n python-aubio
106 Summary:        aubio Python bindings
107 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki aubio
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110
111 %description -n python-aubio
112 aubio Python bindings.
113
114 %description -n python-aubio -l pl.UTF-8
115 Wiązania Pythona do biblioteki aubio.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 sed 's/\([A-Z_]\+\)+="\(.*\)"/\1="$\1 \2"/' -i configure.ac
121
122 %build
123 %{__libtoolize}
124 %{__aclocal}
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         --enable-alsa \
130         --enable-lash \
131         --enable-jack
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %py_postclean
142 rm -f $RPM_BUILD_ROOT%{py_sitedir}/aubio/_aubiowrapper.{la,a}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README THANKS TODO
153 %attr(755,root,root) %{_libdir}/libaubio.so.*.*.*
154 %attr(755,root,root) %{_libdir}/libaubioext.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libaubio.so.2
156 %attr(755,root,root) %ghost %{_libdir}/libaubioext.so.2
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libaubio.so
161 %attr(755,root,root) %{_libdir}/libaubioext.so
162 %{_libdir}/libaubio.la
163 %{_libdir}/libaubioext.la
164 %{_includedir}/%{name}
165 %{_pkgconfigdir}/aubio.pc
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libaubio.a
170 %{_libdir}/libaubioext.a
171
172 %files progs
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/aubionotes
175 %attr(755,root,root) %{_bindir}/aubioonset
176 %attr(755,root,root) %{_bindir}/aubiotrack
177 %{_mandir}/man1/aubionotes.1*
178 %{_mandir}/man1/aubioonset.1*
179 %{_mandir}/man1/aubiotrack.1*
180 %{_datadir}/sounds/aubio
181
182 %if %{with python}
183 %files -n python-aubio
184 %defattr(644,root,root,755)
185 %dir %{py_sitedir}/aubio
186 %attr(755,root,root) %{py_sitedir}/aubio/_aubiowrapper.so
187 %{py_sitescriptdir}/aubio
188 # examples
189 %attr(755,root,root) %{_bindir}/aubiocut
190 %attr(755,root,root) %{_bindir}/aubiopitch
191 %{_mandir}/man1/aubiocut.1*
192 %{_mandir}/man1/aubiopitch.1*
193 %endif
This page took 0.089587 seconds and 4 git commands to generate.