]> git.pld-linux.org Git - packages/aubio.git/blob - aubio.spec
4434dc7f05cfb99e0ef93a1c4e30d2650ecaa7af
[packages/aubio.git] / aubio.spec
1 # TODO:
2 #       - package doc and create audacity-plugin
3 #
4 # Conditional build:
5 %bcond_without  python  # python bindings
6 #
7 Summary:        aubio - library for audio labelling
8 Summary(pl.UTF-8):      aubio - biblioteka do oznaczania dźwięku
9 Name:           aubio
10 Version:        0.3.2
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        http://aubio.piem.org/pub/%{name}-%{version}.tar.gz
15 # Source0-md5:  ffc3e5e4880fec67064f043252263a44
16 Patch0:         %{name}-python.patch
17 URL:            http://aubio.piem.org/
18 BuildRequires:  alsa-lib-devel >= 0.9.0
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  docbook-to-man
22 BuildRequires:  fftw3-single-devel >= 3.0.0
23 BuildRequires:  jack-audio-connection-kit-devel >= 0.15.0
24 BuildRequires:  lash-devel >= 0.5.0
25 BuildRequires:  libsamplerate-devel >= 0.0.15
26 BuildRequires:  libsndfile-devel >= 1.0.4
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 #BuildRequires: puredata-devel (m_pd.h)
30 %if %{with python}
31 BuildRequires:  python-devel
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.219
34 BuildRequires:  swig-python
35 %endif
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 aubio is a library for audio labelling.
40
41 %description -l pl.UTF-8
42 aubio to biblioteka do oznaczania dźwięku.
43
44 %package devel
45 Summary:        Header files for aubio library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki aubio
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       fftw3-single-devel >= 3.0.0
50 Requires:       libsamplerate-devel >= 0.0.15
51 # for libaubioext:
52 # alsa-lib-devel >= 0.9.0
53 # jack-audio-connection-kit-devel >= 0.15.0
54 # libsndfile-devel >= 1.0.4
55
56 %description devel
57 Header files for aubio library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki aubio.
61
62 %package static
63 Summary:        Static aubio library
64 Summary(pl.UTF-8):      Statyczna biblioteka aubio
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static aubio library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka aubio.
73
74 %package progs
75 Summary:        Example applications using aubio library
76 Summary(pl.UTF-8):      Przykładowe programy korzystajace z biblioteki aubio
77 Group:          Applications/Sound
78 Requires:       %{name} = %{version}-%{release}
79
80 %description progs
81 A few examples of applications using aubio library:
82 - aubioonset: outputs the onset detected.
83 - aubionotes: uses both onset and pitch to extract symbolic music data
84     from an audio source and emit MIDI like data.
85 - aubiocut: a Python script that takes an input sound and creates one
86     new sample at each detected onset or beat. The slices produced by
87     aubiocut are useful for use with a sequencer such as Hydrogen.
88 - aubiopitch: a Python script to extract pitch tracks from sound
89   files.
90
91 %description progs -l pl.UTF-8
92 Kilka przykładowych aplikacji korzystających z biblioteki dubio:
93 - aubioonset - wypisuje wykryty początek.
94 - aubionotes - wykorzystuje początek i wysokość do wyciągnięcia
95   symbolicznych danych muzycznych ze źródła dźwięku i stworzenia
96   danych typu MIDI.
97 - aubiocut - skrypt Pythona pobierający dźwięk wejściowy i tworzący
98   nową próbkę dla każdego wykrytego początku lub taktu. Fragmenty
99   tworzone przez aubiocut są przydatne do wykorzystania przez
100   sekwencer, jak np. Hydrogen.
101 - aubiopitch - skrypt Pythona do wyciągania ścieżek wysokości z
102   plików dźwiękowych.
103
104 %package -n python-aubio
105 Summary:        aubio Python bindings
106 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki aubio
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109
110 %description -n python-aubio
111 aubio Python bindings.
112
113 %description -n python-aubio -l pl.UTF-8
114 Wiązania Pythona do biblioteki aubio.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %build
121 %{__libtoolize}
122 %{__aclocal}
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 %configure \
127         --enable-alsa \
128         --enable-lash \
129         --enable-jack
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %py_postclean
140 rm -f $RPM_BUILD_ROOT%{py_sitedir}/aubio/_aubiowrapper.{la,a}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README THANKS TODO
151 %attr(755,root,root) %{_libdir}/libaubio.so.*.*.*
152 %attr(755,root,root) %{_libdir}/libaubioext.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libaubio.so.2
154 %attr(755,root,root) %ghost %{_libdir}/libaubioext.so.2
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libaubio.so
159 %attr(755,root,root) %{_libdir}/libaubioext.so
160 %{_libdir}/libaubio.la
161 %{_libdir}/libaubioext.la
162 %{_includedir}/%{name}
163 %{_pkgconfigdir}/aubio.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libaubio.a
168 %{_libdir}/libaubioext.a
169
170 %files progs
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/aubionotes
173 %attr(755,root,root) %{_bindir}/aubioonset
174 %attr(755,root,root) %{_bindir}/aubiotrack
175 %{_mandir}/man1/aubionotes.1*
176 %{_mandir}/man1/aubioonset.1*
177 %{_mandir}/man1/aubiotrack.1*
178 %{_datadir}/sounds/aubio
179
180 %if %{with python}
181 %files -n python-aubio
182 %defattr(644,root,root,755)
183 %dir %{py_sitedir}/aubio
184 %attr(755,root,root) %{py_sitedir}/aubio/_aubiowrapper.so
185 %{py_sitescriptdir}/aubio
186 # examples
187 %attr(755,root,root) %{_bindir}/aubiocut
188 %attr(755,root,root) %{_bindir}/aubiopitch
189 %{_mandir}/man1/aubiocut.1*
190 %{_mandir}/man1/aubiopitch.1*
191 %endif
This page took 0.063471 seconds and 3 git commands to generate.