]> git.pld-linux.org Git - packages/atk.git/blob - atk.spec
8db711e74d62e1395d19ba1632e6d7672af46a4a
[packages/atk.git] / atk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        ATK - Accessibility Toolkit
7 Summary(pl.UTF-8):      ATK - biblioteka ułatwiająca niepełnosprawnym korzystanie z komputerów
8 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
9 Name:           atk
10 Version:        1.20.0
11 Release:        2
12 Epoch:          1
13 License:        LGPL v2+
14 Group:          X11/Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/atk/1.20/%{name}-%{version}.tar.bz2
16 # Source0-md5:  b1a9e28d9f54ea306bd85a4c84b25fb8
17 URL:            http://developer.gnome.org/projects/gap/
18 BuildRequires:  autoconf >= 2.54
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 1:2.14.1
22 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
23 BuildRequires:  gtk-doc-automake >= 1.8
24 BuildRequires:  libtool >= 2:1.5.16
25 BuildRequires:  perl-base
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.197
28 Requires:       glib2 >= 1:2.14.1
29 Obsoletes:      libatk1.0_0
30 # sr@Latn vs. sr@latin
31 Conflicts:      glibc-misc < 6:2.7
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The ATK library provides a set of interfaces for adding accessibility
36 support to applications and graphical user interface toolkits. By
37 supporting the ATK interfaces, an application or toolkit can be used
38 as tools such as screen readers and magnifiers, and alternative input
39 devices.
40
41 %description -l pl.UTF-8
42 Biblioteka ATK udostępnia zestaw interfejsów ułatwiających
43 niepełnosprawnym korzystanie z aplikacji i poszczególnych elementów
44 graficznego interfejsu użytkownika. Poprzez wykorzystanie interfejsów
45 ATK, aplikacja lub element interfejsu może być używany z takimi
46 narzędziami jak czytniki ekranu i narzędzia powiększające oraz
47 alternatywnymi urządzeniami wejściowymi.
48
49 %description -l pt_BR.UTF-8
50 A biblioteca ATK provê um conjunto de interfaces para adicionar
51 suporte a acessibilidade para aplicações e interfaces gráficas.
52 Suportando a interface ATK, uma aplicação ou interface gráfica pode
53 ser utilizada como ferramentas de leitura e aumento de tela,
54 dispositivos de entrada alternativos, etc.
55
56 %package devel
57 Summary:        ATK - header files
58 Summary(pl.UTF-8):      ATK - pliki nagłówkowe
59 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{epoch}:%{version}-%{release}
62 Requires:       glib2-devel >= 1:2.14.1
63 Obsoletes:      libatk1.0_0-devel
64
65 %description devel
66 ATK - header files.
67
68 %description devel -l pl.UTF-8
69 ATK - pliki nagłówkowe.
70
71 %description devel -l pt_BR.UTF-8
72 Interfaces para suporte a acessibilidade.
73
74 %package static
75 Summary:        ATK static library
76 Summary(pl.UTF-8):      Biblioteka statyczna ATK
77 Summary(pt_BR.UTF-8):   Interfaces para suporte a acessibilidade
78 Group:          X11/Development/Libraries
79 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
80
81 %description static
82 ATK static library.
83
84 %description static -l pl.UTF-8
85 Biblioteka statyczna ATK.
86
87 %description static -l pt_BR.UTF-8
88 Interfaces para suporte a acessibilidade.
89
90 %package apidocs
91 Summary:        ATK API documentation
92 Summary(pl.UTF-8):      Dokumentacja API ATK
93 Group:          Documentation
94 Requires:       gtk-doc-common
95
96 %description apidocs
97 ATK API documentation.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API ATK.
101
102 %prep
103 %setup -q
104
105 %build
106 %{?with_apidocs:%{__gtkdocize}}
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
114         %{?with_apidocs:--with-html-dir=%{_gtkdocdir}} \
115         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static \
116         --enable-shared
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
127         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
128 %find_lang atk10
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files -f atk10.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %doc ChangeLog
144 %attr(755,root,root) %{_libdir}/lib*.so
145 %{_libdir}/lib*.la
146 %{_includedir}/atk*
147 %{_pkgconfigdir}/atk*
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/lib*.a
153 %endif
154
155 %if %{with apidocs}
156 %files apidocs
157 %defattr(644,root,root,755)
158 %{_gtkdocdir}/atk
159 %endif
This page took 0.070135 seconds and 3 git commands to generate.