]> git.pld-linux.org Git - packages/at-spi.git/blob - at-spi.spec
2a84fe105484ccf9c2f08003e07a7b3a4a1c3604
[packages/at-spi.git] / at-spi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Assistive Technology Service Provider Interface
6 Summary(pl.UTF-8):   Interfejs pozwalający na korzystanie z urządzeń wspomagających
7 Name:           at-spi
8 Version:        1.7.15
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/at-spi/1.7/%{name}-%{version}.tar.bz2
13 # Source0-md5:  b8af15556d24e850feb2ffb40eda1d31
14 URL:            http://developer.gnome.org/projects/gap/
15 BuildRequires:  ORBit2-devel >= 2.14.4
16 BuildRequires:  atk-devel >= 1:1.12.4
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gail-devel >= 1.9.3
20 BuildRequires:  gnome-common >= 2.12.0
21 BuildRequires:  gtk+2-devel >= 2:2.10.7
22 BuildRequires:  gtk-doc >= 1.7
23 BuildRequires:  intltool
24 BuildRequires:  libbonobo-devel >= 2.16.0
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpm-build >= 4.1-10
28 BuildRequires:  xorg-lib-libXft-devel >= 2.1
29 BuildRequires:  xorg-lib-libXtst-devel
30 Obsoletes:      libat-spi1
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 at-spi allows assistive technologies to access GTK-based
35 applications. Essentially it exposes the internals of applications for
36 automation, so tools such as screen readers, magnifiers, or even
37 scripting interfaces can query and interact with GUI controls.
38
39 %description -l pl.UTF-8
40 at-spi pozwala na korzystanie z urządzeń wspomagających w celu dostępu
41 do aplikacji bazujących na GTK. Przede wszystkim udostępnia wewnętrzne
42 interfejsy aplikacji dla automatyzacji, więc urządzenia takie jak
43 czytniki ekranu, lupy, czy nawet interfejsy skryptowe mogą odpytywać i
44 współpracować z kontrolkami interfejsu graficznego.
45
46 %package devel
47 Summary:        at-spi development files
48 Summary(pl.UTF-8):   Pliki programistyczne at-spi
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       ORBit2-devel >= 2.14.4
52 Requires:       atk-devel >= 1:1.12.4
53 Requires:       gail-devel >= 1.9.3
54 Requires:       gtk+2-devel >= 2:2.10.7
55 Requires:       libbonobo-devel >= 2.16.0
56 Obsoletes:      libat-spi1-devel
57
58 %description devel
59 at-spi development files.
60
61 %description devel -l pl.UTF-8
62 Pliki programistyczne at-spi.
63
64 %package static
65 Summary:        at-spi static library
66 Summary(pl.UTF-8):   Statyczna biblioteka at-spi
67 Group:          X11/Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 at-spi static library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka at-spi.
75
76 %package apidocs
77 Summary:        at-spi API documentation
78 Summary(pl.UTF-8):   Dokumentacja API at-spi
79 Group:          Documentation
80 Requires:       gtk-doc-common
81
82 %description apidocs
83 at-spi API documentation.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API at-spi.
87
88 %prep
89 %setup -q
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__automake}
95 %{__autoconf}
96 %configure \
97         %{!?with_static_libs:--disable-static} \
98         --enable-gtk-doc \
99         --enable-static \
100         --with-html-dir=%{_gtkdocdir}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         HTML_DIR=%{_gtkdocdir}
109
110 # no static modules
111 rm -f $RPM_BUILD_ROOT%{_libdir}/{gtk-2.0/modules,orbit-2.0}/*.{la,a}
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/lib*.so.*.*
124 %attr(755,root,root) %{_libdir}/at-spi-registryd
125 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so
126 %attr(755,root,root) %{_libdir}/gtk-2.0/modules/lib*.so
127 %{_libdir}/bonobo/servers/*
128 %{_datadir}/idl/*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %{_includedir}/*
133 %attr(755,root,root) %{_libdir}/lib*.so
134 %{_libdir}/lib*.la
135 %{_pkgconfigdir}/*
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/*.a
141 %endif
142
143 %files apidocs
144 %defattr(644,root,root,755)
145 %{_gtkdocdir}/*
146 %{_docdir}/%{name}-%{version}
This page took 0.032013 seconds and 3 git commands to generate.