]> git.pld-linux.org Git - packages/aspell.git/blob - aspell.spec
- corrected version, there was not first 0 in version string
[packages/aspell.git] / aspell.spec
1 %define         ver     .33.7.1
2
3 Summary:        Aspell is an Open Source spell checker
4 Summary(pl):    Aspell jest kontrolerem pisowni
5 Name:           aspell
6 Version:        0%{ver}
7 Release:        1
8 Epoch:          1
9 License:        LGPL
10 Group:          Applications/Text
11 Group(de):      Applikationen/Text
12 Group(fr):      Utilitaires/Texte
13 Group(pl):      Aplikacje/Tekst
14 Vendor:         Kevin Atkinson <kevinatk@home.com>
15 Source0:        http://metalab.unc.edu/kevina/aspell/%{name}-%{ver}.tar.gz
16 URL:            http://metalab.unc.edu/kevina/aspell/
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pspell-devel
19 Provides:       ispell
20 Obsoletes:      ispell
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Aspell is an Open Source spell checker designed to eventually replace
25 Ispell. Its main feature is that it does a much better job of coming
26 up with possible suggestions than Ispell does. In fact recent tests
27 shows that it even does better than Microsoft Word 97's spell checker
28 in some cases. In addition it has both compile time and run time
29 support for other non English languages. Aspell also doubles as a
30 powerful C++ library with C and Perl interfaces in the works.
31
32 %description -l pl
33 Aspell jest kontrolerem pisowni zaprojektowanym tak, by móc zast±piæ
34 ispell'a. Dodatkowo zawiera wsparcie dla innych jêzyków ni¿ angielski.
35 Interfejs aspella napisany zosta³ w C++, a interfejsy w Perlu i C s±
36 aktualnie rozwijane.
37
38 %package devel
39 Summary:        Libraries and header files for aspell development
40 Summary(pl):    Biblioteki i pliki nag³ówkowe dla developerów aspella
41 Group:          Development/Libraries
42 Group(de):      Entwicklung/Libraries
43 Group(fr):      Development/Librairies
44 Group(pl):      Programowanie/Biblioteki
45 Requires:       %{name} = %{version}
46
47 %description devel
48 Aspell is an Open Source spell checker.
49
50 Libraries and header files for aspell development.
51
52 %description -l pl devel
53 Aspell jest kontrolerem pisowni. Pakiet ten zawiera biblioteki i pliki
54 nag³ówkowe dla developerów aspella.
55
56 %package static
57 Summary:        Static Libraries for aspell development
58 Summary(pl):    Biblioteki statyczne dla developerów aspella
59 Group:          Development/Libraries
60 Group(de):      Entwicklung/Libraries
61 Group(fr):      Development/Librairies
62 Group(pl):      Programowanie/Biblioteki
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 Aspell is an Open Source spell checker.
67
68 Static Libraries for aspell development.
69
70 %description -l pl static
71 Aspell jest kontrolerem pisowni. Pakiet ten zawiera biblioteki
72 statyczne dla developerów aspella.
73
74 %prep
75 %setup -q -n %{name}-%{ver}
76
77 %build
78 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
79 %configure %{_target_platform} \
80         --libdir=%{_datadir} \
81         --enable-shared \
82         --enable-static
83 %{__make} 
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT \
90         pkgdatadir=%{_datadir}/aspell \
91         libdir=%{_libdir}
92
93 #cp -pr $RPM_BUILD_ROOT%{_prefix}/doc/aspell .
94
95 ln -sf aspell $RPM_BUILD_ROOT%{_bindir}/ispell
96 rm -rf $RPM_BUILD_ROOT%{_prefix}/{bin/run-with-aspell,share/aspell/ispell}
97
98 gzip -9nf manual/manual2.lyx manual/man-text/*.txt
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc README TODO manual/{*,man-text/*.txt}.gz
109 %attr(755,root,root) %{_bindir}/*
110 %{_datadir}/aspell
111 %{_libdir}/libaspell.so.*.*
112
113 %files  devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libaspell.so
116 %{_includedir}/aspell
117 %{_libdir}/libaspell.la
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libaspell.a
This page took 0.051556 seconds and 4 git commands to generate.