]> git.pld-linux.org Git - packages/aspell.git/blob - aspell.spec
370ecff83d18efdef4a0ece71f0f6a1ebb478931
[packages/aspell.git] / aspell.spec
1 %define         ver     .33.7.1
2
3 Summary:        Aspell is an Open Source spell checker
4 Summary(pl):    Aspell jest kontrolerem pisowni
5 Name:           aspell
6 Version:        0%{ver}
7 Release:        1
8 Epoch:          1
9 License:        LGPL
10 Group:          Applications/Text
11 Vendor:         Kevin Atkinson <kevinatk@home.com>
12 Source0:        http://metalab.unc.edu/kevina/aspell/%{name}-%{ver}.tar.gz
13 URL:            http://metalab.unc.edu/kevina/aspell/
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  pspell-devel
16 Provides:       ispell
17 Obsoletes:      ispell
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Aspell is an Open Source spell checker designed to eventually replace
22 Ispell. Its main feature is that it does a much better job of coming
23 up with possible suggestions than Ispell does. In fact recent tests
24 shows that it even does better than Microsoft Word 97's spell checker
25 in some cases. In addition it has both compile time and run time
26 support for other non English languages. Aspell also doubles as a
27 powerful C++ library with C and Perl interfaces in the works.
28
29 %description -l pl
30 Aspell jest kontrolerem pisowni zaprojektowanym tak, by móc zast±piæ
31 ispell'a. Dodatkowo zawiera wsparcie dla innych jêzyków ni¿ angielski.
32 Interfejs aspella napisany zosta³ w C++, a interfejsy w Perlu i C s±
33 aktualnie rozwijane.
34
35 %package devel
36 Summary:        Libraries and header files for aspell development
37 Summary(pl):    Biblioteki i pliki nag³ówkowe dla developerów aspella
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}
40
41 %description devel
42 Aspell is an Open Source spell checker.
43
44 Libraries and header files for aspell development.
45
46 %description -l pl devel
47 Aspell jest kontrolerem pisowni. Pakiet ten zawiera biblioteki i pliki
48 nag³ówkowe dla developerów aspella.
49
50 %package static
51 Summary:        Static Libraries for aspell development
52 Summary(pl):    Biblioteki statyczne dla developerów aspella
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}
55
56 %description static
57 Aspell is an Open Source spell checker.
58
59 Static Libraries for aspell development.
60
61 %description -l pl static
62 Aspell jest kontrolerem pisowni. Pakiet ten zawiera biblioteki
63 statyczne dla developerów aspella.
64
65 %prep
66 %setup -q -n %{name}-%{ver}
67
68 %build
69 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
70 %configure %{_target_platform} \
71         --libdir=%{_datadir} \
72         --enable-shared \
73         --enable-static
74 %{__make} 
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT \
81         pkgdatadir=%{_datadir}/aspell \
82         libdir=%{_libdir}
83
84 #cp -pr $RPM_BUILD_ROOT%{_prefix}/doc/aspell .
85
86 ln -sf aspell $RPM_BUILD_ROOT%{_bindir}/ispell
87 rm -rf $RPM_BUILD_ROOT%{_prefix}/{bin/run-with-aspell,share/aspell/ispell}
88
89 gzip -9nf manual/manual2.lyx manual/man-text/*.txt
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README TODO manual/{*,man-text/*.txt}.gz
100 %attr(755,root,root) %{_bindir}/*
101 %{_datadir}/aspell
102 %{_libdir}/libaspell.so.*.*
103
104 %files  devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libaspell.so
107 %{_includedir}/aspell
108 %{_libdir}/libaspell.la
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libaspell.a
This page took 0.099764 seconds and 3 git commands to generate.