]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- md5.
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6 %define         _state          stable
7 %define         _ver            1.2.2
8 #%%define               _snap           040110
9 %define         _kdever         3.2.2
10 #
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 Source0:        http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
21 # Source0-md5:  83ca7e7a33c55de34e12bfc360190795
22 # http://download.kde.org/stable/3.2.1/src/arts-1.2.1.tar.bz2
23 #Source0:       http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
24 URL:            http://www.kde.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel}
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  docbook-dtd41-sgml
30 BuildRequires:  docbook-utils >= 0.6.13-3
31 BuildRequires:  esound-devel
32 BuildRequires:  glib2-devel >= 2.0.0
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt-devel >= 6:3.2.1-4
39 BuildRequires:  unsermake
40 Obsoletes:      arts-glib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 aRts sound server.
45
46 %description -l pl
47 Serwer d¼wiêku aRts.
48
49 %description -l pt_BR
50 O aRts é um sintetizador analógico em tempo real que é completamente
51 modular. Você pode criar sons e músicas (síntese em tempo real de
52 midi) usando pequenos módulos como oscilador para criar waveforms,
53 vários filtros, mixers, faders, etc. Você pode configurar tudo através
54 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
55 design foi escolhido para permitir que outras aplicações usem o aRts
56 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
57 outros.
58
59 %package devel
60 Summary:        Sound server - header files
61 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
62 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
63 Group:          Development/Libraries
64 Requires:       %{name} = %{epoch}:%{version}-%{release}
65 # not necessary for all libs (e.g. mcop), but propagated by artsflow
66 %{?with_alsa:Requires:  alsa-lib-devel}
67 Requires:       audiofile-devel
68 Requires:       esound-devel
69 Requires:       glib2-devel >= 2.0.0
70 Requires:       libmad-devel
71 Requires:       libvorbis-devel
72 %{?with_nas:Requires:   nas-devel}
73
74 %description devel
75 Header files required to compile programs using arts.
76
77 %description devel -l pl
78 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
79 arts.
80
81 %description devel -l pt_BR
82 Arquivos para desenvolvimento com o o aRts.
83
84 # separate from arts-devel because they are mostly independent and
85 # have very # different deps  there is no artsc base - it would be
86 # small and would require arts - so there is no reason to separate
87 %package -n artsc-devel
88 Summary:        Development files for artsc libraries
89 Summary(pl):    Pliki programistyczne bibliotek artsc
90 Group:          Development/Libraries
91 Requires:       %{name} = %{epoch}:%{version}-%{release}
92 Requires:       glib2-devel >= 2.0.0
93 Conflicts:      arts-devel < 12:1.2.0.031126-2
94
95 %description -n artsc-devel
96 Development files for artsc libraries (C interface to aRts sound
97 system).
98
99 %description -n artsc-devel -l pl
100 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
101 d¼wiêku aRts).
102
103 %package X11
104 Summary:        X11 dependent part of aRts
105 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
106 Group:          X11/Libraries
107 Requires:       %{name} = %{epoch}:%{version}-%{release}
108
109 %description X11
110 X11 dependent part of aRts (x11globalcomm module).
111
112 %description X11 -l pl
113 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
114
115 %package qt
116 Summary:        QT dependend part of aRts
117 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
118 Group:          X11/Libraries
119 Requires:       %{name} = %{epoch}:%{version}-%{release}
120 Requires:       qt >= 6:3.2.1-4
121
122 %description qt
123 QT dependend part of aRts (qtmcop library).
124
125 %description qt -l pl
126 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
127
128 %package qt-devel
129 Summary:        Development files for qtmcop library
130 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
131 Group:          X11/Development/Libraries
132 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
133 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
134 Requires:       qt-devel >= 6:3.2.1-4
135
136 %description qt-devel
137 Development files for qtmcop library.
138
139 %description qt-devel -l pl
140 Pliki programistyczne dla biblioteki qtmcop.
141
142 %prep
143 # qboosh leave it this way, 'cause its easier to change to snap later
144 %setup -q -n %{name}-%{version}
145
146 %build
147 cp /usr/share/automake/config.sub admin
148 export UNSERMAKE=/usr/share/unsermake/unsermake
149
150 %configure \
151         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
152         --%{?debug:en}%{!?debug:dis}able-debug \
153         --disable-rpath \
154         --enable-final \
155         --with-qt-libraries=%{_libdir} \
156         --with%{!?with_alsa:out}-alsa
157
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 %{__make} install \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 # Debian manpages
167 install -d $RPM_BUILD_ROOT%{_mandir}/man1
168 cd debian/man
169 for f in *.sgml ; do
170         base="$(basename $f .sgml)"
171         upper="$(echo ${base} | tr a-z A-Z)"
172         db2man $f
173         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
174 done
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %post   X11 -p /sbin/ldconfig
183 %postun X11 -p /sbin/ldconfig
184
185 %post   qt -p /sbin/ldconfig
186 %postun qt -p /sbin/ldconfig
187
188 %files
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/artscat
191 %attr(755,root,root) %{_bindir}/artsd
192 %attr(755,root,root) %{_bindir}/artsdsp
193 %attr(755,root,root) %{_bindir}/artsplay
194 %attr(755,root,root) %{_bindir}/artsrec
195 %attr(755,root,root) %{_bindir}/artsshell
196 %attr(755,root,root) %{_bindir}/artswrapper
197 # shared libraries
198 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
199 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
200 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
207 # lt_dlopened modules (*.la needed)
208 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
209 %{_libdir}/libartscbackend.la
210 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
211 %{_libdir}/libartsdsp.la
212 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
213 %{_libdir}/libartsdsp_st.la
214 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
215 %{_libdir}/libartsgslplayobject.la
216 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
217 %{_libdir}/libartswavplayobject.la
218 #
219 %{_libdir}/mcop
220 %{_mandir}/man1/artscat.1*
221 %{_mandir}/man1/artsd.1*
222 %{_mandir}/man1/artsdsp.1*
223 %{_mandir}/man1/artsplay.1*
224 %{_mandir}/man1/artsrec.1*
225 %{_mandir}/man1/artsshell.1*
226 %{_mandir}/man1/artswrapper.1*
227
228 %files devel
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_bindir}/mcopidl
231 %attr(755,root,root) %{_libdir}/libartsflow.so
232 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
233 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
234 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
235 %attr(755,root,root) %{_libdir}/libgmcop.so
236 %attr(755,root,root) %{_libdir}/libkmedia2.so
237 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
238 %attr(755,root,root) %{_libdir}/libmcop.so
239 %attr(755,root,root) %{_libdir}/libmcop_mt.so
240 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
241 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
242 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
243 # shared libraries
244 %{_libdir}/libartsflow.la
245 %{_libdir}/libartsflow_idl.la
246 %{_libdir}/libgmcop.la
247 %{_libdir}/libkmedia2.la
248 %{_libdir}/libkmedia2_idl.la
249 %{_libdir}/libmcop.la
250 %{_libdir}/libmcop_mt.la
251 %{_libdir}/libsoundserver_idl.la
252 #
253 %{_includedir}/arts
254 %exclude %{_includedir}/arts/qiomanager.h
255 %{_mandir}/man1/mcopidl.1*
256
257 %files -n artsc-devel
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{_bindir}/artsc-config
260 %attr(755,root,root) %{_libdir}/libartsc.so
261 %attr(755,root,root) %{_libdir}/libartscbackend.so
262 %attr(755,root,root) %{_libdir}/libartsdsp.so
263 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
264 %{_libdir}/libartsc.la
265 %{_includedir}/artsc
266 %{_mandir}/man1/artsc-config.1*
267
268 %files X11
269 %defattr(644,root,root,755)
270 # lt_dlopened module (.la needed)
271 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
272 %{_libdir}/libx11globalcomm.la
273
274 %files qt
275 %defattr(644,root,root,755)
276 # shared library
277 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
278
279 %files qt-devel
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/libqtmcop.so
282 %{_libdir}/libqtmcop.la
283 %{_includedir}/arts/qiomanager.h
This page took 0.045569 seconds and 4 git commands to generate.