]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- cut off Vendor (we are package vendors and developers, program
[packages/arts.git] / arts.spec
1 # _without_alsa - disable alsa
2
3 %define         _state          stable
4 %define         _kdever         3.1
5
6 Summary:        aRts sound server
7 Summary(pl):    Serwer d¼wiêku
8 Summary(pt_BR): Servidor de sons usado pelo KDE
9 Name:           arts
10 Version:        1.1
11 Release:        5
12 Epoch:          12
13 License:        LGPL
14 Vendor:         The KDE Team
15 Group:          Libraries
16 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
17 %ifnarch sparc sparcv9 sparc64
18 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
19 %endif
20 BuildRequires:  audiofile-devel
21 BuildRequires:  glib2-devel >= 2.0.0
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel
24 # not needed, only ./configure check for this
25 #BuildRequires: libvorbis-devel
26 #BuildRequires: mad-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  qt-devel >= 3.1
29 URL:            http://www.kde.org/
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _htmldir        /usr/share/doc/kde/HTML
33
34 %define         no_install_post_chrpath         1
35
36 %description
37 aRts sound server.
38
39 %description -l pl
40 Serwer d¼wiêku aRts.
41
42 %description -l pt_BR
43 O aRts é um sintetizador analógico em tempo real que é completamente
44 modular. Você pode criar sons e músicas (síntese em tempo real de
45 midi) usando pequenos módulos como oscilador para criar waveforms,
46 vários filtros, mixers, faders, etc. Você pode configurar tudo através
47 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
48 design foi escolhido para permitir que outras aplicações usem o aRts
49 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
50 outros.
51
52 %package X11
53 Summary:        X11 dependent part of aRts
54 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
55 Group:          X11/Libraries
56
57 %description X11
58 X11 dependent part of aRts.
59
60 %description X11 -l pl
61 Czê¶æ aRts wymagaj±ca X11.
62
63 %package qt
64 Summary:        QT dependend part of aRts
65 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
66 Group:          X11/Libraries
67 Requires:       %{name} >= %{version}
68 Requires:       qt >= 3.1
69
70 %description qt
71 QT dependend part of aRts.
72
73 %description qt -l pl
74 Czê¶æ aRts wymagaj±ca QT.
75
76 %package devel
77 Summary:        Sound server - header files
78 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
79 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
80 Group:          Development/Libraries
81 Requires:       qt-devel >= 3.1
82 Requires:       %{name} >= %{version}
83
84 %description devel
85 Header files required to compile programs using arts.
86
87 %description devel -l pl
88 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
89 arts.
90
91 %description devel -l pt_BR
92 Arquivos para desenvolvimento com o o aRts.
93
94 %package glib
95 Summary:        GLib dependend part of aRts
96 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
97 Group:          X11/Libraries
98 Requires:       glib >= 1.2.6
99
100 %description glib
101 GLib dependend part of aRts.
102
103 %description glib -l pl
104 Czê¶æ aRts wymagaj±ca GLib.
105
106 %prep
107 %setup -q
108
109 %build
110 kde_htmldir="%{_htmldir}"; export kde_htmldir
111 kde_icondir="%{_pixmapsdir}"; export kde_icondir
112
113 %configure \
114         --%{?debug:en}%{!?debug:dis}able-debug \
115         --enable-final \
116         --with-xinerama \
117         --with%{?_without_alsa:out}-alsa
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install DESTDIR=$RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %post X11   -p /sbin/ldconfig
130 %postun X11 -p /sbin/ldconfig
131
132 %post qt   -p /sbin/ldconfig
133 %postun qt -p /sbin/ldconfig
134
135 %post glib   -p /sbin/ldconfig
136 %postun glib -p /sbin/ldconfig
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/artscat
144 %attr(755,root,root) %{_bindir}/artsd
145 %attr(755,root,root) %{_bindir}/artsdsp
146 %attr(755,root,root) %{_bindir}/artsplay
147 %attr(755,root,root) %{_bindir}/artsrec
148 %attr(755,root,root) %{_bindir}/artsshell
149 %attr(755,root,root) %{_bindir}/artswrapper
150 %attr(755,root,root) %{_bindir}/testdhandle
151 %{_libdir}/lib[!gqx]*.la
152 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
153 %{_libdir}/mcop
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/artsc-config
158 %attr(755,root,root) %{_bindir}/mcopidl
159 %{_libdir}/*.so
160 %{_includedir}/arts
161 %{_includedir}/artsc
162
163 %files X11
164 %defattr(644,root,root,755)
165 %{_libdir}/libx11globalcomm.la
166 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
167
168 %files glib
169 %defattr(644,root,root,755)
170 %{_libdir}/libgmcop.la
171 %attr(755,root,root) %{_libdir}/libgmcop.so.*
172
173 %files qt
174 %defattr(644,root,root,755)
175 %{_libdir}/libqtmcop.la
176 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.074338 seconds and 4 git commands to generate.