]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- spaces -> tabs
[packages/arts.git] / arts.spec
1 #
2 # TODO: consider:
3 # - separating artsc and its -devel? (but what are artsc deps?)
4 #
5 # Conditional build:
6 %bcond_without  alsa    # disable ALSA support
7 %bcond_with     nas     # enable NAS support
8 #
9
10 %define         _state          snapshots
11 %define         _ver            1.2.0
12 %define         _snap           040104
13
14 Summary:        aRts sound server
15 Summary(pl):    Serwer d¼wiêku
16 Summary(pt_BR): Servidor de sons usado pelo KDE
17 Name:           arts
18 Version:        %{_ver}.%{_snap}
19 Release:        1
20 Epoch:          12
21 License:        LGPL
22 Group:          Libraries
23 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
24 Source0:        http://ep09.pld-linux.org/~djurban/kde/%{name}-%{_snap}.tar.bz2
25 # Source0-md5:  36606412608b4c1683d0f583dfd8e3c6
26 Patch0:         kde-common-am18.patch
27 Patch1:         kde-common-libltdl-am18.patch
28 URL:            http://www.kde.org/
29 %{?with_alsa:BuildRequires:     alsa-lib-devel}
30 BuildRequires:  audiofile-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  docbook-dtd41-sgml
34 BuildRequires:  docbook-utils >= 0.6.13-3
35 BuildRequires:  esound-devel
36 BuildRequires:  glib2-devel >= 2.0.0
37 BuildRequires:  libmad-devel
38 BuildRequires:  libtool >= 2:1.5-2
39 BuildRequires:  libvorbis-devel
40 %{?with_nas:BuildRequires:      nas-devel}
41 BuildRequires:  pkgconfig
42 BuildRequires:  qt-devel >= 6:3.2.1-4
43 Obsoletes:      arts-glib
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 aRts sound server.
48
49 %description -l pl
50 Serwer d¼wiêku aRts.
51
52 %description -l pt_BR
53 O aRts é um sintetizador analógico em tempo real que é completamente
54 modular. Você pode criar sons e músicas (síntese em tempo real de
55 midi) usando pequenos módulos como oscilador para criar waveforms,
56 vários filtros, mixers, faders, etc. Você pode configurar tudo através
57 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
58 design foi escolhido para permitir que outras aplicações usem o aRts
59 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
60 outros.
61
62 %package devel
63 Summary:        Sound server - header files
64 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
65 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
66 Group:          Development/Libraries
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68 # not necessary for all libs (e.g. mcop), but propagated by artsflow
69 %{?with_alsa:Requires:  alsa-lib-devel}
70 Requires:       audiofile-devel
71 Requires:       esound-devel
72 Requires:       glib2-devel >= 2.0.0
73 Requires:       libmad-devel
74 Requires:       libvorbis-devel
75 %{?with_nas:Requires:   nas-devel}
76
77 %description devel
78 Header files required to compile programs using arts.
79
80 %description devel -l pl
81 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
82 arts.
83
84 %description devel -l pt_BR
85 Arquivos para desenvolvimento com o o aRts.
86
87 # separate from arts-devel because they are mostly independent and have very
88 # different deps
89 # there is no artsc base - it would be small and would require arts - so there
90 # is no reason to separate
91 %package -n artsc-devel
92 Summary:        Development files for artsc libraries
93 Summary(pl):    Pliki programistyczne bibliotek artsc
94 Group:          Development/Libraries
95 Requires:       %{name} = %{epoch}:%{version}-%{release}
96 Requires:       glib2-devel >= 2.0.0
97 Conflicts:      arts-devel < 12:1.2.0.031126-2
98
99 %description -n artsc-devel
100 Development files for artsc libraries (C interface to aRts sound
101 system).
102
103 %description -n artsc-devel -l pl
104 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
105 d¼wiêku aRts).
106
107 %package X11
108 Summary:        X11 dependent part of aRts
109 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
110 Group:          X11/Libraries
111 Requires:       %{name} = %{epoch}:%{version}-%{release}
112
113 %description X11
114 X11 dependent part of aRts (x11globalcomm module).
115
116 %description X11 -l pl
117 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
118
119 %package qt
120 Summary:        QT dependend part of aRts
121 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
122 Group:          X11/Libraries
123 Requires:       %{name} = %{epoch}:%{version}-%{release}
124 Requires:       qt >= 6:3.2.1-4
125
126 %description qt
127 QT dependend part of aRts (qtmcop library).
128
129 %description qt -l pl
130 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
131
132 %package qt-devel
133 Summary:        Development files for qtmcop library
134 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
135 Group:          X11/Development/Libraries
136 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
137 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
138 Requires:       qt-devel >= 6:3.2.1-4
139
140 %description qt-devel
141 Development files for qtmcop library.
142
143 %description qt-devel -l pl
144 Pliki programistyczne dla biblioteki qtmcop.
145
146 %prep
147 %setup -q -n %{name}-%{_snap}
148 %patch0 -p0
149 %patch1 -p0
150
151 %build
152 cp /usr/share/automake/config.sub admin
153 %{__make} -f admin/Makefile.common cvs
154
155 %configure \
156         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
157         --%{?debug:en}%{!?debug:dis}able-debug \
158         --disable-rpath \
159         --enable-final \
160         --with-qt-libraries=%{_libdir} \
161         --with%{!?with_alsa:out}-alsa
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 # Debian manpages
172 install -d $RPM_BUILD_ROOT%{_mandir}/man1
173 cd debian
174 for f in *.sgml ; do
175         base="$(basename $f .sgml)"
176         upper="$(echo ${base} | tr a-z A-Z)"
177         db2man $f
178         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
179 done
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %post   X11 -p /sbin/ldconfig
188 %postun X11 -p /sbin/ldconfig
189
190 %post   qt -p /sbin/ldconfig
191 %postun qt -p /sbin/ldconfig
192
193 %files
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_bindir}/artscat
196 %attr(755,root,root) %{_bindir}/artsd
197 %attr(755,root,root) %{_bindir}/artsdsp
198 %attr(755,root,root) %{_bindir}/artsplay
199 %attr(755,root,root) %{_bindir}/artsrec
200 %attr(755,root,root) %{_bindir}/artsshell
201 %attr(755,root,root) %{_bindir}/artswrapper
202 # shared libraries
203 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
208 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
209 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
210 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
211 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
212 # lt_dlopened modules (*.la needed)
213 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
214 %{_libdir}/libartscbackend.la
215 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
216 %{_libdir}/libartsdsp.la
217 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
218 %{_libdir}/libartsdsp_st.la
219 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
220 %{_libdir}/libartsgslplayobject.la
221 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
222 %{_libdir}/libartswavplayobject.la
223 #
224 %{_libdir}/mcop
225 %{_mandir}/man1/artscat.1*
226 %{_mandir}/man1/artsd.1*
227 %{_mandir}/man1/artsdsp.1*
228 %{_mandir}/man1/artsplay.1*
229 %{_mandir}/man1/artsrec.1*
230 %{_mandir}/man1/artsshell.1*
231 %{_mandir}/man1/artswrapper.1*
232
233 %files devel
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_bindir}/mcopidl
236 %attr(755,root,root) %{_libdir}/libartsflow.so
237 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
238 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
239 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
240 %attr(755,root,root) %{_libdir}/libgmcop.so
241 %attr(755,root,root) %{_libdir}/libkmedia2.so
242 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
243 %attr(755,root,root) %{_libdir}/libmcop.so
244 %attr(755,root,root) %{_libdir}/libmcop_mt.so
245 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
246 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
247 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
248 # shared libraries
249 %{_libdir}/libartsflow.la
250 %{_libdir}/libartsflow_idl.la
251 %{_libdir}/libgmcop.la
252 %{_libdir}/libkmedia2.la
253 %{_libdir}/libkmedia2_idl.la
254 %{_libdir}/libmcop.la
255 %{_libdir}/libmcop_mt.la
256 %{_libdir}/libsoundserver_idl.la
257 #
258 %{_includedir}/arts
259 %exclude %{_includedir}/arts/qiomanager.h
260 %{_mandir}/man1/mcopidl.1*
261
262 %files -n artsc-devel
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_bindir}/artsc-config
265 %attr(755,root,root) %{_libdir}/libartsc.so
266 %attr(755,root,root) %{_libdir}/libartscbackend.so
267 %attr(755,root,root) %{_libdir}/libartsdsp.so
268 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
269 %{_libdir}/libartsc.la
270 %{_includedir}/artsc
271 %{_mandir}/man1/artsc-config.1*
272
273 %files X11
274 %defattr(644,root,root,755)
275 # lt_dlopened module (.la needed)
276 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
277 %{_libdir}/libx11globalcomm.la
278
279 %files qt
280 %defattr(644,root,root,755)
281 # shared library
282 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
283
284 %files qt-devel
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_libdir}/libqtmcop.so
287 %{_libdir}/libqtmcop.la
288 %{_includedir}/arts/qiomanager.h
This page took 0.067111 seconds and 4 git commands to generate.