]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- use ftp.k.o
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6
7 %define         _state          stable
8 %define         _ver            1.2.0
9 #%%define               _snap           040110
10
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
21 #Source0:       http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
22 # Source0-md5:  f17708ad3c91b0a2f0c83674f78c3e53        
23 URL:            http://www.kde.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.13-3
30 BuildRequires:  esound-devel
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  libmad-devel
33 BuildRequires:  libtool >= 2:1.5-2
34 BuildRequires:  libvorbis-devel
35 %{?with_nas:BuildRequires:      nas-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt-devel >= 6:3.2.1-4
38 Obsoletes:      arts-glib
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 aRts sound server.
43
44 %description -l pl
45 Serwer d¼wiêku aRts.
46
47 %description -l pt_BR
48 O aRts é um sintetizador analógico em tempo real que é completamente
49 modular. Você pode criar sons e músicas (síntese em tempo real de
50 midi) usando pequenos módulos como oscilador para criar waveforms,
51 vários filtros, mixers, faders, etc. Você pode configurar tudo através
52 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
53 design foi escolhido para permitir que outras aplicações usem o aRts
54 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
55 outros.
56
57 %package devel
58 Summary:        Sound server - header files
59 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
60 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
61 Group:          Development/Libraries
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63 # not necessary for all libs (e.g. mcop), but propagated by artsflow
64 %{?with_alsa:Requires:  alsa-lib-devel}
65 Requires:       audiofile-devel
66 Requires:       esound-devel
67 Requires:       glib2-devel >= 2.0.0
68 Requires:       libmad-devel
69 Requires:       libvorbis-devel
70 %{?with_nas:Requires:   nas-devel}
71
72 %description devel
73 Header files required to compile programs using arts.
74
75 %description devel -l pl
76 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
77 arts.
78
79 %description devel -l pt_BR
80 Arquivos para desenvolvimento com o o aRts.
81
82 # separate from arts-devel because they are mostly independent and have very
83 # different deps
84 # there is no artsc base - it would be small and would require arts - so there
85 # is no reason to separate
86 %package -n artsc-devel
87 Summary:        Development files for artsc libraries
88 Summary(pl):    Pliki programistyczne bibliotek artsc
89 Group:          Development/Libraries
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91 Requires:       glib2-devel >= 2.0.0
92 Conflicts:      arts-devel < 12:1.2.0.031126-2
93
94 %description -n artsc-devel
95 Development files for artsc libraries (C interface to aRts sound
96 system).
97
98 %description -n artsc-devel -l pl
99 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
100 d¼wiêku aRts).
101
102 %package X11
103 Summary:        X11 dependent part of aRts
104 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
105 Group:          X11/Libraries
106 Requires:       %{name} = %{epoch}:%{version}-%{release}
107
108 %description X11
109 X11 dependent part of aRts (x11globalcomm module).
110
111 %description X11 -l pl
112 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
113
114 %package qt
115 Summary:        QT dependend part of aRts
116 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
117 Group:          X11/Libraries
118 Requires:       %{name} = %{epoch}:%{version}-%{release}
119 Requires:       qt >= 6:3.2.1-4
120
121 %description qt
122 QT dependend part of aRts (qtmcop library).
123
124 %description qt -l pl
125 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
126
127 %package qt-devel
128 Summary:        Development files for qtmcop library
129 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
130 Group:          X11/Development/Libraries
131 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
132 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
133 Requires:       qt-devel >= 6:3.2.1-4
134
135 %description qt-devel
136 Development files for qtmcop library.
137
138 %description qt-devel -l pl
139 Pliki programistyczne dla biblioteki qtmcop.
140
141 %prep
142 # qboosh leave it this way, 'cause its easier to change to snap later
143 %setup -q -n %{name}-%{version}
144
145 %build
146 cp /usr/share/automake/config.sub admin
147 %{__make} -f admin/Makefile.common cvs
148
149 %configure \
150         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
151         --%{?debug:en}%{!?debug:dis}able-debug \
152         --disable-rpath \
153         --enable-final \
154         --with-qt-libraries=%{_libdir} \
155         --with%{!?with_alsa:out}-alsa
156
157 %{__make}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 # Debian manpages
166 install -d $RPM_BUILD_ROOT%{_mandir}/man1
167 cd debian
168 for f in *.sgml ; do
169         base="$(basename $f .sgml)"
170         upper="$(echo ${base} | tr a-z A-Z)"
171         db2man $f
172         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
173 done
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %post   X11 -p /sbin/ldconfig
182 %postun X11 -p /sbin/ldconfig
183
184 %post   qt -p /sbin/ldconfig
185 %postun qt -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/artscat
190 %attr(755,root,root) %{_bindir}/artsd
191 %attr(755,root,root) %{_bindir}/artsdsp
192 %attr(755,root,root) %{_bindir}/artsplay
193 %attr(755,root,root) %{_bindir}/artsrec
194 %attr(755,root,root) %{_bindir}/artsshell
195 %attr(755,root,root) %{_bindir}/artswrapper
196 # shared libraries
197 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
198 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
199 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
200 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
206 # lt_dlopened modules (*.la needed)
207 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
208 %{_libdir}/libartscbackend.la
209 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
210 %{_libdir}/libartsdsp.la
211 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
212 %{_libdir}/libartsdsp_st.la
213 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
214 %{_libdir}/libartsgslplayobject.la
215 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
216 %{_libdir}/libartswavplayobject.la
217 #
218 %{_libdir}/mcop
219 %{_mandir}/man1/artscat.1*
220 %{_mandir}/man1/artsd.1*
221 %{_mandir}/man1/artsdsp.1*
222 %{_mandir}/man1/artsplay.1*
223 %{_mandir}/man1/artsrec.1*
224 %{_mandir}/man1/artsshell.1*
225 %{_mandir}/man1/artswrapper.1*
226
227 %files devel
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_bindir}/mcopidl
230 %attr(755,root,root) %{_libdir}/libartsflow.so
231 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
232 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
233 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
234 %attr(755,root,root) %{_libdir}/libgmcop.so
235 %attr(755,root,root) %{_libdir}/libkmedia2.so
236 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
237 %attr(755,root,root) %{_libdir}/libmcop.so
238 %attr(755,root,root) %{_libdir}/libmcop_mt.so
239 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
240 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
241 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
242 # shared libraries
243 %{_libdir}/libartsflow.la
244 %{_libdir}/libartsflow_idl.la
245 %{_libdir}/libgmcop.la
246 %{_libdir}/libkmedia2.la
247 %{_libdir}/libkmedia2_idl.la
248 %{_libdir}/libmcop.la
249 %{_libdir}/libmcop_mt.la
250 %{_libdir}/libsoundserver_idl.la
251 #
252 %{_includedir}/arts
253 %exclude %{_includedir}/arts/qiomanager.h
254 %{_mandir}/man1/mcopidl.1*
255
256 %files -n artsc-devel
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_bindir}/artsc-config
259 %attr(755,root,root) %{_libdir}/libartsc.so
260 %attr(755,root,root) %{_libdir}/libartscbackend.so
261 %attr(755,root,root) %{_libdir}/libartsdsp.so
262 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
263 %{_libdir}/libartsc.la
264 %{_includedir}/artsc
265 %{_mandir}/man1/artsc-config.1*
266
267 %files X11
268 %defattr(644,root,root,755)
269 # lt_dlopened module (.la needed)
270 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
271 %{_libdir}/libx11globalcomm.la
272
273 %files qt
274 %defattr(644,root,root,755)
275 # shared library
276 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
277
278 %files qt-devel
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_libdir}/libqtmcop.so
281 %{_libdir}/libqtmcop.la
282 %{_includedir}/arts/qiomanager.h
This page took 0.051134 seconds and 4 git commands to generate.