]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- rel. 1 STBR to Ac.
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 #
6 %define         _state          stable
7 %define         _ver            1.2.3
8 #%%define               _snap           040110
9 %define         _kdever         3.2.3
10 #
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 #Source0:       http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
21 Source0:        http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
22 # Source0-md5:  fca8a9ec7538c4fe8e4c79767bb2a7e8
23 # http://download.kde.org/stable/3.2.1/src/arts-1.2.1.tar.bz2
24 URL:            http://www.kde.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel}
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  docbook-dtd41-sgml
30 BuildRequires:  docbook-utils >= 0.6.13-3
31 BuildRequires:  esound-devel
32 BuildRequires:  glib2-devel >= 2.0.0
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 BuildRequires:  unsermake >= 040511
37 %{?with_nas:BuildRequires:      nas-devel}
38 BuildRequires:  pkgconfig
39 BuildRequires:  unsermake >= 040511
40 BuildRequires:  qt-devel >= 6:3.2.1-4
41 Obsoletes:      arts-glib
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The Analog Real-Time Synthesizer, or aRts, is a modular system for
46 synthesizing sound and music on a digital computer. Using small
47 building blocks called modules, the user can easily build complex
48 audio processing tools. Modules typically provide functions such as
49 sound waveform generators, filters, audio effects, mixing, and
50 playback of digital audio in different file formats. The artsd sound
51 server mixes audio from several sources in real time, allowing
52 multiple sound applications to transparently share access to sound
53 hardware.
54
55 %description -l pl
56 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
57 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
58 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
59 d¼wiêku. Modu³y umo¿liwiaj± generacjê kstza³tu fali, filtrowanie,
60 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
61 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
62 odtwarzanie d¼wiêku z wielu ¼róde³.
63
64 %description -l pt_BR
65 O aRts é um sintetizador analógico em tempo real que é completamente
66 modular. Você pode criar sons e músicas (síntese em tempo real de
67 midi) usando pequenos módulos como oscilador para criar waveforms,
68 vários filtros, mixers, faders, etc. Você pode configurar tudo através
69 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
70 design foi escolhido para permitir que outras aplicações usem o aRts
71 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
72 outros.
73
74 %package devel
75 Summary:        Sound server - header files
76 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
77 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
78 Group:          Development/Libraries
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80 # not necessary for all libs (e.g. mcop), but propagated by artsflow
81 %{?with_alsa:Requires:  alsa-lib-devel}
82 Requires:       audiofile-devel
83 Requires:       esound-devel
84 Requires:       glib2-devel >= 2.0.0
85 Requires:       libmad-devel
86 Requires:       libvorbis-devel
87 %{?with_nas:Requires:   nas-devel}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 # separate from arts-devel because they are mostly independent and #
100 have very # different deps there is no artsc base - it would be #
101 small and would require arts - so there is no reason to separate
102 %package -n artsc-devel
103 Summary:        Development files for artsc libraries
104 Summary(pl):    Pliki programistyczne bibliotek artsc
105 Group:          Development/Libraries
106 Requires:       %{name} = %{epoch}:%{version}-%{release}
107 Requires:       glib2-devel >= 2.0.0
108 Conflicts:      arts-devel < 12:1.2.0.031126-2
109
110 %description -n artsc-devel
111 Development files for artsc libraries (C interface to aRts sound
112 system).
113
114 %description -n artsc-devel -l pl
115 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
116 d¼wiêku aRts).
117
118 %package X11
119 Summary:        X11 dependent part of aRts
120 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
121 Group:          X11/Libraries
122 Requires:       %{name} = %{epoch}:%{version}-%{release}
123
124 %description X11
125 X11 dependent part of aRts (x11globalcomm module).
126
127 %description X11 -l pl
128 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
129
130 %package qt
131 Summary:        QT dependend part of aRts
132 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
133 Group:          X11/Libraries
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135 Requires:       qt >= 6:3.2.1-4
136
137 %description qt
138 QT dependend part of aRts (qtmcop library).
139
140 %description qt -l pl
141 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
142
143 %package qt-devel
144 Summary:        Development files for qtmcop library
145 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
146 Group:          X11/Development/Libraries
147 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
148 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
149 Requires:       qt-devel >= 6:3.2.1-4
150
151 %description qt-devel
152 Development files for qtmcop library.
153
154 %description qt-devel -l pl
155 Pliki programistyczne dla biblioteki qtmcop.
156
157 %prep
158 # qboosh leave it this way, 'cause its easier to change to snap later
159 %setup -q -n %{name}-%{version}
160
161 %build
162 cp %{_datadir}/automake/config.sub admin
163 export UNSERMAKE=%{_datadir}/unsermake/unsermake
164 %{__make} -f admin/Makefile.common cvs
165
166 %configure \
167         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
168         --%{?debug:en}%{!?debug:dis}able-debug \
169         --disable-rpath \
170         --enable-final \
171         --with-qt-libraries=%{_libdir} \
172         --with%{!?with_alsa:out}-alsa
173
174 %{__make}
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 # Debian manpages
183 install -d $RPM_BUILD_ROOT%{_mandir}/man1
184 cd debian/man
185 for f in *.sgml ; do
186         base="$(basename $f .sgml)"
187         upper="$(echo ${base} | tr a-z A-Z)"
188         db2man $f
189         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
190 done
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post   -p /sbin/ldconfig
196 %postun -p /sbin/ldconfig
197
198 %post   X11 -p /sbin/ldconfig
199 %postun X11 -p /sbin/ldconfig
200
201 %post   qt -p /sbin/ldconfig
202 %postun qt -p /sbin/ldconfig
203
204 %files
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_bindir}/artscat
207 %attr(755,root,root) %{_bindir}/artsd
208 %attr(755,root,root) %{_bindir}/artsdsp
209 %attr(755,root,root) %{_bindir}/artsplay
210 %attr(755,root,root) %{_bindir}/artsrec
211 %attr(755,root,root) %{_bindir}/artsshell
212 %attr(755,root,root) %{_bindir}/artswrapper
213 # shared libraries
214 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
215 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
216 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
217 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
218 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
223 # lt_dlopened modules (*.la needed)
224 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
225 %{_libdir}/libartscbackend.la
226 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
227 %{_libdir}/libartsdsp.la
228 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
229 %{_libdir}/libartsdsp_st.la
230 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
231 %{_libdir}/libartsgslplayobject.la
232 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
233 %{_libdir}/libartswavplayobject.la
234 #
235 %{_libdir}/mcop
236 %{_mandir}/man1/artscat.1*
237 %{_mandir}/man1/artsd.1*
238 %{_mandir}/man1/artsdsp.1*
239 %{_mandir}/man1/artsplay.1*
240 %{_mandir}/man1/artsrec.1*
241 %{_mandir}/man1/artsshell.1*
242 %{_mandir}/man1/artswrapper.1*
243
244 %files devel
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/mcopidl
247 %attr(755,root,root) %{_libdir}/libartsflow.so
248 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
249 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
250 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
251 %attr(755,root,root) %{_libdir}/libgmcop.so
252 %attr(755,root,root) %{_libdir}/libkmedia2.so
253 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
254 %attr(755,root,root) %{_libdir}/libmcop.so
255 %attr(755,root,root) %{_libdir}/libmcop_mt.so
256 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
257 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
258 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
259 # shared libraries
260 %{_libdir}/libartsflow.la
261 %{_libdir}/libartsflow_idl.la
262 %{_libdir}/libgmcop.la
263 %{_libdir}/libkmedia2.la
264 %{_libdir}/libkmedia2_idl.la
265 %{_libdir}/libmcop.la
266 %{_libdir}/libmcop_mt.la
267 %{_libdir}/libsoundserver_idl.la
268 #
269 %{_includedir}/arts
270 %exclude %{_includedir}/arts/qiomanager.h
271 %{_mandir}/man1/mcopidl.1*
272
273 %files -n artsc-devel
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_bindir}/artsc-config
276 %attr(755,root,root) %{_libdir}/libartsc.so
277 %attr(755,root,root) %{_libdir}/libartscbackend.so
278 %attr(755,root,root) %{_libdir}/libartsdsp.so
279 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
280 %{_libdir}/libartsc.la
281 %{_includedir}/artsc
282 %{_mandir}/man1/artsc-config.1*
283
284 %files X11
285 %defattr(644,root,root,755)
286 # lt_dlopened module (.la needed)
287 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
288 %{_libdir}/libx11globalcomm.la
289
290 %files qt
291 %defattr(644,root,root,755)
292 # shared library
293 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
294
295 %files qt-devel
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/libqtmcop.so
298 %{_libdir}/libqtmcop.la
299 %{_includedir}/arts/qiomanager.h
This page took 0.063782 seconds and 4 git commands to generate.