]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- BR: libstdc++-devel
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5 %ifarch sparc sparcv9 sparc64
6 %define         _without_alsa   1
7 %endif
8 Summary:        aRts sound server
9 Summary(pl):    Serwer d¼wiêku
10 Summary(pt_BR): Servidor de sons usado pelo KDE
11 Name:           arts
12 Version:        1.1.2
13 Release:        1
14 Epoch:          12
15 License:        LGPL
16 Vendor:         The KDE Team
17 Group:          Libraries
18 Source0:        ftp://ftp.kde.org/pub/kde/stable/3.1.2/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  5d5a1858f8dcf0d88600291899dff75b
20 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
21 BuildRequires:  audiofile-devel
22 BuildRequires:  glib2-devel >= 2.0.0
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel
25 BuildRequires:  libstdc++-devel
26 # not needed, only ./configure check for this
27 #BuildRequires: libvorbis-devel
28 #BuildRequires: mad-devel
29 %{?_with_nas:BuildRequires:     nas-devel}
30 BuildRequires:  pkgconfig
31 BuildRequires:  qt-devel >= 3.1
32 URL:            http://www.kde.org/
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _htmldir        /usr/share/doc/kde/HTML
36
37 %description
38 aRts sound server.
39
40 %description -l pl
41 Serwer d¼wiêku aRts.
42
43 %description -l pt_BR
44 O aRts é um sintetizador analógico em tempo real que é completamente
45 modular. Você pode criar sons e músicas (síntese em tempo real de
46 midi) usando pequenos módulos como oscilador para criar waveforms,
47 vários filtros, mixers, faders, etc. Você pode configurar tudo através
48 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
49 design foi escolhido para permitir que outras aplicações usem o aRts
50 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
51 outros.
52
53 %package X11
54 Summary:        X11 dependent part of aRts
55 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
56 Group:          X11/Libraries
57
58 %description X11
59 X11 dependent part of aRts.
60
61 %description X11 -l pl
62 Czê¶æ aRts wymagaj±ca X11.
63
64 %package qt
65 Summary:        QT dependend part of aRts
66 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
67 Group:          X11/Libraries
68 Requires:       %{name} >= %{epoch}:%{version}
69 Requires:       qt >= 3.1
70
71 %description qt
72 QT dependend part of aRts.
73
74 %description qt -l pl
75 Czê¶æ aRts wymagaj±ca QT.
76
77 %package devel
78 Summary:        Sound server - header files
79 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
80 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
81 Group:          Development/Libraries
82 Requires:       qt-devel >= 3.1
83 Requires:       %{name} >= %{epoch}:%{version}
84 %{?_with_nas:Requires:  nas-devel}
85
86 %description devel
87 Header files required to compile programs using arts.
88
89 %description devel -l pl
90 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
91 arts.
92
93 %description devel -l pt_BR
94 Arquivos para desenvolvimento com o o aRts.
95
96 %package glib
97 Summary:        GLib dependend part of aRts
98 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
99 Group:          X11/Libraries
100 Requires:       glib >= 1.2.6
101
102 %description glib
103 GLib dependend part of aRts.
104
105 %description glib -l pl
106 Czê¶æ aRts wymagaj±ca GLib.
107
108 %prep
109 %setup -q
110
111 %build
112 kde_htmldir="%{_htmldir}"; export kde_htmldir
113 kde_icondir="%{_pixmapsdir}"; export kde_icondir
114
115 %configure \
116         --%{?debug:en}%{!?debug:dis}able-debug \
117         --disable-rpath \
118         --enable-final \
119         --with-xinerama \
120         --with%{?_without_alsa:out}-alsa
121
122 %if %{!?_with_nas:1}0
123 # Cannot patch configure.in because it does not rebuild correctly on ac25
124 sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
125         < config.h \
126         > config.h.tmp
127 mv -f config.h{.tmp,}
128 %endif
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install DESTDIR=$RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %post   X11 -p /sbin/ldconfig
140 %postun X11 -p /sbin/ldconfig
141
142 %post   qt -p /sbin/ldconfig
143 %postun qt -p /sbin/ldconfig
144
145 %post   glib -p /sbin/ldconfig
146 %postun glib -p /sbin/ldconfig
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %files
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/artscat
154 %attr(755,root,root) %{_bindir}/artsd
155 %attr(755,root,root) %{_bindir}/artsdsp
156 %attr(755,root,root) %{_bindir}/artsplay
157 %attr(755,root,root) %{_bindir}/artsrec
158 %attr(755,root,root) %{_bindir}/artsshell
159 %attr(755,root,root) %{_bindir}/artswrapper
160 %attr(755,root,root) %{_bindir}/testdhandle
161 %{_libdir}/lib[!gqx]*.la
162 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*.*.*
163 %{_libdir}/mcop
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/artsc-config
168 %attr(755,root,root) %{_bindir}/mcopidl
169 %{_libdir}/*.so
170 %{_includedir}/arts
171 %{_includedir}/artsc
172
173 %files X11
174 %defattr(644,root,root,755)
175 %{_libdir}/libx11globalcomm.la
176 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
177
178 %files glib
179 %defattr(644,root,root,755)
180 %{_libdir}/libgmcop.la
181 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
182
183 %files qt
184 %defattr(644,root,root,755)
185 %{_libdir}/libqtmcop.la
186 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.040825 seconds and 4 git commands to generate.