]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- updated to 1.0.4: bug fix release.
[packages/arts.git] / arts.spec
1 Summary:        aRts sound server
2 Summary(pl):    Serwer d¼wiêku
3 Summary(pt_BR): Servidor de sons usado pelo KDE
4 Name:           arts
5 %define _kdever 3.0.4
6 Version:        1.0.4
7 Release:        1
8 Epoch:          10
9 License:        LGPL
10 Vendor:         The KDE Team
11 Group:          Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/stable/%{_kdever}/src/%{name}-%{version}.tar.bz2
13 %ifnarch sparc sparcv9 sparc64
14 BuildRequires:  alsa-lib-devel
15 %endif
16 BuildRequires:  audiofile-devel
17 BuildRequires:  glib2-devel >= 2.0.0
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel
20 # not needed, only ./configure check for this
21 #BuildRequires: libvorbis-devel
22 #BuildRequires: mad-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt-devel >= 3.0.5
25 URL:            http://www.kde.org/
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _prefix         /usr/X11R6
29 %define         _htmldir        /usr/share/doc/kde/HTML
30
31 %description
32 aRts sound server.
33
34 %description -l pl
35 Serwer d¼wiêku aRts.
36
37 %description -l pt_BR
38 O aRts é um sintetizador analógico em tempo real que é completamente
39 modular. Você pode criar sons e músicas (síntese em tempo real de
40 midi) usando pequenos módulos como oscilador para criar waveforms,
41 vários filtros, mixers, faders, etc. Você pode configurar tudo através
42 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
43 design foi escolhido para permitir que outras aplicações usem o aRts
44 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
45 outros.
46
47 %package X11
48 Summary:        X11 dependent part of aRts
49 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
50 Group:          X11/Libraries
51
52 %description X11
53 X11 dependent part of aRts.
54
55 %description X11 -l pl
56 Czê¶æ aRts wymagaj±ca X11.
57
58 %package qt
59 Summary:        QT dependend part of aRts
60 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
61 Group:          X11/Libraries
62 Requires:       %{name} >= %{version}
63 Requires:       qt >= 3.0.5
64
65 %description qt
66 QT dependend part of aRts.
67
68 %description qt -l pl
69 Czê¶æ aRts wymagaj±ca QT.
70
71 %package devel
72 Summary:        Sound server - header files
73 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
74 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
75 Group:          Development/Libraries
76 Requires:       qt-devel >= 3.0.3
77 Requires:       %{name} >= %{version}
78
79 %description devel
80 Header files required to compile programs using arts.
81
82 %description devel -l pl
83 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
84 arts.
85
86 %description devel -l pt_BR
87 Arquivos para desenvolvimento com o o aRts.
88
89 %package glib
90 Summary:        GLib dependend part of aRts
91 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
92 Group:          X11/Libraries
93
94 %description glib
95 GLib dependend part of aRts.
96
97 %description glib -l pl
98 Czê¶æ aRts wymagaj±ca GLib.
99
100 %prep
101 %setup -q
102
103 %build
104 kde_htmldir="%{_htmldir}"; export kde_htmldir
105 kde_icondir="%{_pixmapsdir}"; export kde_icondir
106
107 #%{__make} -f Makefile.cvs
108
109 %configure \
110         --%{?debug:en}%{!?debug:dis}able-debug \
111         --enable-final \
112         --with-xinerama \
113         --with-alsa 
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install DESTDIR=$RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %post X11   -p /sbin/ldconfig
126 %postun X11 -p /sbin/ldconfig
127
128 %post qt   -p /sbin/ldconfig
129 %postun qt -p /sbin/ldconfig
130
131 %post glib   -p /sbin/ldconfig
132 %postun glib -p /sbin/ldconfig
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/artscat
140 %attr(755,root,root) %{_bindir}/artsd
141 %attr(755,root,root) %{_bindir}/artsdsp
142 %attr(755,root,root) %{_bindir}/artsplay
143 %attr(755,root,root) %{_bindir}/artsrec
144 %attr(755,root,root) %{_bindir}/artsshell
145 %attr(755,root,root) %{_bindir}/artswrapper
146 %attr(755,root,root) %{_libdir}/lib[am]*.so.*.*
147 %attr(755,root,root) %{_libdir}/libs[!h]*.so.*.*
148 %attr(755,root,root) %{_libdir}/lib[ams]*.la
149 %attr(755,root,root) %{_libdir}/libkmedia*.so.*.*
150 %attr(755,root,root) %{_libdir}/libkmedia*.la
151 %{_libdir}/mcop
152
153 %files X11
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
156 %attr(755,root,root) %{_libdir}/libx11globalcomm.la
157
158 %files qt
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
161 %attr(755,root,root) %{_libdir}/libqtmcop.la
162
163 %files glib
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
166 %attr(755,root,root) %{_libdir}/libgmcop.la
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/artsc-config
171 %attr(755,root,root) %{_bindir}/mcopidl
172 %{_libdir}/lib[mqsxg]*.so
173 %{_libdir}/libarts[!k]*.so
174 %{_libdir}/libkmedia*.so
175 %{_includedir}/arts
176 %{_includedir}/artsc
This page took 0.043795 seconds and 4 git commands to generate.