]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- fixed nas bcond
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5 %ifarch sparc sparcv9 sparc64
6 %define         _without_alsa   1
7 %endif
8 Summary:        aRts sound server
9 Summary(pl):    Serwer d¼wiêku
10 Summary(pt_BR): Servidor de sons usado pelo KDE
11 Name:           arts
12 Version:        1.1.2
13 Release:        1
14 Epoch:          12
15 License:        LGPL
16 Vendor:         The KDE Team
17 Group:          Libraries
18 Source0:        ftp://ftp.kde.org/pub/kde/stable/3.1.2/src/%{name}-%{version}.tar.bz2
19 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
20 BuildRequires:  audiofile-devel
21 BuildRequires:  glib2-devel >= 2.0.0
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel
24 # not needed, only ./configure check for this
25 #BuildRequires: libvorbis-devel
26 #BuildRequires: mad-devel
27 %{?_with_nas:BuildRequires:     nas-devel}
28 BuildRequires:  pkgconfig
29 BuildRequires:  qt-devel >= 3.1
30 URL:            http://www.kde.org/
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _htmldir        /usr/share/doc/kde/HTML
34
35 %description
36 aRts sound server.
37
38 %description -l pl
39 Serwer d¼wiêku aRts.
40
41 %description -l pt_BR
42 O aRts é um sintetizador analógico em tempo real que é completamente
43 modular. Você pode criar sons e músicas (síntese em tempo real de
44 midi) usando pequenos módulos como oscilador para criar waveforms,
45 vários filtros, mixers, faders, etc. Você pode configurar tudo através
46 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
47 design foi escolhido para permitir que outras aplicações usem o aRts
48 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
49 outros.
50
51 %package X11
52 Summary:        X11 dependent part of aRts
53 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
54 Group:          X11/Libraries
55
56 %description X11
57 X11 dependent part of aRts.
58
59 %description X11 -l pl
60 Czê¶æ aRts wymagaj±ca X11.
61
62 %package qt
63 Summary:        QT dependend part of aRts
64 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
65 Group:          X11/Libraries
66 Requires:       %{name} >= %{version}
67 Requires:       qt >= 3.1
68
69 %description qt
70 QT dependend part of aRts.
71
72 %description qt -l pl
73 Czê¶æ aRts wymagaj±ca QT.
74
75 %package devel
76 Summary:        Sound server - header files
77 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
78 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
79 Group:          Development/Libraries
80 Requires:       qt-devel >= 3.1
81 Requires:       %{name} >= %{version}
82 %{?_with_nas:Requires:  nas-devel}
83
84 %description devel
85 Header files required to compile programs using arts.
86
87 %description devel -l pl
88 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
89 arts.
90
91 %description devel -l pt_BR
92 Arquivos para desenvolvimento com o o aRts.
93
94 %package glib
95 Summary:        GLib dependend part of aRts
96 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
97 Group:          X11/Libraries
98 Requires:       glib >= 1.2.6
99
100 %description glib
101 GLib dependend part of aRts.
102
103 %description glib -l pl
104 Czê¶æ aRts wymagaj±ca GLib.
105
106 %prep
107 %setup -q
108
109 %build
110 kde_htmldir="%{_htmldir}"; export kde_htmldir
111 kde_icondir="%{_pixmapsdir}"; export kde_icondir
112
113 %configure \
114         --%{?debug:en}%{!?debug:dis}able-debug \
115         --disable-rpath \
116         --enable-final \
117         --with-xinerama \
118         --with%{?_without_alsa:out}-alsa
119
120 %if %{!?_with_nas:1}0
121 # Cannot patch configure.in because it does not rebuild correctly on ac25
122 sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
123         < config.h \
124         > config.h.tmp
125 mv -f config.h{.tmp,}
126 %endif
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install DESTDIR=$RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %post   X11 -p /sbin/ldconfig
138 %postun X11 -p /sbin/ldconfig
139
140 %post   qt -p /sbin/ldconfig
141 %postun qt -p /sbin/ldconfig
142
143 %post   glib -p /sbin/ldconfig
144 %postun glib -p /sbin/ldconfig
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/artscat
152 %attr(755,root,root) %{_bindir}/artsd
153 %attr(755,root,root) %{_bindir}/artsdsp
154 %attr(755,root,root) %{_bindir}/artsplay
155 %attr(755,root,root) %{_bindir}/artsrec
156 %attr(755,root,root) %{_bindir}/artsshell
157 %attr(755,root,root) %{_bindir}/artswrapper
158 %attr(755,root,root) %{_bindir}/testdhandle
159 %{_libdir}/lib[!gqx]*.la
160 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*.*.*
161 %{_libdir}/mcop
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/artsc-config
166 %attr(755,root,root) %{_bindir}/mcopidl
167 %{_libdir}/*.so
168 %{_includedir}/arts
169 %{_includedir}/artsc
170
171 %files X11
172 %defattr(644,root,root,755)
173 %{_libdir}/libx11globalcomm.la
174 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
175
176 %files glib
177 %defattr(644,root,root,755)
178 %{_libdir}/libgmcop.la
179 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
180
181 %files qt
182 %defattr(644,root,root,755)
183 %{_libdir}/libqtmcop.la
184 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.052329 seconds and 4 git commands to generate.